## Contents

**CRYSTAL REPORTS TUTORIAL** .......................................................... 1

- Getting Started ................................................................................. 2
- Step 1: Creating an Export File ...................................................... 3
- Step 2: Linking the Export File to a New Report ......................... 7
- Step 3: Adding and Organizing Report Data ................................. 13
- Step 4: Formatting the Appearance of the Report ....................... 30
- Step 5: Saving the Report ............................................................. 39
Crystal Reports Tutorial

Getting Started ................................................................. 2
Step 1: Creating an Export File .............................................. 3
Step 2: Linking the Export File to a New Report ......................... 7
Step 3: Adding and Organizing Report Data .............................. 13
  Inserting Data Fields ......................................................... 13
  Resizing Fields ............................................................... 16
  Moving Fields ............................................................... 17
  Editing Field Headings ...................................................... 18
  Sorting Records .............................................................. 20
  Grouping Records .......................................................... 21
  Adding Subtotals, Summaries, and Grand Totals ...................... 24
  Filtering Report Results ................................................... 27
  Suppressing Fields ......................................................... 28
Step 4: Formatting the Appearance of the Report ....................... 30
  Inserting Text Fields ....................................................... 30
  Inserting Special Fields ..................................................... 32
  Formatting Fields Using the Format Editor ............................ 34
  Adding Lines and Borders ................................................ 36
Step 5: Saving the Report ..................................................... 39
  Refreshing a Report ........................................................ 41
  Setting the Database Location for a Saved Report ................. 42
Blackbaud Student Information System contains many standard reports to help you quickly produce information you need. However, for unique reporting needs, you can use Crystal Reports to create custom report designs that contain data from Blackbaud Student Information System.

**Note:** A Crystal Reports Professional license is required to use Crystal Reports to run reports directly from a SQL Server database running SQL Server Standard or Enterprise, or MSDE with Read-Only Database Assistance.

Blackbaud Student Information System includes one license for Crystal Reports XI. You need a license for each person who creates custom reports. In addition, each license is associated with a particular product, which means if one person is reporting for both Blackbaud Student Information System and The Raiser's Edge, that individual needs two Crystal Reports XI licenses. For information about purchasing additional Crystal Reports XI licenses, contact your account representative or send an email request to solutions@blackbaud.com.

### Getting Started

This tutorial guides you through the steps necessary to create a basic Crystal report. We create a custom report that presents Admissions Office applicant information grouped by age and includes the total number of applicants for the specified time period. We also use formatting features, such as lines, borders, and color, to draw attention to certain areas of the report. The beginning of the finished report appears as shown here:

<table>
<thead>
<tr>
<th>Age</th>
<th>Applicant</th>
<th>Ethnicity</th>
<th>Current Status</th>
<th>Application Date</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Brother Brett Sader</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Brother Chris Nyce</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Brother James Tipton</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Brother Jason Lewis</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Brother John Alderson</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Brother Joshua Rassel</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Brother Karen Davis</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Brother Kevin Hamilton</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Brother Luke Bailey</td>
<td>Asian or Pacific Islander</td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Brother Russell Koch</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Brother Timothy Patick</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Brother Todd White</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Brother Warner Parsa</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Carolyn Heap</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Darrell Haeck</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Eric Keith</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Garrett Peter Bridgeman</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Jennifer Jordan</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Kate Kuhn</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Alicia Willing</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Alphon Reddy</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Alpas Godkin</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Amanda Oxendine</td>
<td>American Indian or Alaska Native</td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Amy Eaves</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Ann Fryman</td>
<td>Latino or Hispanic</td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Annette Schuman</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Bailey Ronn</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Carol Potroski</td>
<td>American Indian or Alaska Native</td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Collin Reimer</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Collins Tepp</td>
<td>Asian or Pacific Islander</td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Dana Lutz</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Deborah Rawles</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Eric Wallen</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Helen Barber</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Irene Lee</td>
<td>Latino or Hispanic</td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Jacon Yama</td>
<td>American Indian or Alaska Native</td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Jenny Nelson</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Jessica West</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Joan Neave</td>
<td>Latino or Hispanic</td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Joanna Kramer</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Karen Phelps</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Kathie Naylor</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Linda Oates</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Margaret Re</td>
<td>Latino or Hispanic</td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Margaret Jones</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Marian Redding</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Megan Fischer</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Megan Hunt</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Megan Wall</td>
<td>Latino or Hispanic</td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Monica Leaks</td>
<td>American Indian or Alaska Native</td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Noris Gajewski</td>
<td>Latino or Hispanic</td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Noris Rate</td>
<td>Asian or Pacific Islander</td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Pamela King</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Patricia Robbin</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Patty Grew</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Rosanne Pelle</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Sandie Reaing</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Sara Kajee</td>
<td></td>
<td>Current Student</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Mike Sherman Frazier</td>
<td>American Indian or Alaska Native</td>
<td>Current Student</td>
<td></td>
</tr>
</tbody>
</table>

04/23/2007
Each step of the report process is broken down into individual procedures. For information about Crystal Reports not addressed in this tutorial, see the Crystal Reports help file. To access the help file, from the Crystal Reports menu bar, select Help, Crystal Reports Help.

Step 1: Creating an Export File

Before creating a custom report, you need to decide what kind of information you want to present on the report and which fields you need from Blackbaud Student Information System to produce these results. We recommend drawing the report on paper first to help you think through your design. Once you have a clear idea of the data you need, you can create the export file.

When setting up your export, keep in mind that once you are working in Crystal Reports, only Blackbaud Student Information System fields included in the export file are available for the report. We recommend including all the fields you may need, including any you are not sure about. If you are missing a field, you have to update the export and refresh the report.

For our sample report, we create an export that includes applicant fields. For more information about creating export files, see the Export Guide for Blackbaud Student Information System.

Creating a new export file

1. On the navigation bar in Admissions Office, click Export. The Export page appears.
2. On the action bar, click New. The Create a New Export screen appears.
3. In the What type of export do you want to create? box, select “Applicant”.
4. In the Export format field, select “Blackbaud Report Writer Database (MDB)“.
5. Click **Create Now**. The New Applicant Export screen appears.

![New Applicant Export Screen]

6. We filter the export results with a query so only those who applied during the selected dates are included. On the Filters tab, choose “Selected” in the **Include** field for Applicants. The Selected Applicants screen appears.

7. Mark **Query**.

![Selected Applicants Screen]
8. In the **Query name** field, enter “Applicants by Date” and click **OK**. You return to the Filters tab and “Applicants by Date” appears in the **Selected Filters** field for Applicants.

![Image of Crystal Reports Filters tab]

9. Select the Output tab.

10. In the **Available Fields** box, a tree view lists all the criteria groups available for the Applicant export type. Click the plus sign next to the Applicant criteria group to view all of the fields available.

![Image of Crystal Reports Output tab]

11. To add a field from the tree view to the **Output** box, double-click the field or select the field and click **Select**. The field moves to the **Output** box.

![Image of adding fields to Output box]
For this example, we add the Applicant name, Age, Ethnicity, and Current status fields.

12. We then expand the Applications and Education/School criteria groups and add the Application date and Name fields.

13. To print or preview a control report listing the selected criteria groups, output fields, and field header names for the export, mark Create Control Report and select Print or Preview. The control report prints or previews after the export processes.

14. Click Export Now to run the export. The Export file name screen appears.
15. Browse to the location where you want to save the database file and enter “Applicant Statistics” in the File name field.

16. Click Save. You return to the export record and processing screens appear. When the export finishes, a screen appears telling you the number of rows exported and the time elapsed.

17. Click OK. You return to the export record.

18. Click Save and Close. The Save Export As screen appears.

19. Enter a name and description for the export record and mark if other users can run or modify this export.

20. Click Save. You return to the Export page.

**Step 2: Linking the Export File to a New Report**

After you create the export, you are ready to start building your custom report. In this procedure, you link the database file you created in Export to a new Crystal report.

- **Linking a Blackbaud Student Information System export file with a new Crystal report**
  1. From the Windows taskbar, click Start. Select Programs, Crystal Reports 11.
Crystal Reports opens and the Getting Started screen appears.

2. In the Getting Started frame, click Blank Report. The Database Expert screen appears.

3. Click the plus beside Create New Connection to expand the tree view.

4. Click the plus beside Database Files. The Open screen appears so you can find your Blackbaud Student Information System database file.
5. Highlight the .mdb file you created in Blackbaud Student Information System, and click Open. You return to the Database Expert screen. Notice all your database fields are listed in the tree view.

6. Highlight the path to your .mdb file in the Available Data Sources box.
Note: When you select the export format Blackbaud Report Writer Database (MDB) in Export, linking tables are included in the data file (in addition to the fields you select). Typically, you may not use this data in your Crystal report. However, it is best to select all data for your report in these beginning steps. By doing this, you avoid repeating steps if you leave intended fields for your report behind.

7. To move all of the fields in the .mdb file to the Selected Tables box, click the right double arrow button. The fields appear in the box to indicate they have been included for your Crystal report.

Note: The Visual Linking Expert screen shows the tables in the export file, and how they link together. For most reports, you do not need to alter these tables or their links manually. When you click OK, Crystal Reports automatically links the tables correctly.
8. Click OK. The Visual Linking Export on the Links tab appears.

![Database Expert](image)

9. Click OK.

**Note:** The Workbench appears on the right side of the screen. You use the Workbench to contain projects that have one or more reports. For more information, see the *Crystal Reports XI* help file. To remove the Workbench from your screen, click the X in the top right corner of the screen.

10. The blank Crystal report is now available.
11. To display the **Field Explorer** frame, select **View, Field Explorer** from the menu bar. The frame appears on the right side of the screen.

12. This frame contains all the fields you exported from **Blackbaud Student Information System**. You will use these fields to build your report.
Step 3: Adding and Organizing Report Data

You are now ready to start adding data to the report. The Design tab is divided into five major sections to help you organize your report.

- **Report Header.** The Report Header appears at the top of the first page of the report. It includes information such as the title page, company logo, or introductory information.

- **Page Header.** Information in the Page Header section, such as the print date/time or report title, appears at the top of each page of the report.

- **Details.** The Details section is the largest area of the report and holds the bulk of the data. You place database fields and formulas in this section.

- **Report Footer.** The Report Footer appears at the bottom of the last page of the report. You can insert grand totals or summary data in this section.

- **Page Footer.** The Page Footer appears at the bottom of each page of the report. This is a good place for page numbers and explanations about figures in the report.

If you add a group, summary, or subtotal to the report, the program creates a Group Header and Group Footer.

- **Group Header.** The Group Header holds the group name field. It appears once at the beginning of a group, directly above the details section.

- **Group Footer.** If you add a summary, the summary value appears in the Group Footer. It appears once at the end of a group, directly below the details section.

### Inserting Data Fields

You use the Field Explorer to add data fields to the report. The Field Explorer contains all the **Blackbaud Student Information System** data fields you included in the export.

For this example, we insert these fields:
Inserting fields into a new report

1. From the new report, on the Field Explorer screen, click the plus sign next to Database Fields. The data tables from Blackbaud Student Information System appear.

   Note: The export process adds links and identifier keys to the database file, in addition to the data fields. Make sure to insert only fields in the report, not LINKs or IDKEYs.

2. Click the plus sign next to each of the tables. The data fields from each table appear.
3. Select **ApptsAppt_Applicantname**. Click and drag it to the left side of the Details section. Release your mouse to drop the field in place.

When you add a field to the Details section, *Crystal Reports* automatically adds the field name to the Page Header section above the field. You can change the field heading text to make it more reader-friendly. For more information see, “Editing Field Headings” on page 18.

4. Click and drag **ApptsEdu_1_01_Sch_Name** into the Details section next to **ApptsAppt_Applicantname**.

5. Continue adding fields. For this example, we also add the **ApptsAppt_Age**, **ApptsAppt_Ethnicity**, **ApptsAppt_Currentstatus**, and **ApptsAppls_1_01_Applicationdate** fields to the Details section.

6. When finished inserting fields on the report, close the Field Explorer screen.
7. To preview the report, click the **Print Preview** button on the toolbar. The Preview tab appears displaying the report.

### Resizing Fields

If the standard length or height of a field is too large or too small to display your information correctly, you can adjust its size after you place it on the report. If the field’s frame is too small, the data will be truncated. If the frame is too large, there will be too much white space between fields.

For this example, we resize the **ApptsAppt_Applicantname** field.

1. On the Design tab, click on the **ApptsAppt_Applicantname** to select it.
2. Move your cursor over the small black square on the right side of the selected frame until it changes to a double arrow.

---

**Note:** You may need to resize and move fields several times during the report creation process.
3. Using the double arrow, click and drag the frame to the left to shorten the field size, or to the right to lengthen the field.

4. To save time, you can resize multiple fields at one time. Select a field and then press and hold the CRTRL key while selecting the other fields.
5. Release the CRTRL key and using the double arrow, shorten or lengthen one of the selected fields. As you resize the field, the size adjustments are made to the other selected fields too.

Moving Fields

Once you insert fields, you can move them around on the report to adjust the spacing and improve the layout. You can use guidelines on the Design and Preview tabs to help you align and size fields precisely. To view guidelines, from the View menu, select Guidelines in Design and Guidelines in Preview. While some guidelines are added automatically when you insert a field, you can also add additional guidelines by clicking on the ruler at the top or left side of the Design and Preview tabs.

For this example, we move the ApptsEdu_1Sch_Name field.

Moving fields in a report

Note: You may need to resize and move fields several times during the report creation process.

1. On the Design tab, click on the ApptsEdu_1Sch_Name to select it.
2. Drag it to the left closer to the `ApptsAppt_Applicantname` field.

3. To save time, you can move multiple fields at one time. Select a field and then press and hold the **CTRL** key while selecting the other fields.

4. Release the **CTRL** key and drag the selected fields to the new location.

**Note:** To create more or less space in sections, move the bar separating the sections up or down.

---

**Editing Field Headings**

*Blackbaud Student Information System* exports program field names whose meanings are often not intuitive to your report’s audience. You can change the name of a field heading on your report to make it more reader-friendly; for example, you can change “ApptsAppt_Applicantname” to “Applicant”.

For the sample report, we update all the field headings in the Page Header section.

1. **Editing field headings**
   1. On the Design tab, in the Page Header section, select the `ApptsAppt_Applicantname` field heading.
2. Right-click and select **Edit Text Object** from the submenu. An active cursor appears in the field header frame.

3. Replace the “ApptsAppt_Applicantname” with “Applicant” and then click once outside the frame.

4. Continue by updating the other field headings.

5. Select the Preview tab to view the updated headings.
Sorting Records

You can sort the order records appear in the Details section of the report. The type of data field you sort by determines the sorting method. For example, if you sort by a text field, the data sorts alphabetically, while a date field sorts in chronological order.

For this example, we sort by applicant name.

- **Sorting records**
  1. On the Preview tab of the report, click on a name in the Applicant column. All names in the column become selected and are treated as one field.
  2. On the toolbar, click the Sort Order button. The Record Sort Order screen appears.
  3. In the Report Fields box on the left, select the ApptsAppt_Applicantname field and click Add to move it into the Sort Fields box on the right.
  4. In the Sort Direction box, select Ascending.
5. Click OK. Applicants are now sorted according to name.

Grouping Records

You can use groups to sort data and break it up into meaningful sections. You can also add summary information to groups, such as subtotals, counts, or averages.

When you create a group, the program adds a group header section above the group for the group name field and a group footer section below for any subtotals or summary values.

If you create multiple groups, on the Preview tab, you can use the group tree on the left to view your groups in an outline form. Using the group tree, you can quickly jump to the beginning of a group by clicking on the group name. If the group tree is not visible, click the Toggle Group Tree button on the toolbar.

For this sample report, we group applicants by age.
Grouping records

1. On the Design tab of the report, select Insert, Group from the menu bar. The Insert Group screen appears.

2. In the first field, select the field to group the data by. For this example, we select ApptsAppt_Age.

3. In the second field, select the sort direction. You can sort in ascending, descending, specified, or original order. Original order groups records in the order they appear in the database file. If you select specified order, you can create custom groups based on database fields.

   For example, we want applicants grouped and sorted by age in ascending order.

4. If you sorted by ascending, descending, or original order, in the Group Options frame, you can select a group name. The default group name is the field you are grouping by. Mark the Customize Group Name Field checkbox to use a different field value. You can select one of these options:

   • Choose From Existing Field — Select this option to select a different field for the group name. For example, your report is grouped by School ID, but you would rather display the School name.

   • Use a Formula as Group Name — Select this option to create a formula for the group name. Click the Group Name Formula button and the Group Name Formula Editor screen appears. For more information about creating formulas, see the Crystal Reports help file.

5. You can mark Keep Group Together to prevent groups from breaking at the end of a page. If there is not enough room for the entire group on a page, the program prints the group on the next page rather than splitting it into parts across two pages. We mark this option for our report.

   Note: To hide the group header name, right-click the group header, select Format Field, and click Suppress on the Common tab of the Format Editor.

6. You can mark Repeat Group Header on Each Page to print a new group header at the top of each page if a group is spread over several pages. Otherwise, a group header prints only at the beginning of the group. We leave this option unmarked.
7. Click OK to close the Insert Group screen and return to the report. A group header section appears.

8. For our example, we also move the age group to the Details section so it aligns with the other fields. For more information about moving fields, see “Moving fields in a report” on page 17. We also add a field heading for the group. For more information, see “Inserting Text Fields” on page 30.
Adding Subtotals, Summaries, and Grand Totals

Once you create groups, you can add summaries and subtotals in the Group Footer. You can also add grand totals to the end of the report in the Report Footer. You can create subtotals for numeric or currency fields only.

For our sample report, we add a summary count of applicants for each age level group and a grand total of all applicants at the end of the report.

- **Adding summary counts**
  1. To add a count of applicants per age level, from the menu bar on the Design tab, select **Insert, Summary**. The Insert Summary screen appears.
  2. In the **Insert a field which calculates the [ ] field**, select “count”.
  3. In the second field, select the field to count. For this example, we select “ApptsAppt_Applicantname”.

9. Select the Preview tab to view the report.
4. In the **When the report is printed, the records will be sorted and grouped by [ ] field**, select the group or field to sort and group by. In this case, we use “Group #1: ApptsAppt.ApptsAppt.Age-A”.

5. Click **OK**. You return to the Design tab of your report and the count appears in the Group Footer #1 section.
Adding grand totals

1. To add a grand total of all applicants, from the Preview tab, click on an applicant name in the Applicant column. All names in the column become selected and are treated as one field.

2. Right-click and select Insert, Grand Total from the submenu. The Insert Grand Total screen appears.
3. Select “count” in the first field.
4. In the second field, we use the default field, ApptsApplicantname.
5. Click **OK**. You return to the Preview Tab. A new grand total appears in the Report Footer section.

![Crystal Reports screenshot](image.png)

**Filtering Report Results**

The Select Records Expert is a filtering tool in *Crystal Reports* you can use to limit the results of your report without having to change your report or export design. For this example, we filter the results of our report to show only applicants aged 17 and older.

- **Using the Select Records Expert in a report**
  1. From the Preview tab, from the menu bar select **Report, Select Expert**. The Choose Field screen appears.
  2. Select the field to filter by and click **OK**. For this example, we select ApptsAppt.ApptsAppt_Age. The Select Expert screen appears.
  3. In the first field, select “is not one of.” A second field appears.

**Note:** In most instances you can use an easier formula value, such as “is between” or “is not between”, or “is greater than” or “is less than”. 
4. Select every age less than “17” in the field. This equation tells the program to show only applicants aged 17 or older.

5. Click OK. A screen appears asking if you want to use data saved from the last time you made a change or if you want to refresh the data.

6. Click Refresh Data. You return to the Preview screen of your report. Only applicants aged 17 or older appear on the report.

Suppressing Fields

You can use the suppress fields options to hide values you do not want to appear in the report. You can hide all instances of a field or, if a field is followed directly by its duplicate, you can suppress duplicates so the value displays just once.

- **Suppressing duplicate fields**
  1. To suppress duplicate ages, from the Preview tab, click on an age in the Age column.

  2. Right-click and select Format Field from the submenu. The Format Editor appears displaying the Common tab.

  *Note: Be careful not to mark the Suppress checkbox at the top of the screen. Marking this checkbox excludes all the selected data.*
3. Mark **Suppress If Duplicated** at the bottom of the screen.

4. Click **OK**. The **Age** column now displays each age only once.
Step 4: Formatting the Appearance of the Report

After you add data to the report, you can format the report's appearance. *Crystal Reports* offers a variety of formatting options to help you create a professional report. You can format the font, size, style, and color of fields and select the format for dates, numbers, and other values. You can also insert lines, borders, and graphics to draw attention to data and you can insert text fields for titles or labels. Most design and format changes can be made from both the Design and Preview tabs.

### Inserting Text Fields

You can insert text fields for titles, labels, notes, callouts, and mail merge letters. You can also combine text fields with database, formula, and special fields so you can manipulate these as one entity. For example, if you have separate fields for the **Student First Name** and **Student Last Name**, you can insert these in a text field so the fields are formatted, sized, and moved as one item. Also, when a field is combined with a text field, the program automatically adjusts the field’s size so there is no extra white space on either side.

For our sample report, we insert a report title and add labels for the grand total and subtotal fields.

- **Inserting a report title**
  1. From the Design tab of the report, click the **Insert Text Object** button on the toolbar. A text box appears with your pointer.
  2. Drag the box down into the Report Header section and click once to place the text box. An active cursor appears in the text box.
  3. In the text box, enter “Applicant Statistics” and then click once outside the box, or press the **ESC** key on your keyboard.

Note: To create more or less space in sections, move the bar separating the sections up or down.

4. To center the title across the report, select the title and using the black squares on either side of the box, stretch the field to the left and right across the entire length of the Report Header section.
5. On the toolbar, click the **Align Center** button. The title moves to the center of the report.

6. Select the Preview tab to view the new title.

- **Inserting field labels**

  **Note:** As you make formatting changes, you may need to resize and move fields. For more information, see “Resizing fields in a report” on page 16 and “Moving fields in a report” on page 17.

  1. From the Design tab of the report, click the ab button on the toolbar. A text box appears with your pointer.

  2. Drag the box to the Group Footer #1 section and drop it next to the summary count field. An active cursor appears in the text box.

  3. In the text box, enter “Total by age” and then click once outside the box, or press the **ESC** key on your keyboard.

  4. To add a label for the grand total field, we repeat these steps and insert the text field in the Report Footer section.
5. Select the Preview tab to view the new labels.

Inserting Special Fields

You can insert special fields in the report that update automatically as information changes, such as page numbers, record numbers, group numbers, print dates, and total page counts. You can also combine special fields with text fields so you can manipulate these as one entity. For more information about combining fields, see “Inserting Text Fields” on page 30.

For this example, we insert a print date field that updates with the current date each time you print the report. For more information about other special fields, see the *Crystal Reports* help file.

- **Inserting a date field**
  1. From the Design tab of the report, on the menu bar, select **Insert, Field Object**. The Field Explorer screen appears.
2. Expand the Special Fields group.

![Field Explorer]

3. Click and drag the **Print Date** field to the bottom right of the report and drop it in the Page Footer section.
4. Select the Preview tab. The report now displays the print date.

Formatting Fields Using the Format Editor

You can use the Format Editor for a variety of tasks, such as formatting text, lines, borders, numbers, dates, and graphics. The tabs and options available on the Format Editor change depending on the type of field you select. For example, if you select a date field, the Date/Time tab appears.

For our sample report, we use the Format Editor to change the font style, size, and color of text. We also change the date format. For more information about other Format Editor options, see the *Crystal Reports* help file.

- **Formatting text**
  1. From the Design tab of your report, select a field heading and right-click.
  2. Select **Font** from the submenu. The Format Editor screen appears displaying the Font tab.
  3. In the **Font** field, select “Verdana”.

  **Note:** As you make formatting changes, you may need to resize and move fields. For more information, see “Resizing fields in a report” on page 16 and “Moving fields in a report” on page 17.

  4. In the **Style** field, select Bold”.
  5. In the **Size** field, select “10”.
  6. In the **Color** field, select “Navy”.
7. Mark the **Underline** checkbox.

![Format Editor](example.png)

8. Click **OK**. The Format Editor closes and you return to the report.

9. We continue until all report text is formatted. To make changes to multiple fields at once, press the **CTRL** key on the keyboard while selecting each field on the Design tab. Right-click and select **Format Objects**.

10. Select the Preview tab to view the changes.
Formatting date fields

Note: As you make formatting changes, you may need to resize and move fields. For more information, see “Resizing fields in a report” on page 16 and “Moving fields in a report” on page 17.

1. From the Preview tab, click on a date in the Date Applied column. All dates in the column become selected and are treated as one field.

2. Right-click and select Format Field from the submenu. The Format Editor screen appears displaying the Date/Time tab.

3. In the Style box, select “3/1/99”.

4. Click OK. The Format Editor closes and you return to the report. The Date column now displays reformatted application dates.

Adding Lines and Borders

You can add lines and borders to separate or draw attention to data and headings. You can add a border using the Format Editor or you can draw a box around the area or item and format it as a border. When you use the Format Editor, the program fits the border around the field’s frame and you can not resize the border without resizing the field. To prevent this issue, you should draw the border using the box tool.

For this example we add lines between each grade level group and add a border to the report grand total.

Adding lines

Note: To create more or less space in sections, move the bar separating the sections up or down.

1. On the Design tab, select Insert, Line from the menu bar. Your cursor becomes a pencil you can use to draw the line.
2. In the Group Footer # 1 section, click and drag the pencil to draw a line under the subtotal field from the left margin to the right.

![Screenshot of Crystal Reports]

3. Select the line and right-click. A submenu appears.
4. Select **Format Line**. The Format Editor appears.
5. In the **Style** field, select “Single”.
6. In the **Width** field, select “1 pt”.
7. In the **Color** field, select “Red”.

![Format Editor Screenshot]

8. Click **OK**. You return to the report.
9. Select the Preview tab. A red line appears under each grade level group.

![Image of Crystal Reports]

- **Adding borders**
  1. On the Preview tab, select the **Insert, Box** from the menu bar. Your cursor becomes a pencil you can use to draw the border.
  2. Click and drag the pencil diagonally across the grand total field. As you drag the pencil, a box is drawn around the field.
  3. To format the border, right-click on the box. A submenu appears.
  4. Select **Format Box**. The Format Editor appears.
  5. In the **Style** field, select “Single”.
  6. In the **Width** field, select “1 pt”.
  7. In the **Color** field, select “Navy”.
  8. Mark **Drop Shadow**.
9. In the Fill frame, mark **Color** and select “Silver” in the field that appears.

10. Click **OK** and you return to the report. The border is now formatted.

---

**Step 5: Saving the Report**

**Note**: Use **Save Data with Report** option if you plan to distribute the report to users who do not have access to the original database.
You can save your report with data or save only the report parameters. If you select the **Save Data with Report** option, the program saves a static version of your data with your report. The next time you open the report, the data appears exactly as it existed when you saved the report — any changes in the database since that time do not appear. Use the **Save Data with Report** option if you plan to distribute the report to users who do not have access to the original database. You can always later refresh the report to update the data. For more information about refreshing reports, see “Refreshing a Crystal report” on page 41.

If you save the report parameters without data, each time you open the report the data refreshes automatically so it displays the most recent data available from the database. This is helpful for reports you run on a regular basis using the same parameters.

- **Saving a Crystal report**
  1. From the menu bar of the open report, select **File, Save Data with Report** to save your report with data or **File, Save** to save only the report layout. A check mark appears next to the option you select.

  ![Save Data with Report](image1)

  2. On the toolbar, click the **Save** button. The Save As screen appears.

  3. In the **File name** field, enter the name of your report, for example, “Applicant Statistics Report”.

  4. In the **Save as type** field, select “Crystal Reports for Blackbaud”.

  ![Save As](image2)

  5. Click **Save**.
6. To close your report, click the X button in the top right corner.

**Refreshing a Report**

You can refresh a report to include the current data. To do this, update the export in *Blackbaud Student Information System* to get the latest data and then refresh the saved *.rpt* file.

- **Refreshing a Crystal report**
  1. In *Export*, open the export to update.

  **Note:** If your export uses a static query to filter, you need to refresh the query before you refresh the export.

  2. Make any changes and then click *Export Now* to refresh the results. The Export File Name screen appears.

  ![Export file name screen](image)

  3. Save the *.mdb* file using the same file name. A message appears asking if you want to replace the existing file. Click *Yes*.

  4. In *Crystal Reports*, open the saved *.rpt* file you want to refresh.
5. Click the **Refresh** button on the toolbar. The report refreshes and the newest data appears.

Setting the Database Location for a Saved Report

If the file name or location changes for the database attached to your report (for example, you move the database to a different drive or need to attach a different database file to the report parameters), you can use **Set Location** to point the report to the database’s new location.

**Note:** You must save the report before you can use the **Same as Report** button.

You can also click the **Same as Report** button on the Set Location screen to set the location of the selected database to the same path as the report. This feature makes it easier to distribute the report to other users because they can place the report and database in any location they choose and the report will always find the database if it is in same folder as the report.

- **Setting the location for an existing Crystal report**
  1. Open the saved *.rpt file.
  2. Select **Database, Set Location** from the menu bar. The Set Location screen appears.
3. Click **Set Location**. The Data Explorer screen appears.

4. In the tree view, click the plus sign next to the Database Files folder.

5. Select **Find Database File**, and click **Set**. The Open screen appears.

6. Browse to the *.mdb file’s new location and click **Open**. You return to the Set Location screen. (The original *.mdb file path still appears in the **File** field. This changes after you complete the following steps.)

7. Select the first table in the list and click **Set Location**. The Data Explorer screen appears again.

8. Click **Set**. A message appears asking if you want to apply these changes to the other tables with the same original information.

9. Click **Yes**. You return to the Set Location screen. The new *.mdb file path appears in the **File** field.

10. Click **Done**. You return to your Crystal report.