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Welcome to the GIFTS
Administrator
Congratulations for choosing GIFTS! GIFTS is a highly flexible
software application that you can customize to meet the needs of
your organization. This manual includes step-by-step instructions for
using the GIFTS Administrator Module to set up your installation of
GIFTS.
This manual also contains information about the optional GIFTS
Customizer Module. The Customizer Module allows GIFTS
administrators to add custom data fields to GIFTS records. Data in
these fields can then be added, viewed, modified, and reported on in
GIFTS.
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About the Administrator Module
In most organizations, the staff member designated as the GIFTS
administrator is responsible for setting up and administering GIFTS. The
administrator should understand the use of the Code Tables, classification
codes, security, letter templates, grant requirements, and other system
options described in this manual.
For more information about planning the implementation of your system,
please refer to the GIFTS Setup Course Manual that you received during your
GIFTS training; the accompanying GIFTS Setup Implementation Workbook
includes worksheets that can help you plan and track your implementation.
Note: If you are using Essential GIFTS, the level of functionality that you

have is dependent upon which of the options, such as the Contacts Manager,
that you have purchased. Please be sure to read “Essential GIFTS
Functionality” below for more information.
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Conventions Used in This Manual
Before you read the Administrator’s Guide, it is helpful to familiarize yourself
with the conventions used throughout this manual. Doing so will enhance
the usefulness of the documentation.

Essential GIFTS Functionality
For users of Essential GIFTS, the level of functionality that you have is
determined by which options, such as the Contacts Manager, that you have
purchased. The following icons are used in this manual to indicate which
features are available on your system.
Icon

Description
This feature is available for users of the Contacts Manager option.
This feature is available for users of the Correspondence option.
This feature is available for users of the Calendar / Activity
Tracking option.
This feature is only available in GIFTS.

Please note that the name “GIFTS” is used generically to refer to any
configuration of the system, including the Essential GIFTS configurations.
Since GIFTS is a modular system available in a variety of configurations, the
screens shown in this document may not always reflect the configuration of
your system.
Example: The number of folders displayed in the GIFTS Organizer is

dependent upon your configuration. Here are the Organizer folders for a
basic GIFTS configuration:

Conventions Used in This Manual
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These are the folders for a system with optional modules:

Procedural and Typographic Conventions
Procedural conventions help identify procedures and tasks you’ll perform.
❖

Important procedures are always given as a numbered set of tasks.

❖

Check marks indicate a checklist of general items or tasks.

❖

Characters given in this font are examples of data that you should enter,
such as the directory path to a file.

❖

Data elements within the GIFTS system are presented with an Initial
Capital Letter. For example, the word “request” is capitalized when it is
used to refer to a Request record within GIFTS.

Different Types of Notes
When appropriate, notes provide additional information or warnings that
may apply to you. The Administrator’s Guide uses four types of notes. Each
type of note serves a unique purpose as defined below.
Note: A note with this format and the heading “Note” provides information

that applies to some users. Notes apply to special situations. For example, a
Note might explain minor differences in setup procedures among network
and standalone systems.
Important: A note with this format and the heading “Important” provides

information that applies to all users. This type of note provides information
that is essential to the completion of a task. Unlike a Note, Important notes
should not be disregarded.

x
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Caution: A note with this format and the heading “Caution” provides

important information that applies to all users. Pay special attention to these
notes.

Tip: A note with this format and the heading “Tip” provides useful
information that applies to most users. Although Tips are not essential to
the completion of a task, they provide alternative methods, shortcuts, or
special applications relating to the procedures in the text.
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Chapter Summaries
Use the procedures in this manual to set up and maintain your GIFTS
system. Following is a brief description of the chapters in this manual.
Chapter

Description

“Getting Started” on page 1

Describes the basics of defining your GIFTS workflow,
GIFTS setup, and entering historical data into the system.
It also describes how to start the Administrator Module.

“Maintaining the Open
Classification System” on
page 13

Develop the Code Tables and codes used in the coded
fields throughout the system and in the Coding Sheets
used to classify Requests, Organizations, and Contacts.

“Setting the System
Preferences” on page 43

Set system options, including the location of your word
processor and spreadsheet programs so that they may
work in conjunction with GIFTS.

“Controlling Access to
GIFTS” on page 89

Each authorized user of GIFTS must be identified to the
system. You can determine the level of access granted to
each user group on your system.

“Setting Default Grant
Requirements” on
page 117

To streamline your data entry, this facility allows you to
set up default Requirements that are automatically
attached to new proposals and grants.

“Setting Up Multi-Currency
Options” on page 121

If you engage in international grant-giving, you may want
to track the value of your giving to your recipients using
another currency. This chapter explains how to set up and
maintain exchange rates for other currencies.

“Defining Correspondence
Templates” on page 159

All grant makers send letters and correspondence to the
Organizations that request funding and to other people
associated with the grant making process.
You can create correspondence templates that merge your
standard letters with information in the GIFTS database.
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Chapter

Description

“Managing GIFTS Reports”
on page 193

The GIFTS Report Library contains more than 200
templates for generating presentation-quality reports.
This section discusses how to manage your Report Library.

“Maintaining Your GIFTS
Data” on page 209

Describes the utilities that you can use to consolidate
“duplicate” data records, recalculate summary fields, and
purge old documents from your system.

“Customizer Planning” on
page 217

This and the following chapter provide information to
clients using the optional GIFTS Customizer Module. The
Customizer Module allows you to create custom forms for
GIFTS records, in which you can record data specific to
your needs.
Before you create custom forms, it is a good idea to plan
your needs for data fields and other elements on paper
first. This chapter describes how to plan the customizing
of your GIFTS system.

Chapter Summaries

“Building Custom Forms”
on page 235

This chapter describes how GIFTS Customizer Module
users design the data entry forms used to enter their
custom data.

“Setting Up Branch
Security” on page 291

Branch Security allows grantmakers with multiple sites to
capture all of their information in a centralized database,
while preventing users from different branches from
editing (or viewing, if desired) each other’s data.

“Importing Matching GIFTS
Summary Data” on
page 263

Describes how to import matching gifts summary data
from an external system into GIFTS.
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Using the GIFTS Documentation Set
The GIFTS documentation provides step-by-step procedures and reference
information on GIFTS features. These manuals assume you have a working
knowledge of your operating system and its conventions, including how to
use a mouse and standard menus.
GIFTS includes the following documentation.
Describes how to use GIFTS to manage your giving,
including how to enter data, search for data, and run reports from the
GIFTS Organizer.

GIFTS User’s Guide

Installation and Technical Reference Guide

Contains system requirements

and detailed installation procedures.
Describes how to run reports from the GIFTS Report
Library. Includes a variety of sample reports for the GIFTS and Employee
GIFTS products.

Using GIFTS Reports

Describes how to set up and maintain your
GIFTS system. This manual should be read by the person within your
organization designated as the GIFTS Administrator.

GIFTS Administrator’s Guide

Related Documentation
If you use optional GIFTS modules such as Employee GIFTS or the Internet
Grant Application Manager, you will receive additional documentation.
Describes how to track matching gifts and
volunteer gifts with the Employee GIFTS Module.

Employee GIFTS User’s Guide

Describes how to use the Budget Module to
track your committed, granted, and paid funds.

Budget Module User’s Guide

Describes how to review
grant applications that have been submitted through the Internet.

Internet Grant Application Manager User’s Guide

Describes how to use the A/P Module to share
data with an external accounting system or to print checks.
A/P Module User’s Guide

Describes how to import data from external
systems into the GIFTS database.

Import Module User’s Guide

xiv

Using the GIFTS Documentation Set

The GIFTS Connections Documentation Set
If you have set up a GIFTS Connections server and have users and/or
reviewers accessing GIFTS data online, you will receive additional
documentation.
Describes how to get the most out of your online
GIFTS data access using MyGIFTS.

MyGIFTS User’s Guide

Describes how to set up GIFTS Connections
and MyGIFTS to grant your users online access to GIFTS data.

MyGIFTS Administrator’s Guide

Describes how to
extend the functionality of the GIFTS Reviewers Module by granting
reviewers online access to their Reviews.

Reviewers Module and ReviewerConnect User’s Guide

For more information on the resources available to you as a MicroEdge
client, please refer to the MicroEdge Client Resource Guide.

Using the GIFTS Documentation Set
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Using Online Help
While you work with GIFTS, you can find answers to your questions by
reading the documentation or by using GIFTS online help. Use online help
when you need immediate assistance. Most of the material that is in the
documentation is also in online help.
From the Help menu of any GIFTS module, you can:
Choose

To

Contents

Display the contents of the GIFTS online help.

Index

Display the index of the GIFTS online help.

MicroEdge on the Web

Go to the MicroEdge Home Page.
(http://www.microedge.com)
❖ MicroEdge Knowledgebase
❖ GIFTS Compatibility Fact Sheet
These links now take you to the MicroEdge Support
Services webpage.
For access to the current knowledgebase and
online documents please login to GIFTS PowerME.

xvi

Technical Support

Display information about contacting MicroEdge
Technical Support.

About GIFTS

Display copyright and release information for
GIFTS.

Using Online Help

Maintenance and Support Program
Members of MicroEdge’s Maintenance and Support Program receive
unlimited telephone consultation on the use of the software, assistance in
error isolation and correction, prompt furnishing of any available problem
solutions relating to the currently supported versions of GIFTS, and
software updates.
Our toll free Technical Support hotline is available Monday through Friday,
8:00 A.M. to 8:00 P.M. Eastern time. You may contact MicroEdge’s Technical
Support Specialists as follows:
Phone

1-877-704-3343

E-mail

helpdesk@microedge.com

Web

Go to www.microedge.com and login to the PowerME portal
to access the knowledgebase and submit a new case if
necessary.

Note: To access the web, you must have an Internet connection (either a

LAN connection or a dial-up connection) and a frames-enabled browser
(Microsoft Internet Explorer 8.0 or later, or Firefox/Chrome).
For details about our support policies, please refer to the MicroEdge Client
Resource Guide. If you have any questions regarding the Maintenance and
Support Program, please contact our Client Administration Representative
at 1-800-899-0890, option 6, then 2, who will be happy to assist you.

Maintenance and Support Program
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Using the Documentation
MicroEdge provides you with the GIFTS documentation in Portable
Document Format (PDF). To view these files, you will need to install
Adobe®’s Acrobat® Reader, which is available for free from Adobe Systems,
Inc. at http://www.adobe.com.
The documentation allows you to print out selected pages, sections,
chapters, or the entire book. You can also install the files on your computer
or network so you can access them online, and take advantage of features
such as a “hot” table of contents, index, and cross-references within books.
Acrobat Reader’s other features are described in the Reader’s online Help.
Note that MicroEdge does not provide technical support for the Acrobat
Reader. We cannot assist you with the installation, configuration, or use of
this product.

xviii
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Getting
Started

This chapter describes the major steps needed to implement GIFTS
before you begin to enter your grant making data.
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Setting Up GIFTS
Please keep the following considerations in mind as you plan the
implementation of your GIFTS system. For information about installing or
upgrading GIFTS, please refer to the Installation and Technical Reference
Guide.
✔ For each of your giving programs, such as “cash grants” or “in-kind
giving,” define a workflow. Each workflow should encompass the entire
life cycle of requests—from receipt, to approval or declination, to final
closure.
✔ Define the roles and responsibilities of each member of your staff for each
giving program.
✔ Define and set up the classification codes you will be using for your Coding
Sheets. For example, Request Coding Sheets enable you to set up
classifications like “Program Area is Education.”
✔ Define and set up the System Code Tables. (The System Code Tables
define the options—like the Request Status categories and Contact
Roles—available in the pull-down lists used throughout GIFTS.)
✔ Set up your system preferences. In particular, you should determine
whether GIFTS should search for duplicate Organization or Contact
records during data entry.
✔ Identify which reports from the GIFTS Report Library you will use and
define how and when your staff will use them. For samples of the GIFTS
reports, please refer to Using GIFTS Reports.
✔ Set up your correspondence templates. GIFTS can merge your data into
both printed letters and e-mail messages.
✔ Set up GIFTS user accounts based on the responsibilities of your staff.
✔ Create a procedures guide for your staff. This should include your data
entry, reporting, and grant management procedures—as well as any other
GIFTS functions used by your organization.
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✔ Create a realistic time frame for your implementation. Given the items
listed here and the other matters you may be handling, how long do you
need to make the appropriate decisions and put them in place?
Once you have determined your workflow and procedures, you can set up
the GIFTS options as described in this manual.
Note: If you are using the optional GIFTS Budget Module, you must plan

and allocate your Budget for the current or coming year before any data
entry begins. Complete instruction is provided in the Budget Module User’s
Guide.

Setting Up GIFTS
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About Classifications
The GIFTS Open Classification System (OCS) is the means by which you
can classify the Requests, Organizations, and Contacts in your database. To
do this, you set up Coding Sheets that describe these entities, and you can
define the individual categories and classification codes used within these
Coding Sheets.
For instance, the Coding Sheet for Organizations can have a ‘Organization
Type’ category with classifications like ‘Civic & Community’ or ‘Education.’
You could then use these classifications to identify Organizations as either
Civic & Community organizations or Education Organizations.
Most grantmakers already have a manual classification system in place,
where they categorize each entry according to certain criteria. Others have
inherited a classification system from another software program. Setup is
the perfect time to make sure that your current classification system meets
your needs, and to expand or modify it as necessary.
Note: Essential GIFTS supports coding of Requests only.
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Defining Your Workflow
For each of your giving programs, you should define a workflow that
describes how requests are to be handled—from receipt, to approval or
declination, to the conclusion of grants management. The following
diagram illustrates the workflow of a cash grants giving program; you can
refer to this example when planning your own workflow:
Request
Received

Within
Guidelines?

No

Immediate
Declination

Yes

Log
Request

Reviewed by
Staff

Declined

Considered for
Board

Need More
Information

Send Letter

Update
Request

Send Letter

Create Write Up

Run Board Meeting
Agenda Report

(to Board meeting)
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(from Agenda Report)

Board Meeting

Declined

Approved

Send Declination
Letter

Schedule
Payments

Schedule
Requirements

Send Award
Letter

Grant
Management

Payments
* Process
* Resolve
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Delegating Tasks
Once you have defined your workflow, determine how you will divide
specific tasks and responsibilities among your staff. This ensures consistency
in data entry, and prevents duplication of effort.
To assist you, the following table is an example of how the daily tasks for a
typical grantmaker can be divided among staff members. Refer to this
example as you delegate your responsibilities

Delegating Tasks

Task

Performed By

Review incoming requests and separate immediate declinations
from those to be reviewed.

Program Staff

Enter declinations into the system and produce declination
correspondence.

Assistants

Enter proposals with all relevant information, and assign each to
a specific member of your staff.

Assistants

Gather information on proposals through site visits, telephone
calls, meetings, and so forth.

Program Staff

Update proposal information.

Assistants

Prepare write-ups for board meetings.

Assistants

Record board decisions and produce approval and declination
correspondence.

Assistants

Produce reports of payments due and check requests, update
payments.

Finance

Monitor grants.

Program Staff

Track payments.

Finance

7
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About Request Type, Disposition, and
Status
Since your organization may handle different types of Requests—for
instance, many grantmakers have a different workflow for each of their
giving programs—you can define a Request Type that identifies each type of
Request as belonging to the appropriate program. For instance, ‘Cash
Grants,’ ‘Dinners and Events,’ and ‘In Kind’ are commonly-used Request
Types.
At any given time, each Request in GIFTS has a Disposition and a Status.
You can use these two indicators to keep track of which stage in your
workflow a particular Request has reached.
There are three Dispositions, which give a general indication of a Request’s
place within your workflow:
Disposition

Type of Request

Pending

Proposals

Approved

Grants

Declined

Declinations

The Status of a Request gives more detail about its progress in your
workflow. For example, assume a Request has a Disposition of “Declined”
and a Status of “Declined by Staff.” With this information, you could tell
exactly where this Request resides within the sample workflow illustrated on
page 5.
The three Dispositions are permanently defined by the system because
these general classifications can apply to all Requests in any workflow. In
contrast, there are separate Status classifications for each Request Type in
your system.
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For example, a foundation might use the following Status codes for Cash
Grants Requests:
Disposition

Status Codes

Pending

Initial Review
Ready for Decision
Considered for Board

Approved

Active Grant
Closed Grant

Declined

Staff Declined
Board Declined

In contrast, the following Status codes would be more appropriate for
Dinners and Events Requests:
Disposition

Status Codes

Pending

Invited

Approved

Accepted
Attended
Tickets Donated

Declined

Declined

About Request Type, Disposition, and Status

Tables Full
Tables to be Filled
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Entering or Importing Historical Data
If you intend to enter historical data, you should decide what information
from your previous automated or manual system you wish to maintain in
GIFTS. Develop clear procedures for your data entry staff.
Make sure that your historical data is entered in the same manner as the new
information you will be tracking; data consistency is essential for accurate
reporting. For information about the GIFTS Quick Entry feature for
historical data, please refer to the GIFTS User’s Guide.
If you are using the optional Budget Module, you should also determine the
extent of the historical budget information you wish to enter. Most
organizations do not enter budget information for historical data.
If you have converted data from another grants management system, you
should review your data and/or coding structure.
If you want accurate reports that reflect both your current and historical
information, it is important that the data is entered in the same places within
the system and that it uses the same classification system.
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Starting the Administrator Module
The first time you log in to the Administrator Module, use the Admin Login
ID that comes with GIFTS. To prevent unauthorized use of the
Administrator Module, you should protect the Admin user name with a
password, as described in “Setting, Resetting, or Clearing a User Password”
on page 107.
You can also create other users that are permitted to log in to the
Administrator Module; for more information about system security, please
refer to “Controlling Access to GIFTS” on page 89.

Tip: You can also integrate your Windows NT logins with GIFTS. For more
information, please refer to “Setting the System Preferences” on page 43.

Logging In
You can start the Administrator Module from within GIFTS or from the
Microsoft® Windows® desktop. To log in from within GIFTS:
1 Log in to GIFTS as the Admin user.
2 Choose Options ➤ Administrator from the Main menu. The
Administrator Module starts. (Since you are already logged into GIFTS as
a user with permission to use the Administrator Module, you are not
prompted to log in.)
To start the Administrator Module from Windows:
1 Select MicroEdge GIFTS from the Programs folder of the Windows Start
menu, and then choose Administrator from the submenu.
You are prompted to log in:

Starting the Administrator Module
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2 Enter Admin into the Login ID field (or your user name if you or someone
else has already set up your system security).
3 Enter your password, if necessary.
4 Click OK. The Administrator Module starts.

Logging in as a Different User
In some cases, it is convenient to log in to another user’s workstation while
he or she is using GIFTS. You can log in without having to exit out of the
system or log in on another machine:
1 From the Administrator menu, choose Options ➤ Change User. You are
prompted to enter a Login ID to the system.
2 Log in and click OK.
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Maintaining
the Open
Classification System
This chapter describes how to set up and maintain the Open
Classification System used for Coding Sheets and coded data entry
fields.
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About the Open Classification System
In order to produce meaningful reports and queries, it is necessary to classify
the records in your database. For instance, if you want to see all of the grants
awarded to programs in Education, these grants would have to be classified
as Education grants in order for you to see this information.
In addition, you need to use consistent terms to classify information. For
example, you may want to use the following terms to describe your giving
programs: Cash Grants, Dinners & Events, and In-kind Giving.
If users could enter anything to describe the giving program for a grant—
such as ‘Cash Grants,’ ‘Cash,’ ‘Dinners and Events,’ ‘Dinners,’ and so
forth—you’d never be able to retrieve all the grants of a certain type.
To address these issues, the GIFTS Open Classification System (OCS) allows
you to create a set of categories and classifications that your users can use to
consistently classify your data. For example, for the category of ‘Program
Area’ you can include such classifications as ‘Arts & Culture’ or ‘Education.’
GIFTS stores your categories in Code Tables, and stores the classifications
within each Code Table as codes. To set up your classification system:
1 Set up your Code Tables (you can use some or all of the tables provided
with the system).
2 Enter the appropriate codes into each of your Code Tables.
The following sections describe the two areas of the system in which the
OCS codes are used:
❖

Coding Sheets for Requests, Organizations, and Contacts

❖

Coded fields for data entry

About Coding Sheet Setup
GIFTS allows you to classify Requests, Organizations, and Contacts with a
Coding Sheet. You define the Coding Sheets for each type of record to
include Code Tables that represent the categories of information that are
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important to you. During data entry, users enter classification codes into
these tables so that those records can be included in reports and queries.
Note: In Essential GIFTS, there are no Coding Sheets for Organizations or

Contacts, and you cannot add or remove the Request Coding Sheet
categories.
The Open Classification System gives you full control over both the Code
Tables included on the Coding Sheets, and the classification codes in each
table. For example, these are the codes for the Program Area Code Table:

Note that this Code Table has multiple levels, or “tiers”; you can define the
number of levels for each user-defined Code Table to meet your needs. By
using different levels to classify increasingly specific information, you
increase the flexibility you have in reporting.
You can choose to see information based on the broad categories on the top
level, or the very specific codes on the bottom level.
Important: Modifying your coding structure after you already have data in

your system can be complicated, so it is best to plan your classifications in
advance. The result will be an efficient, easy-to-use system.
Use the Implementation Workbook for the “GIFTS Setup” or “Introduction to
Essential GIFTS” training course to plan your classification system in
writing.

About the Open Classification System
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About Coded Field Setup
In addition to the Coding Sheet Code Tables used to classify Organizations,
Requests, and Contacts, GIFTS uses System Code Tables to define the
items—such as the Request Status categories, Contact Roles, and G/L
Account Codes—available in the coded fields used throughout the system.
For example:

You can modify the codes in System Code Tables in order to determine the
items that your users can use in the coded fields. However, you cannot add
or remove System Code Tables since each table corresponds to a specific
field within the GIFTS database.
Note: Unlike most coded data entry fields, the available values in the Support

Type and Fund fields displayed on Payment records are defined in Coding
Sheet Code Tables, not by System Code Tables. GIFTS is designed this way
so that these values can default to those chosen on the Request’s Coding
Sheet.
To plan the implementation of your system codes, you can use the
worksheets provided with your GIFTS Setup or Introduction to Essential GIFTS
training course.
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Maintaining the Code Tables
This section describes how to add, modify, and delete Coding Sheet Code
Tables so that the appropriate categories will be available for your Coding
Sheets. In addition, you can edit the classification codes in each table.
Note: Users of Essential GIFTS cannot create, modify, or delete Code

Tables.

Tip: You can add user-defined Coding Sheet Code Tables, but keep in mind

that many of the reports in the GIFTS Report Library use the pre-defined
Code Tables that come with the system. When practical, you should use the
pre-defined Code Tables so that your users can take advantage of as many
reports as possible.

Refreshing GIFTS Code Tables
You should keep in mind that whenever you make changes to the Code
Tables, they will not be available in the other GIFTS modules until you
refresh your system. Any other users who are logged into GIFTS when you
make changes will also need to refresh before they can see your changes.
To refresh GIFTS, choose Options ➤ Refresh System Settings from the
Organizer. GIFTS may also be refreshed by logging out of the system, then
logging back in.

Default Preferences for Coding Sheets
GIFTS includes the following Code Tables for use on your Coding Sheets.
You can modify these tables, but please note that the table name and the
number of levels for pre-defined Code Tables cannot be modified. You can
also add tables if these do not meet your needs.
The check marks (✔) indicate which tables are used on each Coding Sheet
type (Organization, Request, or Contact). For information about adding and
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removing Code Tables from the Coding Sheets, please refer to “Coding
Sheet Preferences” on page 70.
Coding Sheets

18

Table Name

Description

Org

Req

Age Group

The age group served by the Request or
Organization

✔

✔

Auspices

The overall auspices of the Organization.

✔

Budget Committee

An internal committee whose
jurisdiction the Organization or Request
is under.

✔

Conference Board

The Conference Board’s classification.

✔

Decline
Classifications

For Requests that are declined.

Ethnicity

The ethnicity of the population served by
the Organization or Request, or the
ethnicity of the Contact

✔

✔

Fund Donor

The fund donor from which the funds for
the Request or Organization will be
drawn.

✔

✔

Gender

The gender of the population served by
the Organization or Request, or the
gender of the Contact.

✔

✔

Geographical Area
Served

The geographic location served by the
Organization or Request (not necessarily
the Organization’s location).

✔

✔

Internal Program

An internal category, usually used to
track initiatives and projects distinct
from the Program Area.

✔

✔

Organization Type

The type of institution.

✔

Population Type

A general category used to track a target
population; often used to track
economic status or specific disabilities.

✔

Con

✔

✔
✔

✔

✔
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Coding Sheets
Table Name

Description

Org

Req

Program Area

The program under which the efforts of
the Organization or Request fall, such as
Education or Environment.

✔

✔

Support Type

The type of support requested, such as
project or endowment support.

✔

✔

Con

Adding or Modifying a Code Table
To add or modify a Code Table, use the following procedure:
1 From the Administrator menu, choose Setup ➤ Code Tables. The Table
Maintenance window opens. On the Coding Sheets tab, the Coding Sheet
Code Tables are displayed:
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2 To add a new Code Table, click New Table. Or, to modify an existing
table, highlight it and click Edit Table. The Table window opens:

Field

Description

Name

The name of the Code Table. Names can contain more
than one word. This field is limited to 50 characters,
including spaces. You cannot modify the name of a predefined Code Table.

Levels

The number of levels in the Code Table; each table can
have as many as five levels. The number of levels for predefined tables cannot be modified.

Max # of
Selections

The number of codes that users can supply in this Code
Table during data entry.
Example:Many grantmakers allow users to enter
more than one code in the Geographical Area
Served table so they can reflect the fact that a
grant serves more than one area.
In most cases, only one code should be provided in each
field on the Coding Sheet. When multiple selections are
allowed, the GIFTS Reports use the primary code to sort or
group data.
When you search for records or select a group of records to
include in a report, on the other hand, both the primary
and secondary codes are used.

Require Coding
at Lowest Level

20

Use this option to require that users enter codes at the
lowest (most detailed) level of this table.
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Field

Description

Track Amount
Percentages

Checking this box enables Percentage Coding for the code
values in the specific table. This then allows users to
allocate Request/Grant amounts by percentage in GIFTS,
IGAM, and MyGIFTS to selected code values.

2

Percentage Code Requirements:
❖

You must be on a SQL or Oracle database.

❖

This option is only available on tables associated with
the Request/Budget Code Sheet.

❖

The Max # of Selections must be set to 2 or greater to
enable this field.

❖

If using GCS, you must have version 3.6 or higher.

❖

If using Plus Pack, you must have version 5.1 or
higher.

3 Click OK to save the Code Table. You can add another Code Table, or
click Cancel to exit.
4 If you added a new table, add codes to the table as described in “Adding
Codes” on page 24.

Deleting a Code Table
You can delete a user-defined Code Table from your system at any time. The
codes within the Code Table are deleted as well, and all references to those
codes in your database records are removed. If you have used the Code Table
in a Coding Sheet, GIFTS warns you.

!

Caution: There is no way to retrieve a Code Table and its codes once you

have deleted them.
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To delete a Code Table:
1 From the Administrator menu, choose Setup ➤ Code Tables. The Coding
Sheet Code Tables are displayed on the Coding Sheet tab.
2 Highlight the table you wish to delete, and click Delete Table. If you have
already included the Code Table on a Coding Sheet and used it to classify
Requests, Organizations, or Contacts, a warning message is displayed.
3 Click Yes to delete the table.
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Maintaining Codes
You can add, edit, deactivate, delete, or replace codes in order to maintain
the integrity of your coding system and to match your needs as they evolve.
As with your Code Tables, be sure to plan how you will use your
classifications in advance, and use the Implementation Workbook for the
“GIFTS Setup” training course to plan your classification system in writing.
The following sections describe how to maintain the codes in your Code
Tables:
Adding Codes.......................................................................... 24
Editing Codes.......................................................................... 25
Deactivating and Activating Codes ........................................ 26
Deleting Codes........................................................................ 27
Transferring Codes ................................................................. 28
Replacing Codes...................................................................... 33
Sorting Codes.......................................................................... 40
Viewing and Printing Code Reports....................................... 41
Note that if you are working with a System Code Table or a pre-defined
Coding Sheet Code Table, there may be restrictions on the changes you can
make. For instance, you cannot delete certain pre-defined codes.

Refreshing GIFTS Codes
Remember that whenever you make changes to the Codes, they will not be
available in the other GIFTS modules until you refresh your system. Any
other users who are logged into GIFTS when you make changes will also
need to refresh before they can see your changes.
To refresh GIFTS, choose Options ➤ Refresh System Settings from the
Organizer. GIFTS may also be refreshed by logging out of the system, then
logging back in.

Maintaining Codes

23

2

Maintaining the Open Classification System

Adding Codes
To add classification codes to a table:
1 Select Setup ➤ Code Tables from the Administrator menu. The Table
Maintenance window opens.
2 Highlight the table you wish to edit and click Edit Codes. The Code
Maintenance window opens:

Use these buttons to
collapse and expand
the code levels.

You can also click on
the folders to collapse
and expand the levels.

3 In a single-level table, choose File ➤ New to add a new classification. In a
multiple-level table, you can:
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❖

Choose File ➤ New to create a new classification at the current level
(the same level as the highlighted classification).

❖

Highlight a code and File ➤ New Sub to create a subordinate
classification. For instance, if you create a subordinate classification
for a Level 1 code, you are creating a Level 2 classification beneath it:
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4 Enter the new classification:
❖

The Description is the full name of the classification that appears on
screen during data entry and in the GIFTS Reports. This field is
required.

❖

The Code is an optional value that can be used as an alternative to the
full description. If you choose to enter a Code, it will be displayed
next to the Description during data entry. It is used by grant makers
who enter data into GIFTS from paper forms that use code
abbreviations. Note that Codes are not displayed in the GIFTS
Reports.

5 Click OK. You are returned to the Code Maintenance window.
6 Click Save and Close to save your changes, or choose File ➤ Close to
cancel your changes.

Editing Codes
When you edit a code, every instance of that code in the system is updated
to reflect the change. All occurrences of the code within your reports,
searches, and data entry will use the new terminology.
Be sure to consider whether you are simply changing the terminology used
in its description, or whether you are also changing the meaning of the code.
If the term’s meaning is changing then all historical uses of the term should
be reviewed to ensure that they are consistent with the meaning of the new
term.
For example, changing the Organization Type classification’s Description
from ‘College’ to ‘Colleges & Universities’ does not affect its relationship to
your existing data. All of the Organizations that were coded as ‘Colleges’ are
described by ‘Colleges & Universities’ as well.
As another example, suppose the Organization Type ‘Education’ was
initially used to classify any Organization which was involved in education
or (as in the case of many public radio and television stations) that was
owned by an educational institution.

Maintaining Codes

25

2

Maintaining the Open Classification System

Later it was decided that this was not sufficiently precise and the term
‘Education’ would only be used for schools. Each organization would have
to be examined to see if it qualified. A new Organization Type would have
to be created to classify the public radio and television stations, and the
codes of those Organizations would have to be changed to reflect the new
type.
You can also replace codes with other codes in the database and revise the
structure of the codes in a table. For more information, please refer to
“Replacing Codes” on page 33.
To edit a classification code:
1 Select Setup ➤ Code Tables from the Administrator menu. The Table
Maintenance window opens.
2 Highlight the table you wish to edit and click Edit Codes. The Code
Maintenance window opens.
3 Highlight the classification code and choose File ➤ Edit. The Editing
‘[Code]’ window opens:

4 Edit the Description and/or Code.
5 Click OK. You are returned to the Code Maintenance window. Please note
that the changes you make to the Code Table are not saved until you exit
the Code Maintenance window.
6 Click Save and Close to save your changes, or choose File ➤ Close to
cancel your changes.

Deactivating and Activating Codes
To keep your coding structure up-to-date and still maintain accurate codes
for historical data, GIFTS allows you to specify codes as inactive. A code
marked as inactive is available on reports containing historical information
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and for queries, and will appear in existing data with “(Inactive)” beside the
Description. Inactive codes are not available during data entry.
To make a code inactive:
1 Go to the Code Maintenance window for the table in which the code
resides and click on the code to select it.
2 From the Code Maintenance menu, choose Action ➤ Deactivate. The
word “(Inactive)” appears following the code description:

For a code that is already inactive, the Deactivate menu option is replaced
with the Activate option. Choose Action ➤ Activate to return the code to
an active status.

Deleting Codes
When you delete a code from the Code Table, GIFTS removes all references
to that code from your data. This means that any records classified with that
code will have no value in that field after the deletion takes place.
Important: In most cases, deactivating classification codes is preferable to

deleting them in order to preserve your historical code data for reporting.
To delete a classification code:
1 Go to the Code Maintenance window for the table in which the code
resides and click on the code to select it.
2 From the Code Maintenance menu, choose File ➤ Delete. The code is
deleted.
Note: If GIFTS cannot allow deletion of the code because its removal

would impair operation of the system, you are given the option to mark
the code as inactive instead. Click Yes to deactivate the code.
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Transferring Codes
The GIFTS Administrator Module includes a Transfer Codes feature that
you can use to transfer all of the codes in a “source” Coding Sheet Code
Table to a “target” Coding Sheet Code Table; all references to the codes you
transfer are updated.

When Should I Transfer Codes?
This feature is useful for clients who have converted their data from a legacy
system, and who need to transfer the codes so that their data in GIFTS
accurately reflects their data in their legacy system. It is also useful for
clients who wish to change the implementation of their system.
GIFTS is shipped with pre-defined tables used for commonly used
classifications like “Geographical Area Served.” You can also create, modify,
and use user-defined tables to meet your needs. Note that if you wish to
change the use of a user-defined table, you can simply change its name.
However, if a pre-defined table exists for the classification data with which
you’re working, avoid creating or renaming a similar table for that data
(such as “Geographic Region”) whenever possible.
For example, if the “Region” codes from your legacy system were converted
to a user-defined table in GIFTS, you should use this feature to transfer the
codes to the pre-defined “Geographical Area Served” table in GIFTS instead
of renaming the user-defined table.
Many GIFTS reports group on pre-defined Code Tables or contain
information from them, but few reports contain information from userdefined tables. The pre-defined tables are:
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Age Group

Auspices

Budget Committee

Ethnicity

Fund

Gender

Geographical Area Served

Internal Program

Organization Type

Population Served

Program Area

Type of Support

Transferring Codes

Maintaining the Open Classification System

2

Note: You cannot change the names of the pre-defined tables.

Task 1: Make a Backup of Your Database

!

Caution: Before transferring codes from one table to another, make a

backup of your database. The transfer process cannot be reversed, and
involves major changes to your data.

Task 2: Prepare the Target Table
Before you transfer codes to a table, ensure that it does not contain any
codes. If the table includes any codes, you must move them to another table
or delete them before using it as a target. For information about deleting
codes from a table, please refer to “Deleting Codes” on page 27.
The following conditions also apply to the target table; you can set these
parameters in Task 3 as part of the transfer process.
The number of
selections allowed determines whether users can enter only one code for the
Code Table per record, or if they can enter secondary codes onto Coding
Sheets that use that table.

Allows the same number of selections as the source table.

For instance, with secondary codes a user can enter “Arts & Culture /
Performing Arts” as the primary Level 1 and Level 2 Program Area codes for
a grant that funds a community theater, and “Civic and Community /
Community Events” as the grant’s secondary codes.
When multiple selections are allowed, the GIFTS reports use the primary
code to sort or group data. However, when you use search criteria to
determine which records are included in a report, both the primary and
secondary codes are recognized.
Note that the Transfer Codes process allows you change the number of
selections allowed by the target; it is not necessary to change it before you
begin.
Has at least as many levels as the source table. If the target table has fewer
levels than the source table, the levels not supported by the target table are
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deleted. Note that the Transfer Codes process allows you change the
number of levels allowed by the target; it is not necessary to change it before
you begin.
Note: You cannot change the number of levels for certain pre-defined tables.
The Program Area and Geographical Area Served tables have five levels, and
all other pre-defined tables have one level—including the Request User
Tables and the Recipient User Tables.

Task 3: Transfer the Codes
To transfer codes from a source table to a target table:
1 From the Administrator menu, select Setup ➤ Code Tables. A list of the
Coding Sheet Code Tables is displayed.
2 Highlight the source table and click Transfer Codes. You are reminded
that the transfer cannot be undone and that you should have a backup of
your database.
3 Click Yes. The Transfer Codes window opens:

4 In the To field, choose the target table.
5 Adjust the target table’s levels and maximum number of selections so that
they match the properties of the source table. Note that if the target table
is a pre-defined table, you may not be able to change these properties.
6 Click OK. You are prompted to confirm the source and target tables that
you have selected.
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7 Click OK to transfer the codes. If any conditions exist that can cause the
loss of data, you are informed and given the opportunity to cancel the
transfer.
8 When the transfer is complete, a confirmation message is displayed.

Task 4: Add the Target to Your Coding Sheets
In order to view the data that has been transferred to the target Code Table,
you must use the Coding Sheet Preferences to add the target table to the
Coding Sheet for which it is intended.

Tip: The Coding Sheet Preferences determine which tables are displayed by
the system; changes to the preferences do not alter your data. You can work
with the preferences at any time—before or after you transfer your codes.

To add the target table to a Coding Sheet:
1 Choose Setup ➤ Preferences from the Administrator Module menu, and
go to the Coding Sheet tab:

2 Click the Request, Organization, or Contact button to display the Coding
Sheets for the relevant type of record.
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3 Click Add. A list of available tables is displayed:
To search for a table, enter several
letters from its name here and
press ENTER or TAB.

4 Highlight the target table and click Save and Close. It is added to the
Coding Sheet and you are returned to the Coding Sheet Preferences.
Note: You can make data entry for this table required or set up a default
code. For details on these features, please refer to “Requiring a Category”
on page 72 or “Adding Default Classification Codes” on page 73.

5 If the source table is on the Coding Sheet and you wish to remove it, you
can highlight it and click Remove. The Code Table is removed from the
Coding Sheet.
6 Click OK to close the preferences and save your changes.

Task 5: Verify the Results
Open several of your Request, Organization, Contact and/or Donor records
and review their Coding Sheets to verify that the transfer yielded the desired
results.
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Replacing Codes
Within a particular Code Table, you can replace all occurrences of one code
with another. Then, since all references to the obsolete code have been
removed from the system, you can delete it from the GIFTS Code Table
without any loss of data.
Coding Sheet classification codes flagged as primary or secondary inherit
these settings when they are replaced. In other words, primary codes are
always replaced by primary codes, and secondary codes are always replaced
by secondary codes.
Note: The Code Replacement feature is not available for the Country and

Branch/Division tables.

Planning a Code Change
Careful advance planning is essential when using this feature. Consult the
following examples for assistance in planning your code replacements.
Example: Single-tier Code Table

Assume your database has two Fund classifications: ‘Foundation Grants’ and
‘Foundation.’ There was a distinction between these two codes in the past,
but now you want to retain the code for ‘Foundation Grants’ and eliminate
the code for ‘Foundation.’
Using the Code Replace feature, you can replace all instances of
‘Foundation’ with ‘Foundation Grants.’ After the replacement is complete,
there should no longer be any records referencing the ‘Foundation’ code;
you can delete the code without any loss of data.
Example: Multi-tiered Code Table

Replacing Codes
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A more complex example involves multi-level tables, such as ‘Program
Area.’ Assume you want to change a two-tiered coding structure to a threetiered coding structure. Initially, you have the following codes:

You have decided to change over to the following structure:

To accomplish this, you would first enter the new codes into your Code
Table. For the moment, the table looks like this:

Tip: If you are going to have to leave the table in this state for any length of
time, consider marking your “old” codes as inactive until you are ready to
delete them. This ensures that users entering new data see only the new
coding structure, and do not become confused.

Then, replace each code with its new version. In this example, you would
perform the following replacements:
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Old Code

New Code

Arts & Culture/Museums

Arts & Culture/Visual Arts/Museums
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Old Code

New Code

Arts & Culture/Galleries

Arts & Culture/Visual Arts/Galleries

Arts & Culture/Theater

Arts & Culture/Performing Arts/Theater

Arts & Culture/Dance

Arts & Culture/Performing Arts/Dance

2

When you perform these replacements, each record currently coded with
the value in the left column is re-coded with the corresponding value in the
right column.
Once the replacements are complete, the codes in the left column are no
longer used; you can delete these codes from the ‘Program Area’ Code
Table without any loss of data.
After you have deleted the “old” codes, the Code Table reflects your new
coding structure:

Considerations for Multi-tiered Tables
If you are replacing codes in a multi-tiered table, please be aware that only
the specific code you choose will be replaced. For instance, assume you have
a ‘Program Area’ Code Table with the following structure:

If you replace ‘Arts & Culture/Visual Arts’ with another code, the records
coded for ‘Arts & Culture/Visual Arts/Museums’ and ‘Arts & Culture/
Visual Arts/Galleries’ are not affected. Only those records coded exactly
with ‘Arts & Culture/Visual Arts’ are affected.
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Likewise, if you replace ‘Arts & Culture/Visual Arts/Museums’ with
another code, records coded with ‘Arts & Culture/Visual Arts’ and records
coded with ‘Arts & Culture/Visual Arts/Galleries’ are not affected. Only
those records coded exactly with ‘Arts & Culture/Visual Arts/Museums’ are
affected.
If you need to replace many codes in a hierarchical table—for instance, to
replace an entire “branch” of the hierarchy—the simplest approach is to
start at the lowest level of the hierarchy and work your way up. Replace all of
the codes in each tier before moving up to the next.

Replacing Codes in the State Table
For all of the Code Tables besides State, both the Code field and the
Description field of a classification are replaced—even if the classification
has the same value in the Code field or Description field as another
classification in that table. For instance, assume you have the following
codes in your Fund table:
❖

[FND] Foundation Grant

❖

[FND] Foundation

❖

[FOUND] Foundation Grants Program

If you replace ‘[FND] Foundation’ with ‘[FOUND] Foundation Grants
Program,’ ‘[FND] Foundation Grant’ is entirely unaffected.
However, in the State table, the replacement of one Code or Description
affects all of the classification codes in that table with the same Code or
Description value. For instance, assume you have the following
classifications:
❖

[WASH] Washington, DC

❖

[WASH] Washington, District of Columbia

❖

[DC] Washington, DC

If you replace ‘[WASH] Washington, DC’ with ‘[DC] Washington, DC’, all of
the records coded for “[WASH] Washington, District of Columbia” are
affected as well. Likewise, if you replace ‘[WASH] Washington, DC’ with
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‘[WASH] Washington, District of Columbia’, all of the records coded for
‘[DC] Washington, DC’ are affected as well.

Replacing Codes
Before You Begin: Make sure that you have thought about your coding

structure and planned your replacements carefully. In addition, make sure
you have a current backup of your GIFTS database. In case of error, you may
need to restore this backup in order to continue working. You cannot
restore the codes that you have replaced.
To illustrate the code replacement process, the screens in this procedure
show the process of replacing the Level 2 ‘Media Communications’ code
(which is subordinate to the Level 1 ‘Arts & Culture’ code) with a Level 1
‘Media Communications’ code.
To replace a code:
1 From the Administrator menu, choose Setup ➤ Code Tables. The Table
Maintenance window opens.
2 Highlight the table containing the code you wish to replace and click Edit
Codes. The Table Maintenance window opens:

This is the code
that is going to be
replaced.

3 If you are going to replace the code with a new code, create the new code
as described in “Adding Codes” on page 24.

Replacing Codes

37

2

Maintaining the Open Classification System

Example: Create the Level 1 ‘Media Communications’ code.

This is the new code.

Tip: You can add “(old)”
to the name of the old
code to make sure you
don’t get the two codes
confused.

4 Highlight the “old” code you wish to replace (not the code with which
you wish to replace it) and choose Action ➤ Replace from the menu. A
message warns that a backup of your database should be available before
you continue.
Note: If you have made any changes to the Code Table, such as the
addition of new codes, GIFTS prompts you to save your changes to the
table before continuing.

5 Click Yes. You are prompted to select the code with which you will replace
the original code:

The “old” code is
displayed in the top
section.
To enable the OK
button, click on the
new code to select it.
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6 Select the code with which you wish to replace the first code, and click
OK. A message describes the replacement that is to be made. Read this
description carefully and make sure it accurately reflects your intentions.
The message also indicates the approximate number of records that will
be affected by the change.
7 Click Yes. The code is replaced and all occurrences of the code are updated.
8 When the replacement is complete, a message indicates that the process
is finished. Click OK. You are returned to the Code Maintenance window.
9 Delete the codes you are no longer using, if necessary. (To delete a code,
select it and choose File ➤ Delete from the menu.
Example: Delete the Level 2 ‘Media Communications’ code.

You can repeat the steps in this procedure as needed to restructure your
coding. When you are finished, click Save and Close.

Replacing Codes

39

2

Maintaining the Open Classification System

Sorting Codes
You can alphabetically sort the classifications in a table by either their Code
name or Description name:
1 From the Administrator menu, choose Setup ➤ Code Tables. The Table
Maintenance window opens.
2 Highlight the table containing the codes you wish to sort and click Edit
Codes. The Code Maintenance window opens:

3 From the menu, choose Action ➤ Sort. You are prompted to specify
whether you want to sort the codes by their Codes or their Descriptions.
4 Choose Description or Code and click Sort. The codes are sorted.
5 Click Save and Close to save your changes, or choose File ➤ Close to
cancel your changes.
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Viewing and Printing Code Reports
You can print a report listing all of the classification codes in your system, or
a list of the codes in a single Code Table.

To Print All Codes
1 From the Administrator menu, choose Setup ➤ Code Tables. The Table
Maintenance window is displayed.
2 Click the Report button. The report is generated and displayed.
3 Click the Print button to print the report.

To Print the Codes for a Single Code Table
1 From the Administrator menu, choose Setup ➤ Code Tables. The Table
Maintenance window is displayed.
2 Select a table and click Edit Codes. The Code Maintenance window is
displayed.
3 From the Code Maintenance menu, choose the Action ➤ Report. The
report is generated and displayed.
4 Click the Print button to print the report

Viewing and Printing Code Reports
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Setting the
System Preferences
GIFTS has been designed to meet the needs of a wide variety of grant
making organizations. Since your giving program is unique, you can
use the preferences to help tailor the system to meet your needs.
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About the Preferences
In GIFTS 6.5, the Administrator Preferences are accessed by going to Setup
➤ Preferences. The Preferences are divided into a General and External
window.

Refreshing GIFTS Preferences
You should keep in mind that whenever you make changes to the
Administrator preferences, they will not be available in the other GIFTS
modules until you refresh your system.
Any other users who are logged into GIFTS when you make changes will
also need to refresh before they can see your changes.
To refresh all your GIFTS modules, go to the GIFTS Organizer and choose
Options ➤ Refresh System Settings.

GIFTS may also be refreshed by logging out of the system, then logging
back in.
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General Preferences
These preferences include general system options, including default options
relating to data entry, settings for online research, request processing, and
grant term end date definitions. Options that do not apply to your
configuration of GIFTS are deactivated.
International settings, such as the currency format and date format used by
GIFTS, are managed by the Regional Settings control panel of the
Windows® operating system. For more information, refer to the “regional
settings” index entry of the Windows online help.
To edit the General Preferences, choose Setup ➤ Preferences ➤ General
from the Administrator menu.
The General Preferences window is divided into five tabs.

General Preferences

Section

Description

General

General system options; includes default options relating to data
entry, settings for online research, and grant term end date
definitions.

Security

This tab has options for Branch Security (if enabled), Extended
Password Security, and GIFTS Login requirements.
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Section

Description

Request

Default options relating specifically to Requests, including
default payment options, grant reference numbers, and the
handling of payment receipts.

Coding Sheet

This is where you define which Code Tables are included in the
Coding Sheets for Requests, Organizations, and Contacts. You can
control which Code Tables appear on which Coding Sheets, the
order in which they appear, and any default or required codes to
stream-line data entry. These preferences are not available to
users of Essential GIFTS.

External

These preferences control the paths to the different external
programs that can be used with GIFTS, including word processors,
spreadsheets, e-mail programs, and document viewers.

Salutations/
Payments

Use these preferences to define default formats for the
salutations used in merged correspondence and to define default
information that is automatically added to new Payments—
including default wire transfer, general ledger account, and
Payment Type information.

You can click on the folder tabs to move between the sections. When you are
finished setting the preferences, click OK to save them.

Options
You can select from the following options:
The School field in the Contact
record allows you to record the school attended by the Contact. This option
determines whether the School field is a text field or a “pointer” to an
Organization in the database.

Require contact’s school to be on File

If the School is an Organization, you can track its address, grant, and other
information—but you have to create an Organization record for each school
used. If School is a simple text field, users can type in any name during data
entry and no further information is maintained.
Ignore City, State, and Postal Code fields for addresses outside the United
States and Canada If you have Contacts or Organizations with addresses

outside the United States or Canada, this option omits these fields when
users generate correspondence.
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Displays the Description field of
state, county, or province classifications (such as ‘Arkansas’) instead of the
Code field (‘AR’).

Store State Description with Addresses

Automatically search for duplicate Organizations Each time a user enters

the name for a new Organization, GIFTS automatically searches for that
name. If no match is found, the user can continue entering the new record.
If a match is found, GIFTS lists the Organizations that met the search.
Each time a user enters
the last name of a new Contact or—if you use Employee GIFTS—Donor,
GIFTS automatically searches for a name “starting with” the name entered.
If no match is found, the user can continue entering the new record. If a
match is found, GIFTS lists the Contacts or Donors that met the search.

Automatically search for duplicate Contacts/Donors

Limits the list of
Contacts available as CCs during the letter merge process to those Contacts
associated directly with the Request. Otherwise, this list contains all the
Contacts associated in any way with the Organization as well as those
associated directly with the Request.

Limit Request letter addresses to Request’s Affiliations

Limits the list of Contacts
available as recipients of Payment event letters to those Contacts associated
directly with the Payment’s Request (i.e., the Request with which the
Payment is associated). Otherwise, this list contains all the Contacts
associated in any way with the Payment’s Organization as well as the
Payment’s Request.

Limit payee contacts to request contacts only

By default, the
Contacts affiliated with each letter in a batch are included in the CC list for
each letter. For instance, the Contacts affiliated with the Request to which a
Payment letter belongs are included in the CC list. Use this option to omit
the CC lists in batch letters.

Don’t include affiliated contacts as CCs in batch letters

When saving a batch of merged
GIFTS correspondence to disk, use this option to create a separate word
processor document for each letter in the batch. Otherwise, all of the letters
in the batch are saved to a single word processor document file—with each
letter separated by a section break.

Merge batch letters as separate documents

General Preferences
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Default new Contacts to omit Organization name from Contact’s office mailing
label This option controls whether the “Omit Organization name from

label” option is selected for new Contacts. It does not affect the setting of
this option for your existing Contacts.
This option, which is located on the Address tab of each Contact record,
omits the Contact’s Organization Name from the “Mailing Label” merge
field used in correspondence. It can be used for individuals who are tracked
as both a Contact and an Organization, and for Contacts whose division
name is different than that of their Organization’s.
By default, the Contacts in the CC
list of merged letters are formatted with their prefix and Organization
name—such as “cc: Dr. Mattingly Fisher, Brooklyn Ballet.” Use this option
to format names in the CC list without their prefix or Organization—such as
“cc: Mattingly Fisher.”

Format CCs w/o prefix and organization

Use this option to determine whether
new Requests are flagged as Complete when they are created.

Default New Requests to Complete

Default New Organizations to Public Charity Use this option to determine
whether new Organizations are flagged as charitable Organizations when
they are created.

If your GIFTS system uses
Microsoft SQL Server as its back end, GIFTS will dump your SQL
transaction log before users perform large batch operations. This prevents
the log from becoming full, which can interrupt the operation. If your
network security guidelines do not permit users to dump the transaction
log, you can disable this option. However, be sure that your network
administrator regularly dumps the transaction log.

Dump Transactions During Batch Procedures

This option defaults the first
subtitle of reports run from the Report Library to the search criteria (such as
“Program Area is ‘Human Services’”) that the user used when generating
the report.

Default Report Sub-title 1 to selection criteria

When this option is off, users can go to
an Organizer folder and press a letter on the keyboard to initiate a search for
items that “begin with” that letter. No further search options are available;
the search is run as soon as a letter is pressed.

Extended alpha search capabilities
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With extended alpha search on, the search dialog for name searches is
displayed when users press a letter. This allows users to:
❖

Enter more characters or choose a search condition (like “begins with” or
“contains”) to refine the search.

❖

Cancel the search if he or she pressed a letter accidentally. (Without the
extended search feature on, users have to wait for the search to run.)

For example, if a user presses the letter “S” in the Contacts folder, the name
search dialog is displayed and he or she can enter additional letters to refine
the search before clicking Find Now.
This option allows users to run Quick Reports, which
automatically populate the Reports Library with selected Record IDs as the
search criteria. For more information, Using GIFTS Reports.

Enable Quick Reports

Enable Document Properties This option will enable the addition of
Request_ID, Organization_ID, Contact_ID, and Staff_ID as Custom
Properties in Word documents created using GIFTS Correspondence
Templates. Please contact MicroEdge Custom Programming Services to
update existing documents created as GIFTS correspondence with
Request_ID, Organization_ID, Contact_ID, and Staff_ID as Custom
Properties with the corresponding field values.

Budget
The options in this section only apply to clients with the optional Budget
Module.

This option allows you to turn the Estimated
Payout feature on or off. Only users with appropriate permissions will have
access to this feature.

Track Estimated Payout

Select this option if you want
to require codes for Requests without enforcing the requirements in the
Budget Module.

Ignore Required Codes in the Budget Module

General Preferences
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Individual budget
items may be assigned authorized users who have permissions to access and
edit them. Select the check box to enable this feature, and then select one of
the option buttons to determine the permissions for budget items without
authorized users.

Restrict Budget Resolution/Transfers to Authorized Users

Organization Name Search Searches On

Organization searches are performed in many areas of the system, such as in
the Quick Find search and when you search for an Organization from within
a data entry form. Check each of the Organization name fields you would
like GIFTS to search for: Name, Sort As, A.K.A., and Legal Name.

“Requests from Individuals” Organization
GIFTS is designed to track giving per Organization. If you make grants to
individuals and want to track the giving histories for these grantees, you
should create an Organization record and a Contact record for each of these
grantees.
Therefore, you can use their Organization records to track their giving
histories and their Contact records to address their letters and enter more
information about the individuals.
If you don’t make grants to individuals, however, there is no giving history
to track: every proposal from an individual is immediately declined. To
streamline the entry of immediate declinations, you can enter a “Requests
from Individuals” Organization record with which these declinations can be
associated.
Therefore, when GIFTS users enter immediate declinations using the Quick
Entry feature described in the GIFTS User’s Guide, they can associate
proposals from individuals to the “Requests from Individuals” Organization.
To set up the “Requests from Individuals” Organization:
1 Use GIFTS to create the Organization.

50

General Preferences

Setting the System Preferences

3

2 In the “Requests from Individuals” Organization section of the General
Preferences, click the Find button to select the Organization you created
in Step 1.

Postal Code Maintenance
When you enable this option, GIFTS maintains a lookup list of Postal Code/
City/State/Country combinations that simplify data entry.
Users entering new addresses can skip the City, State, and Country fields. If
the Postal Code the user enters is in the lookup list, GIFTS fills the City,
State, and Country fields automatically. If this information is not correct, the
user can edit it.
Use the following settings to enable the postal code data entry shortcut and
specify how existing postal codes are updated in the lookup list.
Setting
Off

Description
Disables both the lookup list and postal code list updates.
When you select this option, users must enter the City, State, and
Country manually. New Postal Code/City/State/Country
combinations are not added to the list.

Use latest

As users enter data, GIFTS updates the Postal Code list with the
most recent Postal Code/City/State/Country combinations.
Example:In your lookup list, Postal Code 11231 is defined
as “New York, NY.” If a user enters an address for a Contact
in Brooklyn, NY 11231; GIFTS changes the lookup list
entry to “Brooklyn, NY.” The next time a user enters
11231, GIFTS populates the City and State fields with
“Brooklyn, NY.”

General Preferences

Use first

If a user enters a Postal Code/City/State/Country combination that
differs from the Postal Code information already on file, GIFTS
does not update the list.

Ask user

If a user enters a Postal Code/City/State/Country combination that
differs from the Postal Code information already on file, GIFTS
prompts the user to confirm that they want to change the list
before updating the lookup list.
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The postal code list is updated when users create or edit an address in
GIFTS. To view or edit the Postal Code list, click Edit Postal Codes:

❖

If your data was converted from another source—or you upgraded from
an earlier version of GIFTS—your list may contain few (if any) postal
codes. You can populate the postal code list with addresses that are already
in your database.
To populate the list, choose Action ➤ Populate from the Postal Codes
menu and then click Continue. You are prompted before any existing
Postal Code/City/State/Country combinations in the list are changed. If
there is more than one city/state/country combination for a postal code
in your database, the list is populated with the first combination found.
Note that this process modifies the postal code list only; no changes are
made to your address data in GIFTS.

❖

You can also click New or Edit from the Postal Code list to manually add
or edit postal codes.

When you are done, choose File ➤ Close from the Postal Codes menu to
save your changes.

Setting the Telephone Number Format
You can help users speed their data entry by defining a telephone number
format and/or a default area code.
❖
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formatting—like dashes, spaces, and parentheses—that you specify.

General Preferences

Setting the System Preferences

❖

3

When users enter a telephone number without an area code, GIFTS adds
the default area code. If the default is not appropriate, the user can edit it
manually.

To define a telephone number format:
1 Enter the format (or Telephone Mask) exactly as you want telephone
numbers to appear in GIFTS. Use “#” to take the place of the numerals.
2 Enter the default area code that you want added to telephone numbers
that are entered without an area code:

In the example above:
If a user types...

The telephone number is displayed in GIFTS as...

1234567890

(123) 456-7890

4567890

(606) 456-7890

011-000-11-2222

011-000-11-2222

GIFTS applies formatting to telephone numbers when no non-numeric
characters—such as spaces, parentheses, and hyphens—are entered and:
❖

The number of digits entered equals the number of pound signs (“#”) in
the mask.

❖

The number of digits entered equals the number of pound signs (“#”) in
the mask minus the length of the default area code. In this case, GIFTS also
appends the default area code to the front of the digits entered.

Otherwise, no formatting is applied.
Note: If the mask is “(###) ###-####” and a user enters a seven-digit

number with a hyphen separating the first three digits from the last four
digits, GIFTS appends the default area code and formats the number
according to the mask. This is to take into account that many users will enter
U.S. numbers as ###-####.

General Preferences
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Research Settings
As users review grant applications in GIFTS, they can link to a research Web
site of your choice for information on applicant Organizations. If you have a
subscription to a research site, you may configure the GIFTS link to
automatically log your users in to the site for access to subscriber content. In
the Research section of the General Preferences tab, you will need to select a
research site and provide its URL, as well as your GuideStar subscriber email address and password (if applicable):

Use this drop-down menu to select either
GuideStar or a version of RevenueCanada (French or English) as your
Internet research site. You may also select “Other” if you wish to use a
different research site.

Research sites drop-down

If you have selected GuideStar or RevenueCanada as your research
site, this field will automatically populate with the appropriate URL. Note
that the default URL for GuideStar integrates the U.S. Tax ID of your target
Organization, along with your subscription information (e-mail address and
password). Even if you are not a GuideStar subscriber, you do not need to
change this URL for the GuideStar link to function properly.

URL

If you have selected “Other” in the research site drop-down menu, the URL
field will be left blank. You must supply the appropriate URL for other
research sites.
If you have made changes to the GuideStar or
RevenueCanada URL and it no longer works correctly, click this button to
reset the URL field to the system default.

Reset to Default URL
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Subscriber E-mail If you have a GuideStar subscriber account, enter your
subscriber e-mail address in this field. GIFTS will use this information, along
with your password in the next field, to automatically log you in to the
GuideStar site when you link from GIFTS.

If you have a GuideStar subscriber account, enter your
subscriber password in this field. GIFTS will use this information, along
with your e-mail address in the previous field, to automatically log you in to
the GuideStar site when you link from GIFTS.

Subscriber Password

Grant Term
When users approve grants, they must enter a grant term. GIFTS will
automatically designate an End Date for the grant based on the Start Date,
the grant term, and whichever option you choose in this preference. With
the first option selected, GIFTS will designate an End Date on the same
numerical day as that of the Start Date. For example, a 12-month grant that
starts on 1/1/2011 will end on 1/1/2012.
If you select the second option, GIFTS will designate an End Date on the
numerical day before that of the Start Date. In this case, the same 12-month
grant that starts on 1/1/2011 will now end on 12/31/2011.

Defaults
To ease data entry, the default values you enter for Address State, Address
Country, and Contact Prefix are entered automatically each time a new
address or a new Contact is created. If there is no consistency to your data in
these areas, supply the defaults as “None.”
The Name Search Method allows you to choose the default method for
Organization searches in GIFTS. Note that this option does not apply to
Advanced searches.

Currency Display
The currency display options determine how monetary values are displayed
by the system. You can choose to omit either the currency symbol, such as a
dollar sign or pound sign, or decimal places.

General Preferences
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By default, your functional currency is determined by your Windows
Regional Settings. If you use GIFTS multi-currency features and want to
designate a different currency as your functional currency, you can specify
the currency here. For more information, please see “Choosing Your
Functional Currency” on page 124.
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Security Preferences
The Security Preferences allow you to set up your Branch Security options,
establish extended password security, and choose to use or ignore Windows
NT Integrated Security.
To edit the Security Preferences, choose Setup ➤ Preferences ➤ General
from the Administrator menu and go to the Security tab.

Security Preferences
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Branch Security
If your organization has a number of divisions and you use Branch Security
to establish user rights for each division, here you choose which Branch
Security model you are going to use:

Select “Use ‘Create User’ to determine branch” if your organization plans to
use the decentralized data entry model. Select “Allow user to determine
branch” if you follow the centralized data entry model.
Note: For information about these two data entry models, please see “About

Branch Security” on page 292.
In the same section of the Branch Preferences tab, you can also set the
following Branch Security options:
Users who have both the
Budget Module and Branch Security can use this option to allow users to
access the entire Budget without the restrictions imposed by Branch
Security.

Ignore Branch security in the Budget module

View-only Branches see only Approved Requests For systems with Branch
Security, you can specify that users with view-only privileges for a Branch’s
Requests can see only those Requests that have a Disposition of Approved.
Make G/L Account Codes Branch Sensitive In organizations with multiple
branches, each branch typically has a set of general ledger account codes
that are valid for that branch only. You can stamp the G/L account codes in
GIFTS with the name of the branch to which they are assigned; users at each
branch can see and work with only the codes assigned to their branch. For
information about Branch Security, please refer to “Setting Up Branch
Security” on page 291.
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If your system uses Employee GIFTS and
Branch Security, this option restricts users from viewing information about
Donors that were entered by other branches.

Donors are branch specific

Extended Password Security
By default, passwords are not required in GIFTS. By selecting Extended
Password Security, you can require users to enter a password each time they
log in. After selecting the Extended Password Security option, you must
assign each user a password, as described in “Setting, Resetting, or Clearing
a User Password” on page 107.

Security Preferences

59

3

Setting the System Preferences

Once Extended Password Security is enabled, the following options will also
be accesible:
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Field

Description

Maximum age for
passwords (in days)

You can set the password expiration time limit from one to 365
days. Entering zero indicates no password expiration limit. Users
are notified five days before their password expires that they
should change it; upon expiration, users cannot log in until they
change their password.

Inactivate user
after X invalid
login attempts

Enter a number here is you would like the user account to be
disabled after a certain number of invalid login attempts.

Security Preferences
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Field

Description

Set Password Rules

Clicking this button will open the form below with five more
password options.

Minimum length

This option allows you to specify the minimum number of
characters required in a password from three to a maximum of
eight. Users entering a password outside this range receive a
message prompting them for a password of the correct length.

Numeric
Characters

Require a specific number of numeric characters to be included
in the password.

Special Characters

Require a specific number of special characters to be included in
the password.

Uppercase
Characters

Require a specific number of uppercase characters to be included
in the password.

Lowercase
Characters

Require a specific number of lowercase characters to be included
in the password.

Note: Users entering a password without the required number of characters

receive a message prompting them for a password with the correct number
of numerical characters.

General Security
With Windows NT Integrated Security active, GIFTS retrieves the user’s
Windows NT Login ID and—if there is a matching ID in GIFTS—
automatically logs the user into GIFTS. (The user’s GIFTS password, if any,

Security Preferences
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is ignored.) If the Login ID is not found, the user is prompted to log in to
GIFTS.
With Windows NT Integrated Security for GCS active, MyGIFTS users can
log into MyGIFTS using their Windows NT Login ID and/or password
(select User ID Only or User ID and Password, depending on your
preference). If the IIS server is on a different domain than the GIFTS
database/application directory, it must be specified in the Domain field.
Important: You must select the Windows NT Integrated Security checkbox

for this option to be available.
For more information about setting up this feature, please refer to “Setting
Up Windows NT Login Integration” on page 115.
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Request Preferences
The Request Preferences allow you to set options related to how Request
and Payment information is tracked and how fiscal year is determined. To
edit the Request Preferences, choose Setup ➤ Preferences ➤ General from
the Administrator menu and go to the Request tab:

Options
You can enable or disable the following options:
While many grant makers identify grants
with the unique Request IDs generated by GIFTS, some grant makers have
an internal reference numbering system for their grants. You can use this
option to set up GIFTS to automatically assign a reference number to each
Request, beginning with the number you define. You can specify that GIFTS
assign this number either when the Request is created or when it is
Approved. You can also specify that GIFTS assign the reference number
when a Request is created, then add a prefix when the Request is approved.

Generate grant reference number

Note: If a user assigns a reference number to a Request manually, GIFTS

does not overwrite the user-assigned reference number.
The Current Value field indicates the next reference number that will be
used. You can also specify a prefix to precede the reference number. For

Request Preferences
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example, if you want to track your grants by fiscal year, you could enter the
following information in these fields at the beginning of Fiscal Year 2001.

In this case, the first Request approved in fiscal year 2011 is assigned the
Reference Number FY2011-0001. You could then maintain this numbering
system from year to year by simply changing the prefix at the start of each
fiscal year.
Use this option to change the value used to
generate Request IDs. To prevent duplicate IDs from being entered, GIFTS
ensures that the value you enter is greater than the Request IDs currently
used by the system.
Change ‘request id’ value

When a grant is
approved, GIFTS can automatically create a Payment Schedule based on the
number of Payments you specify. If you enable this option, GIFTS also
marks the first (or only) Payment in the schedule as Paid.

Mark first ‘automatically scheduled’ payment as ‘Paid’

Grant makers who cut the check for the first Payment immediately can save
data entry time with this option. GIFTS uses the Request Approval Date as
the Payment date; however, no check number information is supplied.

Default Request Type
The Request Type describes the giving program to which the Request
belongs, such as “cash grants” or “in-kind.” Many grantmakers use only one
Request Type, and still others use one much more frequently than they use
the others. To speed data entry, all Requests are automatically assigned to
the default Request Type (which can be modified, if necessary).

Payment Receipts
The U.S. Internal Revenue Service (IRS) requires that each non-profit
organization receiving a grant payment of over $250 must furnish the donor
with a receipt verifying that the contribution was received. GIFTS can
schedule these receipts automatically by creating a Payment Requirement
indicating that a receipt is required.
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Certain Funds may not require these receipts, and each Payment contains a
Fund code such as ‘Corporation’ or ‘Foundation.’ This option allows you to
specify which Funds require receipts, and which do not.
❖

Click Add to open the Fund code table, listing all your giving funds (such
as ‘Corporate’ or ‘Foundation’). For each Fund that requires a receipt,
highlight the code and click Insert. The Fund is moved to the Receipts area.

❖

If the fund does not require a receipt and has been incorrectly added to
the list, you can highlight the Fund in the Receipts area and click Remove.
The Fund is removed from the area.

For more information about Payment Requirements, please refer to the
GIFTS User’s Guide.

Fiscal Year
Fiscal Year fields appear in Requests, Payments, and Grant Amendment
Activities. Fiscal year information from these fields is used by the Budget
Module and in standard financial reports.
If your organization’s fiscal year is different from the calendar year, you can
set up the end date and other characteristics of your fiscal year here. You can
also specify how Request and Payment Fiscal Years are determined and
updated:

Note: If you change your fiscal year specifications after you have been

working with GIFTS, please refer to “Recalculating Data” on page 213 for
information on how to recalculate fiscal years assigned to your existing
grants and Payments, so they coincide with your new fiscal year setup.

Request Preferences
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First, define your Fiscal Year (FY) by specifying its end date:
Field

Description

FY [current calendar
year] ends on:

Enter the last day of the fiscal year shown in the field label.
The default date is 12/31/[current calendar year].
For example, if you are setting up your Fiscal Year in
December 2010, the field label will read “FY 2010 ends on:”. If
your fiscal years run from October 1 through September 30,
and last year was considered fiscal year 2010, enter 09/30/
2010 in this field.
This field is required. If cleared, it will reset to the default date
specified above.

Next you can determine how the Fiscal Year for each grant (i.e., approved
Request) is initially determined during the approval process.
Field

Description

Grant FY Is Based On

Select one of the following options:
❖ Approval date - The fiscal year in which the Request’s
Approved Date falls is saved as the grant Fiscal Year.
❖ First Payment date - The fiscal year in which the earliest
Payment’s Date Paid falls is saved as the grant Fiscal Year.
If no Payments are marked as Paid before or during
Request approval, the Request’s Approved Date will
determine the grant Fiscal Year.

Tip: If you select “First Payment date” to determine your grant Fiscal Year,
you will probably want to set up your GIFTS system to recalculate grant
Fiscal Year automatically (as shown following this tip). Suppose no
Payments are Paid when you approve the Request; the Request Fiscal Year is
determined by the approval date instead. But if GIFTS is set up to
recalculate grant fiscal year, it will be updated automatically when the
grant’s Payments are paid later.
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You can use the next options to allow your GIFTS system to update Fiscal
Year fields automatically when Requests or Payments change:
Field

Description

Recalculate Grant FY
Automatically

Select this check box to allow GIFTS to recalculate an approved
Request’s Fiscal Year when and if certain dates are changed.
Which events cause Fiscal Year to be updated depend on what
your grant Fiscal Year is based on.
If in the “Grant FY Is Based On:” field you select approval date,
grant Fiscal Year will be recalculated if the Request’s Approved
Date is changed.
If you base your grant Fiscal Year on first Payment date, grant
Fiscal Year will be recalculated when:
❖ the first Payment is marked Paid.
❖ another Payment is marked Paid (if this Payment’s Date
Paid is now the earliest, the grant Fiscal Year could change).
❖ the Date Paid of the Payment paid earliest is changed (if
the Date Paid is now earlier, or another Payment becomes
the earliest paid, the grant Fiscal Year could change).
If this check box is cleared, the Request Fiscal Year
determined during grant approval will not be updated
automatically, even if approval or Payment dates change.

Recalculate FY
Automatically
(Scheduled Payments)

GIFTS can also be set up to recalculate the Fiscal Year of
scheduled, contingent, or canceled Payments, or Payments on
hold.
Select this check box and GIFTS will recalculate a Payment’s
Fiscal Year when its Schedule Date changes.
If you clear this check box, the Payment’s Fiscal Year will
remain what it was when first calculated.
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Field

Description

Recalculate FY
Automatically (Paid
Payments)

The Fiscal Year of paid Payments can also be recalculated
automatically. From the drop-down menu, select when you
want paid Payments’ Fiscal Years to be updated:
❖ Never - the Fiscal Year of paid Payments will remain what
it was when first calculated.
❖ When paid date changes - any change to the Date Paid of
a paid Payment, Date Voided of a voided Payment, or Check
Date of a refunded Payment will trigger an update to that
Payment's Fiscal Year.
❖ When schedule date changes - any change to the Schedule
Date of a paid or voided Payment, or the Received Date of
a refunded Payment will trigger an update to that
Payment's Fiscal Year

The last fiscal year option allows you to add the Fiscal Year field to pending
Requests (normally, the Fiscal Year field is only shown in approved Request):
Field

Description

Show FY for Pending
Requests

Select this check box to include the Fiscal Year field on the
Page 2 tab of pending Request records.
If selected, the Fiscal Year field of pending Requests will be
populated with the current fiscal year. This field may be left
blank, and will only be recalculated when and if the Request
is approved.

Note: A user can manually change the Fiscal Year in Requests, Payments,
and Grant Amendment Activities, if his or her permission set allows it. This
ability is controlled by the following four permissions, listed under GIFTS in
the Permissions window:
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❖

Update Payment Fiscal Year (Paid, Void, Refund)

❖

Update Payment Fiscal Year (Scheduled, Hold, Canceled, Contingent)

❖

Update Grant Fiscal Year

❖

Update Amendment Fiscal Year
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In each case, select Execute to allow users assigned the permission set to
change Fiscal Year when editing those records.
For information on working with GIFTS permission sets, please see
“Managing Permission Sets” on page 92.
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Coding Sheet Preferences
Users of GIFTS can use the Coding Sheet preferences to:
❖

Specify which categories (Code Tables) are used on the Coding Sheets for
Organizations, Requests/Budget, and Contacts. To this end, you can add,
remove, and arrange the categories.

❖

Specify that a category must be coded during data entry.

❖

Enter default classification codes so that when new records are created
they are automatically coded with the default information.

❖

Print a Coding Sheet report for your records.

Adding a Category
To add one or more categories (Coding Sheet Code Tables) to a Coding
Sheet:
1 Choose Setup ➤ Preferences ➤ General from the Administrator menu
and go to the Coding Sheet tab.
2 Click the button that indicates which Coding Sheet you are working with:
Organization, Request/Budget, or Contact.
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3 Click Add. The “Select from available tables” window opens:
To search for a table, enter the
first several letters of its name
here and press ENTER or TAB.

4 Highlight each Code Table you wish to add to the Coding Sheet (to
deselect a Code Table, click it again).
Note: If the category you want is not available, refer to “Maintaining the

Code Tables” on page 17 for information about adding or modifying the
Coding Sheet Code Tables that are used as categories on your Coding
Sheets.
5 Click Save and Close. The Code Tables you selected are displayed on the
Coding Sheet as categories.

Arranging Categories
The order of the categories shown in the preferences is the same order in
which they are presented to users. You can arrange them in the order most
appropriate for your users. To arrange the categories:
1 Choose Setup ➤ Preferences ➤ General from the Administrator menu
and go to the Coding Sheet tab.
2 Click the button that indicates which Coding Sheet you are working with:
Organization, Request/Budget, or Contact.
3 Highlight the category you wish to move.
4 Click the Up or Down button to move the category.

Removing a Category
You can remove a category from a Coding Sheet at any time.

Coding Sheet Preferences
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!

Caution: If any user has classified records using a category, please be advised

that those classification codes, along with the category itself, are removed
from the existing Coding Sheets for the record type (Organization, Request,
or Contact) you are working with.
Removing a category from the Coding Sheet does not remove its Coding
Sheet Code Table or its associated codes from the system, nor does it
remove the category from the Coding Sheets for the other record types
(Organization, Request, or Contact) where it may be used. If you wish to
remove the Code Table from your system entirely, please refer to “Deleting
a Code Table” on page 21.
To remove a category from a Coding Sheet:
1 Choose Setup ➤ Preferences ➤ General from the Administrator menu
and go to the Coding Sheet tab.
2 Click the button that indicates which Coding Sheet you are working with:
Organization, Request/Budget, or Contact.
3 Highlight the category you wish to remove.
4 Click Remove. If any user has used the category to classify records, a
warning message is displayed.
5 Click Yes. The category is removed, and any classifications that were used
in that category are deleted from your records.

Requiring a Category
In order to maintain your database, it is important to have consistent data
entry. If you wish to run accurate reports based on a certain category, such
as Program Area, it is important that every relevant record be coded.
Otherwise, relevant records won’t appear under the appropriate heading in
the report, and their absence creates errors in your count and total
information.
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To prevent this, you can require that users code specific categories. For
Organization and Contact Coding Sheets, users cannot save new records
unless they first code the required categories.
For Requests, you can require coding either when Requests are created or
when they are approved, as determined by the setting at the bottom of the
preference screen:

To make a category required or optional:
1 Choose Setup ➤ Preferences from the Administrator menu and go to the
Coding Sheet tab.
2 Click the button that indicates which Coding Sheet you are working with:
Organization, Request/Budget, or Contact.
3 Highlight the category.
4 Click the Required button to make it required, or the Not Required button
to make it optional. If the category is required, it is displayed in bold type.
Note: You can also require that users enter a code at the lowest (most

detailed) level for a category. For details, please see “Adding or Modifying
a Code Table” on page 19.

Adding Default Classification Codes
Default classifications can save data entry time and provide consistency in
your coding. Each time a user creates a new Request, Organization or
Contact record, the default codes you have specified are entered into the
Coding Sheet for the record.
For instance, the kind of grantmaking you are involved in may mean that
most of the Organizations that you enter are schools. Rather than have to
code each Organization’s Organization Type as ‘School,’ you can set
‘School’ as the default Organization Type classification. Each new
Organization created will be assigned an Organization Type of School; users
would only need to modify the coding for the exceptions.
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It is not necessary to enter any default codes; if the default coding is going to
be corrected more often then not, then a default code should not be defined.
To add a default code:
1 Choose Setup ➤ Preferences from the Administrator menu and go to the
Coding Sheet tab.
2 Click the button that indicates which Coding Sheet you are working with:
Organization, Request/Budget, or Contact.
3 Highlight the category for which you wish to supply a default code.
4 Click Default. A list of the codes in that category is displayed.
5 Highlight the code you wish to supply as the default, and click Insert. (Even
if the category allows more than one code, you can only supply one code
as the default.)
6 Click Done.
If you wish to change the default code value, select the current default code
and click Remove. Then, add a new default code.

Printing the Coding Sheet Report
To print the Coding Sheet Report for a Coding Sheet:
1 Choose Setup ➤ Preferences from the Administrator menu and go to the
Coding Sheet tab.
2 Click the button that indicates which Coding Sheet report you want to
print: Organization, Request/Budget, or Contact.
3 Click Report. The report lists the categories, along with their parameters,
that have been assigned to the Coding Sheet.
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Salutation/Payments Preferences
You can define default formats for the salutations that are used for your
correspondence. You can also specify default payment information that is
applied to each new Payment you generate, including wire transfer, quid pro
quo and in-kind tracking, and/or G/L account information and Payment
Type.

Salutation Defaults
When you create letter templates, you can include salutations that contain
merged information from your Contact records. Use this preference to
define the default format of these salutations; users with proper permission
can edit the salutations from the Contact record.
Note: The default Salutation format is only applied to Contacts that are

added or imported after you define it.
Type

Description

Formal

The standard salutation that begins most correspondence. The
default is: Prefix and Last Name.
Example:“Mr. Rogers”

Salutation/Payments Preferences
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Type

Description

Informal

You might include this in correspondence to a contact that is
closely affiliated with your organization. The default is: First
Name.
Example:“Henry”

Addressee

This appears at the beginning of Address Block merge fields. The
default is: Prefix, First Name, Middle Name, Last Name, and
Suffix.
Example:“Mr. Henry Lee Rogers, Jr.”

Note: In conformance with the Chicago Manual of Style, 14th ed., GIFTS

excludes the Contact’s Prefix from salutations when the Suffix is “Ph.D”,
M.D.”, or “Esq.”
To define a salutation format:
1 Choose Setup ➤ Preferences ➤ General from the Administrator menu
and go to the Salutation/Payments tab.
2 Choose a Salutation Type from the Salutation list.
3 Select the elements you want to include for the salutation.

4 Click OK to save your changes.

Quid Pro Quo Information
Many grant makers, particularly corporations, make donations for which a
service or a product is rendered in return, such as a dinner. The actual
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monetary value of the dinner received is not tax deductible, and must be
tracked separately.
If you make grants of this nature, use this option to activate the Quid Pro
Quo tracking fields of your Payments, which are described in the GIFTS
User’s Guide.

In-kind Information
Many grant makers, particularly corporations, donate products and wish to
track separate values for tax purposes. If you make grants of this nature and
wish to track a Book Value, Tax Value, and Fair Market Value for each gift,
use this option to activate the In-kind tracking fields of your Payments,
which are described in the GIFTS User’s Guide.

Wire Transfer
Some organizations prefer to make payments by wire transfer when the
payment is over a certain amount or the payee is in another country. You can
use these options to automatically flag Payments as wire transfers when
they are greater than a specified amount, or paid to payees in countries that
you define.
Users can also define default wire transfer information for Organizations
and Requests. When a Payment is created for the Organization or Request,
this default wire transfer information is automatically added to the Payment
when it is flagged as a wire transfer.
Note: The Organization’s default wire transfer information is only added to

the Payment if no default information was specified for the associated
Request.
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To set up the list of countries to which Payments should be made by wire
transfer:
1 Choose Setup ➤ Preferences ➤ General from the Administrator menu
and go to the Salutation/Payment tab:

2 Select the “Default to Wire Transfer when Payment Address is in” check
box.
3 Select a country from the list, or type a country name into the list. The
Add button is enabled.
4 Click Add. The country is added to the list and displayed in the box beneath
the country list.

Default Payment Codes
To set up default Payment codes:
1 Choose Setup ➤ Preferences ➤ General from the Administrator menu
and go to the Salutation/Payment tab.
2 You can edit the following defaults:
If most of the Payments that your staff generates are of a
particular Type, you can save data entry time by defining a default
Payment Type that is added to each new Payment. If the default does not
apply to the Payment, users can change it.

Payment Type

If your organization uses a general ledger
accounting system to track grant payments, you can define a default G/
L account number that is added to each new Payment by selecting it
from the list. If the default account number you specify does not apply to
a Payment, the user can search for another G/L account.

Payment G/L Account
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Note: The Support Type and Fund fields on Payment records default to the

Support Type and Fund classifications, if any, entered onto the Coding Sheet
of the Request associated with the Payment.
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External Preferences
GIFTS can interface with external word processor, spreadsheet, and e-mail
software packages. In order to take advantage of this functionality, you can
install the compatible software and set the appropriate External Preferences.
If you are using the optional Document Manager, you can also configure
alternate viewers for specific file types.
Before You Begin: Read the following section, “Using System-wide and

Local Preferences”.

Using System-wide and Local Preferences
If you have installed GIFTS on a network, you may need to set up External
Preferences that are specific to your workstations.
Example: You want each of your GIFTS workstations to link the spreadsheet

program located on the workstation hard drive. If the spreadsheet’s program
file is not in the same location on every workstation, you need to set up local
External Preferences on each workstation to “point” to the correct location
of the spreadsheet’s program file.
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Setting System-wide External Preferences
If you need to set up local preferences for any of your workstations, first use
the following procedure to set your system-wide External Preferences:
1 On any GIFTS workstation, log in to the Administrator Module.
2 From the Administrator menu, choose Setup ➤ Preferences ➤ External.
3 Select the “System-wide” radio button and set up the system-wide
External Preferences (specific instructions for each setting are given in the
sections that follow) that apply to most workstations.
4 Click OK to save the system-wide preferences.
At this point, your system-wide preferences have been saved and you can
edit the local preferences on each of your workstations, as necessary.

Setting Workstation External Preferences
To edit the local preferences for a workstation:
1 On the workstation for which you are setting the local preferences, log in
to the Administrator Module.
2 From the Administrator menu, choose Setup ➤ Preferences ➤ External.
3 Select the “This workstation” radio button and set preferences that are
specific to the workstation. Note that some preferences are not available;
for example, since all workstations must use the same spreadsheet, you
cannot change the spreadsheet used. You are only permitted to edit the
specific path used by the workstation to locate the spreadsheet’s .EXE file.
4 Click OK to save the workstation’s local preferences. The paths you
entered are used by that workstation. Note that the system-wide
preferences are the default values: the workstation uses the system-wide
preferences where you do not enter local values.
Repeat the preceding procedure on each workstation that needs local
preference settings.
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Word Processor Used
GIFTS and Essential GIFTS systems with the Correspondence option link
with Microsoft Word in order to create merged letters, write-ups, and batch
correspondence. Choose Word from the list.
❖

The Document Path is where merged documents saved to the system are
stored. Typically, this is a directory within the GIFTS directory, such as
F:\GIFTS\DOCUMENT. Network users who wish to share documents must
have the documents stored on an accessible network drive.
If you want to organize your merged documents by correspondence
event, you can create a document subdirectory for an event and save
documents for the event to the subdirectory. For details, see “EventSpecific Document Subdirectories” on page 190.

❖

The Template Path is where the templates used to create merged
documents are stored. Typically, this is a directory within the GIFTS
directory, such as F:\GIFTS\TEMPLATE. Network users who wish to share
templates must have the templates stored on an accessible network drive.

Spreadsheet Used
The spreadsheet interface is used with the Organizer and the optional
Budget Module. Users who have a compatible spreadsheet installed can
export ad hoc reports and Budget information to a spreadsheet for further
manipulation. To link GIFTS to your spreadsheet:
1 Choose your spreadsheet from the Spreadsheet Used list.
2 In the Program file name field, enter the path to the spreadsheet
application file. You can click Browse to choose the file from your
directory structure. A common location for Microsoft Excel, for example,
is C:\Program Files\Microsoft Office\ Office\EXCEL.EXE.

Reports Path
The Reports path specifies the location of your report (.RPT) files.
❖
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On most network systems, the report files are stored in the GIFTS
directory on a network file server.

If you have moved your report files to another directory, you can edit the
report path by placing the cursor in the Report Path field and clicking
Browse.

Report Designer
If you have the optional GIFTS Report Designer, you must provide the
location of the CRW32.EXE file for Crystal Reports, the software used by
the Report Designer.
If you do not know the location of the CRW32.EXE file, click Browse to
choose the file from your directory structure.

E-Mail Program Used
GIFTS and Essential GIFTS systems with the Correspondence option link
with external e-mail programs to send e-mail messages to Contacts with
Internet addresses, as well as contacts that are part of your internal e-mail
system.
You can manually change this setting if you think it is incorrect by selecting
from the two options here:
❖

Microsoft Outlook (Microsoft Exchange).

❖

SMTP/POP (Internet email) used by most internet email providers such
as Yahoo mail, Hotmail, Gmail and others.
If your provider requires authentication, then check the “E-Mail Server
Requires Authentication” radio button.
Enter the name of your SMTP server—such as smtp.model.org—in the
available field.

Note: The VIM protocol, used by cc:Mail and Lotus Notes, is no longer

supported in GIFTS.
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Personal Information Manager Used
If you use Microsoft Outlook to maintain contact information,
appointments, and other personal data, you can specify it here.

Document Manager Program Used
If you link GIFTS with your external document management application,
users can launch it from within GIFTS by clicking the External Document
Manager button on the Main toolbar.
To link your external document manager:
1 Enter the path to its executable (EXE) file, or click Browse to choose the
file from your directory structure.
2 In the Parameters list, choose the parameters to be sent to the application
when users launch it. For example, choose “Request ID & User ID” to
send the Request ID associated with the Request and the Staff ID of the
person logged into GIFTS to the external document manager.

Configuring Alternate Viewers
If you have the optional Document Manager, users can link external
documents to GIFTS. By default, users can then view these documents with
the Outside In Document Viewer shipped with the Document Manager.
You can configure the system to use other viewers—such as word
processors, Internet browsers, and graphics-editing applications—to view
specific file types. For instance, you can use your Internet browser to open
images in standard formats like PDF, JPG, and GIF.
Note: GIFTS uses the following internal command to launch the alternate
viewer: <Program Name> <File Name>. The names are separated by a
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single space; if your viewer does not support this command format, it cannot
be used as an alternate viewer.

To configure an alternate viewer for a specific file type:
1 In the File Extension column of the Alternate Document Viewers table,
enter the three-letter file extension of the document type.
2 Press TAB. The Browse button is activated because the cursor in the
Viewer Program Name column of the Alternate Document Viewers table.
3 Click Browse and highlight the EXE file you wish to launch when users
open this file type from within GIFTS.
4 Click Open to return to GIFTS. The file path is displayed in the Viewer
Program Name column.

External Preferences

85

3

Setting the System Preferences

Using the Preferences Editor
In addition to the preferences described in the preceding sections, GIFTS
maintains a variety of system and user preferences. Occasionally, you may
need to use the Preferences Editor to edit these preferences.

!

Caution: In most cases, the Preferences Editor should be used only under

the direction of MicroEdge Technical Support. Never delete a preference
unless you are specifically instructed to do so by a MicroEdge Support
Specialist. The removal of preferences can disable GIFTS.
The following section describes how to use the Preferences Editor to set the
maximum number of entries permitted in the “Table” fields used in GIFTS
correspondence.

Setting the ‘TableMax’ Limit
Several correspondence merge fields in GIFTS generate tables with data
merged from GIFTS. For instance, the Giving History Table merge field for
Organization correspondence merges a detailed history of an Organization's
Requests into your correspondence.
If there are more than 200 entries in these tables, a summary is automatically
merged in place of this detailed listing. Many clients use this limit to prevent
their correspondence from being too cluttered. This limit can be increased
using the TableMax preference.
Note: You may receive an error message when generating correspondence if
too much data is loaded into the merge field because of a higher limit. This
error can occur regardless of whether the letter you are working with
contains one of the affected merge fields (such as the Giving History Table).
If you receive errors while generating correspondence, please lower the
TableMax limit.

The TableMax limit does not apply to the Grant Requirements Table,
Payment Requirements Table, and Payments Schedule Table merge fields.
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To use the Preferences Editor to set the TableMax limit:
1 Log in to the GIFTS Administrator as a member of the Admin user group.
(Only users in the Admin group have access to the Preferences Editor.)
2 Choose Setup ➤ Preferences ➤ General from the Administrator menu.
3 On the General tab, click the Preferences Editor button. You are prompted
to save the preferences.
4 Click Yes to save the preferences and continue. The Preference Editor lists
the preference sections for the SYSTEM (all users) and for each user. In
the following example, the user logins CR, LW, and SS are shown:

5 Expand the list of sections for the user, and click the Correspondence
section:

6 Click Edit. The user’s Correspondence preferences are displayed.

Using the Preferences Editor
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7 On a new line within the list of preferences, enter TableMax= followed by
the number of entries you want to permit in the merge fields before a
summary list is used:

8 Click OK to save the preference.
9 From the Preferences Editor menu, choose File ➤ Close.
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Controlling
Access to GIFTS

GIFTS has a detailed internal system security feature. You can
control the View, Edit, Add, Update, and Execute access rights for
all major functions and sensitive fields in the system.
Note: Essential GIFTS does not support detailed security.
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About GIFTS Security
To simplify the process of setting up your security permissions, the security
rights for each staff member are determined by the group to which they
belong.
A group is simply a group of staff members with identical security access
rights. The group’s security access rights are determined by the permission
set assigned to the group. If you intend to use security, you must first decide
which sets of access rights are necessary to your organization.
For example, a foundation might have the following groups:
Group

Description/Access Rights

Administrator

The administrator and the backup administrator need full access
rights to all areas of the system.

Program Officers

Program officers need to be able to view and modify information
and run reports.

Program Assistants

Assistants need to enter and update records, run reports, create
letters, and so forth.

Executives

The president and other executives only wish to view
information.

Each of these groups will require different security access rights and hence
be assigned a different permission set.
You can also place Approval Restrictions on a group in order to block users
from approving any Request of a given Type, such as ‘Cash Grants’ or ‘Inkind Giving,’ or from approving Requests over a specific amount.

Tip: Approval Restrictions are particularly useful for grantmakers with
“officer” or “discretionary” grant programs where some personnel can
approve certain types of Requests up to a certain amount.
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In the Implementation Workbook for the GIFTS setup training course, you
should have defined your users and groups—as well as the permissions
granted to each group. If you have not, please take the time to do so now.
Then you can set up your system security as follows:
1 Create permission sets that define users’ system access rights.
2 Create your user groups and assign a permission set to each user group.
3 Define the Approval Restrictions that apply to any of your groups.
4 Create a user account for each member of your staff and assign each to his
or her appropriate user group.
Note that if a member of your staff will no longer use the system, you can
mark their user account ‘Inactive’ so that it cannot be used but will remain
in your historical data.

About GIFTS Security
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Managing Permission Sets
Permission sets allow you to create a set of permissions for specific job types
and tasks and apply them to one or more user groups. You can also copy and
edit an existing permission set, and print a report of permissions in a set.
To view your permission sets, choose Access ➤ Permissions from the
Administrator menu. The Permissions Sets window opens; existing
permission sets are displayed:

Please refer to the following sections to learn how to:
❖

Create, edit, or copy a permission set.

❖

Use field-level and staff override permissions.

❖

Delete a permission set.

❖

Print a permission set report.

Creating and Editing Permission Sets
To create or edit a permission set:
1 Click Access ➤ Permissions from the Administrator menu. The
Permission Sets window opens.
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2 To edit a permission set, highlight it and click Edit. To create a new set,
you can click New or highlight an existing set and click Save As.
Tip: If you want to create a new set with permissions that are similar to
those of an existing set, highlight the existing set and click Save As to
minimize the number of permissions that you’ll have to change.

To view the permissions
that you can set for
each GIFTS module,
click here to expand the
permissions grid.

3 Enter or edit the set’s Name and Description.
4 Use the check boxes to set the following permissions for each function.
The permissions grid displays permissions for individual modules much
in the same manner that Windows® Explorer® displays the directories
and files on your computer. To work with the permissions for a GIFTS
module, expand them by clicking on the box to the left of the module.
Check boxes shaded gray are not available.
Permission

Description

View

Permission to display the data. Without view access no other
access (add, update, or delete) is possible.
When setting most security permissions, you cannot disable the
View permission. To restrict the ability of users to view
information in GIFTS, you can use the field-level permissions
described in “Using the Field Level and Staff Override Permissions”
on page 94.

Update

Managing Permission Sets

Permission to edit existing entries of the type selected.
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Permission

Description

Add

Permission to create new entries of the type selected. A user needs
both add and update privileges to create and edit entries.

Delete

Permission to delete existing entries of the type selected.

Execute

Permission to perform the function selected.
Employee GIFTS users can disable the Login permission for the
Matching GIFTS and/or Volunteer GIFTS modules to prevent users
from viewing employee gifts-related data.

Tip: With the optional Branch Security feature, you can restrict the ability of
users to access data from other branches or divisions. For more information,
please refer to “Activating Branch Security” on page 296.

5 Click Save and Close to save your changes.

Using the Field Level and Staff Override
Permissions
Field-level permissions enable you to restrict users from updating the
following Request fields: Requested Amount, Recommended Amount,
Approval Amount, and Project Title. To restrict access to these fields, use
the permissions that begin with “Field:”

Often, grantmakers want to restrict user groups from updating these fields
in other people’s Requests, but would like these users to have the ability to
edit these fields in their own Requests. By enabling the Request - Staff
Override permission, you can override the restrictions on these sensitive
fields when users are working with their own Requests.
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Note: To prevent users from assigning Requests to themselves in order to

access these fields, users are denied access to the Staff field of Requests that
are not assigned to them.

Limiting Review Updates
The Update Other Staff Reviews permission by default is set to ON to
emulate functionality in prior versions of GIFTS.
If you would like to limit review updates to only the assigned reviewer, then
uncheck this box..

IGAM Permissions
Resubmission
Permissions to allow publishing an application or requirement for
resubmission are available. The Admin group has these permissions
available by default. The permissions default to off for all others.
1)Publish Application Resubmission
2)Publish Requirement Resubmission

Managing Permission Sets
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Transfers
Two permissions under the Grant Application Manager set control whether
a user has the ability to Transfer Requests or Requirements to a new grantee
owner.

Deleting a Permission Set
You can delete a permission set as long as it is not assigned to any user
group. If you attempt to delete a permission set assigned to any user group,
you are notified that you must remove the user groups from the permission
set before deleting it.
To delete a permission set:
1 Click Access ➤ Permissions from the Administrator menu. The
Permission Sets window opens.
2 Highlight the permission set and choose File ➤ Delete from the
Permission Sets window menu.
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Printing the Permission Set Reports
You can print reports listing permissions for all permission sets in the system
or for an individual permission set.
To print a report summarizing all permissions sets in the system:
1 From the Administrator menu, choose Access ➤ Permissions. The
Permission Sets window opens.
2 Click Report.
To print a report listing permissions for a single permission set:
1 Choose Access ➤ Permissions from the Administrator menu. The
Permission Sets window opens.
2 Highlight the permission set in the list and click Edit. The permission set
grid opens.
3 Click Report.
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Managing User Groups
The access rights for a user group are determined by the permission set to
which it is assigned. If all of your staff members will have equal unlimited
access to GIFTS, they can use the permission set for the Admin group that
comes with the system. For details on creating a new permission set, please
refer to “Managing Permission Sets” on page 92.

!

Caution: Do not modify the Admin group or its permission set. You should

always have a user group with unlimited administrative privileges; each
Admin group user should use a password to prevent unauthorized use of his
or her account.
To work with the GIFTS user groups, choose Access ➤ Groups from the
Administrator menu. The Groups window opens, listing the currentlydefined groups:

❖

To create a new group, click New. You are prompted to enter the name of
the group, and the group’s permission set.
Note: Users with Branch Security also specify the Branch Security
permissions for the group at this point. For more information, please refer
to “Assigning Groups to Branches” on page 299.

Click Save and Close. You are returned to the list of groups, which now
displays the group you created.
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❖

To create a new group with the same permissions as an existing group,
highlight the existing group and click Save As. You are prompted to enter
the name of the new group, and its permission set. If you have Branch
Security, you also specify the Branch Security permissions for the group.
When you are finished, click Save and Close.

❖

To edit the name of a group, highlight it and click Edit. You are prompted
to edit the group name. When you are finished, click Save and Close.

❖

To change the permission set of a group, highlight it and click Edit. Select a
new permission set and click Save and Close.

❖

To delete a group, highlight it and choose File ➤ Delete from the Groups
menu. You are prompted to confirm that you want to delete the group or,
if there are users assigned to the group, you are notified that you cannot
delete the group unless no users are associated with it.
If you want to delete a group that has users associated with it, you must
either assign those users to another group or remove them from the
system.

❖

To print a report of the permissions and approval restrictions for all groups
listed, click Report.

When you are finished working with your groups, choose File ➤ Close
from the Groups menu.
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Setting Approval Restrictions
You can place Approval Restrictions on any user group in order to block
users in that group from Approving any Request of a given Type, such as
Cash Grants or In-kind Giving, or from Approving Requests over a specific
amount. This section describes how Approval Restrictions work, and then
how to enter them into the system.

About Approval Restrictions
The following lists detail the restrictions applied when a group either has no
approval rights to a particular Request Type, or approval rights only up to a
specified amount.
No Access If users are restricted from access to a particular Request Type,
they cannot:
❖

Add, approve, or modify the Payment Schedule of a Request of that Type.

❖

Change the Type of existing Requests from that Type to another, or vice
versa.

❖

Use the Request Type in the Budget Module.

If users are restricted to a particular amount for a certain
type, they cannot:

Limited Access
❖

Approve a grant over the limited amount or modify a grant’s Payment
Schedule in such a way that would cause the Grant Amount to exceed the
limit.

❖

If an existing grant of another Type exceeds the limited amount: change
the Type of the existing grant to the restricted Type.

Setting Up Approval Restrictions
Before You Begin: The permission to Approve a Request must be available
to a group in order for the Approval Restrictions to be effective; otherwise,
users in that group cannot approve any Request. The Admin group is used
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as an override to this feature. No Approval Restrictions can be applied to the
Admin group.
To set up the Approval Restrictions, use the following procedure:
1 From the Administrator menu, choose Access ➤ Groups. The Group list
is displayed.
2 Highlight the group for which you want to define Approval Restrictions,
and click Edit.
3 Click Approval Restrictions. The Approval Restrictions for [Group]
window opens:

Initially, this window is empty since no Approval Restrictions exist. For
each Request Type for which you wish to specify restrictions, you will add
an item to this list. Once added, you can edit or delete them at any time.
Note: By default, no restrictions are applied to Request Types. If you do

not need restrictions for a particular Request Type, do not add it to the
list.
4 Click New. The Approval Restriction window opens:

5 Use the Type field to choose the Request Type for which you are creating
restrictions.
6 Set the restrictions for the Request Type:
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❖

To block users from approving any Requests of this Type, ensure that
the Accessible check box is cleared.

❖

To place a limit on the value of Requests that this user group can
approve, select the Accessible check box and enter the limit amount
in the Limit field.

7 Click Save and Close. The restrictions are displayed in the Approval
Restrictions list for the group.
8 You can set up your remaining Approval Restrictions for the group as
follows:

102

❖

To add restrictions for other Request Types, click New.

❖

To modify a restriction, highlight it and then click Edit.

❖

To delete a restriction, highlight it and choose File ➤ Delete from the
Approval Restrictions menu.
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Managing User Accounts and Passwords
Every person who will have access to GIFTS must be identified as a user
with a valid login ID. In addition, you may have other members of your staff
whom you wish to be able to associate with Requests, Activities, or other
items, but should not have access to the system. In both cases, each
individual must be entered as a user.
If you selected the Extended Password Security option in the General
Preferences tab, you should set a password for each user. If you did not
select this option, users are responsible for creating their own passwords as
described in the GIFTS User’s Guide. In either case, be sure to protect your
administrative account with a password.
With the Administrator Module, you can:
❖

Add and modify user accounts.

❖

Mark a user account as inactive or reactivate an inactive account.

❖

Delete user accounts.

❖

Set, reset, or clear a user’s password.

❖

Print a user summary report listing the users on your system.

Note: If you are using the client/server version of GIFTS or you are running

GIFTS on Windows NT, please refer to “Global Client/Server Login
Options” on page 110 and “Setting Up Windows NT Login Integration” on
page 115 for additional information before setting up your user accounts.
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Adding and Modifying User Accounts
Before defining your users, make sure that you have entered your user
groups and set up the appropriate permissions for each group. To work with
your users:
1 Choose Access ➤ Users from the Administrator menu. The Users window
opens, listing all users currently defined in your system:

2 Click New to add a user, or highlight a user and click Edit to modify an
existing user. The Adding a New User window or Editing an Existing User
window opens:

104

Field

Options

Login ID

The name the user enters when he or she logs in to GIFTS—
usually the initials of the user or an abbreviation of his or her
name.

Name

The full name of the user.

Title

The user’s title.

E-Mail

The user’s e-mail address, which can be included in reports
and exports.
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Field

Options

Group

The group to which this user is assigned.

4

3 When the information is complete, click OK.
Important: To prevent unauthorized account access, you should create a

password for each user. Otherwise, anyone can use his or her account
without entering a password.

Deactivating or Reactivating a User Account
If a member of your staff will no longer use the system, you can mark their
user account ‘Inactive’ so that it cannot be used but remains in your
historical data. You can mark a user account as inactive at any time using the
following procedure:
1 From the Administrator menu, choose Access ➤ Users. The Users
window opens.
2 Highlight the user you wish to delete and click Deactivate. The user’s
Login ID is displayed in red, indicating that the account is inactive. All lists
of users will either omit this user or mark it as inactive, as appropriate.
When this user is selected, the Deactivate button is replaced by Activate.
You can click Activate to reactivate the user account.

Replacing a User Account
You can replace one user account with another. All GIFTS records
associated with the former user account will now be associated with the
new account.
For example, Sarah Sullivan, a staff member within your organization, has
gotten married and assumed her husband’s surname. You can create a new
user account (with her new last name), then replace her old user account
with the new one:
1 Create a new user account, as described in “Adding and Modifying User
Accounts” on page 104.

Managing User Accounts and Passwords

105

4

Controlling Access to GIFTS

2 From the Administrator menu, choose Access ➤ Users. The Users
window opens.
3 Select the user account you want to replace and choose Action ➤ Replace
User from the Users window menu. The Replace User window opens:

4 From the drop-down menu, select the user account that will replace the
other. Click OK. A summary of your proposed changes appears, asking
you to confirm the replacement:

5 Click Yes. A message informs you when the replacement has been
completed.

Deleting a User Account
You can delete a user account at any time using the following procedure:
1 From the Administrator menu, choose Access ➤ Users. The Users
window opens.
2 Highlight the user account and Choose File ➤ Delete from the Users
menu.
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❖

If there are no records in your GIFTS database associated with this
user account, the account is now deleted.

❖

If any GIFTS records are still associated with this user account, your
will receive the following message:

Click OK to clear the message. The user account is not deleted.
If you need to delete a user account that still appears in your GIFTS records,
first replace the user account with a new one, then delete the account. For
more information on replacing user accounts, see “Replacing a User
Account” on page 105.
Important: To maintain a user’s presence in your historical data while not

permitting access to the system, you can mark their user account inactive as
described in “Deactivating or Reactivating a User Account” on page 105.

Setting, Resetting, or Clearing a User Password
If you select the Extended Password Security option in the General
Preferences, you can set and reset user passwords. Passwords that you set or
reset are temporary. Users are prompted to change the new password the
next time they log in.
If you do not select Extended Password Security, you can only clear an
existing password. After you clear a user’s password, he or she can log on to
GIFTS without entering a password.

Setting an Individual User’s Password
You can set an individual password by using the following procedure:
1 From the Administrator menu, choose Access ➤ Users. The Users
window opens.
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2 Highlight the user and click Set Password. You are prompted to enter and
verify the new password.
3 Click OK to set the password.

Setting All User Passwords
You can set a global password for all users (except yourself ) by using the
following procedure:
1 From the Administrator menu, choose Access ➤ Users. The Users
window opens.
2 Click Set All Passwords. You are prompted to enter and verify the new
password.
3 Click OK to set the global password.

Resetting a User’s Password
If a user forgets his or her password, you can reset it using the following
procedure:
1 From the Administrator menu, choose Access ➤ Users. The Users
window opens.
2 Highlight the user and click Reset Password. You are prompted to enter
and verify the new password.
3 Click OK to reset the password.

Clearing a User’s Password
If you did not select Extended Password Security in the General Preferences,
you may only clear user passwords. Once you clear a user’s password, he or
she can log on without entering a password. To clear a password, use the
following procedure:
1 From the Administrator menu, choose Access ➤ Users. The Users
window opens.
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2 Highlight the user and click Clear Password.
3 Click OK to clear the password, or Close to cancel.

Printing a User Summary Report
You can print a user summary report that lists the Login ID, User Name,
Title, and User Group Name for the users on your system.
To print a user summary report:
1 From the Administrator menu, choose Access ➤ Users. The Users
window opens.
2 Click Print and specify your print setup options as described in the GIFTS
User’s Guide. (Note that for the user summary report, there are no report
grouping options.)
3 When you are finished, click Print from the Print Setup menu.
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Global Client/Server Login Options
By default, GIFTS uses a single, global Login ID and encrypted password to
log users on to your client/server database (Microsoft SQL Server or Oracle
server). This User ID and password are maintained in the Connect string in
the [SQL Server] section of the GIFTS.INI file on each workstation.
To change the database Login ID or password, you must edit the GIFTS.INI
file on each workstation. You can streamline this editing process by
maintaining a single login for all users, as described in “Maintaining a Global
Client/Server Login” on page 110.
For information about changing the database login ID and password, please
refer to “Changing the Client/Server Login ID and Password” on page 111.
Rather than use a global client/server database login ID and password, you
can require that GIFTS users log on to the database individually. You can
accomplish this with either of the following approaches:
❖

“Client/Server Login Integration” on page 113

❖

“Requiring Individual Database User Logins” on page 113

Maintaining a Global Client/Server Login
You can streamline this editing process by moving the [SQL Server] section
(including the Connect string) from GIFTS.INI to the GIFTS.SYS file. Once
you have copied this section to GIFTS.SYS, the [SQL Server] section in
GIFTS.INI is ignored; you can change the database login ID or password for
all users by editing the Connect string in the GIFTS.SYS file, rather than by
editing GIFTS.INI on each workstation.
To copy the database login information to the GIFTS.SYS file, use the
following procedure:
1 In a text editor such as Notepad, open the GIFTS.INI file (this file resides
in the C:\WINDOWS or C:\WINNT directory).
2 Locate the [SQL Server] section. It should resemble the example below:
[SQL Server]
DatabaseName=f:\GIFTS\gifts.mdb
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Connect=ODBC;UID=[Login ID];PWD=Ù¥ÕCÝ‚©Œ;DSN=GIFTS;DATABASE=GIFTS
PWDEncrypted=-1

3 Copy the entire [SQL Server] section (including the Connect string) to the
GIFTS.SYS file.
4 Save the GIFTS.SYS file with your changes.
Note: Whether you choose to maintain your global database login
information in the GIFTS.INI or GIFTS.SYS file, GIFTS always encrypts
the database password.

Changing the Client/Server Login ID and
Password
For security reasons, you may want to periodically change your client/
server database login ID or password. Remember, whether you maintain
this information in the Connect string of the GIFTS.INI or GIFTS.SYS file,
the database password is automatically encrypted by GIFTS.
To Change the Client/Server Database Password If you maintain your
database login information in the GIFTS.INI or GIFTS.SYS file, you can
change the encrypted password using the following procedure:

1 In a text editor such as Notepad, open the GIFTS.INI or GIFTS.SYS file.
2 Locate the [SQL Server] section. It should resemble the following example:
[SQL Server]
DatabaseName=f:\GIFTS\gifts.mdb
Connect=ODBC;UID=[Login ID];PWD=Ù¥ÕCÝ‚©Œ;DSN=GIFTS;DATABASE=GIFTS
PWDEncrypted=-1

3 Type the new unencrypted client/server database password after PWD=
in the Connect string. For example, if you want to change the password
to NEWPWD the Connect string should look like this:
Connect=ODBC;UID=[Login ID];PWD=NEWPWD;DSN=GIFTS;DATABASE=GIFTS

4 Delete the password encryption key that reads PWDEncrypted=-1 or
change it to read PWDEncrypted=0. The [SQL Server] section should now
look like the following example:
[SQL Server]
DatabaseName=f:\GIFTS\gifts.mdb
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Connect=ODBC;UID=[Login ID];PWD=NEWPWD;DSN=GIFTS;DATABASE=GIFTS
PWDEncrypted=0

5 Save the file with your changes.
If you are changing the GIFTS.SYS file, immediately log on to GIFTS. Doing
so automatically encrypts the new password and resets the password
encryption key to PWDEncrypted=-1. If you are changing the GIFTS.INI
file, you must repeat steps 1–5 for each workstation that runs GIFTS.
After you change GIFTS.INI, GIFTS automatically encrypts the password
and resets the encryption key the next time the user logs on to GIFTS from
his or her workstation.

!

Caution: Do not remove or change the password encryption key

(PWDEncrypted=-1) without first typing a password in the Connect string.
Removing the password encryption key without typing a new password in
the Connect string could result in an encrypted password that the encryption
algorithm is unable to read.
To Change the Client/Server Login ID If you maintain your database login
information in the GIFTS.INI or GIFTS.SYS file, you can change the
database login ID using the following procedure:

1 In a text editor such as Notepad, open the GIFTS.SYS file.
2 Locate the [SQL Server] section. It should resemble the example below:
[SQL Server]
DatabaseName=f:\GIFTS\gifts.mdb
Connect=ODBC;UID=[Login ID];PWD=Ù¥ÕCÝ‚©Œ;DSN=GIFTS;DATABASE=GIFTS
PWDEncrypted=-1

3 Type the new login ID after UID= in the Connect string. For example, if
you want to change the login ID to NEWLOGID, the Connect string should
look like this:
Connect=ODBC;UID=NEWLOGID;PWD=Ù¥ÕCÝ‚©Œ;DSN=GIFTS;DATABASE=GIFTS

4 Save the file with your changes. If you are maintaining your client/server
database login ID in the GIFTS.INI file you must repeat steps 1–4 for each
workstation that runs GIFTS.
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Client/Server Login Integration
If you remove the client/server database login information from the
GIFTS.INI or GIFTS.SYS file, users are required to log in to the server by
means of Microsoft SQL Server or Oracle server. When you remove the
database login information, the login process for users is as follows:
1 When the user attempts to open GIFTS, the server prompts them for their
SQL or Oracle user name and password.
2 If the user name and password are valid, GIFTS checks its database for the
same user name and password. If these are found in GIFTS, the user is
logged in.
3 If the user name and password are not found in the GIFTS database, the
user is prompted to log in to GIFTS.
The Oracle database is
organized in such a way that each user ID has its own schema. Tables
created by a given user belong to the schema for that user.
Important: Considerations for Oracle Server

GIFTS assumes that all users will log in using the standard login. If you
decide to take advantage of the Integrated Logins feature, you must create
synonyms for the GIFTS tables so that these tables will be accessible to all
users.
A script that renames all GIFTS database tables to include the prefix GFW_
and create synonyms for these newly renamed tables is available from
MicroEdge. Please contact MicroEdge Technical Support if you wish to
receive these materials.

Requiring Individual Database User Logins
By removing the login ID and password from the Connect string in the
GIFTS.INI or GIFTS.SYS file, you can require users to enter database login
information manually each time they log in to GIFTS.
To remove the login ID and password from the Connect string:
1 In a text editor such as Notepad, open the GIFTS.INI or GIFTS.SYS file:
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2 Locate the [SQL Server] section. It should resemble the following example:
[SQL Server]
DatabaseName=f:\GIFTS\gifts.mdb
Connect=ODBC;UID=[Login ID];PWD=Ù¥ÕCÝ‚©Œ;DSN=GIFTS;DATABASE=GIFTS
PWDEncrypted=-1

3 Remove the login ID and password so the Connect string reads:
Connect=ODBC;UID=;PWD=;DSN=GIFTS;DATABASE=GIFTS

4 Save the file with your changes.
If you are editing the Connect string in the GIFTS.INI, file you will need
to repeat steps 1–4 for each workstation that runs GIFTS.
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Setting Up Windows NT Login Integration
With Windows NT Integrated Security active, GIFTS retrieves the ID that
the user used to log into Windows NT and—if there is a matching Login ID
in GIFTS—automatically logs the user into GIFTS. (If the user has a
password in GIFTS, it is ignored.)
If the Login ID is not found in GIFTS, the user must log in to GIFTS.
Important: For this feature, you should create and maintain all GIFTS users

with Login IDs that are identical to their Windows NT Login IDs.
To activate this feature, select the Use Windows NT Integrated Security
check box in the General Preferences, as described in “General Preferences”
on page 45.
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Setting Up Windows NT Login Integration
with GCS
With Windows NT Integrated Security for GCS active, users can use their
Windows NT Login ID and, optionally, their password to log into MyGIFTS.
Important: For this feature, you should create and maintain all GIFTS users

with Login IDs that are identical to their Windows NT Login IDs.
To activate this feature, select the Use Windows NT Integrated Security for
GCS checkbox in the General Preferences, as described in “General
Preferences” on page 45.
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This chapter explains how to apply Default Grant Requirements to
your pending and approved Requests. This feature is not available in
Essential GIFTS.
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About Default Requirements
Most grantmaking organizations have reporting guidelines that are required
of their grantees. These usually follow a specific pattern, with specific kinds
of reports—such as progress reports and final reports—required at specific
points in time.
In addition, many grant makers also require a specific set of materials from
each prospective grantee at the time that a proposal is being evaluated. In
GIFTS, you can schedule Default Grant Requirements for any Request Type
in your system.
You can create lists of Requirements for both pending and approved
Requests, and they will be imposed automatically when a Request is entered
and/or approved, saving data entry time and guaranteeing consistency.
In the Implementation Workbook for the GIFTS setup training course, you
should have defined your Request Types—such as Cash Grants or In-kind
Giving—according to the different types of giving programs you wish to
track in GIFTS. Since different types of requests normally follow different
processes, you can maintain separate Default Requirement Schedules for
each Request Type.
When a Pending Request is created, the default Requirements specified for a
Request of that Type and Disposition are automatically entered for that
Request. Users can modify and update the Requirement information just as
they would if the Requirements were scheduled manually. When a Request
is approved, the Requirements specified for approval are scheduled.
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Setting Default Requirements
Before You Begin: Ensure that the Requirement Type codes that you need

have been entered in the Activity Type Code Table. See “Maintaining
Codes” on page 23 for more information about editing codes.

To set your Default Grant requirements:
1 From the Administrator menu, choose Setup ➤ Grant Requirements. The
Grant Requirement Defaults window opens:

2 In the Type field, choose the Request Type for which you wish to define
Default Requirements.
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3 Click on the appropriate radio button to choose default Requirements for
new proposals or for approved Requests. You can define both lists, but
you must do so one at a time.
4 To schedule a Requirement, highlight the Requirement Type and specify
the frequency at which this particular Requirement should be scheduled.
❖

Choose Once to have it scheduled only once, and then choose the
appropriate interval of time. Dates are calculated from the Request
Date for pending items, and from the Project Start Date for approved
items.

❖

Choose Recurring if the same Requirement will be needed several
times, and then specify the frequency of the Requirement. For
example, if you require Project Reports from grantees every year
until the conclusion of the project, click Recurring and specify a
frequency of 12 months. The Project Report would be scheduled
once a year for each year of the grant.

5 Click Add to add the Requirement to the Schedule. It is displayed in the
schedule.
6 Continue adding Requirements until the schedule is complete.
❖

o remove a Requirement, highlight it and then click Remove.

❖

To edit a Requirement, highlight it and change the options as
necessary.

7 When the Requirement schedule is complete, click Assign. The schedule
is assigned to the Request Type you chose.
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This chapter explains how to set up and maintain exchange rates for
other currencies. This feature is not available in Essential GIFTS.
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About Currencies and Exchange Rates
If you are involved in international grant-giving and want to track Request
and Payment amounts in two currencies—your own, and another currency
used by the grantee—you can do it using GIFTS multi-currency features.
The basic concept behind GIFTS multi-currency features is fairly simple:
You enter other currencies (and their exchange rates) in the Administrator
Module’s Exchange Rate Table. Then, when adding or modifying a pending
Request or unpaid Payment, you can specify a second currency (e.g., Euro,
Japanese Yen). Enter a Request or Payment amount in one currency, and
GIFTS then automatically calculates the amount in the other, based on the
exchange rate in the Exchange Rate Table. The Request or Payment record
is saved with both amounts specified.
After that, however, it gets a lot more complicated. You’re well aware that
exchange rates are not static: They fluctuate daily—even hourly!
So what happens when exchange rates change? How do you update the
Exchange Rate Table? Do you want two-currency Request and Payment
amounts recalculated when you update exchange rates? Which amount do
you want to remain constant—the amount in your currency, or in the other
currency?
GIFTS’s flexible multi-currency features allow you to make these decisions
yourself and set rules for your GIFTS system using the Administrator
Module. You can also decide whether to enforce this rules strictly, or allow
users (or members of certain user groups) to change multi-currency
behavior for Requests and Payments.
One consequence of this flexibility, however, is that choosing and using the
multi-currency options can become rather complicated. Please read this
chapter very carefully before deciding how to implement multi-currency
features in your GIFTS system.
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The Exchange Rate Table
In the Exchange Rate Table, you enter the local/other currencies your
grantees may use, the exchange rate for each currency, and other currency
details:

For information on accessing and adding currencies to the Exchange Rate
Table, please see “Adding Currencies” on page 142.
You can also update a currency’s exchange rate in the Exchange Rate Table.
For details, please see “Updating Exchange Rates Manually” on page 146.

Key Terms: “Functional” versus “Local/Other”
The amount of a Request or Payment can be tracked in two currencies.
GIFTS refers to these as the functional currency—the currency your
organization’s headquarters uses—and the local/other currency—the
currency the grantee uses.
Your functional currency is specified in the multi-currency preferences of
the GIFTS Administrator Module. By default, GIFTS uses the currency
selected in your Windows Regional Settings. However, you can enter a
different currency to use as your functional currency. For details on
specifying your functional currency, please see “Choosing Your Functional
Currency” on page 124.
A local/other currency can be selected within pending Requests or unpaid
Payments by GIFTS users. This can be any currency saved in the Exchange
Rate Table.
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You can also specify a default local/other currency. Note that if you do, all
new pending Requests and unpaid Payments will automatically save the
default currency and—depending on your preferences—the resulting local/
other amount.
Just as we refer to functional and local/other currencies, we also refer to
functional and local/other amounts.
The functional amount is the amount in your currency that you are granting
out of your giving budget. When you then specify a local/other currency to
a Request or Payment, GIFTS multiplies the functional amount times the
exchange rate specified for the currency. The product is saved in the GIFTS
record as the local/other amount.

Choosing Your Functional Currency
By default, your functional currency is the currency specified in your
Windows Regional Settings. This work will work well for many users.
However, certain organizations may wish to designate a different functional
currency. For example, a charity based in Great Britain may have the British
Pound specified in its Windows Regional Settings. However, their giving
budget is specified in Euros, not Pounds. In that case, they may want to
change their GIFTS functional currency to the Euro.
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A different functional currency can be specified in the General Preferences
of the GIFTS Administrator Module:
1 From the Administrator menu, select Setup ➤ Preferences. The
Preferences window opens:

2 In the Currency Display section of the General tab, select the “Always use
the currency below” radio button, then fill in the following required fields:
Field

Description

Name

Enter the name of the currency, e.g., “Euro” or “Canadian
Dollar.”

Designation

Enter a unique three-character designation for the currency.
You may want to use the standard designations used in the
currency market, such as EUR for the Euro or GBP for the
British Pound.

Symbol

Enter the symbol you want to use to mark the currency. This
symbol will be used to indicate the currency in Payment
amounts, appearing in front of the number.
GIFTS does not provide currency symbols that are
unavailable on standard workstation keyboards. Use
Windows Character Map to find other symbols, or paste the
symbol from Microsoft Word.
You can also enter a letter or letters as a symbol, such as DM
for the German Mark (Deutschmark).

About Currencies and Exchange Rates

125

6

Setting Up Multi-Currency Options

Field

Description

Rounding Factor

When GIFTS uses an exchange rate to calculate amounts, it
will calculate the figure exactly. After the calculation is
completed, however, GIFTS rounds the figure based on the
Rounding Factor.
GIFTS can, at its most exact, round to the nearest 1/100 of the
currency (.01). However, you may prefer to track Requests
and Payments using less detailed amounts. Large amounts
may not need to be tracked to the .01 decimal place.
Here you are determining how precisely you want functional
amounts calculated when you they are adjusted, either by
exchange rate changes or changes to the local/other
amount.
For instance, you decide that you want to track amounts to
the nearest hundred units of the currency. Enter 100 in the
Rounding Factor field.
For example, imagine that you have entered 3.25 as the
Exchange Rate for the Euro. You then add a Request,
entering a local/other amount of 50,000 Euros. GIFTS
calculates the exact functional amount as 15,384.62 of your
specified functional currency. It then considers your
Rounding Factor of 100 and rounds the number to the
nearest 100. The Payment in your functional currency will be
recorded in GIFTS as 15,400.

3 The last two options are available for either kind of functional currency,
whether based on Windows Regional Settings or your own functional
currency:
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Option

Description

Don’t Display
Currency Symbol

Select this check box if you don’t want GIFTS currency fields
to include the currency’s symbol.
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Option

Description

Don’t Display
Decimal Places

Select this check box if you don’t want GIFTS currency fields
to display the decimal point and any fractional amount
following it.
This option may not be advisable for multi-currency users,
unless you have also set up your local/other currencies to
round calculated local/other amounts to the nearest whole
unit (in which case they wouldn’t have any fractional
amount to display to the right of the decimal point).
NOTE: You can designate a local/other currency’s rounding
factor when adding or updating an exchange rate. This and
other options are discussed in “Adding Currencies” on
page 142.

4 Click OK in the lower left corner of the General tab to save your
Preferences.

About Currencies and Exchange Rates

127

6

Setting Up Multi-Currency Options

Setting Up Your Multi-Currency
Preferences
The multi-currency features in GIFTS are flexible, allowing you many
different options for handling exchange rate changes and their effect on
Request and Payment amounts. This flexibility requires careful attention to
the multi-currency preferences you set up in the GIFTS Administrator
Module.
The topics below discuss each preference in turn. Think about how your
organization handles multi-currency, read this section carefully, and consider
which options best suit your needs.

Accessing Multi-Currency Preferences
To access the multi-currency preferences discussed below:
1 From the Administrator menu, select Setup ➤ Local/Other Currencies ➤
Preferences. The Local/Other Currency Preferences window opens:

2 To activate the multi-currency options in GIFTS, select the “Track Local/
Other Currency for Payments/Requests” check box. The other
preferences are now available.
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Default Local/Other Currency
After you have added some local/other currencies to the Exchange Rate
Table, you can choose one to be the default local/other currency:

You can select a default local/other
currency here.

This option is useful if most of your second-currency giving is limited to one
local/other currency. Select the default currency from the drop-down menu;
it lists all the local/other currencies you have entered in the Exchange Rate
Table.
Select <None> if you do not want to specify a default local/other currency.
Note: For information on the Exchange Rate Table and adding currencies to

it, please see “Adding Currencies” on page 142.
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Currency Display Options
The next two options determine which currency—functional or local/
other—is displayed as the primary currency in Requests and Payments
where two currencies are specified:

Currency display options are
selected here.

The Primary Display Currency option
determines which of the two currencies is displayed on first tabs of Request
and Payment records. Below is a Request in a GIFTS system where the
local/other currency is the primary display currency:

Primary Display Currency

If the preference
specifies that the
local/other currency is
the primary display
currency, amounts on
Page 1 of the Request
shows these amounts
in the currency
selected.

Note that amounts in both currencies will both be saved, regardless of which
is primarily displayed.
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Tip: Select the currency in which your GIFTS users are more likely to think

of grants and grant amounts. For example, if most of your international
grant-giving commitments are made in the local/other currency—for
example, you agree to give 10,000 Japanese yen in four quarterly payments,
regardless how exchange rates fluctuate and affect the amount in your
functional currency—it might make more sense to display primarily the
local/other currency.
The selection here works the same as it does in the
Primary Display Currency option. In this case, however, it determines which
currency the Project Budget field of Requests is shown in:
Project Budget Display

Multi-currency
features do not
convert the Project
Budget from
functional to local/
other amounts, or vice
versa. The currency
chosen to display here
will be the only
currency in which the
project budget
amount will be saved.

Note: Since there is only one Project Budget field in a Request (even if the

Request has two currencies), the display currency you choose here will be the
only one saved.

When Exchange Rates Change
Suppose that your GIFTS system already contains a number of Requests and
Payments which have been calculated in another currency. The calculations
were based on the exchange rate for that currency, entered in the Exchange
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Rate Table. What happens to such a Request or Payment when the
exchange rate changes?
First of all, you should be aware that
there are a couple of ways that the exchange rate for a Request or Payment
could change:
Defining “Exchange Rate Changes”

❖

You (the GIFTS administrator) update the exchange rates to reflect
changes in the currency market. (Please see “Updating Exchange Rates”
on page 145 for more information.)

❖

A user changes the local/other currency specified in the Request or
Payment to one with a different exchange rate.

❖

A user changes the Rate Date specified in a pending Request or unpaid
Payment, changing it to a day when a different exchange rate for the local/
other currency was in effect.
Every exchange rate has a Rate Date—the date on which the rate took
effect. You have the option (discussed below in “Tracking Changes to
Exchange Rates” on page 140) to track exchange rates over time. If you
track historical exchange rates, GIFTS will save the old rates and the
dates on which each took effect.

If a user changes the Rate Date in a pending Request or unpaid
Payment—once a a Payment is paid or Request is approved, he or she
won’t be able to do that—the Rate Date might coincide with a different
exchange rate than the current one. Thus, the exchange rate for that
Request or Payment changes.
Note: If you don’t track historical exchange rates, the Rate Date field will
not be editable.
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What Happens when the Exchange Rate Changes?

It is here in the multi-

currency preferences that you decide:

In regard to pending Requests, you can set the options
described in this topic as a default, or as a rule GIFTS will
enforce.
Select the “Allow override on Requests” check box to allow
users to change the way each particular pending Request
handles exchange rate changes.
Clear the check box, and the rule you set here will be
enforced for all pending Requests.

GIFTS can adjust an amount—either the functional currency amount or the
local/other currency amount—based on the new exchange rate. Note that
these adjustments will only apply to pending Requests and unpaid
(scheduled, contingent, or hold) Payments.
(Once a Request is approved or declined, or a Payment is paid, you will want
to keep track of it as was when the decision or payment was made. This is
why exchange rate changes can adjust only the Requests and Payments
specified above.)
Deciding Whether or Not to Make Adjustments So that’s the first thing to
decide: do you want GIFTS to adjust the amounts of pending Requests and
unpaid Payments when you update exchange rates?

Setting Up Your Multi-Currency Preferences

133

6

Setting Up Multi-Currency Options

If you do not, select “Do not adjust either amount”:

If you do, then have a second decision:
You have
the option to decide which amount—functional or local/other—is
recalculated when exchange rates change.

Deciding to Adjust Functional Amounts or Local/Other Amounts

You have two options concerning recalculation of amounts. When exchange
rates change, GIFTS can:
❖

Keep the local/other amount constant, and adjust the functional amount
based on the new exchange rate.
To do this, select “Adjust Functional Amount.”

❖

Keep the functional amount constant, and adjust the Local/Other
Amount based on the new exchange rate.
To do this, select “Adjust Local/Other Amount.”

Which option should you
choose, whether on a system level or for an individual Request? It depends
on the commitment you have made for grants that use the local/other
currency.

Choosing an Option That Suits Your Needs

When your organization approves a Request from an Organization that uses
a different currency, you will most likely agree to a specified amount in one
of the two currencies—your functional currency, or their currency. If
Payments are to made over a period of time, fluctuations in currency
exchange rates must be taken into account. How you want to deal with
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these fluctuations in GIFTS depends on the currency in which you made
your giving commitment.
❖

Scenario 1 — You have committed to a grant amount of 10,000 US Dollars
(your functional currency) to be paid to an Organization using Euros. The
commitment has been made in your functional currency. Exchange rate
changes will change the value of that $10,000 (in terms of the equivalent
number of Euros needed to match it), but the $10,000 will remain constant.
In this case, you will want to set your multi-currency preferences to
“adjust Local/Other Amount” when exchange rates change.

❖

Scenario 2 — You have committed to a grant to be paid to an Organization
using a local/other amount. For example, the agreement stipulates that
the commitment is for 10,000 Euros.
In this case, you probably want to make sure that each Payment you
make in US Dollars is equivalent to the promised amount in Euros. (In
fact, this scenario is one where up-to-date exchange rates are most
important.) Suppose the grant is being made in two Payments, each to
equal 5,000 Euros.
At the time the first Payment is made, the exchange rate for Euros is set
to 2.0 (i.e., 1 dollar equals 2 Euros). You can see that the functional
amount of the first Payment will be for 2,500 dollars (2,500 x 2 = 5,000
Euros).
Six months later, the exchange rate for Euros has risen to 2.5—1 dollar
now equals 2.5 Euros. You need to adjust your second Payment to the
functional currency amount of 2,000 dollars (2,000 x 2.5 = 5,000 Euros).
Thus, you have fulfilled your commitment to make two Payments of five
thousand Euros.
In this scenario, you would want to select “adjust Functional Amount”
when exchange rates change. This keeps the local/other currency
amount (in this example, Euros) consistent, while allowing the exchange
rate to determine the functional amount of your Payment in your
functional currency (here, US Dollars).
Note: If you use the optional Budget Module, be aware that Payments

that have been resolved against the budget will be automatically “reresolved” if the amount changes, so that the budget reflects the true paid
amount. If the budget Line Item or Reserve Fund against which the
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Payment is resolved does not have sufficient funds to cover the increased
Payment Amount, the Payment will not be changed. A message appears
noting that, due to insufficient funds, the Payment or Payments have not
been updated.

When Adjusting Payment Amounts
The next multi-currency preference allows you to determine how GIFTS
adjusts grant amounts based on changes to Payments amounts:

To understand these options, first consider what can happen to Payments
and their Requests when exchange rates change.
How Exchange Rate Changes Affect Grant Amounts An exchange rate change
may adjust a Payment’s functional or local/other amount. These changes
can, in turn, affect the grant amount (i.e., the amount of the approved
Request associated with the Payments):
❖
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When the local/other amount is adjusted — Since in this case the Payment
functional amount (the “real” amount) remains the same, the change does
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not affect the grant total. GIFTS will simply adjust the local/other amount
of the Payment and inform you of the change in the process log:

Note: In the Payment’s affiliated Request, the functional amount will not

change.
❖

When the functional amount is adjusted — More care should be taken in these
cases, as a Payment’s adjusted functional amount means either adjusting
the grant (Request) amount or possibly adding another Payment to make
up the difference (when the Payment’s functional amount decreases).
Note: If you use the optional Budget Module, be aware that unpaid

Payments that have been resolved against the budget will be
automatically “re-resolved” if the functional amount changes, so that the
budget will reflect the true paid amount. If the budget Line Item or
Reserve Fund against which the Payment is resolved does not have
sufficient funds to cover the increased functional amount, the Payment
will not be changed. A message appears noting that, due to insufficient
funds, the Payment or Payments have not been updated.
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This multi-currency
preference will determine what happens in these cases:

When adjusting functional Payment Amounts...

If you do not need the functional amounts of a Request and its Payments to
reconcile, select “Never” in this drop-down menu. If you do need to
reconcile those functional amounts, however, GIFTS can prompt users to
create Grant Amendments to reconcile the amounts. In this multi-currency
preference, you decide when users will be so prompted:
❖

Only when the sum of the Payments exceeds the grant amount

❖

Always (even when the grant amount will decrease)

If an updated exchange rate increases the functional Payment amount(s), the
Request Amount is automatically increased to cover the Payment totals
(unless you choose “Never” for this preference). The process log tells you
the amount that both the Payment and the associated Request have
increased:
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If the exchange rate change decreases the functional Payment amount(s), and
you have selected “Only when the sum of the Payments exceeds the grant
amount,” the grant amount is not changed. The user will have to add
another Payment (or increase an existing Payment) if you want to make up
the difference. The process log indicates the change in the functional
Payment Amount, and also notes the Request’s remaining unscheduled
balance:

If the exchange rate change decreases the Payment Amount(s), and you have
selected the second option, “Always (even when the grant amount will
decrease),” the grant amount is decreased to the sum of the new functional
Payment amounts. The process log tells you the amount that both the
Payment and the associated Request have decreased:

Note: In each of the process logs shown as an example above, only one kind

of amount change is shown. Be aware—if you have selected the Request
override option described in “When Exchange Rates Change” on page 131,
that each Request can be set to handle exchange rate changes differently.
Some items in a process log may show changes to the local/other amount,
while others in the same log show that the functional amount has been
adjusted. Read the process log carefully every time you change an exchange
rate. You can also save the log, or print it.
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Tracking Changes to Exchange Rates
The last two options to select for your multi-currency preferences concern
tracking changes to exchange rates:

Select the Maintain Historical
Exchange Rates check box if you want to maintain a table of past exchange
rates for each currency entered in your Exchange Rate table. When you
update an exchange rate, the rate your are replacing is saved to the exchange
rate history.

Maintaining Historical Exchange Rates

These historical rates can then be applied to pending Requests and unpaid
Payments when users change the Rate Date to an earlier date. They can also
be used when approving a Request: In the Currency Information page of the
Approval Wizard, users can enter a past Rate Date, when a different rate
may have been in effect.
Note: Which (if either) of the two Request amounts will be recalculated
depends on your multi-currency preferences. Both user actions mentioned in
the previous paragraph may result in an exchange rate change. As noted
above, what happens when exchange rates change depends on several
factors. These were discussed in “When Exchange Rates Change” on
page 131—refer to that section for information on what happens if a changed
Request or Payment date results in an exchange rate change.
Tracking Exchange Rate Changes with Historical Activities GIFTS can create
a Historical Activity noting a change in either the functional or local/other
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amount for each Payment and Request that is affected by an exchange rate
update:

To have GIFTS create Activities to track changes to Payment and Request
amounts following exchange rate updates, select the “Create a Historical
Activity when an amount is adjusted after an exchange rate update” check
box.
Important: If you update exchange rates on a regular basis, and you have set

your multi-currency preferences to adjust amounts based on these updates,
using this option could end up creating a very large number of Historical
Activities. Keep this in mind when deciding whether to track changes to
exchange rates in this manner.
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Adding Currencies
To add a new currency to your Exchange Rate Table:
1 From the Administrator menu, select Setup ➤ Local/Other Currencies ➤
Exchange Rate Table. The Exchange Rate Table opens:

2 From the Exchange Rate Table menu, select File ➤ New, or click the New
button on the table toolbar. The New Currency window opens:

3 Fill in the following fields:

142

Field

Description

Currency

Enter the name of the currency, e.g., “Euro” or “Canadian
Dollar.”

Designation

Required. Enter a unique three-character designation for the
currency. You may want to use the standard designations
used in the currency market, such as EUR for the Euro or
GBP for the British Pound.
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Field

Description

Symbol

Required. Enter the symbol you want to use to mark the
currency. This symbol will be used to indicate the currency in
Payment amounts, appearing in front of the number.
GIFTS does not provide currency symbols that are unavailable
on standard workstation keyboards. Use Windows Character
Map to find other symbols, or paste the symbol from
Microsoft Word.
You can also enter a letter or letters as a symbol, such as DM
for the German Mark (Deutschmark).

Rate Date

The date on which the exchange rate you are entering goes
into effect.
This date is important if you are planning to track rate
changes over time, and want to know what different
exchange rates were in effect for the currency at different
times.
For more information on tracking historical exchange rates,
and what uses you can make of that information, please see
“Maintaining and Using Historical Rates” on page 152.

Exchange Rate

Enter the exchange rate for the currency. This figure is based
on your functional currency. More specifically, if 1 of your
functional currency equals X of the local/other currency, then
enter X here.
Your functional currency is specified in the GIFTS
Administrator General Preferences. For information on
setting your functional currency, please see “Choosing Your
Functional Currency” on page 124.
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Field

Description

Rounding Factor

When GIFTS uses the exchange rate you are entering to
determine the local/other amount’s value in the other
currency, it will calculate the figure exactly. After the
calculation is completed, however, GIFTS rounds the figure
based on the Rounding Factor.
GIFTS can, at its most exact, round to the nearest 1/100 of the
currency (.01). However, you may prefer to track Payments
using less detailed amounts. Large Payments may not need
to be tracked to the .01 decimal place.
For instance, you decide that you want to track Payments to
the nearest hundred units of the currency. Enter 100 in the
Rounding Factor field.
In this example, imagine that you have entered 2.348 as
the Exchange Rate. You then take a Payment of 1, 000 of your
functional currency and change it to this currency. GIFTS
calculates the exact amount as 2,348.00 units of the other
currency. It then considers your Rounding Factor of 100 and
rounds the number to the nearest 100. The Payment in the
other currency will be recorded in GIFTS as 2,300.

4 If you want to save the currency and add another currency, click Save and
New.
If you want to save the currency and exit the New Currency window, click
Save and Exit. Click Cancel to cancel the new currency.
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Updating Exchange Rates
Keeping your exchange rates up-to-date is certainly the most important
aspect of keeping your Request and Payment local/other currency data
useful.
When you update a local/other currency’s exchange rate, GIFTS will
update amounts of pending Requests and unpaid Payments using that
currency. (Your multi-currency preferences or the a record’s multi-currency
settings can be set to recalculate neither if you prefer.)
When GIFTS recalculates based on exchange rate change, there are two
questions about what to adjust:
❖

What kinds of record amounts do you want to recalculate? Payment
Amount, Request Recommended Amount, Request Requested Amount,
or any combination of these can be adjusted with each exchange rate
change.
You as GIFTS administrator will make this decision each time you
update exchange rates. For more information on this choice, please see
“Request and Payment Update Options” on page 150.

❖

Which amount in a given record will be changed? The functional amount,
or the local/other amount?
Whether it is the functional or local/other amount that is recalculated
depends on your GIFTS settings. In your multi-currency preferences,
you specify which amount you want recalculated when exchange rates
change. (For details, please see “When Exchange Rates Change” on
page 131.) If in those same preferences you allow user override, which
amount changes depends on the setting of the pending Request that 1)
GIFTS is updating or 2) is associated with unpaid Payment that GIFTS is
updating.

You can update one exchange rate at a time manually from within the
Exchange Rate Table; for details, please see “Updating Exchange Rates
Manually” on page 146.
GIFTS can also import a correctly-formatted XML file which includes new
exchange rates, and update multiple local/other currency rates at once. This
is discussed in “Updating Exchange Rates Automatically” on page 147.
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Updating Exchange Rates Manually
You can update the exchange rate for a single currency manually. You may
want to enter a new exchange rate, or move an existing rate’s Rate Date to a
different starting point.
1 From the Administrator menu, select Setup ➤ Local/Other Currencies ➤
Exchange Rate Table. The Exchange Rate Table opens.
2 Select the currency in the grid and click Edit in the Exchange Rate Table
toolbar. The Edit Currency window opens:

3 You can edit any of the fields in the Edit Currency window. However, since
you are updating an existing exchange rate, your changes are likely to be
limited to Exchange Rate and Rate Date.
Field

Description

Rate Date

The date on which you want the new exchange rate to go into
effect.
By default, this field contains the same date entered the last
time the exchange rate was updated. Be sure to update the
Rate Date if you track historical rate changes. Only one rate
can be saved per date, so a rate associated with a date will be
lost if a new rate with the same date is entered.

Exchange Rate

Enter the new exchange rate for the currency. As you will
recall, this figure is based on your functional currency. More
specifically, if 1 of your functional currency equals X of the
other currency, then enter X here.

Note: For full details on these and other fields, please see “Adding

Currencies” on page 142.
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4 Change other fields in the Edit Currency window as needed, then click
OK. The Exchange Rate Update window opens:

Choose which amounts of unpaid Payments and pending Requests you
want to recalculate using the new exchange rate. (This applies to those
records which already have the update currency specified.) For more
information on these options, please see “Request and Payment Update
Options” on page 150.
5 Select the options in the message above you want to use, then click OK.
GIFTS performs the exchange rate update, adjusting Payment, Request
Requested, and/or Request Recommended Amounts as indicated.
A process log lists the results of your update:
You can print or save your results using these
process log buttons.
Click Close to close the process log.

Updating Exchange Rates Automatically
GIFTS multi-currency features include a separate application (file name
FXImport.exe) that can update multiple local/other currency exchange
rates automatically. The application imports an Extensible Markup
Language (XML) file which can include a new Rate Date and Exchange Rate
for each currency in your Exchange Rate Table.
This is useful for grant-making organizations which receive currency
exchange rate data from a third-party vendor. These organizations may be
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able to work with the vendor to have the data supplied in the correct format
for use with GIFTS.
There are a couple specifications that the XML file
must meet to be imported successfully:
Formatting the XML File
❖

The file name should always be CurrentRates.xml. You can save the file
to any location on your network and specify the network path within the
application, but the file name itself must remain constant.

❖

The XML file itself must be formatted properly. They should be specified
in the document as shown below:
<EXCHANGERATES>
<EXCHANGERATE DESIGNATION=“EUR” DATE=“12/08/2004” RATE=“.82”/>
<EXCHANGERATE DESIGNATION=“GBP” DATE=“12/08/2004” RATE=“1.85”/>
</EXCHANGERATES>

You need only specify the currency’s three-letter Designation from
GIFTS, the Rate Date for the new rate, and the new exchange rate itself.
Be sure to use unique Rate Dates if you track historical rate changes.
Only one rate can be saved per date, so a rate associated with a date will
be lost if a new rate with the same date is entered.
Note: The XML file can list only those currencies you want to update. If

a currency in your Exchange Rate Table is not found in the XML file, it
will keep its current rate and rate date.
Setting Up Your Automatic Update Preferences

To set preferences for the

FXImport application:
1 From the Administrator menu, select Setup ➤ Local/Other Currencies ➤
Exchange Rate Table. The Exchange Rate Table opens.
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2 From the Exchange Rate Table menu, select Tools ➤ Auto Update. The
Automatic Exchange Rate Update window opens:

3 In the Current Rates Location field, click Browse to find the
CurrentRates.xml file you want to import.
4 Under “When new rates are obtained:”, select which amounts of unpaid
Payments and pending Requests you want to recalculate using the new
exchange rate. (This applies to those records which already have one of
the updated currencies specified.) For more information on these options,
please see “Request and Payment Update Options” on page 150.
Note: If your CurrentRates.xml file lists rates for multiple local/other

currencies, please note that pending Requests and unpaid Payments using
these currencies will be all be updated (or not) the same way, based on the
options you choose here.
5 Click OK.
Running the Automatic Update Application The FXImport.exe file is

installed in the same folder as the other GIFTS executables on your
workstation. Open your workstation’s GIFTS folder in Windows Explorer
and double-click FXImport.exe to run the application.
The application can be run by a user with exchange rate update rights, or it
can be scheduled to run automatically at set intervals under Windows Task
Manager.

Tip: If you plan to update exchange rates on a regular, frequent basis,
MicroEdge recommends running the application under Windows Task
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Manager. If you use this option, be sure to save the XML currency file in the
same location with the same file name each time. This will prevent the need
of changing application preferences to account for file name and location
changes.
Whether the application runs under Windows Task Manager, or is run
manually, the following occurs:
❖

GIFTS updates the Exchange Rate Table with the new rates.

❖

If you have chosen to track historical exchange rates, the old rate you
just replaced is saved. A Historical Activity record for each changed
rate is also created, if you have selected that preference. (See
“Tracking Changes to Exchange Rates” on page 140 for details on
these preferences.)

❖

A log file called FXImport (mmddyyyy).log is created and placed in
the FXImport subdirectory of the GIFTS directory. It details the
changes in functional or local/other amount made to any Requests
and/or Payments as a result of the exchange rate update.

Request and Payment Update Options
When you update an exchange rate, you may have pending Requests and
unpaid Payments already calculated in that local/other currency. GIFTS
offers you options on which amounts you want to change for those
particular Requests and Payments.
When you update an exchange rate, you can select to have any and all of the
following amounts recalculated with the new rate:
❖

Payment Amount

❖

Request Recommended Amount

❖

Request Requested Amount

Remember, these only apply to unpaid Payments and pending Requests that
have already had the updated local/other currency specified.
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Important: Note that these options, when presented to you during an

exchange rate update, will not indicate whether your action will adjust the
functional amount or the local/other amount. Which is adjusted is based on
your multi-currency preferences. For details on the option that determines
whether functional or local/other amounts are changed when exchange
rates change, please see “When Exchange Rates Change” on page 131.
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Maintaining and Using Historical Rates
Exchange rates change and updating rates is one of the keys to making
GIFTS multi-currency data useful to your organization. GIFTS also allows
you to maintain a history of past exchange rates for your local other
currencies, allowing you to:
❖

track changes to exchange rates over the course of your gift-giving.

❖

recalculate Request and Payment amounts using previous (or newer)
exchange rates in case a key date (for example, an unpaid Payment’s
Schedule Date) is changing.

❖

use the Functional Continuity Schedule report (found in the GIFTS Report
Library) to view exchange rate-related changes to functional amounts
over the life of a grant.

Historical exchange rate tracking is set up in your multi-currency
preferences. For details, please see “Tracking Changes to Exchange Rates”
on page 140.
Important: To track historical exchange rates correctly, care should be taken

when updating the rates. Be sure not to use a Rate Date already in use for a
given currency. For each currency, only one rate can be saved per date, so a
rate associated with a date will be lost if a new rate with the same date is
entered.

How Users May Use Historical Rates
If you choose the maintain a history of the exchange rates of your local/
other currencies, GIFTS users can use this history to recalculate amounts of
pending Requests and unpaid Payments.
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In the Local/Other Currency tab of Requests and Payments, any local/other
currency specified requires a Rate Date. Below is the Local/Other Currency
tab of a Payment with a local/other currency of the British Pound:

If you track historical
exchange rates,
changing the date could
change the exchange
rate, and thus either the
functional or local/other
amount, depending on
your preferences.

If you are tracking historical exchange rates, users can change the Rate Date
of a pending Request or unpaid Payment. GIFTS will check any new Rate in
the Request or Payment against the historical record for that currency. If a
different exchange rate was in effect on that date, the record’s amount(s) will
be recalculated using that exchange rate.
Note: Whether it is the functional or local/other amount that is recalculated

depends on your GIFTS settings. In your multi-currency preferences, you
specify which amount you want recalculated when exchange rates change.
(For details, please see “When Exchange Rates Change” on page 131.) If in
those same preferences you allow user override, which amount changes
depends on the setting of the pending Request that 1) the user is giving a new
Rate Date or 2) is associated with unpaid Payment the user is giving a new
Rate Date.
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Viewing and Printing Historical Rates
To view the exchange rate history of a currency:
1 From the Administrator menu, select Setup ➤ Local/Other Currencies ➤
Exchange Rate Table. The Exchange Rate Table opens.
2 Select a currency in the grid, then select Tools ➤ View History. The
currency History window opens:

Listed is each past exchange rate for this currency, with the Rate Date each
went into effect.
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3 Choose File ➤ Print from the currency History menu. The Active Reports
Viewer opens:

Click Print to print the report. From the Active Reports menu, you can
select File ➤ Export to select a number of formats in which to export the
information shown.
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Deactivating a Currency
You can deactivate a currency in the Exchange Rate Table. This allows you
to keep a record of currency, both in the Administrator Module and in any
Requests and Payments that are already calculated in the currency.
You can edit deactivated currencies and even update their exchange rates:
Payments and Requests already calculated in the currency will respond to
these changes.
Deactivating a currency simply makes it unavailable for new calculation of
Requests and Payments. Also note that if you deactivate a currency
designated in your Request preferences as the default local/other currency,
the preference reverts to <None> as the default.
To deactivate a currency:
1 In the Administrator, select Setup ➤ Local/Other Currencies ➤ Exchange
Rate Table to open the Exchange Rate Table.
2 Highlight the currency and click the Deactivate Currency button on the
toolbar. The currency is deactivated.
A currency can be reactivated at any time. Highlight a deactivated currency,
and you will see that the toolbar button now reads Activate Currency. Click
it to reactivate the currency.

Deleting a Currency
You can delete a currency from the Exchange Rate Table if it is not in use
(i.e., if no Requests or Payments in GIFTS are calculated in the currency).
Highlight the currency in the table and select File ➤ Delete from the menu.
The currency is deleted.
If the currency is in use, a message opens informing you of the number of
records using the currency. The message warns you that you cannot delete
the currency while it is in use. The message then asks you if you would like
to deactivate the currency instead. Click Yes to deactivate the currency.
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Reporting Exchange Rate Information
A simple report outlining your current exchange rates for all local/other
currencies can be printed from the Exchange Rate Table. A number of
standard reports found in the GIFTS Report Library also help you track
changes to grants with local/other currencies specified.

Reporting Your Current Exchange Rates
You can print a report showing the details of your Exchange Rate Table:
1 In the Administrator, select Setup ➤ Local/Other Currencies ➤ Exchange
Rate Table to open the Exchange Rate Table.
2 Make sure that the information in the grid is displayed as you want it to
look in your report. Modify the width of the items in the grid as needed.
3 Choose File ➤ Print from the Exchange Rate Table menu. The Active
Reports Viewer opens:

From the Active Reports Viewer, you can print the report, or export the
data to a number of different file types. For more details, please see the
GIFTS User’s Guide.

Standard GIFTS Multi-Currency Reports
The GIFTS Report Library contains special reports that help track grants
calculated in a local/other currency. For more information, please see Using
GIFTS Reports.
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Defining
Correspondence
Templates
Note: This feature is not available to Essential GIFTS clients who do

not have the Correspondence option.
As users work in GIFTS, they can generate Microsoft Word®
documents or e-mail messages that merge correspondence or writeup templates with data from GIFTS. This chapter explains how to
create these templates and manage them within the GIFTS Template
Library.
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Defining Correspondence Templates

Planning Your Templates
In the Implementation Workbook for the GIFTS Setup training course, you
should have defined all of the correspondence and write-up templates that
you need. Refer to that list as you establish your templates.
This section discusses how to choose the fields that you use for your
templates and how to manage them from within GIFTS. However, the use
of the mail merge fields within Microsoft Word is covered in the product
documentation and is not repeated here. If you have not used Word’s mail
merge function, you may wish to familiarize yourself with it before
continuing.
When you choose merge fields for your template, they are added to the
template’s header. The header contains the merge fields that are available for
the correspondence that you generate with the template. (Since so many
fields can be used, having all fields available would be cumbersome and
could slow your document processing time.)
You can create new templates, edit templates, rename templates, copy
templates, copy headers into new templates, and delete templates.

Attaching Printed Templates to Email
Correspondence
Something to keep in mind when planning your correspondence
templates is that GIFTS and IGAM allow you to attach secondary printed
templates from the same event type to Email correspondence. An
example would be sending an email acknowledgement to an applicant and
then attaching a secondary form for them to fill out.

If..Then..Else Conditional Available in Templates
Another option available which may affect your template planning is the
If..Then..Else option. This allows you to set conditional statements in your
templates to be added to a correspondence based on the value of a merge
field. In order to use this properly you must remember to add the merge
field with the value you wish to use for comparison to the template prior to
opening the IF statement window.
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Example: If you normally take two weeks to process a new request up to

$10000 but 4-6 weeks for any higher amount due to additional steps in
processing, you could do the following:
1 Go to Setup ➤ Correspondence Templates to open the Template Library.
2 Select the Acknowledgement Letter template and click the Merge Fields
button on top to open the Show Merge Fields window.
3 Select Request as the field category, Include the Request Amount field,
and click OK.
4 Now click the Open Template button and go to Insert Merge Field >
If...Then...Else to open the Insert IF statement window.

5 Fill in the window as shown below:

This basically says if the Request Amount is greater than $10000, add the
4-6 week statement, otherwise add the 2 week statement.
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About Correspondence Events
Templates are organized by correspondence event. The event determines
when the template is available to generate correspondence.
Event

Description

Activities

Activities templates merge with information about an Activity
and the Contact, Organization, Request, or Payment related to it.

Affiliations

You can create Affiliations templates to merge data about
Contacts’ relationships with Organizations and Requests into
letters and e-mail.
TIP: This is especially useful when Contacts have a number of email or regular addresses associated with different roles they play
with different Organizations or Requests (since each Affiliation
can have a different address).
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Approval

For approved Requests only. Award letters, terms and conditions,
grant Payment correspondence, and so forth would fall into this
category. Fields pertaining to recipients and grants, such the
Grant Amount and Coding Sheet information, are available.

Contacts

Contacts templates merge with information about Contacts and
their Primary Organization, and are useful in conjunction with
GIFTS Mailing List functions to produce mass mailings.

Declination

For declined Requests only. Rejection correspondence would fall
into this category. Fields pertaining to recipients and
declinations, such the Declination Reason and Coding Sheet
information, are available.

Organizations

Include information regarding the Organization, its Tax Status,
Coding Sheet information, and so forth. Organization templates
can summarize their history as a recipient, including the total
number of grants awarded and the total amount granted.

Payments

Payment templates can merge Payment information, including
information about the payee, the Request for which the Payment
is being made, quid pro quo, and the check or wire transfer used
to make the Payment. They also can be used to make check
requisition forms for manual processing.
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Event

Description

Pending

For pending Requests only. Acknowledgment letters, requests for
further information, and similar correspondence would fall into
this category. Fields pertaining to recipients and proposals, such
the Request Date and Coding Sheet information, are available.

Requirements

Requirements templates merge with information about a
Requirement and the Contact, Organization, Request, or Payment
related to it.

Write-up

Used to print a comprehensive summary of a single Request.
Write-ups are generally used to print summaries of proposals for
review at board or committee meetings. You can also create
write-ups for use with grants.

If you have purchased additional GIFTS modules—such as Employee GIFTS
or the Reviewers Module—additional correspondence events are available in
the Template Library.
Note: By default, letters that are generated from the templates are saved in a

single document directory that you specify in the External Preferences. If you
want to organize your document files by event, you can save them to a
document subdirectory that is specific to the event. For details, see “EventSpecific Document Subdirectories” on page 190.

About E-mail and Letter Templates
You can create three types of correspondence templates that merge
information from GIFTS:
Template
E-mail

Description
Generates e-mail messages only.
Use this template type if you want to correspond by e-mail only—
to cut down on paper consumption, for example.

Letter

Generates printed letters only.
Use this template type if you want to correspond by printed letter
only. For example, your organization might want to generate all
correspondence through Word.
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Template

Description

Letters and E-mails

If the recipient’s e-mail address is in the GIFTS database, this
template generates an e-mail message; otherwise it generates a
printed letter.

Note: If you are upgrading GIFTS from Version 4.0 or earlier, your
templates created in those versions will generate only printed letters in
GIFTS 6.2.1.

About Letter/E-mail Templates
Letter/E-mail (or Automatic) templates are really two templates in one. If
you use this template to generate correspondence, applicants that provide
an e-mail address receive their correspondence by e-mail. Otherwise, GIFTS
prints a letter.

For details on creating and editing Letter/E-mail templates, see “Working
with Letter/E-mail Templates” on page 177.

About Editing and Synchronizing Letter/E-mail
Templates
If you are working with a Letter/E-mail template, and you want to
customize the appearance of your letters by taking advantage of Word’s
advanced formatting features, you can edit the “letter” portions of the
template in Word:
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Once you edit a Letter/E-mail template in Word, the template is split into
two templates—an e-mail template and a separate letter template; the
templates are no longer “synchronized.”
The template still functions in the same manner—that is, it prints
correspondence if the applicant does not provide an e-mail address;
otherwise it generates e-mail correspondence. However, the text that you
see in the Template Viewer may not accurately reflect the text of the printed
letters that are generated by the template.
Example: You create Body text for a Letter/E-mail template and then edit

the letter template Body in Word—to add customized fonts or paragraph
formatting, for example. The e-mail text and the letter text no longer match;
they are not synchronized. The texts of the e-mail and printed
correspondence that you generate with the template may differ.
When you edit the letter template in Word, you must continue to edit the
letter portions in the word processor. (You can still edit the e-mail sections as
described in “Working with E-mail Templates” on page 174).
If you want to revert back to the original combination template—and edit
the letter and e-mail portions in the Template Viewer—you can synchronize
the letter and e-mail templates. From the Template Viewer menu, select
Action ➤ Synchronize Letter Template.
Note that when you synchronize the templates, the template that you edited
in Word is deleted. Changes that you made in the word processor are not
transferred back to the Letter/E-mail template. The letter portions of the
template are restored to their original state before you edited them in the
word processor.
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Accessing the Template Library
Correspondence templates are maintained in the Template Library. To
access the Template Library, choose Setup ➤ Correspondence Templates
from the Administrator menu. The Template Library opens:

The following information is displayed for the templates in the Library.
Column

Description

Event/Template
Name

The Template Name and the event with which it is associated.

Letter?

If this icon is displayed, the template can be used to generate
printed letters.

E-mail?

If this icon is displayed, the template can be used to generate email correspondence.

Description

A short description of the template.
Example:“Rejection E-mail for non-charitable
Organizations.”

Letter File

If the template is for generating printed letters, the template’s
document file name.

Created By

The staff member who created the template.

The Template Library displays templates for individual events much in the
same manner that Windows ExplorerTM displays the directories and files on
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your computer. To view the templates for an event, expand them by
clicking on the box to the left of the event.

Branch/Division Assignment to Templates
If you have Branch Security enabled, when creating a new Correspondence
Template, there will be a Branch/Division field that will allow you to assign
the template to a specific branch/division. The default is All.
To assign a Branch/Division to an existing template, right-click on a
template and select Edit Branch/Division.

When sending new correspondence, GIFTS users will be able to filter the
available templates list by Branch/Division on the What tab.

Note: This feature is purely for filtering purposes. It does not prevent the

GIFTS user from changing the Branch and seeing templates they may not
have access to.
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Creating a New Template
1 From the Administrator menu, choose Setup ➤ Correspondence
Templates. The Template Library opens.
2 Highlight the event for the template that you wish to create.
3 Click New Template. The New Template window opens:

4 Enter a Template Name and description. Keep in mind that both should
be clear to other users who will use the template.
5 Select whether the template will be used to generate printed letters, e-mail
messages, or Letters/E-mails (Automatic) correspondence.
Note: If you are creating this template for the Write-up event, you do not
need to select a template type. Write-up templates are used to generate
printed documents only.

6 If you have Branch Security enabled, select the Branch/Division to assign
this new template.
Note: This feature is purely for filtering purposes. It does not prevent the

GIFTS user from changing the Branch and seeing templates they may not
have access to.
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7 Click OK. The Show Merge Fields window opens:
The merge fields available
for the selected category
(below this list) are listed
here. Select the merge fields
you want to include and click
Include.

Formatting
options specific
to the field type
selected in the
grid appear
here. In this
example, you
can choose
how you want
the Meeting
Date formatted
when it is
merged into
the correspondence.

You can highlight a merge
field in the grid on the right
and click Remove to remove
it.

The Category is selected
here. Fields are available
from related records. For
example, this is an approved
Request template; you can
merge data from the grantee
Organization, the Request
Primary Contact, and other
affiliated records.

Important: Microsoft Word templates can accommodate no more than

63 merge fields. GIFTS makes eight standard merge fields available in
every document template, allowing you to add an additional 55 fields.
8 Choose a category of information from the “Select available fields from”
drop-down list. The “Available Fields” list is populated with the merge
fields for the category you have selected.
9 Highlight a merge field and click Include to add it to the template. It is
added to the list of included fields on the right side of the form. Note that
the field name is preceded by the name of the category. For instance,
“Grantee Organization: Address Block.”
10 For each merge field you add to the template, there may be display options
to configure.
❖

For details on the display options available for date, currency, number,
and coding sheet merge fields, please see “Merge Field Display
Options” on page 170.
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❖

For information on table merge fields and the options available for
formatting the tables they generate, please see “Working with Table
Merge Fields” on page 185.
For example, if you add “Coding Sheet: Program Area” to your
header, you can define the following display options:

If you choose three coding levels and a comma as the delimiter (a
delimiter is simply a character used to separate values), the Program
Area of a Request might be displayed as Education, College &
Universities, Scholarships. If you chose to display two levels and a
semicolon as a delimiter, the same Request’s Program Area would be
displayed as Education;Colleges & Universities.
11 When you have included the merge fields that you want to use in the
template, click OK. The new template is displayed.
❖

If you are creating an e-mail template, please proceed to “Working
with E-mail Templates” on page 174.

❖

If you are creating a letter template in Microsoft Word, please
proceed to “Working with Letter Templates” on page 176.

❖

If you are creating a letter/e-mail template, please proceed to
“Working with Letter/E-mail Templates” on page 177.

Merge Field Display Options
Note: For information on table merge fields and the options available for
formatting the tables they generate, please see “Working with Table Merge
Fields” on page 185.
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Date Field Options
Option

Description

Date Format

Indicates the format for the date value in the merge field. Select
from:
❖ Short Date (e.g., 4/29/2011)
❖ Long Date (e.g., Thursday, April 29, 2011)
❖ Month, Year (e.g., April, 2011)
❖ Month Day, Year (e.g., April 29, 2011)
❖ Day Month Year (e.g., 29 April 2011)

Currency Field Options
Option

Description

Don’t display
currency symbol

Indicates whether or not a currency symbol should be displayed
along with the value in the merge field. The currency symbol is
determined by your Windows Regional Options.

Decimal places

Indicates the number of decimal places (0 – 4) to display for the
value in the merge field. If set to “0” the value is rounded to the
nearest whole number. There are two exceptions:
❖ If the global preference “Don’t Display Decimal Places” is
selected, it will override this merge field option.
❖ Merge fields based on custom calculated fields will rely on the
field definitions for decimal place settings.

Show amount in
words

Indicates whether the value in the merge field should be rendered
in text rather than numerically.

Include grouping
character

Indicates whether or not a grouping character (e.g., the comma in
1,000) should be used with the value in the merge field. The
grouping character is determined by your Windows Regional
Options.
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Number Field Options
Option

Description

Decimal places

Indicates the number of decimal places (0 – 4) to display for the
value in the merge field. If set to “0” the value is rounded to the
nearest whole number. There are two exceptions:
❖ If the global preference “Don’t Display Decimal Places” is
selected, it will override this merge field option.
❖ Merge fields based on custom calculated fields will rely on the
field definitions for decimal place settings.

Include grouping
character

Indicates whether or not a grouping character (e.g., the comma
in 1,000) should be used with the value in the merge field. The
grouping character is determined by your Windows Regional
Options.
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Option

Description

Code level to
display

Indicates the code level to be displayed. The available choices
(Level 1 – Level 5) will depend on the number of levels allowed
for the Code Table.

Show parent codes

Select to display the full code hierarchy (e.g., Arts &
Culture\Dance\Ballet) rather than just the code level indicated in
“Code level to display” option.
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Option

Description

Delimiter between
levels

Indicates the delimiter to use between individual levels of a code.
Enter your own character, or select from the following choices:
❖ {carriage return}
❖ {tab}
❖ {space}
❖ ,
❖ /
❖ \
❖ :
❖ ;

Primary/Secondary
codes

Indicates which code is displayed. The available choices are:
❖ Primary only
❖ Secondary only
❖ Primary and Secondary

Delimiter between
codes

Creating a New Template
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“Delimiter between levels” for available choices.)
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Working with E-mail Templates
If a template will be used to generate e-mail, the Template Viewer is
displayed:

The e-mail template is divided into four sections:
Section

Description

Subject

Appears in the Subject section of the message.

Heading

Appears at the top of the message.
Example:The applicant’s name and title.

Body

This might include a salutation and the Contact’s name followed by
the text of the e-mail message.

Close

Appears at the end of the e-mail message.
Example:A closing and the signer’s name, title, and e-mail
address.

1 Select a section and add merge fields or text. To add merge fields, click
Insert Merge Fields and select the fields from the list.
Important: To ensure that your e-mail messages are compatible with the

recipient’s e-mail program, they are created in the Plain Text Format
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only. Text formatting options in the E-mail Template Viewer toolbar are
disabled.
2 When you are finished, skip to the next step or click Preview E-mail to
review your work in the Document Viewer:

In the Document Viewer, you can:
❖

View the e-mail template in Draft, Normal, or Preview mode.

❖

Control the size of the template in the Viewer.

❖

Specify that the Viewer is always displayed on top of other windows
on your desktop.

When you are finished reviewing the template, choose File ➤ Close from
the Document Viewer toolbar. You are returned to the Template Viewer.
3 From the Template Viewer, click Save and Close to save the template. (To
keep a printed copy for your records, choose File ➤ Print E-mail.) You are
returned to the Template Library.
The template is listed below the event with which you are working. The
e-mail icon indicates the template can be used for generating e-mail
correspondence.

Tip: GIFTS does not automatically place carriage returns between the

Subject, Heading, Body, and Close sections. If you want a blank line between
these sections in the merged e-mail message, be sure that you begin or end
each section with a carriage return.
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Working with Letter Templates
If the template will be used to generate printed letters, GIFTS opens it in
Microsoft Word.
To create a letter template:
1 Use Word’s mail merge feature to add merged fields and text to the
template. For instance, here is a Declination letter template in Microsoft
Word:

2 When you are finished defining the template, save the word processor file
and close it. GIFTS uses a number as the filename of the document (such
as 24145823L.DOC) and links it to the Template Name you specified
earlier. (When you use or edit the template later, you can identify it by its
name and won’t need to know its filename.) Be sure not to change the
filename of the document so that its link to GIFTS is maintained.
3 Return to the Template Viewer (you do not have to close Word). The
template is displayed in the Template Library below the event with which
you are working. The letter icon indicates the template can be used for
generating printed correspondence.
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Working with Letter/E-mail Templates
Before You Begin: Review “About Letter/E-mail Templates” on page 164

and “About Editing and Synchronizing Letter/E-mail Templates” on
page 164.
If the template will be used to generate e-mail when the recipient’s e-mail
address is available, and printed letters when no e-mail address is available,
the Template Viewer opens:

The Letter/E-mail template is divided into six sections:
Section

Description

E-mail Subject

When the template is used to generate an e-mail message, this section
appears in the message’s Subject field.

E-mail
Heading

When the template is used to generate an e-mail message, this section
appears at the top of the message.
Example:The applicant’s name.

Letter
Heading

When the template is used to generate a printed letter, this section
appears at the top of the letter.
Example:The applicant’s name and address block.

Body

The body of the e-mail and letter. This might include a salutation and
the applicant contact’s name followed by the text of the
correspondence.
The Body is used for both e-mail and printed correspondence.
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Section

Description

E-mail Close

When the template is used to send an e-mail message, this section
appears at the end of the message.
Example:A closing and the signer’s name, title, and e-mail
address.

Letter Close

When the template is used to generate a printed letter, this section
appears at the end of the letter.
Example:A closing, the signer’s name and title, and space for
the signature.

Note: If you are working with an existing template that was previously
edited in Word, the “letter” sections of the template are not displayed. You
can edit the letter sections separately in Word, or you can synchronize them
with the Letter/E-mail template. For details, please see “About Editing and
Synchronizing Letter/E-mail Templates” on page 164.

To add merge fields or text to the combination Letter/E-mail document:
1 Select a section and add merge fields or text. To add merge fields, click
Insert Merge Fields and select the fields from the list.
Tip: GIFTS does not automatically place carriage returns between the
Subject, Heading, Body, and Close sections. If you want a blank line
between these sections in the merged e-mail message, be sure that you
begin or end each section with a carriage return.

Note that you can also add fields and text to the letter sections of the
template by editing them in Microsoft Word. To do this, click Edit Letter
in Word Processor and add merge fields and text as described in “Working
with Letter Templates” on page 176.
2 When you are finished, click Save and Close to save the template or click
Print Preview to review the e-mail template or the letter template.
To keep a printed copy of the template for your records, choose File ➤
Print. You can print the e-mail template or the letter template.
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3 When you have reviewed and saved your work, you are returned to the
Template Library:

The template is listed below the event with which you are working. The
e-mail and letter icons indicate the template can be used for generating
both e-mail and printed correspondence.
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Editing Templates
Note: You cannot edit the headers of templates that were created prior to
GIFTS v3.5.

From the Template Library, you can open letter templates to edit them and,
if necessary, add merge fields to the template’s header.
1 From the Administrator menu, choose Setup ➤ Correspondence
Templates. The Template Library opens. If the template is not displayed
in the Library, expand the template’s event by clicking the box to the left
of the event. The templates for that event are displayed:

2 Highlight the template you wish to edit.
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❖

If you do not need to add merge fields to the template’s header, skip
to step 3.

❖

If you need to add merge fields to the header, click Merge Fields. You
are prompted to choose the merge fields that you wish to add to the
template:
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When you have added the fields that you need, click OK. You are
returned to the Template Library.
3 Click Open Template. The template opens.
❖

If you are editing an E-mail template, please proceed to “Working
with E-mail Templates” on page 174.

❖

If you are editing a letter template in Microsoft Word, please proceed
to “Working with Letter Templates” on page 176.

❖

If you are editing a Letter/E-mail template, please proceed to
“Working with Letter/E-mail Templates” on page 177.

Important: You can cut and paste text between your templates, but you

should avoid pasting merge fields between letters unless you are sure that
you set up the template to use the merge field that you are copying. For
instance, if you copy the Project Title field to a template that does not use
that field, an error results.
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Copying Templates
If you want to create a template that is similar to an existing template, you
can copy it. If you want to create a new template with the same merge fields
as an existing template—but you want to enter new text for the template—
you can copy the header from an existing template.
To copy a template and/or header:
1 From the Template Library, highlight the template you want to copy and
choose File ➤ Save As from the Main menu.
You are prompted to specify the type of new template you want, and
whether you want to copy the header or both the header and the template.
Note that when you copy a template, the copy must be the same template
type as the original.
If the original
template generates:

You can save the copy as...

E-mail

an e-mail template
-orthe e-mail sections of an letter/e-mail template.

Letters

a letter template.

E-mail and Letters

a letter/e-mail template

If you choose to copy the Header Only, the merge fields from the original
template are copied to the new template. If you select Header and Text,
both the merge fields and the text of the original template are copied. In
either case, you can subsequently add merge fields and edit the template’s
text.
2 Enter a name and description for the new template.
Note: If you do not enter a name, the new template is named “Copy of...”
followed by the original template name. For example, “Rejection E-mail”
would be copied as “Copy of Rejection E-mail.”

3 When you are finished, click OK. The new template is listed in the
Template Library.
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Renaming a Template
To rename a template:
1 From the Template Library main menu, choose File ➤ Rename. You can
enter a name and description for the renamed template.
Note: If you do not enter a name, the template is renamed “Copy of...”

followed by the original template name. For example, a template titled
“Acknowledgement.letter” would be renamed “Copy of
Acknowledgement.letter.”
2 When you are finished, click OK. The template is renamed.
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Deleting a Template
Once a template is deleted, it is no longer available from the Template
Library. Merged letters generated from the template are not deleted when
you delete the template.
1 From the Template Library, highlight the template you wish to delete and
click File ➤ Delete. You are prompted to confirm that you wish to delete
the template.
2 Click Yes. The template is deleted.
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Working with Table Merge Fields
The term “table merge fields” refers to merge fields that create tables of
GIFTS data in your correspondence. There are a number of standard table
merge fields built into the system, but you may also create and save
Organizer Views to use as table merge fields.
For details on adding merge fields to a correspondence template, please see
step 5 in “Creating a New Template” on page 168.

Table Merge Field Options
Most standard table merge fields and all table merge fields created from
saved Views have the same options for manipulating the appearance and
content of the table.

Tip: Table merge fields created from saved Views will ignore the text
formatting (font, size, color, etc.) of their corresponding Views, but will
retain any column-specific formatting (alignment, indentation, delimiters,
etc.). Formatting should be adjusted within the saved View before it is
applied as a table merge field, since table merge fields are limited to the
standard options listed below.

All table merge fields offer the following standard options:
Option

Description

Include Column Headings

The generated table will include column headings. The
column headings are drawn from GIFTS field names.
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Option

Description

Autofit Column Width to
Contents

This option is available for Word templates only. If you
select this option, the generated table alters the column
width to fit more closely around the column entries.
Each column will be as narrow as it can be while still
fitting around the widest entry in the column.
If you do not select this option, each column in the
generated table will be the same width. This might be
wider than you need for dollar amounts, for example,
but not wide enough for text fields.

Use Table Borders

This option indicates whether the table will appear with
a thin border line around each cell in the final merged
correspondence.

Note: There are two table merge fields with additional options, which are

detailed in “Matches Listing Table Merge Field” on page 187 and “Giving
History Table Merge Field” on page 188.

Adding GIFTS Organizer Views
Views from GIFTS Organizer may be added to a correspondence template
the same way as any standard merge field. The View categories which
appear in the “Select available fields from” drop-down list will depend on the
type of template you are working on and if the Organizer folder has any
saved Views.
The available View categories in Pending, Approval, Declination, and WriteUp templates include:
❖ Request Views
❖ Payment Views
❖ Activity Views
❖ Requirement Views
❖ Affiliation Views
After choosing a “Views” category, the saved Views for the Organizer folder
can be selected from the “Available Fields” list box and added to the
template.
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!

Caution: Once a View is added to a correspondence template as a table

merge field, the merge field will not be affected by subsequent changes to
the saved View. If changes are made to the View, you will need to remove the
table merge field from the template and then add it again.
Important: Private saved Views used as merge fields in templates do not limit
the use of the template to the user who created the saved Views. All users
who have permissions to create correspondence from the template will be
able to do so, whether or not they have access to the saved Views used for
merge fields.

Matches Listing Table Merge Field
Note: The Matches Listing table merge field generates a table of data for

Matching GIFTS and Volunteer GIFTS correspondence. It is available only
to users of these optional GIFTS modules.
The Matches Listing table merge field generates a table of employee gifts
matched by the employees’ Organizations. When you add this merge field
to correspondence, the table merge field standard option(s) are available. In
addition, a third option may be chosen:
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If you select the Include Description check box, another column will be
added to the table. This column will contain the description of each
matching gift, as it appears in the Description field of the matching gift
record in GIFTS.

Giving History Table Merge Field
The Giving History Table merge field can be found under the Requests
category and lists previous giving to the grantee Organization to whom you
are sending correspondence.
When you add this table merge field to a correspondence template, you
have several options to determine what data appears in the table. When you
choose this merge field, the options appear as shown below:

As noted before, this option is
only available to Word users.

If you do not specify otherwise, the giving history table will list individual
Requests and grants line by line. This much detail may be unnecessary or
unwieldy; you can choose a year-by-year summary instead. At the same
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time, if you prefer to list Requests, other options allow you to choose which
ones:
Option

Description

Include Column Headers

The two standard table merge field options (for Word users)

Autofit Column Width to
Contents
Summarize by Grant Year

Check this box if you want to limit the table to a year-byyear summary of giving history.
Individual Request and grants will not be listed. For each
year, the total amount of grant money awarded and the
number of grants given are listed.
If you check this check box, the last three options become
unavailable.

Show Approved Requests
Only
Include Request Fund
Include Request Type

If you want the giving history table to list Requests line by
line, these three options will help you determine which
details are listed:
Select the “Show Approved Requests Only” check box to
limit the list to approved Requests only.
Select the “Include Request Fund” check box to add a
column showing the Fund from which the grant was
drawn.
Select the “Include Request Type” check box to add a
column showing the Request type (such as ‘Cash Grant’ or
‘In-Kind’).
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Event-Specific Document Subdirectories
By default, document files for your printed letters are saved in a single
Document directory that you specify in the External Preferences. For
example, you can set up GIFTS to save document files to the directory
G:\GIFTS\DOCUMENTS.
If you want to organize your documents by correspondence event, you can
create a document subdirectory and direct GIFTS to save documents
generated for the event to the subdirectory. For example, you can create the
G:\GIFTS\DOCUMENTS\APPROVAL subdirectory for your Approval
documents.
Before You Begin: Use Windows to create the subdirectories on your

system. For example, if you currently maintain your document files in
G:\GIFTS\DOCUMENTS, you might create document subdirectories like:
G:\GIFTS\DOCUMENTS\APPROVAL
G:\GIFTS\DOCUMENTS\DECLINATION
G:\GIFTS\DOCUMENTS\WRITEUP
Once you create your subdirectories, you can direct GIFTS to save
documents for a specific event to the appropriate subdirectory. In addition,
you can copy existing documents for the event to the new subdirectory.
To specify a document subdirectory for an event:
1 From the Administrator menu, choose Setup ➤ Correspondence
Templates. The Template Library opens.
2 Highlight the event.
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3 From the Library menu, choose File ➤ Document Subdirectory. GIFTS
displays the document event and the current document file path:

Define the subdirectory to which files for the event will be saved. You can
either type the name of the subdirectory or click the search button.
4 When you are finished, click OK. If there are any documents for the event
in the current document directory, you are asked if you want to transfer
them to the new subdirectory. Click Yes to transfer the documents, or No
to leave existing documents in their current directory.
A process log list the results. To keep a copy of the log for your records,
click Print or Save As.
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Managing
GIFTS Reports

This chapter describes how to manage the library of reports available
to your users in the GIFTS Report Library.
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About the Report Library
The GIFTS Report Library refers to the collection of reports designed to
help your users extract important data into usable formats. Reports are
organized into specific categories, based on the information included in the
report and the search criteria applied.
Reports included fall into two groups, depending on their origins and the
methods for working with them:
❖

Standard Reports—When you first install GIFTS, the Report Library
contains a large number of reports that have been designed by MicroEdge
to handle the data reporting needs of most grant makers. These reports
are based on templates (.rpt files) created through Crystal Reports.
Many of these reports may be run “as is,” while some have additional
options that may be applied at runtime. If the initial set of reports is not
sufficient for your reporting needs, you may want to add new standard
reports to the library. You can create a new standard report by designing
a new template in Crystal Reports, or by attaching a saved search to an
existing report.

❖

Saved Organizer Reports—Saved Organizer reports are unique in that
they are created and added to the Report Library through the GIFTS
Organizer, rather than the GIFTS Administrator. (Saving Organizer
reports to the Report Library is not available to Essential GIFTS users.)
These are ad hoc reports designed by individual users, with a large degree
of control over formatting and layout. As with saved views and searches,
saved Organizer reports may be either public or private.
Note: Information on managing saved Organizer reports is included in
this chapter. However, details on creating ad hoc reports and saving them
as Organizer reports are discussed in the GIFTS User’s Guide.

Note: Before working with the Report Library, you should take some time
to browse through the samples of standard reports in Using GIFTS Reports.
You can then determine which standard reports are most useful for your
organization, and what other reports you will need to create to meet your
reporting needs.
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Report Template Files
Standard reports in GIFTS are based on templates (.rpt files) designed in
Crystal Reports. The report templates are located in the directory identified
as the “report path” in the External Preferences. The report templates are
usually stored in your main GIFTS directory.
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Managing the Report Library
An important part of maintaining the effectiveness of your GIFTS system
lies in the management of your Report Library. This section provides
information on performing important administrative tasks.

Adding a Standard Report
If your users frequently specify the same search criteria for a standard report,
you can easily address this need. Simply create a new standard report by
attaching a saved search to the appropriate report template. Your users can
quickly run the new report with the search criteria already applied.
Example: The Report Library includes an Alpha List of Grantee

Organizations report that lists all Organizations in the GIFTS database that
have received funding. The template for this report is o1.rpt. You can add an
Alpha List of Arts Grantees report to your Report Library by attaching a
saved search for Organizations coded as “Arts & Culture” to the o1.rpt
template.
To create a new standard report for inclusion in the Report Library:
1 From the Administrator menu, choose Setup ➤ Reporting ➤ Report
Library. The Report Library opens:
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2 Find the report file which you intend to use as a basis for your new report.
Note the title and description of this report, as well as the filename of its
report template (such as o1.rpt). In the next step, you will need to know
the name of the template file.
Click New. The Create/Edit Report form opens:

3 Configure the following options for the new report:
Option

Description

Name

The name of the report, which can be modified later, if
necessary.

Description

A description of the report’s usage and the information it
contains. This information can be modified to make the use of
the report clearer to users.

Category

Reports are designed to fit into specific categories, based on the
information included in the report and the available search
criteria. You should select the same category as the original
report.
Important: If you choose a different category than the original
report, users may not have access to the Quick Find or
Advanced search criteria they need, or errors may occur.

Template File

The template file for the report. Select the template file used by
the original report.

Mark this report as
“Read Only”

If this option is enabled, users can run the report from GIFTS,
but they cannot modify its titles or the search criteria.
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Option

Description

Make this report
available to all
users

If this option is disabled, only the user who added the report to
the Report Library can access it in GIFTS. This user’s name is
displayed in the Created column of the Report Library listing.

Include this report
in the Report
Library

If this option is disabled, the report will be hidden from all
users. This does not delete the report from the system or the
Report Library; it simply hides the report in the Reports view.
You can restore the report at any time by enabling this option.
NOTE: This option is for template reports only; it is not
available for saved Organizer reports.

Search to use with
this report

This field displays the name of the saved search attached to the
report. At run time, users can add additional criteria.
To attach a saved search to a report, see step 4.

4 Click Get Search. The Saved Searches form opens:

5 Choose a saved search and click Select Search.
For more information about working with saved searches, please refer to
the GIFTS User’s Guide.
6 Click Save and Close to exit and save your new report. The new report is
added to the Report Library under the category you selected.

Editing a Report’s Properties
General properties of each report in your Report Library—including saved
Organizer reports—may be edited through the Administrator Module. If
you want to edit the contents and/or formatting of a saved Organizer
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report, you must do so in GIFTS. For details on editing saved Organizer
reports, refer to the reporting chapter in the GIFTS User’s Guide.

Tip: Although you can alter the properties of the standard reports that were
installed with GIFTS, it may be better to leave them untouched and create
new reports based on the same templates. This way, you can still run the
original reports.

1 From the Administrator menu, choose Setup ➤ Reporting ➤ Report
Library. The Report Library opens.
2 Highlight the report and click Edit. The Create/Edit Report form opens:
3 The following options are available for configuring the report:
Option

Description

Name

The name of the report that appears in the Reports view of the
Organizer.

Description

A description of the report’s usage and the information it
contains. This description also appears in the Reports view of
the Organizer.

Category

Reports are designed to fit into specific categories, based on the
information included in the report and the available search
criteria.
Note: This option is read-only for all reports.

Template File

The template (.rpt file) that the report is based on.
Note: This option is hidden for saved Organizer reports.

Type

Indicates whether the saved Organizer report is a detail report,
a summary report, or a top N report. For details on each type of
report, refer to the GIFTS User’s Guide.
Note: This option is hidden for standard reports and read-only
for saved Organizer reports.

Mark this report as
“Read Only”

If this option is enabled, users can run the report from GIFTS,
but they cannot modify its title or the search criteria.

Make this report
available to all
users

If this option is disabled, only the user who added the report to
the Report Library can access it in GIFTS. This user’s name is
displayed in the Created column of the Report Library listing.

Managing the Report Library

199

8

Managing GIFTS Reports

Option

Description

Include this report
in the Report
Library

If this option is disabled, the report will be hidden from all
users. This does not delete the report from the system or the
Report Library; it simply hides the report in the Reports view.
You can restore the report at any time by enabling this option.

Search to use with
this report

This field displays information about the search attached to the
report. At run time, users can add additional criteria and/or
remove the criteria that you’ve attached.
❖ Standard reports—the name of the saved search is
displayed.
❖ Saved Organizer reports—if a saved search is attached to the
report, the search name is displayed, followed by the specific
search criteria.
To attach a saved search to a report, see step 4.

4 To remove the search that is currently attached to the report, click Clear
Search in the toolbar. To attach a search to the report, or to change the
attached search, click Get Search. The Saved Searches form opens:

5 Choose a saved search and click Select Search.
For more information about working with saved searches, please refer to
the GIFTS User’s Guide.
6 Click Save and Close to exit and save your changes to the report.
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Removing a Report
In most cases, it is better to exclude a report from the Reports view rather
than delete the report from the system. This way, you can always restore a
report if a need for it arises in the future. However, if there is clearly no need
for a report, or a report has been added incorrectly, you can remove it.
(Certain reports cannot be deleted.)

Tip: If you remove or hide all reports from a category, the folder for that
category will be hidden in the Report Library. The folder will be reinstated
automatically once at least one report has been added to it.

Please be advised that this option does not remove the report template (.rpt
file) from your computer or network. If you wish to delete the .rpt file itself,
you must do so from Microsoft Windows.
To remove a report from the Report Library:
1 From the Administrator menu, choose Setup ➤ Reporting ➤ Report
Library. The Report Library opens.
2 Highlight the report and choose File ➤ Delete from the Reports menu.
You are prompted to confirm that you want to remove the report.
3 Click Yes. The report is removed from your Report Library.
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Ad Hoc Reports in the Report Library
Note: Functionality described in this section is not available to Essential
GIFTS users.

GIFTS users can now save ad hoc reports created in the GIFTS Organizer to
the Report Library. (Details on creating and saving ad hoc reports can be
found in the GIFTS User’s Guide.) There are two things GIFTS administrators
should be aware of when setting up GIFTS for this functionality.
The first is global report formatting, which is established in the
Administrator Module and serves as the default formatting for all GIFTS ad
hoc reports. (Users can customize formatting of each ad hoc report they
create or modify.) It is described in the next section of this chapter.
The second is the “Public Saved Report Definition Templates” permission,
which can be set for each permission set. You can grant users rights to add,
modify, and delete saved ad hoc reports which have been made public (i.e.,
available to all users).
Note: All users can add, modify, and delete their own ad hoc reports,
regardless of permissions and whether they make them public or not.

The permission is found in the Permissions window, listed under the GIFTS
category. For details on modifying permissions, please see “Managing
Permission Sets” on page 92.

Tip: To prevent users from modifying or deleting others’ ad hoc report
templates, you may want to deny those rights to all or most user groups.
Even if a user is not allowed to modify public saved report templates, he or
she can save a copy of the report template under another name, then modify
that report as his or her own.
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Global Report Formatting for Ad Hoc
Reports
Note: Functionality described in this section is not available to Essential

GIFTS users.
Ad hoc reporting from the GIFTS Organizer is one of the most versatile
tools available to your users. Unfortunately, the same versatility that makes
ad hoc reporting so powerful may also cause problems for an organization
that adheres to a set of design standards for reports. In order to provide your
users with guidance regarding existing design standards, you may want to
set up global formatting options to be applied as default settings for all new
ad hoc reports.
Note: The global report formatting settings are only applied as defaults, and

individual users may override these settings when they create ad hoc reports.
The setting are intended to be guidelines for your users, not restrictions on
their reporting permissions.
To set up the global formatting defaults for ad hoc reports, open the Global
Report Formatting window. This can be accessed one of two ways:
❖

From the Administrator Module main menu, select Setup ➤ Reporting ➤
Global Formatting.

❖

From the Report Library menu, select Tools ➤ Global Formatting.
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The Global Report Formatting window opens:

Page Setup Tab
Use the options on the Page Setup tab to configure a basic report layout and
the placement of standard report elements. Available options are organized
into the following sections:
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❖

Paper/Layout—Use the Portrait and Landscape option buttons to select
the orientation for reports. The Paper Size field drop-down list allows you
to select one of many standard paper sizes for your reports.

❖

Margins—Use the options in this section to indicate the blank margins
around the perimeter of a report. You may choose to express margin sizes
in either inches or centimeters.
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❖

❖

❖

Report Date—You may choose to have reports indicate the date on which
they are run. The options in this section are as follows:
Option

Description

Placement

Use this option to determine whether reports should indicate
a report date and, if so, whether the date should appear in the
header or footer.

Alignment

Use this option to determine whether report dates should
appear left, right, or center aligned in the header/footer.

Date Format

Allows you to choose a format for report dates from a short list
of standard date formats.

Page Numbers—You may choose to have page number included on
reports. The options in this section are as follows:
Option

Description

Placement

Use this option to determine whether reports should include
page numbers and, if so, whether the numbers should appear
in the header or footer

Alignment

Use this option to determine whether the page numbers
should appear left, right, or center aligned in the header/
footer.

Format

Allows you to choose a format for the page numbers from a
short list of standard numbering formats.

Header and Footer —This section allows you to determine which of the
following text elements should be included on every page of a report:
❖ Title

❖ Footer Text

❖ Subtitle 1

❖ Report Date

❖ Subtitle 2

❖ Page Numbers

Design Tab
The Design tab allows you to set text and border formatting defaults
through an integrated version of the Active Reports viewer that is used to
create ad hoc reports from the Organizer. The Active Reports viewer on this
form displays text elements containing sample text so you can manipulate
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the formatting and view your results. To begin setting your report
formatting defaults, do one of the following:
❖

Click the element you want to change in the preview pane; it will be
highlighted, and the name of the element will appear in the Text Element
field.
Note: To select multiple elements in the preview pane, hold down the
CTRL key as you click on them with the mouse pointer.

❖

Using the Text Element drop-down list, select a specific text element to
format. The text element chosen will be highlighted in the preview pane,
where it may be edited. The text elements available are:
❖ Column Headings

❖

❖ Footer Text

❖ Group 4 Subtotal Label

❖ Grand Total Label

❖ Group 4 Subtotals

❖ Grand Totals

❖ Group 5 Heading

❖ Group 1 Heading

❖ Group 5 Subtotal Label

Group 4 Heading

❖ Group 1 Subtotal Label

❖ Group 5 Subtotals

❖ Group 1 Subtotals

❖ Page Numbers

❖ Group 2 Heading

❖ Report Data

❖ Group 2 Subtotal Label

❖ Report Date

❖ Group 2 Subtotals

❖ Subtitle 1

❖ Group 3 Heading

❖ Subtitle 2

❖ Group 3 Subtotal Label

❖ Title

❖ Group 3 Subtotals
❖
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Use the Report Section drop-down list to choose an entire section of the
report that will share format settings. When you choose a report section
to format, all text elements contained in the section will appear in the
preview pane. The following table lists the report sections available, along
with the text elements contained in each section:
Report Section

Text elements contained within

Column Header

Column Headings

Footer

Footer Text, Report Date*, Page Numbers*
*(depends on settings from Page Setup tab)

Global Report Formatting for Ad Hoc Reports
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Report Section

Text elements contained within

Grand Totals

Grand Totals

Group 1 Header

Group 1 Heading

Group 2 Header

Group 2 Heading

Group 3 Header

Group 3 Heading

Group 4 Header

Group 4 Heading

Group 5 Header

Group 5 Heading

Group 5 Totals

Group 5 Subtotal Label, Group 5 Subtotals

Group 4 Totals

Group 4 Subtotal Label, Group 4 Subtotals

Group 3 Totals

Group 3 Subtotal Label, Group 3 Subtotals

Group 2 Totals

Group 2 Subtotal Label, Group 2 Subtotals

Group 1 Totals

Group 1 Subtotal Label, Group 1 Subtotals

Header

Title, Subtitle 1, Subtitle 2, Report Date*,
Page Numbers*
*(depends on settings from Page Setup tab)

Records

Report Data

Global Report Formatting for Ad Hoc Reports
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Once you have selected a text element or report section in the preview pane,
use the formatting buttons on the toolbar to set its formatting:

Text formatting
options are found
here on the Global
Report Formatting
tool bar.

When you select a Text
Element or Report
Section to modify, the
text in question is
highlighted in the
preview pane.
(This may be difficult
to see in printed
manuals, as the
highlight color is a
light yellow.)

Note: For detailed instruction on working in the Active Reports viewer,
please refer to the GIFTS User’s Guide chapter on ad hoc reporting.
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Maintaining
Your GIFTS Data
This chapter describes how to consolidate duplicate records,
recalculate GIFTS data, purge documents that have been removed
from GIFTS.

In This Chapter
Consolidating Duplicate Records..........................................210
Recalculating Data.................................................................213
Purging Removed Documents..............................................216
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Consolidating Duplicate Records
Data entry errors can result in there being duplicate Organization or
Contact records in your database. You can identify duplicate records, and
consolidate the links to the Requests and Contacts associated with the
duplicates into one record.
For example, assume you have two Organization records for “New
University.” One record is associated with three Requests, and the second is
associated with another Request. After consolidation, you will have only one
record for “New University,” and all four Requests and their affiliated
Contacts are linked to that record.

Tip: You can configure GIFTS to automatically search for duplicate records

when users enter Organization or Contact records. For more information,
please refer to “General Preferences” on page 45.

Searching for Duplicate Records
To find duplicate records, choose Tools ➤ Duplicate Records ➤ Reports
from the Administrator menu, and then choose either Organizations or
Contacts.
❖

The Organization report will list all Organizations that have exactly the
same name as another Organization in the database.

❖

The Contacts report will list all Contacts that have the exact same last
name as another Contact in the database. Note that the report may include
people who are not in fact duplicates, such as “Mary Smith” and “Brad
Smith.”
The report does not check the first names in order to ensure that it
includes duplicate records where the Contact’s first name was entered
differently, such as “Brad Smith” and “Bradley Smith.”
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Consolidating Duplicate Records
Before You Begin: Decide which of the duplicate records you wish to

maintain, and which ones you wish to remove from the system. Usually the
record with the most up-to-date information is designated as the one to be
maintained.
To consolidate the records:
1 From the Administrator menu, choose Tools ➤ Duplicate Records ➤
Consolidate, and then choose either Organizations or Contacts. The
Consolidate Organizations/Contacts window opens:

The records you
select in the list are
consolidated to the
record you choose
below.

2 Identify the records that you want to consolidate:
❖

In the Organizations/Contacts to Consolidate section, either type the
ID of the first record and click Add, or leave the ID field blank and
click Add to search for the record by name.
Do not select the record you wish to keep in this list. You will identify
the Organization or Contact that you wish to keep later.

❖

If you are consolidating more than one duplicate record, add them to
the list as well. To remove a record from the list, highlight it and click
Remove.

Consolidating Duplicate Records
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3 If you wish to delete the duplicate records after the consolidation is
complete, select the Delete Items after Consolidation check box.
4 In the Organization/Contact to Consolidate To section, click the Find
button to search for the record you wish to maintain.
5 Click Consolidate to begin the process. A message details the
consolidation that is about to take place, and prompts you to confirm that
you wish to continue.
6 Click Yes to continue. A process log displays the status of the consolidation
as it proceeds. When the consolidation is complete, you can click Print or
Save As to keep the log for your records.

212

Consolidating Duplicate Records

Maintaining Your GIFTS Data

9

Recalculating Data
GIFTS maintains summary data—such as the balance of a grant or the total
number of payments for a grant—to maximize the speed of queries and
reports. Occasionally, as users work in GIFTS, this data is not properly
synchronized. This can happen for a variety of reasons, including network
communication errors and hardware problems.
If you suspect that the calculations of summary data and totals in GIFTS are
not synchronized, you can use the Recalculate Utility to synchronize your
data.

!

Caution: While the use of this utility is documented here, you should use

this utility only with the guidance of MicroEdge Technical Support. Before
recalculating your data, ensure that you have a valid backup of your database
and that no one else is logged in to GIFTS.
To recalculate your data:
1 From the Administrator menu, choose Tools ➤ Recalculate Utility. The
Recalculate Utility window opens:

2 Choose the recalculation options you want to run.

Recalculating Data
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Recalculate approved Requests’ ‘Paid’, ‘Balance’, and ‘Number of
Payments’ The information in these fields is based on the Payment

Schedule for each Request. This option checks the Payment Schedule for
all approved Requests and refreshes this information.
This option calculates each
Request’s Fiscal Year based on their Approved Dates and your Fiscal Year
setup. If you change your Fiscal Year setup, you can run this process to
correct the Fiscal Year of your existing grants.

Recalculate approved Requests’ Fiscal Year

Recalculate Coding Sheets If your coding information is not

synchronized, there may be inconsistencies between the coding
information displayed in GIFTS and the coding information in your
reports. These options ensure that the coding information used
throughout the system is synchronized with the information displayed
when you view your Coding Sheets.
Each record in the GIFTS database has a unique key field,
or ID. When users enter data, each new database record is assigned to
the next available key. If the key counters are not correct, users may
encounter errors when entering data. This option ensures that the keys
for each database table are set appropriately.

Initialize Keys

This option helps to maintain the integrity of the
GIFTS database, and to make sure that queries return the desired results.
It ensures that each table has a special “zero record,” which is used to
join tables when a relationship does not exist - for instance, when an
Organization does not have a Primary Contact.

Insert Zero Records

Update Foreign Keys Like the preceding option, this recalculation will
help to keep records in your GIFTS database in the proper relationship
with one another. This option makes sure that in every case where a
relationship does not exist between records, the database is “pointing” to
the special zero record.

This option helps you maintain the integrity of the
Coding Sheet information in your database. This is particularly
important in that it ensures that records that have not been coded in a
certain category still appear on reports and queries that group by that
category.

Refresh Codes Table
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Repair Indices This option recreates any standard indices that are not
currently set correctly in the database, and removes any that are not
standard GIFTS indices.

3 Click OK to run the recalculation.
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Purging Removed Documents
When users create merged correspondence, they can choose to save their
word processor documents for later reference. If users no longer need to
access these documents in GIFTS, they can remove them.
Removed documents are not deleted; they are archived to the /GIFTS/
DOCUMENT/TEMP directory. You can manage this archive by periodically
purging removed documents from the /GIFTS/DOCUMENT/TEMP
directory.

!

Caution: Purged documents are deleted and cannot be recovered.

To purge documents from the /TEMP directory:
1 From the Administrator menu, choose Tools ➤ Purge Removed
Documents. The Document Purge window opens:

Specify a date range for the documents you want to purge. If you do not
specify a date range, GIFTS purges all documents up to the current date.
Note: Since removed documents are no longer associated with

Document Activity records, GIFTS uses the document date—the date
that the document was last modified.
2 Click OK. You are prompted with the number of documents that will be
purged and asked to confirm you want to purge them.
3 Click Yes. The documents are purged from the /GIFTS/DOCUMENT/
TEMP directory.
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Customizer
Planning

This and the following chapter provide information to clients using
the optional GIFTS Customizer Module. The Customizer Module
allows you to create custom forms for GIFTS records, in which you
can record data specific to your needs.
Before you create custom forms, it is a good idea to plan your needs
for data fields and other elements on paper first. This chapter
describes how to plan the customizing of your GIFTS system.
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About Customizer Planning..................................................218
Planning Data Fields..............................................................220
Planning Calculated Fields ....................................................224
Planning Web Clippings........................................................225
Field Planning Worksheet .....................................................226
Creating Database Fields.......................................................228

10

Customizer Planning

About Customizer Planning
In order to create your custom forms, you must first determine which types
of records you wish to expand, and then determine what specific data you
wish to collect. Custom forms can be established for Requests,
Organizations, Payments, Activities, Contacts, Requirements, Affiliations,
and/or Reviews. These forms may contain one or more custom elements,
including: custom data fields; read-only calculations based on current data in
the record; and even live Web content. The “Field Planning Worksheet” on
page 226 has been designed to assist you in planning your custom data fields,
calculated fields, and Web clippings.
Once you have defined your data needs using the Field Planning Worksheet,
you can create the custom data fields. At this point, you will establish the
name of each field and the type of data that is to be captured in the field.
Note: GIFTS stores custom data in database tables called extension tables.

For example, when you use the GIFTS Customizer to add fields to the
Contact record, GIFTS adds a table to the database called Contacts_Ext; the
custom fields you create become columns of data in that table. Contacts_Ext
is linked to the standard Contacts table (containing standard GIFTS Contact
fields), so that when a Contact record is opened in GIFTS, any custom data
for that Contact can also be displayed.
The final step is the layout and building of the data entry form(s), which is
covered in detail in the next chapter. The Form Design Worksheet on
page 237 will help you lay out the custom elements you established on the
Field Planning Worksheet. Once you have built your custom forms, users
can immediately begin entering data.
Important: It is important to set up your custom forms as accurately as

possible before rolling the changes out to your users. Although it is possible
to add, remove, and change fields later, this process can take a long time for
the system to complete, particularly if a large amount of data entry has
occurred in the custom fields.
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Custom Fields in GIFTS Connections
Custom data fields and calculated fields are available in MyGIFTS. Data
fields can be displayed, edited, hidden, or made read-only, just like other
GIFTS fields. Calculated fields (which are read-only in MyGIFTS as well as
GIFTS) can also be displayed or hidden using MyGIFTS field-level
permissions.
If you use ReviewerCONNECT, note that custom data fields and calculated
fields added to your Review, Request, and Contact records can be displayed
to your online reviewers. These custom Review fields appear on both edit
and detail pages, but can also be hidden or made read-only using
ReviewerCONNECT field-level permissions.

About Customizer Planning
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Planning Data Fields
First, decide which type of record you wish to customize: Requests,
Organizations, Payments, Activities, Contacts, Requirements, Affiliations, or
Reviews. In doing so, think about how the information you wish to capture
is related to the information already captured by GIFTS.
For instance, you may wish to record the number of books purchased as a
result of each Request. In this case, information about individual grants
(project title, amount awarded, etc.) is part of the Request record. Since the
number of books purchased is specific to each grant, you would want to add
this field to the Request information.
However, if you wish to track specific information about the librarians
involved in the project, you would add fields to the Contact records, since
information regarding specific individuals is maintained in their Contact
records.

Request Type-Specific Data Entry Forms
If your organization tracks Requests for different giving programs, you can
capture information that is specific to each Request type.
For example, if your organization has both a Cash Grants program that
purchases computer equipment and an In-kind computer donation
program, you can track different information for each program. You might
track “# of Computers Purchased” and “Average Purchase Price” for your
Cash Grants Requests and “# of Computers Donated” and “Retail Value”
for your In-kind Requests.

Stage-Specific Data Entry Forms for Reviews
If you use the optional Reviewers Module, you can capture information
specific to each Review Stage.
Review Stages allow you to choose specific types of feedback you want from
different reviewers (internal or external) for different kinds of Requests.
When you add a Review you choose a Stage, and that Stage’s settings are
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reflected in the new Review. Each Review Stage can be further customized
using the GIFTS Customizer Module.

Listing Data Fields
Once you have chosen the appropriate record type for your data, you can
use the Field Planning Worksheet to list the individual fields you wish to
include.
As you list your fields, be sure to separate information into distinct fields.
For instance, you may wish to track the number of books bought and the
amount of money spent. The “Number of Books” should be tracked in one
field and the “Amount Spent” in another. You should also make sure that
each field name accurately represents the field’s intended use.

Tip: For client/server GIFTS systems, the number of data fields that you

may include on a custom form is essentially unlimited; file server and
standalone systems are limited to 255 custom elements. (Calculated fields
and Web clippings don’t count toward these limits.) Regardless, it’s
important to note that the amount of “real estate” on each form is limited.
Any more than 20 data fields, depending on their size, will probably create
difficulties during the layout stage. Other elements, like Web clippings, can
take up a considerable amount of space by themselves. If you have too many
data fields and other elements to fit neatly on one form, consider dividing
your custom elements between two or more forms.
If you are creating Request type-specific fields, list all your Request data
fields on the same worksheet. Although these fields will be displayed in
different data entry forms, the data is stored in the same database extension
table. You can assign the fields to a specific Request type when you design
the layout of your Request data entry forms.

Choosing Data Field Types
Once you have established the data fields you need, you must decide on the
type of data that is to be captured in each field. For instance, if you have a
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field called “Number of Books,” do you want to capture numbers that can
be calculated in your reports? Or, would you rather save the information as
text so users can enter ranges like “over 1000” or “100500”? Or, would you
like to define a list of values from which users can choose?
The following field types are available:
Field Type

Description

Text

Holds any text information up to a limit of 255 characters. If you
want, you can make the character limit smaller.

Long text

Holds any text information up to a very high limit. (The precise limit
varies among different client/server and file server systems, but in
every case it is many tens of thousands of characters.) If you want,
you can designate a specific character limit.

Small number,
no decimal

Permits integers between zero and 255.

Medium
number, no
decimal

Permits integers between -32,768 and 32,767.

Large number,
no decimal

Permits integers between -2,147,483,647 and 2,147,483,647.

Currency

Permits numbers with two decimal places and a currency symbol.

Number, with
decimal

Permits numbers with as many as four decimal places.

Date

Permits dates in the format specified by the Windows Regional
Settings. (For example, the United States date format is mm/dd/
yyyy).

Values

Holds a value from a list that you define. During data entry, users
can choose from the values you enter, much in the same way that
users choose from lists of classifications in coded fields like Request
Status and Request Type.

This data type is not available on client/server systems.

If you choose this field type, you must also enter the available
values.
NOTE: This type field can only hold a maximum of 255 characters.
Anything over 255 characters will be truncated when you save. For a
longer list of values, it is recommended to use a code table instead.
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Field Type

Description

True/False

Permits a “Yes/No” or “True/False” response. On the data entry
screen, it appears as a check box. A selected check box indicates
“True”; a cleared check box “False.”

You can use the Field Planning Worksheet on page 226 to help plan the
implementation of your custom fields.
Important: The names of all currency fields should end with “_Amount”

(like “Ave_Unit_Amount”), and all date fields should end with “_Date”. The
names of fields of other types should not end with “Amount” or “Date.”
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Planning Calculated Fields
Custom calculated fields can dynamically display the results of simple
calculations based on current values in your data fields. For example, if you
are tracking the number of children’s books purchased by a grant, as well as
the total number of books purchased, you can use a calculated field to
display the percentage of books purchased that are for children. You could
also use the total amount of the grant to calculate the percentage of the
grant amount that is being spent on children’s books.
GIFTS handles calculated fields differently than data fields and, as such, does
not require you to create them through the Table Customizer. Instead, you
will create and format calculated fields when you actually build your custom
data entry forms. For now, you should simply determine what calculated
values you wish to display on your forms, and the appropriate formula
needed to calculate each value. For details on adding calculated fields to
your forms, see “Adding and Configuring Calculated Fields” on page 255.
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Planning Web Clippings
Custom Web clippings allow you to display dynamic Web content right in
your GIFTS Organizer. Each Web clipping may be configured to display a
different Web page that will be refreshed automatically whenever you access
the data entry form. Advanced users may even choose to configure the URL
for a Web clipping with context-sensitive parameters (based on the current
record). This allows you to give users instant access to password-protected
or subscriber-only content.
GIFTS handles Web clippings differently than data fields and, as such, does
not require you to create them through the Table Customizer. Instead, you
will create and format Web clippings when you actually build your custom
data entry forms. For now, you should simply determine the URLs for the
Web pages you wish to display on your forms. To determine the URL for a
Web page, navigate to the page and copy the HTTP:// address in the
location bar at the top of your Web browser window. For details on adding
Web clippings to your forms, see “Adding and Configuring Web Clippings”
on page 259.
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Field Planning Worksheet
Completed by:

___________________________________________________

On (date):

___________________________________________________

For customizing (circle one):

Activities

Organizations

Payments

Contacts

Requests

Requirements

Reviews

Affiliations

Request Type: _________________

Review Stage: _________________

Use the following table to list the custom elements you need to capture your grant making
information. Please note that the names of currency fields should end with “_Amount” and
date fields with “_Date”. Other fields should not end with the word “Amount” or “Date”.
Element Name

Type

URL/Calculation

Data Field Types:
Text (255-character limit)
Long text (64,000-character limit)
Small number, no decimal (0-255)
Medium number, no decimal (-32,768 to 32,767)
not available on client/server systems
Large number, no decimal (-2,147,483,647 to 2,147,483,647)

Currency ($1,000,000.00)
Number, with decimal (1.1234)
Date (01/01/2000)
Values (user-defined list)
True/False (check box)

Other Element Types:
Calculated Field
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Field Planning Worksheet

SAMPLE

Completed by:

Mary Brown
___________________________________________________

On (date):

September 20, 2005
___________________________________________________

For customizing (circle one):

Activities

Organizations

Payments

Contacts

Requests

Requirements

Reviews

Affiliations

Grants
Request Type: Cash
_________________

Review Stage: _________________

Use the following table to list the custom elements you need to capture your grant making
information. Please note that the names of currency fields should end with “_Amount” and
date fields with “_Date”. Other fields should not end with the word “Amount” or “Date”.
Element Name

Type

URL/Calculation

Number_of_Books

Medium Number Field

Books_for_Adults

Medium Number Field

Books_for_Children

Medium Number Field

Book_Vendor

Text Field

Discount_Flag

True/False Field

Discount

Text Field

Avg_Unit_Amount

Currency Field

Institution_Type

Values Field

Adult_Books_Pct

Calculated Field

100(Books_for_Adults/Number_of_Books)

Children_Books_Pct

Calculated Field

100(Books_for_Children/Number_of_Books)

Book_Store_Web

Web Clipping

www.bookstore.com

Field Types:
Text (255-character limit)
Long text (64,000-character limit)
Small number, no decimal (0-255)
Medium number, no decimal (-32,768 to 32,767)
not available on client/server systems
Large number, no decimal (-2,147,483,647 to 2,147,483,647)

Currency ($1,000,000.00)
Number, with decimal (1.1234)
Date (01/01/2000)
Values (user-defined list)
True/False (check box)

Other Element Types:
Calculated Field
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Creating Database Fields
When you enter the Table Customizer for Requests, Organizations,
Payments, Activities, Contacts, Requirements, or Reviews, the system
automatically creates the Extension Table(s) needed to contain your new
fields. At this point, you should have completed the planning worksheets on
page 226 and page 238.

!

Caution: Before you modify the GIFTS database, be sure to make a backup

of your GIFTS database and ensure that no other users are logged into
GIFTS.

Accessing the Table Customizer
To create and work with custom fields:
1 Log in to the GIFTS Administrator Module.
2 From the Administrator menu, choose Tools ➤ Customize ➤ Tables.
3 Choose the type of record—Request, Organization, Payment, Activity,
Contact, Requirement, or Review—for which you wish to add custom
fields. The contents of the Extension Table are displayed. For instance, if
you choose Requests, the contents (if any) of the Requests_Ext table are
displayed:
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Adding a New Field
Note: Before adding or modifying fields, you should make sure all GIFTS

users are logged off the system. It is also advisable to back up your GIFTS
database before proceeding.
Each field in the table must have a Name and Type. The Type defines the
type of data that can be stored in the field and how the data is formatted. To
add a new field:
1 In the Table Customizer window, click New. The Adding Field window
opens:
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2 Enter a Name for the field, then the Type. Note that the available options
vary, depending on the Type of field that you are adding:

Field

Usage

Name

The name of the field in the GIFTS database. Field names
cannot contain spaces: if you enter a space, GIFTS
automatically inserts an underscore ( _ ) in its place.
Do not use special characters such as “?,” “!,” “#,” “*,” and so
forth. These characters sometimes have special meanings to
the system.
By default, this name is used as the label that identifies the
field on the data entry form. You may change the label
displayed for your users without changing the field’s database
name.
Important: The names of all currency fields should end with
“_Amount” (for example, “Ave_Unit_Amount”) and all date
fields should end with “_Date”. If the name you specify for a
currency or date field does not end as specified, GIFTS
automatically adds it to the end of the field name. The names
of all other field types should not end with the word “Amount”
or “Date”.

230

Type

Choose the appropriate type for the data you wish to enter in
this field. See the Data Types table on page 222 for a
description of each type.

Max. Length

This field is displayed if you have chosen “Text” as the field
type. Text fields have a limit of 255 characters. If you wish to
limit the number of characters that can be stored in the field to
a smaller number, enter that number here.

Values

This field is displayed if you have chosen “values” as the field
type. This is where you provide the list of values available to
users during data entry. Enter the values in the field,
separating each value by a comma. (Make sure that you do not
use commas within the values—and don’t put a space after a
comma.)
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3 When you are finished defining a field, click OK. The field is saved in the
Table Customizer grid. The Adding Field window clears, and you can
enter another field, click OK after each one you add.
4 When you have finished adding fields, click Cancel to exit the field-creation
process. The fields you have created are displayed in the Table Customizer
window:

5 Click Save and Close to exit the Table Customizer window and save your
changes. A message appears, informing you that this operation required
exclusive access to the GIFTS database. Make sure all other GIFTS users
are logged off before clicking Yes to proceed.
If you click Yes, another message appears advising you to back up your
GIFTS database before proceeding. If you want to proceed, click Yes.
GIFTS updates the database with your new fields.

Modifying an Existing Field
Note: Before adding or modifying fields, you should make sure all GIFTS

users are logged off the system. It is also advisable to back up your GIFTS
database before proceeding.
You can modify the field information at any time, even after data entry has
taken place. Depending on the amount of data entered, the system may
require some time to update the database when you save the new field
information.
Important: If you modify the Type of a field after users have entered data,

any data currently residing in the field that is incompatible with the new
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Type is deleted. For instance, if you change a text field to a numeric field,
text values such as “a lot” are erased, whereas values that can be represented
numerically—such as “15”—are converted to the new Type.
To edit a field:
1 From the Administrator menu, select Tools ➤ Customize ➤ Table ➤
[desired record type]. The Table Customizer window opens.
2 In the gird, highlight the field you want to modify and click Edit. The
Editing Field window opens:

3 Modify the field as needed, then click OK to save your changes.
4 Click Save and Close to exit the Table Customizer window and save your
changes. A message appears, informing you that this operation required
exclusive access to the GIFTS database. Make sure all other GIFTS users
are logged off before clicking Yes to proceed.
If you click Yes, another message appears advising you to back up your
GIFTS database before proceeding. If you want to proceed, click Yes.
GIFTS updates the database with your new fields.

Deleting a Field From the Database
Important: If you delete a field, all data that has been entered into the system for

that field is deleted. The field is removed from any custom data entry forms
on which it appears. Just as when adding or modifying fields, you should
make sure all GIFTS users are logged off before proceeding. It is also
advisable to back up your GIFTS database before making these changes.
1 From the Administrator menu, select Tools ➤ Customize ➤ Table ➤
[desired record type]. The Table Customizer window opens.
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2 In the grid, highlight the field and select File ➤ Delete. You are prompted
to confirm that you want to delete the field.
3 Click Yes to continue.
4 Click Save and Close to exit the Table Customizer window and complete
the deletion. A message appears, informing you that this operation
required exclusive access to the GIFTS database. Make sure all other
GIFTS users are logged off before clicking Yes to proceed.
If you click Yes, another message appears advising you to back up your
GIFTS database before proceeding. If you want to proceed, click Yes.
GIFTS updates the database with your new fields.
The field, and all of the database information that has been entered into it, is
removed from the system.
If you delete or change the name of a custom database field used in an
IGAM form without updating the IGAM form, the field will become invalid
and IGAM users will receive an error when trying to consider applications
that contain invalid fields.

Updating IGAM Forms
To update an IGAM form after you have changed a custom data field used in
that form:
1 Log in to the IGAM and open the Forms Manager.
2 Open the form that uses the field that has been modified. The IGAM
performs an automatic synchronization of the form with the Code Tables
and custom fields in your database, and—if the form uses any fields that
no longer exist—a message is displayed and the invalid fields are removed
from the form.
3 If you wish to replace any of the fields that had been removed, go to the
Fields tab of the Form Design Wizard and add the new or updated field to
the appropriate section of your form.
4 Save and close the form.
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Building
Custom Forms

This chapter describes how to design the data entry forms used to
enter your custom data.
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Planning the Form Layout
Once you have chosen the elements that you wish to include, you may wish
to experiment with the layout of the form on paper before building it in the
system.
Using the “Form Design Worksheet” on page 237, draw the layout—using
the element labels from the Field Planning Worksheet(s) you completed in
the last chapter—in the positions that you think will make the most sense to
your users during data entry. You can also choose a name (or Tab Caption)
for the tab that users select to view the data entry form.

A user-define tab name, as it appears
in GIFTS.

Note: If you are creating Request data entry forms for more than one
Request Type, you should complete a Form Design Worksheet for each
Request Type. The same is also true of Reviews; if you use the optional
Reviewers Module, create a worksheet for each Review Stage.
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Form Design Worksheet
Completed by:

___________________________________________________

On (date):

___________________________________________________

For customizing (circle one):

Activities

Organizations

Payments

Contacts

Requirements

Affiliations

Requests

Reviews

Request Type: _______________

Review Stage: ___________

Tab Caption: _________________

In the following box, design the on-screen layout of your custom elements. For assistance,
please fax this form to MicroEdge Technical Support at (877) 704-3343.
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Form Design Worksheet

SAMPLE

Brown
Completed by: Mary
___________________________________________________
On (date):

April
15, 2003
___________________________________________________

For customizing (circle one):

Activities

Organizations

Payments

Contacts

Requirements

Affiliations

Requests

Book Purchase
Request Type: ______________

Reviews
Review Stage: __________

Books
Tab Caption: _________________
In the following box, design the on-screen layout of your custom elements. For assistance,
please fax this form to MicroEdge Technical Support at (877) 704-3343.

Number of Books Purchased
Books for Adults
Children’s Books
Institution Type
Book Vendor
Discount Received
Discount
Average Unit Price
Percent Adults’ Books
Percent Children’s Books
Book Store Web Site
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Adding Custom Forms
Once you have planned the layout of your custom GIFTS forms, you can
begin to build those forms in your system. At this point, you should have
completed the “Form Design Worksheet” on page 237, where you defined
the form layout.
This section of the chapter describes how to add, rename, and delete custom
form (or tabs). Information on adding, arranging, modifying, and deleting
elements of these tabs is found in:
❖

“Adding and Arranging Data Fields” on page 250.

❖

“Adding and Configuring Calculated Fields” on page 255.

❖

“Adding and Configuring Web Clippings” on page 259.

Opening a New Custom Form
To open the Form Customizer and start a new custom form:
1 From the Administrator menu, choose Tools ➤ Customize ➤ Forms.
2 In the Forms sub-menu, select the type of record for which you wish to
design a form. You may select Organizations, Payments, Activities,
Contacts, Requirements, Affiliations, Reviews, or Requests.
Note: If you select Reviews or Requests, you then select (respectively)

the Review Stage or the Request Type to which you are adding a form.
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For both Reviews and Requests, you can choose “Default,” which adds
the form to all Review or Request records.
The Form Customizer opens:

If you have previously
added forms to the record
type indicated, they would
be displayed here.
In this case, we have not yet
created any custom tabs for
Cash Grant Requests.

3 To open a new custom form, click Add Tab. The form design environment
opens within the new tab:
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Changing the Tab Name
“More[#]” is the default title for a new tab when added. To change the tab
name to something more descriptive and helpful to GIFTS users:
1 Click Edit Caption. The Edit Caption window opens:

2 Enter your tab name in the Caption field and click OK. The Form
Customizer now shows your custom form with the new caption.

Creating Additional Data Entry Forms
When you have too many fields to fit onto one custom form, or if you want
to divide your custom data fields and elements under separate tab captions
for easier location, you can simply create additional forms.
To add a custom form to a GIFTS record type:
1 From the Administrator menu, choose Tools ➤ Customize ➤ Forms.
2 In the Forms sub-menu, select the type of record for which you wish to
design a form. You may select Organizations, Payments, Activities,
Contacts, Requirements, Affiliations, Reviews, or Requests.
Note: If you select Reviews or Requests, you then select (respectively)

the Review Stage or the Request Type to which you are adding a form.
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For both Reviews and Requests, you can choose “Default,” which adds
the form to all Review or Request records.
The Form Customizer opens:

In this example, a second
custom tab, “Miscellaneous,”
has already been added to
Organization records.

Use the Move Left
and Move Right
buttons to place
the custom forms
in the desired
order. Note that
custom tabs will
always appear to
the right of the
record type’s
standard tabs.

3 When the Form Customizer opens, click Add Tab.
4 Click Edit Caption to enter a name for the new tab.
5 Complete the form by adding and arranging your data entry fields and
other elements, as described in later sections of this chapter.

Deleting a Data Entry Form
If you have created an additional data entry form that you no longer wish to
use, you can delete it from your GIFTS system so it will not be available as a
tab in the GIFTS record.
To delete a data entry form:
1 From the Administrator menu, choose Tools ➤ Customize ➤ Forms.
2 In the Forms sub-menu, select the type of record for which you wish to
design a form. You may select Organizations, Payments, Activities,
Contacts, Requirements, Affiliations, Reviews, or Requests.
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Note: If you select Reviews or Requests, you then select (respectively)

the Review Stage or the Request Type to which you are adding a form.
For both Reviews and Requests, you can choose “Default,” which adds
the form to all Review or Request records.
3 When the Form Customizer opens, select the form you wish to delete by
clicking on its tab.
4 Click Remove Tab to delete the form.
Important: If you delete a form, the database will still retain any custom

data fields that were on the form, as well as any data that has been entered in
those fields. If you wish to delete a field from the database, please refer to
“Deleting a Field From the Database” on page 232.
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Working in the Form Customizer
Environment
Specific information about working with data fields, calculated fields, and
Web clippings follows this section. First we will look at some general
features of the Form Customizer environment.

The Custom Form Grid
The custom form grid is designed to help you arrange elements (like data
fields) in straight lines. This makes it easier to arrange custom forms with a
pleasingly symmetrical appearance.
The grid appears as a matrix of dots in the tabs in the Form Customizer:

Move your labels and
your data fields,
calculated fields, and
Web clippings in line
with the dots for a
cleaner, more regular
layout.

The grid can be resized to allow more or less precise of
placement of form elements. The distance between the dots can be modified
to 30, 60, 90, 120, or 150 twips. (A twip is equal to one-twentieth of a
printer’s point, or 1/1440th of an inch.) The defaults is 120 twips.
Changing Grid Size

To change this setting, select View ➤ Grid Size ➤ [30, 60, etc.].
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Toggling the Grid Off If you prefer not to use the grid, you can turn off the
option by selecting View ➤ Show Grid. To toggle back to grid view, select
View ➤ Show Grid again.

“Snapping” to the Grid—Keeping Elements in
Line
When you toggle the grid view on, a second Form Customizer option called
“Snap to Grid” is also toggled on. This feature automatically places elements
and labels in line with grid when you move or resize them. When you move
or adjust them, they automatically “snap” to the nearest grid lines.
If you prefer not to use the feature, you can turn
off the option by selecting View ➤ Snap to Grid. To toggle in back on, select
View ➤ Snap to Grid again.

Toggling Snap to Grid Off

Selecting Items in a Custom Form
After you have added fields and/or Web clippings to a custom form, you can
move, resize, align, or remove them. Before taking those actions, however,
you have to select the field or fields you want to work with. There’s more to
this than meets the eye.
Selecting a label or an element (field or Web clipping) is like selecting other
items on your workstation: Place your mouse over the item and left click.
You can select a group of items by holding down the left mouse button,
scrolling diagonally until you create a sort of “box” around the items, then
releasing the left mouse button. Nothing unusual there.
However, when you are trying to arrange a nicely laid-out custom form, you
may want to move elements and their labels together—or separately. Or you
might want to select multiple items that have other items in between, when
the “box” selection method described above won’t work.
The table below describes the less obvious ways to select items in a custom
form:
Desired Selection

Selection Method

Both an element and its label.

Left click on the element
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Desired Selection

Selection Method

An element, but not its label.

CTRL+left click on the element.

A label, but not its element.

Left click on the label.

A variety of elements, each with its label.

SHIFT+left click on each desired element.

A variety of elements and/or labels.

CTRL+left click on each desired item.

Deselect an item among a group of
selected items.

CTRL+left click on the item you want to
deselect.

Moving Items in the Form Customizer
Elements and labels in the Form Customizer can be moved using the mouse
and its standard drag-and-drop method. However, like selecting items,
moving items also has a few tricks:
Item(s) to Move

Method

An element with its label.

Place mouse pointer over the middle of the element and
drag it to its new location.

An element, but not its
label.

When you click on an element, you will see a green
square in the top right corner of the element. To move
an element independently of its label, place your mouse
pointer over that square, then drag it to its new location.
Hold the left mouse down with the pointer
on this square to move the element
independently of its label.
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A label, but not its element.

Place mouse pointer over the label and drag it to its new
location.

A group of items.

Select the multiple items you want to move together,
then drag them to their new location.
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Removing Elements and Labels
To remove an element from the Form Customizer, select it and click
Remove.

A message reminds you that the element’s label will also be removed; click
Yes to remove them.
You can select multiple items and remove them at once by clicking Remove.
You can remove a label without also removing its field or Web clipping.
Select the label and click Remove. To get the label back, highlight the
element, click Edit, select the Label Visible check box, then click OK.

Resizing Fields and Web Clippings
The sizes of custom form elements—data fields, calculated fields, and
Webclippings—can be modified to suit your new custom tab. There are a
few different ways to change elements’ sizes.
And individual element can be resized using the mouse. When you select a
field or Web clipping, “handles” appear on each corner and each side of the
element:
Hold down the left mouse button over one
of these handles to “grab” it—then move the
mouse to expand or contract the element in
that direction.

You can select multiple elements and make
them all the same size as the first selected one.

Make Fields the Same Size
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Note: “First selected” in this case means the one that is the top or furthest left

one. Change the size of that element, then select it with other items you want
to be the same size.
Select the elements, then select one of the following from the Form
Customizer menu:
❖

Action ➤ Make Same Size ➤ Widths

❖

Action ➤ Make Same Size ➤ Heights

To make the selected fields the same in both dimensions, select one option
right after the other.

The options to make
selected items the
same size can also be
found here.

If you like, you can specify element size right
down to the twip. Since the options for specifying element dimensions and
location look different for data fields, calculated fields, and Web clippings,
these options are discussed in the next sections.

Fine-Tuning Element Size

Aligning Elements and Labels
You can select multiple labels and/or elements and align either vertically or
horizontally.
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Select the items you want align. From the Form Customizer menu, select
Action ➤ Align Field ➤ Tops (for elements next to each other) or Action ➤
Align Field ➤ Lefts (for elements in a list).

Options for aligning
items can also be
found here.
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Adding and Arranging Data Fields
Important: If you have more than one data entry form for a record type,

make sure the correct form is displayed when you are adding or editing
custom data fields.
To add one of your custom data fields to a data entry form:
1 Click Add, and then select Field from the drop-down list. The Add Field
form presents a list of the data fields you created in the database:

If you have already begun building the data entry form, this list does not
include data fields that have already been added to the form. (If no data
fields are displayed in the list, you have not created any custom fields in
the database. Refer to “Creating Database Fields” on page 228 for
information about creating custom data fields.)
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2 Highlight the data fields you would like to add and click OK.
The data fields are displayed in the upper left corner of the form. Note that
each data field on a form is comprised of two parts: the label that identifies
the data field, and the prompt area into which users will enter data.

Each data field is
identified by a
label.

Users will enter
data into the
prompt area of
each data field.

Tip: Although you can add many data fields to a form at once, it is easier
to insert and place a few data fields at a time. When you add data fields to
the form, be sure you move labels and prompts from the upper left corner
before inserting more data fields.

3 To move a prompt or label on the data entry form, click on it and drag it
to the appropriate location.
For information about sizing and renaming the labels and/or prompts,
please refer to “Changing Prompt and Label Properties” on page 251.

Changing Prompt and Label Properties
By editing the field properties, you can determine the size and location of
most prompts and labels. You can also change label names.
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To change the dimensions or options for a label or prompt, highlight it and
click Edit. The properties are displayed:

You can modify the following properties for both prompts and labels:
Property

Description

Left

The distance of the data field from the left border of this custom
tab, in twips.

Top

The distance of the data field from the top border of this custom
tab, in twips.

Height

The height of the field in twips.

Width

The width of the field in twips.

Note: You cannot modify the height of a Values field, and you cannot modify
the dimensions of True/False fields.

You can modify the following properties for prompts only:
Property

Description

Tab Order

In data entry screens, each prompt (field) is assigned a tab order
number; when the user presses TAB, the cursor moves to the next
prompt, as determined by its tab order number. Once you have
established the layout of the fields on the screen, you may wish to set
the tab order so that the user can move logically among prompts using
the TAB key.
Note that the tab order number of the first prompt is zero, not one.

Label Visible
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You may choose to hide the label tied to this particular prompt. Select
this check box to show the label, or clear the check box to hide the
label.
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You can modify the following property for text field prompts only:
Property

Description

Multi-Line

For text fields (but not long text fields), you can choose whether you
want the text to “wrap” during data entry. If you select this check box,
the text the user is entering will wrap to the next line when it exceeds
the width of the field. If this option is not on, the text will scroll to the
right as it is entered.
If you select this check box, you should increase the height of the field
so that more than one line of text can be displayed. The default height
is 300 pixels, or one line of text; for each additional line of text you
want to display, add 300 pixels to the height of the prompt.

You can modify the following property for labels only:
Property

Description

Label Text

To change the label displayed on the form, just edit the text in this
field.
Please note that changes to the label text do not affect the field’s
database name. This may create confusion for users when this field is
used for searching and reporting if your label differs significantly from
the field name.
If the purpose of the field has changed, you should edit the field name
as described in “Modifying an Existing Field” on page 231.

When you are finished editing the properties, click OK to save your changes.
The layout of the custom form reflects the changes you’ve made. When all
of the fields on all the forms have been laid out to your satisfaction, click
Save and Close or create more data entry forms, as discussed in the next
section.

Removing a Data Field from a Form
You can remove data fields from a form at any time. Removing a data field
from the form does not remove it from the database, nor does it delete the
information currently entered in the field. You may re-add the data field to a
form at any time. If you wish to remove the field from the database, and to
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delete any information that has been entered in the field, please refer to
“Deleting a Field From the Database” on page 232.
Important: When you remove a calculated field or Web clipping from a

form, the element’s configuration options are deleted permanently. If you
wish to re-add any of these elements to a form, you will need to configure
them from scratch. Before removing one of these elements, it is a good idea
to make a record of the existing calculation Formula, Launch command line,
or URL.
To remove a data field from a form:
1 Highlight the data field prompt and click Remove. A message opens,
asking you to confirm your intentions.
2 Click Yes to remove the data field and its label.
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Adding and Configuring Calculated Fields
Important: If you have more than one data entry form for a record type,

make sure the correct form is displayed when you are adding or editing
calculated fields.
To add a calculated field to a data entry form:
1 Click Add, and then select Calculation from the drop-down list. The New/
Edit Calculation form opens:

2 Configure the following settings on the New/Edit Calculation form:
Option

Description

Name

The name of the calculated field. This name will be
used as the label for a new field, but the label may
be changed later.

Formula

The formula used to calculate the value to be
displayed in the calculated field. For details on
building formulas for calculated fields, please see
“Formulas for Calculated Fields” on page 257.

Left

The distance of the calculated field from the left
border of this custom tab, in twips.

Top

The distance of the calculated field from the top
border of this custom tab, in twips.

Height

The height of the calculated field, in twips.
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Option

Description

Width

The width of the calculated field, in twips.

Label Visible

Indicates whether or not the label for the
calculated field should be visible on the data entry
form. Default is on (selected).

Display Result As

Indicates whether the result of the calculation
should be displayed as a currency amount or a
number.
Note: If Currency is selected, formatting of
negative values on data entry forms is determined
by Windows regional settings. If the calculated
field is added to the Organizer as a column, the
user may specify negative number formatting in
GIFTS.

The following options are available if you select to display result as a
number.
Decimal Places

Indicates the number of decimal places to display
(0 – 4).

Display Percent
Symbol

Indicates whether the calculated value should
display with a percent symbol preceding it.
Note: Selecting this option does not convert a
calculated value to a percentage. If you want to
calculate a value as a percentage, you must set up
the Formula to do the appropriate calculation.

The following options may be available if you select to display result as
currency. (They will not appear if your Administrator Module systempreferences specify not to display currency symbols.)
Don’t Display
Currency Symbol

Indicates whether the currency symbol should be
displayed.

Currency Symbol

Indicates the appropriate currency symbol to
display.

3 Click OK to add the calculated field to the data entry form.
4 To move the calculated field on the data entry form, click on it and drag
it to the appropriate location.
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Formulas for Calculated Fields
Formulas for calculated fields are built using static numeric values, dynamic
numeric values from GIFTS data fields, and basic arithmetic operations. You
can use both standard GIFTS data fields and your custom data fields for
building formulas.
When you save a calculated field, GIFTS validates the formula you entered
and alerts you if it was not set up properly. You can also have GIFTS check
your formula within the Add/Edit Calculation window by clicking the
Check Syntax button.
Merge fields should be entered into formulas using the following format:
{Category.Field Name}
You may either enter data fields directly into the Formula area of the New/
Edit Calculation form, or use the Field Insert tool to select one or more
fields from any available category. To use the Field Insert tool:
1 Click the Insert Field Reference button located next to the Formula field
on the New/Edit Calculation form. The Add Data Field form opens:

You can select the GIFTS category
(database table) that contains the
field(s) you want to insert here.

2 Use the “Select available fields from” drop-down list to select the GIFTS
category (table) that contains the field(s) you want to insert.
3 Scroll through the Available Fields list and select the check box(es) next to
the field(s) you want to insert, and then click OK.
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You may use any combination of the following operations to build formulas
in calculated fields:
Operation

Symbol

Addition

+

Subtraction

-

Multiplication

* OR ( )

Division

/

The sum of a set of values.

SUM (Field 1, Field 2, Field 3)

The average of a set of values.

AVERAGE (Field 1, Field 2, Field 3)

Example: If you are tracking the number of children’s books purchased by a
grant, as well as the total number of books purchased, you can use a
calculated field to display the percentage of books purchased that are for
children. The formula for this calculated field may be written as:

100*({Requests_Ext.Books for Children}/{Requests_Ext.Number of
Books})

Removing a Calculated Field From a Form
You can remove calculated fields from a form at any time. When you
remove a calculated field from a form, the element’s configuration options
are deleted permanently. If you wish to re-add a deleted calculated field, you
will need to configure it from scratch. Before removing a calculated field, it
is a good idea to make a record of its calculation Formula.
To remove a calculated field from a form:
1 Highlight the calculated field and click Remove. You are prompted to
confirm your intentions.
2 Click Yes to remove the calculated field.
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Adding and Configuring Web Clippings
Important: If you have more than one data entry form for a record type,

make sure the correct form is displayed when you are adding or editing Web
clippings.
To add a Web clipping to a data entry form:
1 Click Add, and then select Web Clipping from the drop-down list. The
Edit Web Clipping form opens:

2 Configure the following settings on the Edit Web Clipping form:
Option

Description

Name

The name of the Web clipping. This name will be used as the
label for a new Web clipping, but the label may be changed
later.

URL

The address of the Web page that should load on the data
entry form. For information on adding context-sensitive
parameters to a URL, refer to “URL Parameters” on page 260.

Left

The distance of the Web clipping from the left border of this
custom tab, in twips.

Top

The distance of the Web clipping from the top border of this
custom tab, in twips.

Height

The height of the Web clipping, in twips.

Width

The width of the Web clipping, in twips.
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Option

Description

Maximize

Selecting this option will resize the Web clipping
automatically to occupy the entire data entry form.
Note: If this option is selected, any other elements on the
data entry form will be blocked by the Web clipping.

Label Visible

Indicates whether or not the label for the Web clipping
should be visible on the data entry form. Default is on
(selected).

Scrollbars

Indicates whether scrollbars should be available for scrolling
through the page in the Web clipping. You may choose to
include a horizontal or vertical scrollbar, both, or none.

3 Click OK to add the Web clipping to the data entry form.
4 To move the Web clipping on the data entry form, click on it and drag it
to the appropriate location.

URL Parameters
To include context-sensitive parameters in a URL, you will need to add
GIFTS data fields, either manually or through a Field Insert tool. Both
standard and custom GIFTS data fields may be used as merge fields in a Web
clipping URL.
Data fields should be entered using the following format:
{Category.Field Name}
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To use the Field Insert tool for selecting one or more merge fields:
1 Click the Insert Field Reference button located below the URL field on the
Edit Web Clipping form. The Add Data Field form opens:

You can select the GIFTS category
(database table) that contains the field(s)
you want to insert here.

2 Use the “Select available fields from” drop-down list to select the GIFTS
category (table) that contains the field(s) you want to insert.
Note: In addition to GIFTS categories, this list contains an

“Authentication” option that allows you to add user data from the
Available Fields list in the next step.
3 Scroll through the Available Fields list and select the field(s) you want to
insert, and then click OK.

Removing a Web Clipping From a Form
You can remove Web clipping from a form at any time. When you remove a
Web clipping from a form, its configuration options are deleted
permanently. If you wish to re-add a deleted Web clipping, you will need to
configure it from scratch. Before removing a Web clipping, it is a good idea
to make a record of its URL.
To remove a Web clipping from a form:
1 Highlight the Web clipping and click Remove. You are prompted to
confirm your intentions.
2 Click Yes to remove the Web clipping.

Adding and Configuring Web Clippings
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Importing
Matching GIFTS
Summary Data
This chapter describes how to import summary data about a
matching gifts program into GIFTS.
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About the Matching GIFTS Summary
Import
The standard GIFTS product includes a Matching GIFTS Summary import
that you can use to populate your database with a summary of matching
gifts data tracked elsewhere, such as in an out-sourced matching gifts
program. It is suitable for files created by matching gift “outsourcing”
agencies.
You can import data from any system provided that you can export it to
ASCII data files that conform to the import file format requirements of
GIFTS.
During the import, GIFTS creates grants that represent the total giving for
each recipient Organization within each imported period. The Payment
Amount of each grant is the sum total of the matches for a recipient
Organization within a single giving period. No information about individual
matches or donors is imported.
Only one Payment can be associated with each imported Request. You can
resolve the imported Payments against a single Line Item in your Budget, or
to create a separate Line Item for each Payment.
Additional imports are supported by the optional GIFTS Import Module, as
described in “About the GIFTS Import Module” on page 265.

How the Import Works
You can use the Import facility of the Administrator Module to verify the
formatting of your ASCII import files and run the import. The import
process creates GIFTS database records for your data, and produces a report
listing all of the records imported. In addition, GIFTS maintains a history of
all imports, allowing you to re-run reports for individual imports as often as
necessary.
In addition, you can “re-do” an import in order to correct errors in the
imported data; re-doing an import deletes all imported records for that
batch and then imports the new data. Be sure to read “Canceling and Redoing Imports” on page 283 for important information about this feature.
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About the GIFTS Import Module
In addition to the Matching GIFTS Summary import included with the
standard GIFTS product, clients who purchase the optional GIFTS Import
Module can run the imports described in this section.
Note: MicroEdge provides conversion utilities for many grants management

products, including MicroEdge’s DOS-based products, Riverside Grants,
Riverside Matching GIFTS, Grants Manager, and Award. For information
about these utilities, please contact MicroEdge Technical Support.
Import Type

Description

Detailed Request
Import

This comprehensive import includes detailed information about
Approved, Pending, and Declined Requests. This import can
include multiple Payments and/or Grant Requirements for each
imported Request, and either background information concerning
Organizations or long descriptions of Requests. This import cannot
be used to update records.

Grant Summary
Import

This import can be used to import summary information about
Requests, including information about the grantee Organization
and a single Payment.
This import may also be used to convert data from other systems if
you only need summary information for historical purposes. This
import cannot be used to update records.

Detailed Matching
GIFTS Import

This import is used to populate your database, most often with
data from a legacy system. It includes individual gift records,
including the Donor and recipient Organization information. In
addition, this type of import groups Approved gifts into batches
and creates the appropriate grant and payment information. This
import cannot be used to update records.

Organization
Import

This import can be used to import detailed information about
grantee Organizations. Each imported record can include the
Organization’s Vendor Number, name, address, Primary Contact,
Tax ID, telephone number and extension, fax number, e-mail
address, and Web site address.

Contact Import

This import is used to import detailed information about Contacts,
and can import multiple Affiliations between a Contact and grant
requests and organizations.

About the GIFTS Import Module
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Import Type

Description

User Import

This import is used to import detailed information about users.
Each imported record can include the user’s name, group, email
address, and title.
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Considerations for Summary Imports
For each recipient Organization within each imported period, the import
creates an Approved Request with a single Payment that represents the total
giving to the Organization within the period.
During the import, you specify the Request Type (such as ‘Matching
GIFTS’) and Status (such as ‘Closed’) of the imported grants. The Request
Type and Status are applied to every grant in the import file.
The following topics apply to the Requests and Payments that are created as
a result of your import.
❖

Default Coding Sheet classifications

❖

Default Grant Requirements

❖

Budget resolution

❖

Setting up your Fiscal Year

Default Coding Sheet Classifications
In the Coding Sheet Preferences of the GIFTS Administrator Module, you
can supply default Coding Sheet codes prior to importing records. Each
Request that does not contain a classification is given the default
classification, if any, that you specified.
Note: The Coding Sheet defaults do not overwrite the classifications in the

import file; defaults are only used to populate blank fields.
If any of the categories on your Request Coding Sheets require a classification
(as described in “Requiring a Category” on page 72), you can supply a
default to ensure that every imported Request has a classification entered for
the required categories.
You can set these defaults during the import, as described in “Step 3:
Specifying Coding Sheet Defaults” on page 281.

Considerations for Summary Imports
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Default Grant Requirements
If your Administrator has established Default Grant Requirements for the
Request Type of the imported grants, you can determine whether these
Requirements are attached to imported Requests. Since you are importing
matches that have already been processed, most grantmakers choose not to
apply Requirements to their summary imports.
This option is displayed during the import, as described in “Step 2: Setting
the Import Options” on page 279.

Budget Resolution
If you are using the GIFTS Budget Module, you can resolve the total amount
of the imported Payments from a single Reserve Fund in your Budget. To
complete the import, you must have a Reserve Fund with a sufficient
available balance, or have a Budget that allows Reserve Funds to carry a
negative balance.
During the import, you can choose to create a Line Item for each imported
Payment, or to create a single Line Item for the entire import.
To resolve your imported Payments, enter “MG” as the Import Type in field
2 of the import file’s header record (described on page 285). To exclude
Budget resolution from the import process, enter “MG_NO_BUDGET” as
the Import Type.

Setting up Your Fiscal Year
To ensure that your financial data is imported properly, be sure to set up
your Fiscal Year in the GIFTS Preferences before you import data. For more
information, see “Fiscal Year” on page 65.

Organization Type Classifications
This import cannot be used to update existing records. If a record in the
import file matches a record in GIFTS, the record in the import file is not
imported.
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However, please note the following exception: if the Organization Type
classifications for an existing Organization are blank and a matching
Organization is found in the import file, the Organization Type 1 and
Organization Type 2 fields in the GIFTS Organization record are updated
with the Type information from the import file.

Considerations for Summary Imports
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Avoiding the Creation of Duplicate
Records
When you import data, it is important to avoid the duplication of records so
that your reports and queries are accurate. For example, you wouldn’t want
a report that divides an Organization’s grants between two “duplicate”
Organization records that in fact represent the same Organization.
During imports, GIFTS searches your database for matching records before
importing new data. If a duplicate record is found, the new data is not
imported in order to avoid the creation of duplicate records.
The process that the system uses to search for duplicate records is known as
matching logic.

Organization Matching Logic
The import feature allows you to determine how aggressive you wish the
system to be when searching for duplicate records. The logic used by each of
the two available methods, and considerations for choosing a method, are
detailed in this section.
The option that you choose may affect how you create your import file and
the nature of the information that you include within it. We recommend
that you take the time to understand this process before you create your
import files.
There are two available matching logic options:
❖

Match on Vendor Number only

❖

Match on Vendor Number, Tax ID, Name, State and Postal Code

Match on Vendor Number Only
With this approach, the system searches for matches between the Vendor
Numbers in your database and the Vendor Numbers specified in the import
file. (In GIFTS, Vendor Numbers are displayed on the Background tab of
each Organization record.)
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If no exact match is found for a Vendor Number in the import file, a new
Organization record is created and populated with the Organization
information from the import file. If an exact match is found, no record is
created and—if you are importing a Request—the Request is associated with
the existing Organization.
If your Organization Vendor Numbers were not entered
consistently, duplicate Organizations record may be created where no
exact match is found between the import file and your database.

Considerations

After the import, use the Administrator Module to merge
duplicate Organizations. Note that this can be time consuming if many
duplicates were created by the import.

Solution

Match on Vendor No., Tax ID, Name, State, and
Postal Code
With this approach, GIFTS makes several attempts to match the
Organization in the import file with an Organization your GIFTS database.
Note that the State field may also be known as County or Province, as
determined by the Regional Settings control panel of Microsoft®
Windows®.
The matching logic is as follows:
1 Does the Vendor Number in the import file match a Vendor Number in
GIFTS?
❖

If the answer is no, proceed to Question #2.

❖

If the Vendor Number matches a single Organization record in
GIFTS, there is a match and the Organization information is not
imported.

❖

If the Vendor Number matches more than one Organization in
GIFTS, GIFTS checks the Tax ID, if available, and name/state/postal
codes to ensure that the correct match is made. A match is made only
if the Vendor Number, Tax ID (if available), and the name/state/
postal code match. Otherwise, proceed to Question #2.

2 Does the Tax ID in the import file match a Tax ID in the database?

Avoiding the Creation of Duplicate Records
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❖

If the answer is no, proceed to Question #3.

❖

If the answer is yes and the Organization in GIFTS does not have a
Vendor Number, proceed to Question #3.

❖

If the answer is yes and the Organization in GIFTS has a Vendor
Number (that did not match in question #1) there is no match and
the Organization data is imported into a new Organization record.

3 Do the name, state, and postal code for the Organization match the name,
state, and postal code of an existing Organization? (Note that all three fields
must match).
❖

If the answer is no, there is no match and the Organization data is
imported into a new Organization record.

❖

If the answer is yes and the Organization in GIFTS has a Vendor
Number (that did not match in question #1) there is no match and
the Organization data is imported into a new Organization record.

❖

If the answer is yes and the Organization in GIFTS does not have a
Vendor Number, there is a match and the Organization information
is not imported.

If an incorrect match is found, imported Requests can be
associated with the wrong Organization and the correct Organization
record would not be created.

Considerations

Manually enter the Organizations that were not imported. Then,
identify each Request that was associated with the wrong Organization
and transfer them to the correct Organization.

Solution

Contact Matching Logic
The following logic is used to match Contacts included in Matching GIFTS
Summary imports. The summary import can include a Primary Contact
with each imported Request.
And
both records contain a Primary Contact, GIFTS attempts to match the
Contact information based on the last name, first name, and middle name of
the Contact.

If an imported Organization matches an existing GIFTS Organization
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❖

If there is an exact match, the Contact is not imported and the Request is
assigned to the Primary Contact from the existing Organization.

❖

If there is not an exact match, a new Contact record is created for the
Contact from the import file. A Request Primary Contact Affiliation
identified this person as the Primary Contact for the Request (the Primary
Contact for the existing Organization is not altered).
Important: Multiple records for the same Contact may be created by this

process, since GIFTS does not attempt to match the Primary Contact of a
Request with the Primary Contact of another Request for that same
Organization.
Its
Primary Contact is imported as both the Organization Primary Contact and
the Request Primary Contact; there is no attempt to search for an existing
Contact.

If the imported Organization does not match an existing Organization

Code Matching Logic
Throughout GIFTS, there are coded fields that restrict data entry to a predefined list of codes. For example, the Request Coding Sheet includes a
‘Program Area’ category that can have classifications like ‘Arts & Culture’ or
‘Education.’
These codes are stored in Code Tables. For example, the Program Area codes
are stored in the Program Area Code Table.
When you import data from an external source, GIFTS attempts to match
the imported codes with your codes in GIFTS. However, the coding
structure in the system used to create the data may not be the same as the
coding structure you have established in GIFTS.
If this is the case, your import may create ‘duplicate’ codes that have the
same meaning. Duplicate codes can make it extremely difficult to obtain
accurate reports and queries from your database.
Note: If duplicate codes are created by an import, you can use the Code

Replace feature described in “Replacing Codes” on page 37 to replace the
duplicates with the correct code.
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During any import that includes codes, GIFTS attempts to match the
imported codes with the codes in your GIFTS database to prevent the
creation of duplicates. The import attempts to match first by the Code
value, and then by the Description. These searches are not case-sensitive, so
“arts” would be recognized as being equal to “ARTS.”
Important: If a GIFTS Code Table contains duplicate Descriptions, the

Description in the import file is matched against the first matching
Description found in the table. Therefore, Descriptions may be mapped
incorrectly more than one codes in a table has the same Description.
If no exact match is found, a new code is created in GIFTS. A match is made
when an imported Description and/or Code value matches an existing code
in GIFTS that:
❖

Is in the same Code Table

❖

If the code is in a multi-level table, is at the same level and has the same
parent code.

The following examples illustrate how this matching logic works. (Note that
no changes are ever made to the existing classifications in GIFTS.)
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Import Code

GIFTS Code

Match?

GIFTS Code After Import

1

Code:HOSP
Desc: Hospitals

Code:HOSP
Desc: Hospitals

✔

Code:HOSP
Desc: Hospitals

2

Code:HOS
Desc: Hospital

Code:HOSP
Desc: Hospitals

✔

Both codes reside in GIFTS
as “duplicates”

3

Code:[blank]
Desc: Hospital

Code:[blank]
Desc: Hospitals

4

Code:HOSP
Desc: Hospitals

Code:HOS
Desc: Hospitals

✔

Code:HOS
Desc: Hospitals

5

Code:CIV
Desc: Civic

Code:CIV
Desc: Civil Liberties

✔

Code:CIV
Desc: Civil Liberties

6

Code:[blank]
Desc: Hospitals

Code:HOSP
Desc: Hospitals

✔

Code:HOSP
Desc: Hospitals

7

Code:HOSP
Desc: Hospitals

Code:[blank]
Desc: Hospitals

✔

Code:[blank]
Desc: Hospitals

Both codes reside in GIFTS
as “duplicates”
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Important: The fifth match is improper, since the Descriptions ‘Civic’ and

‘Civil Liberties’ are intended to represent different information. If you are
importing Code values, be sure that they are unique.
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Running the Import
Before You Begin: Make sure that your import file conforms to the layout
described in “Matching GIFTS Summary Import File Layout” on page 284.
Set up your Fiscal Year in GIFTS to ensure that your financial data is
imported properly.
Important: If you use Branch Security, records imported into the database

are automatically stamped with the Branch ID of the user currently logged into the
system. Make sure that a user with the appropriate branch is logged in before
importing records from a specific branch.
Import processing involves the following steps:
1 Verifying the Import File
2 Setting the Import Options
3 Specifying Coding Sheet Defaults
4 Running the Import

!

Caution: Before you verify or import data, ensure that you have a valid

backup of your database. In case of problems, it may become necessary to
restore the backup in order to continue working.

Step 1: Verifying the Import File
The verification phase of the import is used to identify the import type and
to ensure that there are no errors in the import file.
When you verify an import file, the system obtains the import type from its
header record, confirms that each record contains the appropriate number
of fields, and confirms that the summary information specified in the header
reflects the actual contents of the records in the file’s data area.
Important: If you are importing a large amount of data, the verification
process can take some time. Be aware that if you exit the Import utility
before you have completed the import, you will have to re-verify the import
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file when you re-enter the Import utility. Ensure that you have a valid
backup of your existing database before you verify your import data.
To verify an import file:
1 Start the GIFTS Administrator Module.
2 From the Administrator menu, choose File ➤ Import. The import facility
is displayed.

3 Enter the path to your import file. You can click Browse to search for it,
if necessary.
4 Click the appropriate Organization Match Logic option. (For a description
of these options, please refer to “Organization Matching Logic” on
page 270.)
5 Click Verify to scan the import file. A log of any errors or anomalies that
are encountered in the file is displayed.

Running the Import

❖

If the verification is successful, the log closes and a summary of the
import data is displayed.

❖

If there are informational messages or verification process is not
successful, a detailed description of the errors found is displayed in
the log. Click Print or Save As to keep the log for your records, and
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refer to “Verification Messages and Errors” on page 278 for more
information.
Note that the Import button, Options tab, and Coding Sheet tab are not
available until the verification process has been run successfully.

Verification Messages and Errors
The importing of data is a complex process that can result in permanent
changes to your system, so the verification process notifies you not only of
errors within your import file, but also of any notable changes that your
import will cause.
For instance, some imports can affect the Codes and Descriptions in your
Code Tables, as described in “Code Matching Logic” on page 273. The
Process Log details such changes so that you can ensure that the effect of
your import reflects your intentions.
If the system encounters an error in the number of fields or other
formatting errors in the file, a message similar to the following is displayed.

Other errors related to the import as a whole are displayed in the lower right
portion of the Import window. For example:
The total number
of records specified in the header of the import file does not match the total
number of records present in the file.

[#] Request record(s) were expected, but [#] were found

The
total grant amount specified in the header of the import file does match the
sum total grant amount of the records present in the file.

Total grant amount of [$] was expected, but a total of [$] was found

If you encounter an error message, you must correct the error before you
can proceed with the import. Messages in the Process Log, on the other
hand, can be either informational or in regard to an error. If you require
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assistance in identifying and/or resolving problems related to your import,
please contact MicroEdge Technical Support.

Step 2: Setting the Import Options
To access the options for enhancing your imported data, click the Options
tab . These options apply to your imported Requests and their Payments.

Option

Description

Request Setting of
Import

Choose the Type and Status that you want to apply to the
imported Requests. Note that since all records are imported with
a Disposition of Approved, only the Status codes for Approved
Requests are available.

Incoming Requests
Payment Method

For each grant imported, GIFTS creates a single Payment for the
full grant amount. If you choose the Mark Payment as ‘Paid’
option, the system marks this Payment as Paid with the Payment
Date as same day as the grant date.
If you choose Mark Payment as ‘Scheduled’, GIFTS marks each
Payment as Scheduled on the data you provide in the Schedule
Date field. (You can change the Schedule Date later by editing the
Payment records.) Please note that you must provide a Payment
Schedule Date if you choose this option.

Running the Import
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Option

Description

Scheduled
Requirements

If you select this option, the Default Grant Requirements for your
system are created for each of the imported Requests. For more
information about Default Grant Requirements, please refer to
“Default Grant Requirements” on page 268.

Budget Posting
Method

If you are using the optional Budget Module, you can choose to
create a single Line Item within the Budget for the entire import
or a separate Line Item for each imported Payment that requires
resolution. As you run the import, you will be prompted to
choose a Reserve Fund from which to resolve your Line Item(s).
This option is not displayed for Matching GIFTS Summary imports
that do not include Budget information (as specified by field 2 of
the import file’s header).

Payment
Information

You may choose a Payment Type for each Payment created by the
import. Note that the code provided here does not override data
in the import file where this information has been provided. Only
records where the Payment Type has been left blank are supplied
with this code.

User Information

The staff person chosen here is assigned as the Staff person
responsible for each Request created by the import.

Budget Year

If you use the optional Budget Module and have chosen a
Request Type that is included in your Budget, the Budget Year
specified here is the Budget Year from which funds must be
allocated in order to complete the import.
Example:If the import contains a total of $500,000 in
grants, you is asked to resolve $500,000 against a Reserve
Fund in the Budget Year specified here.
This option is not displayed for Matching GIFTS Summary imports
that do not include Budget information (as specified by field 2 of
the import file’s header).

When the options on this tab are complete, you can continue to step 3 to
define a default Coding Sheet for the imported Requests.
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Step 3: Specifying Coding Sheet Defaults
You can supply default codes for the imported Request records. Each
Request that does not contain a classification (such as ‘Arts & Culture’) in a
given category (such as ‘Program Area’) is given the default classification, if
any, that you specified for that category.

Categories that have
been marked as
required in the Coding
Sheet Preferences are
displayed in bold type.

The defaults you enter
(displayed in blue) are
applied only to Requests
that have not been
classified. The defaults
never overwrite the
imported data.

Note: The classifications specified here never override the data supplied by

the import file; they are used only to populate categories that are blank.
Note that the following considerations may apply to your import:
❖

Your Administrator may have set up default classifications that are applied
when a user enters a new Request into the system. They do not affect
imported records.

❖

Your Administrator may have marked categories as being ‘required,’
meaning that users who enter Requests must enter a classification into the
required categories before the Request can be Approved.

❖

If any of your imported grants do not have a classification in a required
category, a message is generated. (Note, however, that you are still
permitted to import the Request.)
You may wish to enter defaults to ensure that your imported Requests
are not missing required classifications; as an alternative, you can search
for missing classifications after the import.

Running the Import
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To enter a default classification, highlight a category and click Add. To
remove a default, highlight it and click Remove.

Step 4: Running the Import
Once you have chosen import Options and the (optional) default Coding
Sheet classifications, you are ready to proceed with your import.

!

Caution: Before you verify or import data, ensure that you have a valid

backup of your database. In case of problems, it may become necessary to
restore the backup in order to continue working.
To run the import:
1 Click the Import button. A message reminds you to ensure that you have
a valid backup of your database.
2 If your backup is available, click Yes to proceed. A message describes the
Organization Matching Logic option you chose, and asks you to confirm
that it reflects your intentions.
3 Click Yes to proceed.
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❖

If there are required fields on your system’s Request Coding Sheets
and you did not supply a default value in the import’s default Coding
Sheet, a message informs you of this fact. You can click Yes to
proceed.

❖

If you need to resolve the imported Payments against your Budget,
you are prompted to confirm that you wish to proceed with the
Budget resolution. Click Yes to resolve the Payments. For information
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about resolving Payments against the Budget, please refer to the
Budget Module User’s Guide.
4 After you respond to the necessary prompts and start the import, a log is
displayed to track the progress of the import. If any errors are listed, you
can click Print or Save As when the import is complete to keep the contents
of the log for reference.
5 When the import is complete, an import report is displayed in the Crystal
Reports viewer. From the viewer, you can print or export the report.

Canceling and Re-doing Imports
While an import is in progress, you can cancel it by clicking the Cancel
button. Be aware that the cancel button does not delete any of the records
that were imported before you clicked Cancel; it simply stops the import.
After canceling an import, you can run the import later or make changes to
the import file and then re-do the import. The Import utility automatically
determines that you are re-doing the import only if the time-and-date stamp
in the header record of the master file matches the stamp from your earlier
attempt.

!

Caution: An import is considered a redo only if the system can detect that

you are importing the same data again. If you re-import your data, be sure
that the time-and-date stamp in the header of the master file has not
changed. If this information is different, GIFTS cannot recognize that you
are re-importing the same data and may create duplicate data.
When you re-do an import, the system deletes any Requests, Payments, or
Requirements that were imported the first time the import was run. Note
that the system does not delete the Organizations, Contacts, or
classifications that were created. Then, the data in the import file is
imported in the same manner as a first-time import.

Running the Import
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Matching GIFTS Summary Import File
Layout
The import file must contain a header record followed by one data record
for each Request that is to be created by the import. This import allows only
one payment per Request, and all Requests are imported with a Disposition
of Approved.
Note: If the Organization contained in the import file is found to exist in the
GIFTS database, and Organization Type 1/Type 2 classifications have been
supplied in the import file but are blank in GIFTS, the import process updates
the existing Organization with the classifications contained in the import file.

General File Requirements
GIFTS import files are flat ASCII text files that consist of lines, or rows, of
text that are delimited into fields by tab characters. Each line ends with a
carriage return and represents an individual record.
The first record in the Matching GIFTS Summary import file is the header,
which contains summary information about the import. The header record
is followed by one or more body records, which contain the data you are
importing.
Example: Each grant you import has its own line in the Matching GIFTS

Summary import file. Within a line, each data element—such as the recipient
Organization name, the Grant Amount, and so forth—is contained in a field.
GIFTS import files must conform to the following specifications:
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❖

The fields within each record (row) are tab delimited (ASCII character 9).
No other tab characters may appear anywhere in the data that are not field
delimiters (including description fields).

❖

A carriage return (ASCII character 13) and a line-feed (ASCII character 10)
terminate each record.

❖

There is one record per line.

❖

All blank fields are treated as null entries.

Matching GIFTS Summary Import File Layout
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❖

All times in 24-hour format. (example 20:00)

❖

Numeric fields (with the exception of currency fields) contain:
❖

no decimal point (for example, 1234)

❖

no commas

❖

leading negative signs, when appropriate

The imports are sensitive to the Regional Settings Control Panel of
Microsoft® Windows®. The format of the currency and date fields in your
import files must comply to the format specified by your workstation’s
Regional Settings.
The following requirements, and the sample values shown in this
publication, are for the “English (United States)” setting only. If you are
using a different Regional Setting, these requirements may be different.
❖

❖

Currency fields contain:
❖

a decimal point (for example, 30000.00)

❖

no commas

❖

leading negative signs, when appropriate

All dates in mm/dd/yyyy format.

Header Record Layout

1

2

Field Name

Description

GIFTS Format / Example

Req

File Type

Indicates to GIFTS that this is a valid
import file.

Fixed characters (literal)

✔

Indicates the type of import file to
GIFTS. Without this information, GIFTS
cannot determine what type of import
to run.

Fixed characters (literal)

Import Type

Matching GIFTS Summary Import File Layout

GFW_IMPORT_FILE

✔

For Matching Gift Summary
imports: MG
For Matching Gift Summary
imports with no Budget
resolution: MG_NO_BUDGET
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Field Name

Description

GIFTS Format / Example

Req

3

Import Description

A description of the import. This field
is the default Project Title applied to
imported Requests that do not have a
Project Title.

Limited to 255 characters.

✔

4

Import Date

The date that this import was created.

Date format:

✔

Example: 08/25/2000
5

Import Time

The time that this import was created

Time format.

✔

Example: 20:00
6

Total Batch
Amount

Total grant amount to be imported.

Limited to 12 digits, including
decimal.

✔

Example: 300000.00
7

Total Number of
Requests

Total number of grants to be
imported.

Limited to 5 digits.

✔

Example: 1290

Data Area Layout
Each line of the data area should include the import data for a single grant, which consists of
the following fields.

1

2

Field Name

Description

GIFTS Format / Example

Req

Vendor Number

The unique ID of the Organization
from the source database used to
populate the Vendor Number field in
GIFTS; it is matched against existing
Organizations as described in
“Organization Matching Logic” on
page 270.

Limited to 20 characters.

✔

The Name of the Organization

Limited to 255 characters.

Organization Name

Example: UWNY
This field should be unique
to the Organization.

✔

Example: United Way of New
York
3

Organization A.K.A.

An alternate name that may be used to
refer to this Organization.

If not supplied, Organization
A.K.A. name is the same as
Organization name.
Limited to 255 characters.
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Field Name

Description

GIFTS Format / Example

4

Organization
Address 1

The first line of the address of the
Organization.

Limited to 100 characters.

5

Organization
Address 2

The second line of the address of the
Organization.

Limited to 100 characters.

6

Organization City

The city where the Organization is
located.

Limited to 50 characters.

7

Organization State

The state, province, or county where
the Organization is located.

Limited to 20 characters.

8

Organization Postal
Code

The postal (or Zip) code where the
Organization is located.

Limited to 20 characters.

9

Organization
Country

The country where the Organization is
located.

Limited to 50 characters.

10

Contact Last Name

The last name of the Organization’s
Primary Contact. (Contact information
is optional.)

Limited to 50 characters.

12
Req

()

The last name of Contact is
required if any of the other
Contact Name fields are
populated.

11

Contact First Name

The Contact’s First Name.

Limited to 50 characters.

12

Contact Middle
Name

The middle name of the Contact.

Limited to 50 characters.

13

Organization
Contact Title

The title of the Contact at their Primary
Organization.

Limited to 100 characters.

14

Contact Salutation

The salutation of the Contact.

Limited to 100 characters.
Example: Dear Sir

15

16

Organization Type
1

Organization Type
2

Description for the Organization Type
(Level 1) classification. If this
Description is not found in GIFTS, it is
created during the import.

Limited to 75 characters.

Description for the Organization Type
(Level 2) classification. If this
Description is not found in GIFTS, it is
created during the import.

Limited to 75 characters.

Matching GIFTS Summary Import File Layout
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Example: Government
Required if Organization Type
2 is defined

Example: Social Services
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Field Name

Description

GIFTS Format / Example

Organization
Matching GIFTS
Classification

Description of the Organization
Matching GIFTS classification. If this
Description is not found in GIFTS, it is
created during the import.

For users of the optional
Matching GIFTS Module only.
Otherwise, leave this field
empty.

Req

Limited to 75 characters.
Example: Education
18

Tax ID

The Tax ID number of the
Organization. This field is matched
against existing Organizations as
described in “Organization Matching
Logic” on page 270.

Limited to 20 characters.

19

Grant or Match
Date

The award date or match date of the
grant.

Date format:

Grant or Match
Amount

The total Grant Amount of the grant.

Limited to 12 digits including
decimal.

20

✔

Example: 08/25/2000

✔

Example: 300.00
21

22

Payment Date

Hold GIFTS

The actual date the grant was paid.

Date format:

If this date is not supplied, the Grant
Date is used as the payment date.

Example: 08/25/2000

Whether to allow matches for the
Organization.

For users of the optional
Matching GIFTS Module only.
Otherwise, leave this field
empty.
Yes or No (default is No).
Example: No

23

Hold GIFTS
Remarks

Reason the Organization cannot
receive gifts.

For users of the optional
Matching GIFTS Module only.
Otherwise, leave this field
empty.
Limited to 255 characters.
Example: Tax status not
verified
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Field Name

Description

GIFTS Format / Example

Project Title

The Project Title for the grant. If this
field is blank, the text in the Import
Description field of the header record is
used as the Project Title.

Limited to 255 characters.

12
Req

Example: Library Restoration
Project

25

Filler

For future use.

Leave this field blank.

26

Program Area

Description for the Program Area
(Level 1) classification. If this
Description is not found in GIFTS, it is
created during the import.

Limited to 75 characters.
Example: Education

The data you enter here overrides the
default Coding Sheet, if any, that you
created for the import process.
27

Fund Donor

Description for the Fund Donor
classification. If this Description is not
found in GIFTS, it is created during the
import.

Limited to 75 characters.
Example: Corporation

The data you enter here overrides the
default Coding Sheet, if any, that you
created for the import process.
28

Payment Type

Description for the Payment Type
classification for the imported
Request’s Payment. If this Description
is not found in GIFTS, it is created
during the import.

Limited to 75 characters.
Example: Charitable

The data you enter here overrides the
default Payment Type, if any, that you
created for the import process.

Matching GIFTS Summary Import File Layout
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Setting Up
Branch Security
This chapter describes how to use Branch Security to control access
to your grant making data among your branch offices.

In This Chapter
About Branch Security ..........................................................292
Activating Branch Security....................................................296
Managing Branch Codes .......................................................297
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About Branch Security
Branch Security allows grant makers with multiple sites or branches and
separate giving programs to capture all of their information in a centralized
database, while preventing users from different branches from editing (or
viewing, if desired) each other’s data.
Users cannot edit or view data from other branches unless they are granted
permission to do so. In addition, reports and searches generated by users
only include data for the branches for which they have “view” rights.
To accomplish this, you can enter a code for each of your branches into the
system. Each Request and its associated Activities, Payments, and
Requirements are then stamped with a primary branch. Each group’s access
can then be restricted to records based on the branch stamp.
Note: Access to Organization and Contact information is not limited to

specific branches. This ensures that you maintain an accurate giving history
for Organizations that are funded by more than one branch. In addition,
users of Employee GIFTS can use the “Donors are branch specific” option in
the GIFTS Security Preferences to determine whether Donor information is
shared between branches.
When you set up Branch Security for your system, you must choose one of
two ways Requests (and thus their associated Activities, Payments, and
Requirements) can be stamped with a primary branch:
❖

A Request can be automatically stamped with the primary branch of the
user creating it.

❖

The Request form can include a branch field, allowing a user to enter a
specific branch him- or herself.

The option you should choose depends upon which of two different data
entry models you use. Descriptions of each model follow. You should be able
to recognize the model your organization already follows and choose the
correct Branch Security option.
Note: This Branch Security option is set up in your Security Preferences. For
details on setting this option, please see “Branch Security” on page 58.
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Decentralized Data Entry Model
This data entry model is appropriate if members of your various branches or
divisions are receiving, entering, approving, and declining grant requests
more or less independently of one another. Your GIFTS data is all stored
centrally; however, each branch or division works almost exclusively with
Requests and grants that they have entered themselves. For most
foundations and corporations with branches or divisions, this is the model
they follow.
In this case, you would want Requests to be automatically stamped with the
primary branch of the user creating it. This allows members of each branch
to enter Requests (and other associated GIFTS records) that can only be
viewed or edited by other members of the same branch.
In addition, you can:
❖

Create a “Headquarters” division that has access to all data. (Regardless of
the Branch Security settings, the Admin user group has unrestricted access
to all data.)

❖

Transfer Requests and Budget items from one branch to another.

Centralized Data Entry Model
The centralized data entry model is most likely to be used by organizations
that manage several different, wholly separate funds. In this case, a single
user group is accepting, entering, approving, and declining grant requests
for many various funds. However, you also want representatives of the
individual funds to be able to view the data for their fund (and their fund
only).
In this case, you want your users to enter the branch for each Request
manually. This allows a single user to enter Requests for several different
branches.
For example, you could create a “Headquarters” branch that has access to all
data; these users would be employees of your central organization. Then
you can create a branch for each fund you represent, adding the fund’s
representatives to the appropriate branch.

About Branch Security
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Note: If you use the Branch Security option recommended for this model,

you can create user groups with no branch identification. You may want the
user group performing data entry for different funds to have no branch ID.
For details, see “Assigning Groups to Branches” on page 299.
Your users will then assign a branch to each Request they enter, depending
on the specific fund being appealed to. Representatives for each fund (or
“branch”) will then be able to access data concerning their fund only.
When following this model, the branch must be entered in each new
Request manually. You will not be allowed to save a new Request without
entering a branch. The branch field appears in the Request form only if you
choose this Branch Security option.
The branch field may also appear on the following forms when using this
Branch Security option:
❖

Activity forms — If you are creating a new Activity not associated with a
Request, the branch field will appear.
If you create and Activity associated with a Request, the Activity is
automatically stamped with the Request’s branch, and the branch field is
unavailable.

❖

Quick Entry forms — Quick Entry forms for historical grants, immediate
declinations, and pending Requests all require an entry for branch. You
will not be allowed to save a Request entered using Quick Entry without
adding a branch.

❖

Budget item form — In the optional Budget Module, the branch field will
appear on new budget items, if those items are for first-level categories.
In this case, the branch field will be filled in with the branch of the user
entering the budget item. (The user can change the branch at any point.)
If the user has no branch assigned, the field in the budget item defaults to
<None>. Please note, however, that no budget item can be saved
without being assigned to a branch. The user will have to choose a
branch in this case.

❖

294

Employee GIFTS forms — If you use the optional Employee GIFTS Module,
and choose this Branch Security option, you will also see the branch field
on new Volunteer and Matching Gift forms. You will not be allowed to
save a new Gift without adding a branch.
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If you chose in your GIFTS Security Preferences to make Donors branchspecific, the branch field will also be seen on the Donor form for new
Donors you are adding. You will not be able to save a new Donor if you
do not enter a branch.
Note: In all the forms listed above, the Branch field defaults to the branch of

the user adding the record. (The user can change the branch at any point.) If
the user is assigned to no branch at all, <None> will first appear in the field.
You must enter a valid branch before you can save these records.

About Branch Security
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Activating Branch Security
To activate Branch Security, go into your Security Preferences and set up
your Branch Security options. Please see “Branch Security” on page 58.
Note: Currently, the ability to use Branch Security, and the number of
branches you can code, is determined by your GIFTS configuration file, and
is priced separately. If you wish to take advantage of this feature, please
contact MicroEdge.

If your organization has been using GIFTS without Branch Security and you
wish to begin using this feature, you must assign your existing records to
their appropriate branches. Records that are not assigned to a branch are
available only to users in the Admin group.
If you wish to implement Branch Security in the middle of a Budget Year
and have your budget information accurately reflect your branch structure,
you can do one of the following:
❖

Use the “Ignore Branch Security in the Budget Module” option described
in “Security Preferences” on page 57 for the remainder of the Fiscal Year.
At the beginning of your next Budget Year, turn this option off and create
your new Budget Year with Branch Security on.

❖

Use the Transfer Branch option to transfer all your budget items to the
appropriate branches. For details, please see the Budget Module User’s Guide.

❖

Wait until the beginning of the next Budget Year before activating Branch
Security.

For more information about using the Budget Module with Branch Security,
please refer to the Budget Module User’s Guide.

Tip: When Branch Security is active, the primary branch of the user logged
in is displayed at the bottom right corner of the screen. Note that if the user
belongs to the Admin group, no branch name is displayed.
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Managing Branch Codes
The first step in using Branch Security is to create codes for each branch in
your organization. These codes are used to assign your user groups to their
appropriate branches.
To create a new branch code:
1 Select Setup ➤ Code Tables from the Administrator menu. The Table
Maintenance window opens.
2 Click the System tab. The System Code Tables are displayed.
3 Highlight the Branch/Division table and click Edit Codes. The Code
Maintenance window opens.
4 Add your branch codes to the table. (For more information about adding
codes, please refer to “Adding Codes” on page 24.)

Deactivating Branch Codes
If you are no longer using a branch code, you may wish to deactivate the
code so that no new data may be associated with it. A deactivated branch
may not be assigned as the primary branch for any group. It may, however,
be assigned as the secondary branch for a group with view-only permission.

!

Caution: If there are any user groups assigned to a branch with “view only”

permissions (a secondary branch assignment), the branch’s code may be
deactivated but the branch will still be recognized by the system as an active
branch for configuration purposes.
To deactivate a branch code:
1 Select Setup ➤ Code Tables from the Administrator menu. The Table
Maintenance window opens.
2 Click the System tab. The System Code Tables are displayed.

Managing Branch Codes
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3 Highlight the Branch/Division table and click Edit Codes. The Code
Maintenance window opens.
4 Highlight the branch you want to deactivate, and then select Action ➤
Deactivate.
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Assigning Groups to Branches
GIFTS determines the branch of the user logged in to the system by the
group to which they belong. Each group is assigned a primary branch—
users assigned to that group have full access (according to that group’s
permissions) to records assigned to that branch.
Each user group can also access records assigned to other branches, or
secondary branches, based on the following permissions:
Permission

Description

None

Users in this group cannot view or modify Requests, Activities,
Payments, and Requirements for this secondary branch. This is
the default permission.

View Only

Users in this group can view—but not modify—Requests,
Activities, Payments, and Requirements for this secondary
branch.

Use Group’s

Users in this group can view and modify information for this
secondary branch just as they do for their primary branch.

Important: Each Request and its associated Activities, Payments, and

Requirements are stamped with a primary branch. If you have users who are
responsible for data entry for more than one branch, you must do one of the
following:
❖

If you are using the Branch Security option for the decentralized data entry
model (where a Request is automatically stamped with the branch of the
user who entered it), these users should have a separate login at each
branch.

❖

If all your data entry is being performed by one user group (although for
many branches), you should consider using the Branch Security option for
the centralized data entry model (where users manually enter the branch
for new records).
When using this Branch Security option, you can have user groups with
no assigned branch. Users in a user group with no branch ID can access
data from all branches (according to that group’s permissions). This

Assigning Groups to Branches
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would only be recommended for your central group, not for
representatives of the various funds you manage.
To assign an existing group to a branch or branches:
1 From the Administrator menu, choose Access ➤ Groups. The Groups
window opens.
2 Highlight the group you want to work with, and click Edit. The Editing
an Existing Group window opens:

‘<None>’ is an available option only if
you are using the Branch Security
option for centralized data entry
(where users manually enter the
branch for new records).
If you are using the other Branch
Security option, all user groups must
have an assigned branch. (The Admin
group, although it too must have a
branch assigned, can access data from
any branch.)

3 In the Branch/Division Assignment section of this window, select the
Primary Branch/Division for the group.
Note: You cannot assign a user group to an inactive branch. If a branch

code is inactive, it will not be listed in the Primary Branch/Division dropdown menu.
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4 Indicate the group’s permissions for each secondary branch (the default is
None).

Note: The Use Group’s permission option is not listed for inactive

branches.
5 Click Save and Close.

Assigning Groups to Branches
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Branch/Division Correspondence
Templates
If you have Branch Security enabled, when creating a new Correspondence
Template, there will be a Branch/Division field that will allow you to assign
the template to a specific branch/division. The default is All.

To assign a Branch/Division to an
existing template, in the Administrator
module go to Setup ➤ Correspondence
to open the Template Library window.
Right-click on a template listed and select
Edit Branch/Division.
When sending new
correspondence, GIFTS users will
be able to filter the available
templates list by Branch/Division
on the What tab.
Note: This feature is purely for

filtering purposes. It does not
prevent the GIFTS user from
changing the Branch and seeing
templates they may not have access
to.
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Branch-Specific G/L Account Codes
For corporations with multiple divisions, each branch typically has a set of
account numbers that are valid for that branch only. In order to streamline
data entry, you can stamp G/L Account codes with a particular branch
name; during data entry, users from each branch see only the G/L Account
codes designated for their branch.

Activating Branch-Specific G/L Account Codes
1 From the Administrator menu, choose Setup ➤ Preferences. The
Preferences window opens.
2 In the Security section of the Preferences tab, select the “Make
G/L Account Codes Branch Sensitive” checkbox.
3 Click OK to save your changes.
Note: Existing G/L Account codes are not assigned to a branch when this

feature is activated. If existing codes require a branch assignment, you can
enter a new code with the appropriate branch stamp and then replace the
old code with the new, branch-specific code. For more information about
replacing codes, please refer to “Replacing Codes” on page 37.

Adding, Modifying, and Deleting G/L Account
Codes
When the system is set up to use branch-specific G/L Account codes, each
new G/L Account code should be assigned to a branch. G/L Account codes
are automatically stamped with the primary branch of the user that entered
the code; users belonging to the Admin group can enter G/L Account codes
for any branch.
To create a branch-specific G/L Account code:
1 From the Administrator menu, select Setup ➤ Code Tables. The Table
Maintenance Window opens.
2 Click the System tab. The system Code Tables are displayed.

Branch-Specific G/L Account Codes
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3 Highlight the General Ledger Account table and click Edit Codes.
❖

If you are logged in as a member of the Admin group, you are
prompted to choose the branch for which you are editing Account
Codes.

Choose a branch and click OK. GIFTS displays the G/L Account
codes associated with that branch. Any new codes you enter are
automatically associated with that branch.
❖

If you are not logged in as a member of the Admin group, GIFTS
displays the G/L Account codes associated with your primary
branch. Any new codes you enter are automatically associated with
that branch.

4 To add a G/L Account code, click New. The Inserting a New Table Item
window opens:

5 Enter the Code and Description information as necessary.
6 Click OK. The account number is added.
7 Use the Code Maintenance options to add, modify, and delete codes as
necessary. When your changes are complete, click OK to save your
changes.
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This chapter describes how to create review rules for application
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About Review Rules
This feature allows administrators to create a set of rules that, when
triggered, automatically assigns reviewers to Requests (or proposals) after
applications have gone through the consideration process in IGAM. A
Request will have a Review created for it when the content of the Request
matches the criteria specified in the rule. This can include a particular
Disposition, Request Type, and Status, but might also contain a
Recommended Amount (over or under a certain amount), and Coding, such
as Program Area, Fund, or Geographic Region. This Review is assigned to
the Request in GIFTS.
Important: This feature only applies to clients who have the Reviewers

module and IGAM.
For information about assigning rules to IGAM forms, see “Assigning
Review Rules to Forms” in the Reviewers Module and ReviewerCONNECT
User’s Guide.
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Creating Review Rules
You can create one or more review rules that automatically assign reviewers
to Requests when the content of a Request matches the criteria specified in
the rule. After creating rules, you can assign them to specific IGAM forms.
To create review rules:
1 From the Administrator module, go to Setup ➤ Reviewers ➤ Review
Assignment Rules. The Rules for Review Assignment window displays.

Creating Review Rules
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2 Click New to create a new rule, or highlight a previously created rule and
click Edit. The Review Rule window displays.

3 Enter the Rule Name and select the Review Stage.
Note: A Review Stage is a set of preferences defining the properties of
Review records created under it. External reviewers are generally
consultants or field experts outside your organization. Internal reviewers
are individuals with GIFTS user accounts; these are generally members of
your staff. For more information, please see “About Review Stages” in the
GIFTSConnections Reviewers Module and ReviewerCONNECT User’s Guide.

4 Click Define Criteria to bring up the Requests Quick Find and specify the
criteria which a request must meet for the rule to be applied to it. The
Select Search button allows you to select a Saved Search. The selected
criteria displays in the window.

Tip: Click Clear Criteria to clear the selected criteria.
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5 Click Next. The content in the screen below depends on the Review Stage
picked in the previous screen (internal or external reviewers).

You can choose the following:
❖

Status contains all available external statuses for an external stage. For
internal stages, this field only displays Pending.
Note: Review Status codes are managed in the Administrator
module. For more information, please see “Editing Reviewers
Module Code Tables” in the GIFTSConnections Reviewers Module and
ReviewerCONNECT User’s Guide.
❖The Specify Due Date and Specify Acceptance Due Date sections
allow you to set the due date of the review and the date the reviewer
must respond by (for external reviews only), respectively.

6 Click Next. One of three screens appear, depending on whether you are
creating an internal or external reviewer rule:

Creating Review Rules
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❖

External Review Stage

To add reviewers to an External Review Stage:
i. Click Add Reviewers. The Contact Search form displays. After
searching for and locating one or more reviewers, highlight them and
click Select.
ii. Click Finish.
Note: To remove a reviewer, highlight the reviewer and either click
Remove Selected or press the [DELETE] key, and then Yes. You can
select multiple reviewers using the [CTRL] or [SHIFT] keys.
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❖

Internal Review Stage (‘Notify in sequence’ not applied)

Note: ‘Notify in sequence’ is designated when the review stage is
created, and when not applied, indicates that proposals are sent to all
reviewers immediately when a new Review is created and assigned to
them. For more information, see “Designating Review Types and
Stages” in the GIFTSConnections Reviews Module and
ReviewersCONNECT User’s Guide.
To add reviewers to an Internal Review Stage (‘Notify in Sequence’
not applied):
i. Click Add/Remove Reviewers. The User Select form displays.
ii. Click the checkbox next to one or more reviewers, and then click
OK. You can also use the Name contains field to filter by name. To
use this field, enter the text string you wish to filter by, and then click
Apply Filter. When a reviewer is added, he or she is displayed at the
bottom of the Required section.
iii. Click Finish.
Note: To remove a reviewer, click Add/Remove Reviewers, uncheck
the reviewer(s) you do not want, and then click OK.
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❖

Internal Review Stage (‘Notify in sequence’ applied)

Note: ‘Notify in sequence’ is designated when the review stage is
created, and indicates that proposals are sent to reviewers one at a
time in a pre-set order.
To add reviewers to an Internal Review Stage (‘Notify in Sequence’
applied):
i. Click Add/Remove Reviewers. The User Select form displays.
ii. Click the checkbox next to one or more reviewers, and then click
OK. You can also use the Name contains field to filter by name. To
use this field, enter the text string you wish to filter by, and then click
Apply Filter. When a reviewer is added, he or she displays at the
bottom of the Required section.
Note: If you do not want the reviewer to be on the required list, you
can highlight the reviewer, and click Remove. The reviewer moves to
the Not Required list. Likewise, you can add a reviewer from the Not
Required list by highlighting the reviewer and clicking Add. Since the
reviewers in the Required list review in sequence from top to bottom,
you can rearrange the order of this list by highlighting a reviewer and
clicking Move Up or Move Down.
iii. Click Finish.
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Note: To remove a reviewer, click Add/Remove Reviewers, uncheck
the reviewer(s) you do not want, and then click OK.
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clear a user’s password 108
client/server
global login options 110
login integration 113
security issues 113
Code Tables
adding 19
default 17
deleting 21
modifying 19
number of levels 20
number of selections 20
system 16
codes
adding 24
branch 297
deleting 27
editing 25
marking as inactive 26
printing a list of 41
reactivating 26
replacing 33
report 41
sorting 40
transferring 28
Coding Sheets
adding categories to 70
arranging categories 71
default codes 73
definition 14
preferences 70
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setting for users 107, 108
Payments
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permission sets
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staff override 94
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pre-defined tables, list of 28
preferences
about 44
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arranging 251
defined 251
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Q
quid pro quo
setup 76
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regional settings 45
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setup 83
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removing from library 201
setting path to 82
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Request preferences 63
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default Type 64
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Requirement Type codes, creating 119
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research settings 54
reset a user’s password 108
Revenue Canada 54
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S
salutation preferences 75
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searching
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name search method 55
secondary branch
assigning 299

recalculating data 213
receipts for Payments 64
reference number, grant 63
refreshing preferences 44
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security
detailed 89
extended password security 59
of client/server logins 113
password 103
security preferences 57
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spreadsheet setup 82
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staff override permission 94
subtitles, of reports 48
synchronizing correspondence
templates 164
system
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system-wide preferences 80
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template path 82
templates
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copying 182
creating 168
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letter 163
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write-up 163
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