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C H A P T E R  1

INTRODUCTION

With the purchase of the Blackbaud FundWare™ General Ledger module, you will be 
working with a tool that has been designed specifically for those not-for-profit 
organizations that comprise the public sector. General Ledger serves as the heart of your 
financial application and the central point for all monetary reporting. It delivers the 
enhanced inquiry flexibility, powerful analysis tools, and robust reporting options you 
need to adhere to strict budgeting and financial performance tracking.
With General Ledger (and Project/Grant, if you have purchased this additional module), 
you can:

• Maintain unlimited open periods and fiscal years. 
• Reopen your past fiscal year for audit adjustments, and close again as often as 

necessary. 
• Post budget transactions in detail, providing online budget control, detail 

historical reporting, and full budget audit trail. 
• Post units as well as dollar amounts—ideal for posting statistical outcome-based 

information or hours worked, as automatically provided by the FundWare 
Payroll application. 

• Group accounts in unlimited user-defined categories using FundWare’s 
powerful “attributes,” create reports, grouping financial information by 
program-type, fund-type, grant/contract-type, and manager. 

• Cross fiscal years for detailed financial reporting and online inquiry, with access 
to historical transactions for an unlimited period of time. 

This chapter includes some overview of key concepts in General Ledger and P/G. For 
more detailed discussion of these topics, see Chapter 2—Understanding GL–P/G on 
page 31.
Blackbaud, Inc. 1
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WHAT IS GENERAL LEDGER?
General Ledger is the main module in the FundWare system. It allows you to define 
your account structure, manage your transactions, and produce current financial reports 
for staff, board, funding agency, and accountant review. When you work with General 
Ledger accounts, you must follow the rules of double-sided or four-sided accounting. 
Project/Grant is a additional module that combines with GL to allow you to track your 
accounts using “single-sided” entries (i.e., your debits do not need to equal your credits). 
If you have other FundWare modules, you will post your transaction information (i.e., 
revenue and expense) to General Ledger–Project/Grant.
You can post transactions to General Ledger–Project/Grant from:

• The General Ledger Journal Entry window (i.e., manual journal entries);
• Imported, saved, and memorized entries;
• Reversed journal entries; or
• Other modules (e.g., Account Payable, Accounts Receivable, Payroll). (Posting 

to GL from another module is an automatic process.)
The features offered by General Ledger–Project/Grant are all designed to help you 
maintain your accounts efficiently, yet with great flexibility so that you can meet all 
your accounting and reporting needs. Some of these features include:

• Multiple reporting systems (known as ID types in FundWare),
• Account structures, and
• Ledgers (including journals and transactions).

MULTIPLE REPORTING SYSTEMS

FundWare “ID types” allow you to maintain multiple reporting systems simultaneously. 
One of the many ways that this is useful is if your organization must maintain records 
based on one year-end date, but report some transactions on a different year-end date. 

• For example, your organization (a city) must report to the state using a year-end 
of June 30, while your federal grants require a year-end of September 30. 

In this example, you must maintain two separate sets of records. However, since 
FundWare allows you to maintain more than one reporting system, you can enter a 
single transaction and post that information to more than one ID type (or set of records). 
For more information, see ID Types on page 32.
What Is General Ledger? 
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FISCAL PERIODS

The General Ledger–Project/Grant module allows you to set up fiscal periods for each 
ID type and to determine the number of years to maintain/keep on-line. The system uses 
“date tables” to store period lengths and period-ending dates. For more information, see 
Maintaining Your Date Tables on page 116.

ACCOUNT STRUCTURE

General Ledger allows you to use either: 
• A 10- or 15-digit system-defined account number structure.
• A user-defined (i.e., customized to meet the needs of your organization) account 

number structure using up to 18 digits. 
Project/Grant allows you to use either: 

• A 9-digit system-defined account number structure.
• A user-defined (i.e., customized to meet the needs of your organization) account 

number structure using up to 18 digits. 
The account number structure is divided into dimensions that define funds, departments, 
sub-departments, or any other cost center. You can use account number dimensions to 
sort, sum, and select information to include on your reports. For more information, see 
Account Number Structure on page 34.

LEDGERS

FundWare stores your information in five areas (“ledgers”) of the database:
• The general, or actual, ledger maintains account balances for standard reporting. 
• The budget type 1 and 2 ledgers record and report budget information. We offer 

you two budget options to allow you to track an original budget and any 
changes to that budget (e.g., GASB reporting).

• The encumbrance ledger allows accounts to be encumbered for purchases 
ordered but not yet received. 

• The commitment ledger allows accounts to be allocated for purchases not yet 
encumbered.
Blackbaud, Inc. 3
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JOURNALS

Journals are the books of original entry for all transactions that post to one of the 
ledgers. You define how the journal will collect information and what information it will 
accept. For example, you can define certain journals to accept transaction information 
from another FundWare module. In Sample Division 95, we have defined three 
Accounts Payable journals to post encumbrances, expenditures, and cash disbursements. 
These journals do not allow a direct, manual journal entry to General Ledger. Reserving 
specific journals for these transactions preserves the integrity between the two modules 
(i.e., between Accounts Payable and General Ledger).

TRANSACTIONS

When you enter your transactions, you may be asked to select a journal. If you are not, 
then you have predefined your FundWare system to post to specific journals. For 
example, in Sample Division 95, we define that purchase order information is posted in 
detail to the ENCUM journal.
Each time you post a transaction through a journal to a ledger (via General Ledger), the 
system assigns a unique transaction number and creates trace report. When printed, 
these trace reports provide a “paper audit trail” of all entries made into the system. 
To maintain your system, we strongly recommend that you:

• Print trace reports daily to obtain a hard copy of your transactions. 
• Carefully review your trace reports.
• Store all trace reports in numerical order (e.g., in a three-ring binder) at a safe 

location or store the electronic files in an off-site archive.

ADJUSTMENTS AND OTHER SPECIAL ENTRIES

In addition to regular journal entries, General Ledger allows you to enter year-end 
adjustments and reclassifications, budgets and budget adjustments, commitments and 
commitment adjustments, encumbrances and encumbrance adjustments, and reversing 
journal entries.

REPORTS

General Ledger offers you a wide variety of reports, including a balance sheet, trial 
balance, ledger, journals, and transaction reports. The following types of revenue and 
expense reports are also available:

• Period to Date vs. Year to Date
What Is General Ledger? 
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• This Year vs. Last Year
• Revenue and Expense with Variance
• Revenue and Expense with Annual Budget
• Revenue and Expense with Encumbrances

The columns are already formatted for these “standard” reports. You select the accounts 
to include in the rows of the report and how to organize and report the information for 
those accounts.
Because of the variety of reports available in the General Ledger, you can quickly and 
easily prepare information for staff, board, funding agency, and accountant review.

ADVANCED FINANCIAL REPORTING

The Advanced Financial Reporting feature (purchased separately) allows you to:
• Define the contents of your report columns. 
• Compare any combination of periods or years.

For more information on this feature, please contact your FundWare sales representative 
(800-551-4458).

COMPARING GENERAL LEDGER AND PROJECT/GRANT
General Ledger and Project/Grant have one major difference: Project/Grant allows you 
to enter single-sided transactions (i.e., debits do not have to equal credits). However, 
transactions in GL must follow two-sided or four-sided accounting rules for journal 
entries, i.e., debits must equal credits. When you define an ID type through the Setup 
task (see Defining Your ID Types (System Parameter Wizard) on page 69), you specify 
to which module the ID type is assigned (i.e., which accounting rules it will follow).

If you define an ID type by FASB (Financial Accounting Standards Board) or 
GASB (Government Accounting Standards Board) rules, debits must equal 
credits by fund.

Additional differences between the modules include:
• P/G can have all account types, but usually just has revenue and expenditure.

— GL has asset, liability, net asset (fund balance), revenue, and expenditure 
(expense accounts).

• P/G does not have balance sheet type reports.
Blackbaud, Inc. 5
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— GL has balance sheet type reports.
• The P/G year-end process allows you to select whether or not to roll balances 

forward by ID types. For example, if you are tracking multi-year projects, you 
roll all revenues and expenditures into the beginning period for the next year so 
you can have “inception-to-date” reporting as well as “year-to-date” reporting. 
If you are tracking information about meetings, you probably would choose not 
to roll this information forward, as each year stands alone.
— The GL year-end process closes revenue and expenditure accounts into net 

assets accounts before rolling balance sheet account balances into the new 
year.

• You can report information in user-defined balance sheet reports for P/G ID 
types for a fiscal period different than the year ending date defined in your date 
table (i.e., cross-fiscal year reporting) by adding the .YEAR END data item to 
descriptive accounts.
— This feature is not available for GL ID types.

Unless noted otherwise, information in this guide applies to both General Ledger and 
Project/Grant.

THE GENERAL LEDGER HOMEPAGE
The General Ledger HomePage helps you keep an eye on your account balances and 
upcoming activities and provides you with direct access to produce your reports. The 
following areas make up the GL HomePage:

• Account dashboard, 
• Activity Reminders area, and
• Reports area.

ACCOUNT DASHBOARD

Context-sensitive topic: HomePage—Dashboard
The Account Dashboard provides you with a snapshot of up to 10 active GL–P/G 
accounts/account masks. You can view the balance for these accounts, as well as the 
account description and any Budget Control messages. 
The General Ledger HomePage 
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The number of accounts included in the dashboard can impact the time that it 
takes to display the HomePage. For example, if you enter the mask A01 XX-
XX XXXX for Division 95, you would get 141 accounts. This large a number 
of accounts could slow the loading process. Especially if this is just 1 of 10 
account masks.

Use the following instructions to define the accounts displayed in the dashboard.
1.  Open the GL–P/G HomePage to view the account dashboard (Figure 1.1). 

Figure 1.1—Account Dashboard—Not Accounts Defined
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2. Click the ellipsis to display the Account Selector (Figure 1.2). 

Figure 1.2—Account Selector

3. Enter an account mask to define the accounts to be included in the dashboard. 
The remaining elements of the account selector (e.g., description, attributes) are 
not available for filtering these accounts. Only active accounts are included in 
the dashboard.
The General Ledger HomePage 
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4. Click Search for the Account Selector to find the active accounts matching the 
settings (Figure 1.3). 

Figure 1.3—Accounts Filtered by the Account Selector

All the accounts displayed in the results area of the Account Selector 
will be displayed in the dashboard. You cannot use your mouse to select 
only certain accounts for the dashboard.
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5. Click OK. The Account Selector closes and the selected accounts display in the 
dashboard (Figure 1.4). 

Figure 1.4—Accounts Displayed in the Dashboard

6. If you entered an account mas, you can click the plus/minus sign to expand or 
collapse the accounts (Figure 1.5). 

Figure 1.5—Account Mask Collapsed in the Dashboard

UPDATING THE DASHBOARD

Context-sensitive topic: Updating the Dashboard
Each time you open the HomePage, the information is updated. For example, if you add 
accounts to your Chart of Accounts, and these accounts meet an account mask in the 
dashboard, the new accounts will now display in the dashboard.
The General Ledger HomePage 
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PRINTING THE ACCOUNT INFORMATION FROM THE DASHBOARD

Context-sensitive topic: Printing the Account Information From the Dashboard
Click Print or right-click and select Print from the shortcut menu. The preview window 
displays from which you can print your account dashboard information.

REMOVING ACCOUNTS FROM THE DASHBOARD

Context-sensitive topic: Removing Accounts From the Dashboard
To remove an account or account mask from the dashboard, select the dashboard row 
and click Clear Row (or right-click and select Clear Row from the shortcut menu). The 
contents of the row are removed from the dashboard. 

ACTIVITY REMINDERS

The Activity Reminders area allows you to enter a text note and a due date (optional) for 
module tasks (Figure 1.6). When you open the HomePage, any tasks with due dates 
earlier than the system date of your computer (i.e., “overdue”) will display as red. 

Figure 1.6—Activity Reminders Area

Use the following instructions to use the Activity Reminders area.
1.  On the General Ledger HomePage, enter up to 100 alphanumeric characters in 

the Activity field (Figure 1.7). 

Figure 1.7—Example Activity Reminder—Closing ID
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2. If this task has a due date, enter the date in the Due Date field. Click the drop-
down arrow to access the calendar. This field is optional.

If you do not have any text associated with a due date, the due date will 
not be saved when you exit the HomePage.

Your entries are saved when you close the HomePage or FundWare. You can edit the 
text or date information at any time.

PRINTING REMINDERS

Context-sensitive topic: Printing Reminders
Click Print to print the information in the Activity Reminders area. The report output 
will reflect the current sorting and displays in a preview window, from which you can 
print the information.

DELETING REMINDERS

Context-sensitive topic: Deleting Reminders
Use the following instructions to delete a reminder.

1.  Highlight the row.

2. Click Delete. The reminder is removed from your display.

REPORTS AREA

Context-sensitive topic: HomePage—Reports Area
The General Ledger HomePage 
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The same categories that you see in Report Manager for the module will also display in 
the Reports Area of the HomePage (Figure 1.8). Each category can expand and collapse 
to show or hide the reports contained within. A single click of a report title will display 
the report parameters screen. Once you enter the details of the report and click OK, your 
report is produced. 

Figure 1.8—Reports Area of the General Ledger–Project/Grant HomePage

SOME FUNDWARE BASICS
The following sections provide you information and instructions for opening and 
working in FundWare.

OPENING FUNDWARE

As you begin using FundWare, certain information is saved by the program and offered 
as a default. This has been designed to help you save time and steps, but you can change 
these defaults at any time by entering new information or selecting from the available 
options (depending on the field).

• User name—The program will enter the user name (or user number) of the last 
person to log into FundWare on that computer.
— For security reasons, your password is not automatically entered. You must 

always enter your FundWare password.
• Business date—Defaults to the current system date (according to your 

computer’s operating system).
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• Division—The program automatically selects the division you were working in 
the last time you were in FundWare. 
— If you have only one division (or have security rights to only one division) 

and do not have security rights to the System Administration area, the 
program will bypass the division selection window. 

— Or, if you only have security rights to the System Administration area, the 
program will bypass the division selection window and open directly to the 
System Administration HomePage.

• HomePage—The program automatically opens to the HomePage of the module 
in which you were working the last time you were in FundWare. 

Use the following instructions to open and log into FundWare.
1.  Double-click the FundWare icon on your desktop or select Blackbaud 

FundWare® Enterprise or Professional from your Windows Start menu. The 
Login window displays. 

Figure 1.9—FundWare Login Window

2. Enter your user name in the User Name text box. You can enter your user 
number instead of your user name, if preferred. 

The User Name field will default to the last entry on this computer and 
the system will move to the Password field.

3. Enter your password in the Password text box. Your password entries will 
display as asterisks (*) as you type to maintain the privacy of your password. 
Some FundWare Basics 
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4. Accept the default business date or enter a new date. You can manually enter the 
date (moving from day to month to year using the arrow key or mouse) or you 
can click the down-arrow to select a date from the calendar.

Figure 1.10—Selecting the Date

5. Click OK. If your User Name, Password, and Business Date are verified, the 
Select Division window displays, defaulting to the division you were working 
with the last time you were in FundWare. 

Figure 1.11—Selecting the Division

If your organization uses the password aging feature, you may receive a 
message indicating that your password will or has expired. You will be 
offered the chance to enter a new password at this time. See Changing 
Your Password During Login on page 16.

If you have only one division (or have security rights to only one 
division) and do not have security rights to System Administration, the 
program will bypass the Select Division window. Or, if you only have 
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security rights to System Administration, the program will bypass the 
division selection window and open directly to the System 
Administration HomePage.

6. If necessary, select a different division (or System Administration) from the list. 

7. Click OK. FundWare opens to the HomePage of the module that you last 
accessed.

For users upgrading from earlier versions of FundWare, please note that you can only 
have one division open at a time in each instance of FundWare (a change in 
functionality). However, you can open the program multiple times for the same or 
different divisions and/or business dates.

CHANGING YOUR PASSWORD DURING LOGIN

If your organization uses the password aging feature (defined through System 
Administration), you may receive a message indicating that your password will or has 
expired. 

Figure 1.12—Password Expiring

Use the following instructions to change the password at this time.
Some FundWare Basics 
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1.  Click Yes to the password expiration message. The Change Password window 
displays. 

Figure 1.13—Changing Your Password During Login 

2. Enter your password in the Old Password text box.

3. Enter the new password in the New Password text box.

4. Retype your password in the Confirm New Password text box.

5. Click OK. Your password is changed. The next time you log into FundWare, 
you must use the new password or you will receive an error message.

You can also change your password from within the software. See Changing Your 
Password From the Software on page 20.

OPENING FUNDWARE MULTIPLE TIMES

Each “instance” of FundWare (i.e., each time you open the program) represents a single 
division on a single business date. However, you can open as many instances of 
FundWare as necessary to meet your needs. 
When dealing with multiple instances of FundWare, keep the following rules in mind:

• Each instance of FundWare represents a single user, division, and business date, 
or represents access to the System Administration features by a single user. 

• You can open as many instances of FundWare as necessary (i.e., for different 
users, business dates, or divisions).
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• You can still change the business date for the current instance of FundWare 
without opening a new instance. See Changing the Business Date on page 19 
for more information.

OPENING ADDITIONAL INSTANCES—FROM THE DESKTOP/START MENU

If you have one or more instances of FundWare open already, you can open additional 
instances of the program from your desktop or the Windows Start menu. You will be 
asked to identify the user, password, business date, and division (the same steps as 
opening the first instance of FundWare).

OPENING ADDITIONAL INSTANCES—FROM THE PROGRAM

You can also open a new division or a new instance of the same division from within 
FundWare. Because you are opening this division from the program, the system applies 
the same user and password to the new instance and allows you to select a new division 
or business date.

If you want to open a new instance of FundWare for a new division or a new 
business date, you can open the program from the desktop or Windows Start 
menu or from the Change Business Date task. For instructions on changing the 
business date, or opening a second instance of the program with a different 
business date, see Changing the Business Date on page 19.

Use the following instructions to open a new instance of FundWare for the current user 
and business date.

1.  Select File > Open FundWare from the menu bar. The Open New Instance 
window displays, automatically selecting the division you were working with 
the last time you were in FundWare. 

Figure 1.14—Opening a New Instance of FundWare

2. If necessary, select a different division (or System Administration) from the list. 
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3. Accept the default business date or enter a new date. You can manually enter the 
date (moving from day to month to year using the arrow key or mouse) or you 
can click the down-arrow to select a date from the calendar.

4. Click OK. FundWare opens to the HomePage of the module that you last 
accessed.

CHANGING THE BUSINESS DATE

You can change the business date for your current instance of FundWare or open a new 
instance of the same division with a different business date using the Change Business 
Date task. When you choose to open a new instance of the same division, the system 
applies the same user and password to the new instance and takes you directly to the 
HomePage for the module in which you were last working in that division.

1.  Select Edit > Change Business Date from the menu bar. The Change Business 
Date window displays. 

Figure 1.15—Changing the Business Date 

1 Accept the default business date or enter a new date. You can manually enter the 
date (moving from day to month to year using the arrow key or mouse) or you can 
click the down-arrow to select a date from the calendar.

2 Select the applicable option for applying the new business date:
• Current Instance of FundWare—Changes the business date for the current 

instance of FundWare. This option does not apply any changes to other 
instances of FundWare and does not open a new instance of the program.

The “Classic” windows will not accept a changed business date. If you 
have any of the Classic screens open when you attempt to change the 
business date for the current instance of FundWare, the system will 
return a message and not allow you to proceed. Close the Classic 
windows and try again.
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• New Instance of FundWare—Opens a new instance of FundWare to the 
HomePage for the module in which you were last working, applying the 
same user, password, and division but using the new business date.

1.  Click OK. The program applies your selection.

CHANGING YOUR PASSWORD FROM THE SOFTWARE

Use the following instructions to change the password for the current user.
1.  Select Edit > Password from the menu bar. The Change Password window 

displays. 

Figure 1.16—Changing the Current User’s Password

2. Enter your password in the Old Password text box.

3. Enter the new password in the New Password text box.

4. Retype your password in the Confirm New Password text box.

5. Click OK. Your password is changed. The next time you log into FundWare, 
you must use the new password or you will receive an error message.

If your organization uses the password aging feature (defined through System 
Administration) and your password is nearing or has passed the expiration date, you can 
also change your password during the login process. See Changing Your Password 
During Login on page 16.
Some FundWare Basics 
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USING THE MENU BAR

Each module for which your organization is licensed and to which you have security 
rights displays in the menu bar. From these menu options, you can access all module-
specific tasks (e.g., General Ledger > Journal Entries > New). In addition, you will 
use the menu bar to access specific program tasks (e.g., changing the business date):

• File—Open divisions; access Print Manager, Report Manager, or Financial 
Institutions.

• Edit—Change the business date or your password.
• View—View or close Navigator bar; view full or abbreviated menu names; 

view logged in users.
• Window—See all currently open windows, switch between these windows.
• Help—Access online help for the current module and program information. 

KEYBOARD NAVIGATION

To help you navigate quickly through the program, FundWare allows you to use your 
keyboard instead of your mouse to access program tasks.

• Menu bar—You can access any task listed on the menus using a combination of 
the ALT key and a letter and the arrow keys.
— Press the ALT key.
— Press the underlined letter of the item to display the menu. The menu 

displays.
— Use the arrow key and press ENTER to select a task.

• Shortcut menus—Access any applicable shortcut menus (normally displayed 
when you right-click your mouse) from the keyboard by pressing either 
SHIFT+F10 or the Application key (offered on many newer keyboards, located 
between the WINDOWS key and the CTRL key, to the right of the spacebar).

• Shortcut keys—Shortcut keys combine the CTRL key with a letter to give you 
direct access to certain tasks. These shortcuts are listed on the menus with the 
applicable tasks. 

• Drop-down lists—You can access any drop-down list when focus is on the 
associated field by using a combination of the ALT key and the down arrow key. 
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IS YOUR MENU BAR TOO CROWDED?

If your organization is licensed for a number of FundWare modules, your menu bar may 
be too wide to use conveniently. You can change the module names that are listed in the 
menu bar to display as acronyms, which will decrease the width of the bar:

• Select View > Abbreviated Menu Names from the menu bar. To change back, 
select View > Full Menu Names from the menu bar.

HOW YOUR SECURITY RIGHTS IMPACT THE MENU BAR

Your individual security rights may impact the modules and tasks that you see on the 
menu bar. 

• If your organization is licensed for a module, but your individual security 
settings do not allow you to access any tasks in that module, the module will not 
be listed in the menu bar.

• If your security settings allow you to access some, but not all, tasks in a module, 
the restricted tasks will not be listed in the menu bar.

USING THE NAVIGATOR BAR

The Navigator bar provides you with quick, mouse-driven access to your modules, 
module tasks, and currently open windows through two areas:

• Module navigator, and
• Open windows navigator.

You can resize the Navigator bar to meet the needs of your display by using your mouse 
to click on the right frame of the bar and drag the frame to the position you want. You 
can also hide or show the Navigator bar using the options on the View menu. Select the 
option to hide or show the bar, as applicable. These settings will be retained by the 
system when you close FundWare.

MODULE NAVIGATOR

The module navigator lists the modules for which your organization is licensed (unless 
your individual security settings do not allow you to access a module). When you click a 
module (it just takes a single click), the module expands to display all of the associated 
module tasks. 
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Accessing any of the tasks within the module takes another single click on the specific 
item. Some tasks are “nested” below a title. A single click will expand the title, 
displaying the related tasks below. 

Figure 1.17—Module Navigator—Expanded Menus

If your security settings restrict your access to specific tasks, those tasks will not 
be listed in the menu bar. 
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OPEN WINDOWS NAVIGATOR

The open windows navigator lists the windows that are currently open in this instance of 
FundWare, highlighting the window currently displayed. A single click of an entry in 
the open windows navigator redisplays the window in your workspace. 

Figure 1.18—Open Windows Navigator

As with all Windows applications, the more FundWare windows that you open 
concurrently, the greater impact to your processor speed. You can use the Open 
Windows Navigator to monitor how many windows you have open at any one 
time.

HOW YOUR SECURITY RIGHTS IMPACT THE NAVIGATOR BAR

There is no security impact to the open windows navigator. If your security rights 
allowed you to open a task, then that window will display in the open windows 
navigator. However, your individual security rights may impact the modules and tasks 
that you see on the module navigator. 

• If your organization is licensed for a module, but your individual security 
settings do not allow you to access any tasks in that module, the module will not 
be listed in the module navigator.

• Any tasks within a module from which you are restricted will not be listed in the 
menu bar. 

CUSTOMIZING YOUR DISPLAY

Throughout FundWare, you will encounter forms (similar to a table or spreadsheet) that 
allow you to customize the display through the shortcut menu (accessed by right-
clicking your mouse) or through direct manipulation with your mouse. Most of these 
settings are retained with your user name. Therefore, the forms display according to 
your settings wherever you log in to FundWare. (In other words, the program 
remembers how the form displayed when you closed FundWare. This is how it will 
display the next time you open the program.)
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Not all forms provide these options. If you attempt one of the customization 
options described here and are unsuccessful, it is likely that the option is not 
offered on that form.

HIDING AND DISPLAYING COLUMNS

To add or remove a column from a form, hover your mouse over the pane and right-
click. A shortcut menu displays, which allows you to hide or display columns from the 
form. 

Figure 1.19—Example Shortcut Menu for the GL New Journal Entry Form

The columns currently displayed in the form are indicated with a check mark. Select a 
column from the shortcut menu to add or remove that column to the detail pane.

If you have disabled fields through the module setup (e.g., the Accounts 
Payable parameter or stage settings), the associated column will not be listed on 
the shortcut menu.

RE-ORDERING THE COLUMNS

To re-order the columns in a form, “drag and drop” the column by clicking the column 
heading and moving the column to the desired position (holding the mouse button 
down).

In this example, the Account column is disabled 
because this column must always display. 

The remaining columns are currently displayed in the 
New Journal Entry form.
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RESIZING THE COLUMNS

To resize a column, hover your mouse over the column border until the icon changes. 
Figure 1.20—Mouse Icon

Click your mouse button and drag the column border until it is the desired width.

SORTING THE ENTRIES IN A FORM

To resort the entries in a form, click the heading of the column on which you want the 
sort based. To reverse the sort order, click the column heading again. 

Figure 1.21—Sorting the Detail Pane

Sort order is not retained when you close FundWare.

HELP

If you encounter questions or problems while you are working in the program, you can 
access the online help from the Help menu (on the menu bar) or by clicking F1 to access 
the online help for the current module.

Original display.

Entries resorted 
based on Obligation 
number.

Entry order reversed.
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You can also access PDF files (portable document format) of the guides from your 
server:

• FundWare\Data\User Documentation
You must have Adobe Acrobat Reader installed to view the files. This program is 
available from the FundWare CD or as a free download from www.adobe.com.

TRAINING AND CONSULTING SERVICES

Blackbaud, Inc. offers a number of options to help you improve your use of FundWare.
• Regional classes—Training classes held several times per month in various 

cities across the nation. These one- to five-day classes provide a hands-on 
learning environment and low student-to-instructor ratio.

• eClasses—Interactive training classes offered over the Internet provide you and 
your staff the opportunity to receive training from FundWare experts without 
leaving your desk.

• Onsite custom training sessions and consulting—Our training/consulting group 
offers you onsite services, including:
— Training your staff using your data.
— Installing/upgrading and configuring the software to meet the specific needs 

of your organization.
For more information about any of our training or consulting services, please explore 
our Web site (http://www.blackbaud.com) or contact our Client Sales department (800-
551-4458).

USING THIS DOCUMENT

This manual is organized to reflect the most common uses of the module. It provides 
you with overview information of FundWare, followed by specific features and 
functions of the module.
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CONVENTIONS

Use Table 1.1 as a reference for conventions used in this document. 

GETTING SUPPORT

The following table provides a quick reference for getting the support you need for 
FundWare modules.

Table 1.1—Icon Conventions
Indicator Description

A caution or warning that must be heeded. Information contained in a warning should be care
reviewed to avoid adverse affect on software operation.
An example, used to clarify an issue.

ENTER Keyboard directions are indicated in small capital letters (e.g., Press ENTER).
demo user Specific text entries are indicated with italics (e.g., Type demo user for User Name).
Click OK An item on the screen that requires user interface is indicated in bold.

Table 1.2—Getting Support
Department Contact Description

Business 
Office

800-551-4458 Obtain general information or contact a sta
member.

Technical 
Support

800-227-7575
e-mail: FWSupport@blackbaud.com

Get help resolving technical issues with the
product. Please have the following informa
ready when you call:
• Blackbaud Site ID
• FundWare version number
• Error message details

Knowledgebase
www.blackbaud.com

A searchable database where you can typ
your questions and get a list of possible 
answers.
• Requires your license number and Black

Site ID.
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Training 800-551-4458
Ask for the Client Sales department.

www.blackbaud.com

Contact us for more information on our tra
options:
• Regionals—Classes from 1 to 5 days in 

length; held in cities around the country.
• eClasses—Two- to three-hour classes of

over the Internet.
• Onsite custom training and consulting—

consulting staff can implement FundWar
and/or train your employees using your 
organization’s data.

Product 
Management

www.blackbaud.com Contact our Product Management departm
with any suggestions for improving FundW

All other 
information

www.blackbaud.com Links are available for all other FundWare 
information including replacement software
user guides and software updates.

Blackbaud, Inc.
6430 S. Fiddler’s Green Circle, Suite 200
Greenwood Village, CO 80111
800-551-4458
303-756-3030

Table 1.2—Getting Support (Continued)
Department Contact Description
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 Some FundWare Basics 



C H A P T E R  2

UNDERSTANDING GL–P/G

FundWare account numbers are a little like magic—there’s more there than meets the 
eye! Your account number includes not just the numbers that you see, but additional 
associated information (e.g., ID types, dimensions, attributes, data items, aliases) that 
allows you to group your data in almost limitless ways. How you define your accounts 
will lead to how robustly you can report on your financial information.
But before you can begin defining your accounts, you need to understand what options 
FundWare offers and plan how you will make use of these options. Because the planning 
step is key:

• Understand what your options are, including:
— Divisions,
— ID types, 
— Account structures, 
— Dimensions, 
— Attributes, 
— Data items, and 
— Aliases.

• Carefully plan your chart of accounts and how you will use all of your options.
• Apply your use of the options consistently.

Then you will experience the full power and flexibility of FundWare General Ledger.

DIVISIONS
Divisions are the highest level of separation in the program and are equal to a company 
or entity. Within FundWare, you cannot create individual reports for multiple divisions, 
so these entities must have separate reporting needs. For example, a municipality might 
have a division for its library and another division for its fire department. A non-profit 
organization might have only one division to track all their accounts.
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Divisions are the first thing you define when you configure FundWare for your 
organization. Instructions for creating and maintaining your divisions can be found in 
the Blackbaud FundWare System Administration Guide.

ID TYPES
After your division, the ID type is the highest level of categorization in your chart of 
accounts. The ID type is a single-letter code that identifies a specific group of accounts 
for the purposes of tracking and reporting. 

In Sample Division 95, ID type A maintains the core set of accounts for the 
organization. The division also includes ID types F, M, and S (Project/Grant ID 
types) to maintain separate sets of federal and state grant accounts. 

ID types are the first thing you should define within each division when you set up your 
General Ledger. The following rules apply to your ID types:

• Each ID type can have its own account structure. 
• When you are creating your journal entries, you can post a single transaction to 

multiple accounts in different ID types (e.g., to track revenue and expense in 
both a GL ID type and P/G ID type). However, you cannot create a report that 
includes more than one ID type.

• If you have Project/Grant, your ID types will determine the accounting rules 
that the program will follow (i.e., an ID type will follow the rules for either GL 
or P/G, not both). 

• The ID type precedes the account number (e.g., A01 02-00 6110) and is often 
the first element you select when working with account numbers.

• Use cannot use “X” for an ID type because X is used as a “wild card” in 
FundWare (see Using Masks on page 68). 
ID Types 
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Because you specify your account structure when you define the ID type, using different 
ID types allows you to track your account information in a variety of ways. For 
example, Sample Division 95 has one ID type defined for General Ledger and three ID 
types defined for Project/Grant. Each ID type represents a different group of accounts. 
Table 2.1 defines the ID types and shows an example account for Salary and Wages. 

Note that all the ID types include a 4-digit Object dimension. Let’s look at the 
dimension names for ID types A and F (Table 2.2 and Table 2.3). 

This makes the Object dimension a “shared” dimension, allowing you to post a single 
transaction to both ID types A and F. (In FundWare, we call this “twinning.” For more 
information, see Twin Dimensions on page 45.) Now, let’s say you need to record 
income for a grant in the Grant Income account in ID type A. Because this revenue is 
from a federal source, you must also record the income in the Federal Grant Income 
account in ID type F. Therefore, you add two accounts with the same number in the 
shared dimension:

Table 2.1—Example Salary and Wage Accounts in Division 95 GL and P/G ID Types

ID Type Use Example Account

General Ledger ID Types

A The primary ID type; represents all General Ledger accounts A01 02-00 6110

Project/Grant ID Types

F Federal grant accounts F100-01 6110

M Meeting accounts M300-01 6110

S State grant accounts S200-01 6110

Table 2.2—Account Structure for ID Type A

XX
Dimension 1

XX
Dimension 2

XX
Dimension 3

XXXX
Dimension 4

Fund Department Sub-Department Object

Table 2.3—Account Structure for ID Type F

XX
Dimension 1

XXX
Dimension 2

XXXX
Dimension 3

Project Grant Object
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• A01 00-00 4145, Federal Grant Income
• F100-01 4145, Federal Grant Income

When you enter a transaction to one account, you can require that the transaction also 
post to the second account.
Instructions for adding your ID types can be found in Defining Your ID Types (System 
Parameter Wizard) on page 69.

ACCOUNT NUMBER STRUCTURE
An account number structure, unique to each ID type, divides the number into groups, 
called dimensions. Each dimension represents a specific characteristic (e.g., fund, 
object). You can also define separator characters, such as a hyphen (“-”) or slash (“/”), 
between dimensions. For example, account 0101006110 becomes more readable when 
displayed as 01 01-00 6110. Table 2.4 explains this structure. 

Table 2.4—Example Account Structure

Fund Department Sub-Department Object

01 01 - 00 6110
Account Number Structure 
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By using these categories and the masking option to filter your accounts (see Using 
Masks on page 68), you can create meaningful reports for your organization. Table 2.5 
displays examples and results of dimension-based reporting. 

You can use any of the following options to create your account number structure, 
depending on the needs of your organization:

• The GL system-defined 10-digit account number structure (XX XX-XX 
XXXX),

• The GL system-defined 15-digit account number structure (XXX XX-XX 
XXXXX.XXX), 

• The P/G system defined 9-digit account number structure (XXX-XX XXXX), 
or

• A custom-defined account number structure, where you define the number and 
length of dimensions, as well as any separator characters.

See the following sections for more information on system-defined and user-defined 
account number structures. 
You will define the dimensions for your account structure when you add your ID types. 
See Defining Your ID Types (System Parameter Wizard) on page 69 for more 
information.

Table 2.5—Dimension-Based Reporting Examples and Results

Example 1 Example 2 Example 3

• Fund 01/all departments
• Object 6110
• Mask: 01 XX-XX 6110
The following is a sampling of 
the accounts that could result 
from this mask:

• Fund 01/department 01
• All sub-departments/all 

objects
• Mask: 01 01-XX XXXX
The following is a sampling of 
the accounts that could result 
from this mask:

• All funds/department 02
• All sub-departments/all 

objects
• Mask: XX 02-XX XXXX
The following is a sampling of 
the accounts that could result 
from this mask:

• 01 01-00 6110 • 01 01-00 2020 • 01 02-20 6110

• 01 01-01 6110 • 01 01-00 4280 • 02 02-20 5500

• 01 02-00 6110 • 01 01-01 6110 • 02 02-60 6110

• 01 04-00 6110 • 01 01-02 7330 • 04 02-80 4420
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SYSTEM-DEFINED ACCOUNT NUMBER STRUCTURES

The 10-digit account number structure for General Ledger has four dimensions (XX 
XX-XX XXXX). You supply descriptions that suit your organization (Table 2.6). 

The 15-digit account number structure for General Ledger has five dimensions (XXX 
XX-XX XXXXX.XXX). You supply descriptions that suit your organization (Table 
2.7). 

The 9-digit account number structure for Project/Grant has three dimensions (XXX-XX 
XXXX). Again, you can supply descriptions that suit your organization (Table 2.8). 

USER-DEFINED ACCOUNT NUMBER STRUCTURE

A user-defined account number gives you the greatest flexibility in designing your 
account number structure. The FundWare System Parameter Wizard will take you 
through each step of the process. However, you should plan your account number 
structure before beginning the wizard.
Consider the following guidelines when setting up your own account number structure:

• Dimensions can be separated with spaces, or with a character, such as hyphen 
(“-”) or a slash (“/”). 

Table 2.6—Example 10-Digit Account Structure (GL)

XX
Dimension 1

XX-
Dimension 2

XX
Dimension 3

XXXX
Dimension 4

Fund Department Sub-Department Object

Table 2.7—Example 15-Digit Account Structure (GL)

XXX
Dimension 1

XX
Dimension 2

XX
Dimension 3

XXXXX
Dimension 4

.XXX
Dimension 5

Fund Department Sub-Department Object Sub-Object

Table 2.8—Example 9-Digit Account Structure (P/G)

XXX
Dimension 1

XX-
Dimension 2

XXXX
Dimension 3

Project Grant Object
Account Number Structure 
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— In most cases, use a hyphen or a slash to indicate dimensions that are more 
closely related, for instance, department-sub-department. 

— You can also use N (null) to group dimensions without displaying a visible 
separation character.

• Each dimension may be from 1 to 9 digits long.
• You can use up to 9 dimensions.
• The total of all digits in the account number structure may not exceed 18.

However, you are not limited to 18-digits in a transaction account 
number. In transaction entry you can string together multiple ID type/
account combinations to create a transaction account with a maximum 
of 55 characters. See Twin Dimensions on page 45 for more 
information.

DIMENSIONS

Dimensions and dimension values allow you to organize your chart of accounts to best 
match the accounting and reporting needs of your organization. When you use 
dimensions to report your financial information, you can sum and subtotal accounts 
according to all or part of the dimension number (i.e., value). 
For example, in sample division 95 the second dimension for ID A is defined as the 
department dimension. We define departments and dimension values:

• Dimension value 01—Administration department,
• Dimension value 02—Legal department, and
• Dimension value 03—Recreation department.

Then we can combine the fund and department dimension values:
• A01 01-XX XXXX—Administration accounts for the General fund,
• A01 02-XX XXXX—Legal accounts for the General fund,
• A01 03-XX XXXX—Recreation accounts for the General fund,
• A02 01-XX XXXX—Administration accounts for the Water Plant fund,
• A02 02-XX XXXX—Legal accounts for the Water Plant fund,
• A02 03-XX XXXX—Recreation accounts for the Water Plant fund,

You could review your accounts by fund (e.g., General Fund, 01 XX-XX XXXX) or by 
department (e.g., Legal, XX 02-XX XXXX). Or you could view only the Legal accounts 
for a specific fund (e.g., A01 02-XX XXXX).
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CONSISTENCY IN DIMENSION VALUES

If you want to use the dimensions of your account number structure for your reporting, it 
is critical that you are consistent in how you use your dimensions. In the above example, 
if you added a State Grants fund (05) and defined the Administration department as 03 
(i.e., A05 03-XX XXXX), you would exclude the State Grants Administration 
information in a dimension-based report (i.e., a report on XX 02-XX XXXX).

You should always use the dimension maintenance task to add new dimensions 
(General Ledger > Maintenance > Dimensions). For more information, see 
Maintaining Your Dimensions on page 84.

USING DIMENSIONS FOR REPORTING

You can use dimensions in a number of ways when you define your reports:
• Content—Use a mask to define the accounts included in the report.
• Subtotals—Create subtotals in your reports based on dimensions. 
• Grouping—Determine how the accounts in the report will be grouped on each 

page.
• Report headings and account numbers—Present the information in the headings 

and report lines based on the dimensions.
Consider how you would like reports summarized before defining the account numbers. 

For example, if you want to summarize on the first two digits of a 4-digit object 
code, then you should consider dividing the object code into two separate 
dimensions. FundWare provides a special separator character, “N”, that 
displays separate dimensions as a single dimension in the account number. For 
more information, see Setting Up a Manually-Defined Account Structure on 
page 76.

BALANCING YOUR ENTRIES

Within General Ledger, you have two options for balancing your journal entries:
• Double-sided (or two-sided) accounting, and
• Four-sided accounting.

By adding Project/Grant to your system, you add an additional option for balancing your 
journal entries:

• Single-sided accounting.
Account Number Structure 
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The accounting requirements of your organization will determine which of these options 
you use.

TWO-SIDED ACCOUNTING

Two-sided (or double-sided) accounting forces you to enter a second transaction to 
balance the debit/credit. For example:

• You post a $500 debit to A04 00-00 7142, an expenditure account for office 
supplies.

• You then have to post a $500 credit to A01 00-00-1110, an asset account for 
cash in your bank account.

To use two-sided accounting, you select the Commercial accounting option for System 
Type when you define your ID type. For more information, see Defining Your ID Types 
(System Parameter Wizard) on page 69.

FOUR-SIDED ACCOUNTING

Four-sided accounting allows you to keep your segregated monies in balance by forcing 
you to create balancing entries using due to/from accounts when you cross funds. For 
example, you have a $500 expenditure for A04 00-00 7142, crediting A01 00-00-1110 
for the cash account. Because you are crossing funds (fund 04 and 01), you must also 
post to the due to/from accounts. 

• In ID type A, you have defined the first dimension (“fund”) as the fund 
dimension and the third dimension (“sub-department”) as the transfer 
dimension. 

• You have defined the Due To/From account on the journal as A01 00-00 1990 
(fund 01 is your clearing fund, which determines its use here). The system uses 
the fund and transfer dimensions to create the Due To/From account.

• You post a $500 debit to A04 00-00 7142, an expenditure account for office 
supplies.

• You post a $500 credit to A04 00-01 1990.
• You post a $500 debit to A01 00-04 1990. 
• You then have to post a $500 credit to A01 00-00-1110, an asset account for 

cash in your bank account.
To use four-sided accounting, you select the FASB or GASB accounting options for 
System Type when you define your ID type. For more information, see Defining Your 
ID Types (System Parameter Wizard) on page 69.
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SINGLE-SIDED ACCOUNTING

Single-sided accounting allows you to add a single journal entry that posts to an 
account. You are not required to add a second entry to balance that credit/debit.

• All Project/Grant ID types use single-sided accounting.

CLEARING FUNDS

If your organization uses four-sided accounting, you must identify a fund that will act as 
your “clearing” fund. This clearing fund will balance your transactions that cross funds. 
It is usually the general, operating, or unrestricted fund that contains the primary 
checking account, asset, and liability accounts. The clearing fund in Sample Division 95 
is the General Fund (fund 01).
When you define your journals, you must indicate due to/from and suspense accounts 
(due to/from accounts only apply to GL ID types, not P/G ID types). Your entry in the 
due to/from field defines your clearing fund. For example, in Figure 2.1 we have 
defined A01 00-00 1990 as the due to/from account for ID type A. This tells the system 
that fund 01 is the clearing fund. 

Figure 2.1—ID Types Tab of Journal Definition

Invoices totaling $1,500 owed by the Water Plant Fund, fund 02, have been paid 
by the organization’s checking account in the General Fund, fund 01. The 
General Fund is designated as the clearing fund.

• Fund 01 - General Fund (the clearing fund in Sample Division 95)
Due from Water Plant Fund
$1,500 DB

• Fund 02 - Water Plant Fund
Due to General Fund
$1,500 CR
Account Number Structure 
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The General Fund shows the $1,500 as an asset due from the Water Plant Fund. 
The Water Plant Fund shows the $1,500 as a liability due to the General Fund.

TRANSFER DIMENSIONS

When you define your account structure (as part of defining an ID type), you may also 
define a fund and transfer dimension, which identifies the dimensions to be used when 
an interfund transaction occurs. (When you select one of the system-defined account 
structures, the fund and transfer dimensions are also system-defined.) 
The transfer dimension can also have another meaning within your account structure, 
such as the sub-department. Therefore, each dimension may have one meaning on 
Revenue and Expense accounts and something else on Balance Sheet accounts (Table 
2.9). 

Using an earlier example, invoices totaling $1,500 owed by the Water Plant 
Fund, fund 04, have been paid by the organization’s checking account in the 
General Fund, fund 01. The due to/from account is defined as A01 00-00 1990, 
so the transactions would look like this:

• A04 00-00 7142—$1,500 CR
• A04 00-01 1990—$1,500 DB (Amount in fund 04 due to fund 01)
• A01 00-04 1990—$1,500 CR (Amount in fund 01 due from fund 04)
• A01 00-00 1110—$1,500 DB

Table 2.9—Example Fund and Transfer Dimensions

System-Defined 10-Digit Account Number Structure (XX XX-XX XXXX)

XX XX -XX XXXX

Fund Transfer Dimension

System-Defined 15-Digit Account Number Structure (XXX XX-XX XXXXX.XXX)

XXX XX-XX XXXXX .XXX

Fund Transfer Dimension

Example User-Defined Account Number Structure (XX-XX XXX.XXXX)

XX -XX XXX .XXXX

Fund Transfer Dimension
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To complete the interfund transaction, the clearing fund works with the transfer 
dimension (defined when you define your account structure) to create paired due to/
from accounts (also called “clearing accounts”). These “due to/from accounts” maintain 
the balance due to or from an individual fund or the clearing fund by posting equal and 
opposite transactions. For more information, see Defining Your Due To/From Account 
Pattern on page 43.

Length of the Transfer Dimension
To enable the system to keep your funds in balance, the transfer dimension must have an 
equal or greater number of digits as the fund dimension (i.e., the transfer dimension 
cannot have fewer digits than the fund dimension). When your transfer dimension is 
longer than your fund dimension, the system fills the remaining digits with zeros. 

Again using the Water Plant example, invoices totaling $1,500 owed by the 
Water Plant Fund, fund 04, have been paid by the organization’s checking 
account in the General Fund, fund 01. The due to/from account is defined as 
A01 00-0000 1990, so the transactions would look like this:

• A04 00-0000 7142—$1,500 CR
• A04 00-0001 1990—$1,500 DB (Amount in fund 04 due to fund 01)
• A01 00-0004 1990—$1,500 CR (Amount in fund 01 due from fund 04)
• A01 00-0000 1110—$1,500 DB
Account Number Structure 
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DEFINING YOUR DUE TO/FROM ACCOUNT PATTERN

When you define your journals, you must enter an account number in the Due To/From 
field. The system uses the fund dimensions specified in the Due To/From pattern 
(defined on the ID Types tab of the journal definition) and the account used in your 
transaction, along with the remaining numbers of the pattern, to determine your due to/
from account numbers (Figure 2.2). 

Figure 2.2—Example Due To/From Accounts From Pattern

04 00-00 7142Transaction account number:

Due To/From account pattern: 01 00-00 1990

The system takes the fund dimension from the Due To/
From pattern and places it in the transfer dimension, takes 
the fund from the transaction account and places it in the 
position of the transfer dimension, and retains the 
remaining numbers in the Due To/From pattern in their 
original positions.

Noted in bold, the remaining dimensions are taken from the 
Due To/From account pattern.

04 00-01 1990

The system takes the fund from the transaction account 
and places it in the position of the transfer dimension, and 
retains the remaining numbers in the Due To/From pattern 
in their original positions.

Noted in bold, the remaining dimensions are taken from 
the Due To/From account pattern.

01 00-04 1990
Due To/From account 1
Debit $500.00

Due To/From account 2
Credit $500.00

Debit $500.00
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Again using the system-defined 10-digit account structure (XX XX-XX 
XXXX) as an example, let’s see what happens when you involve three funds 
(Figure 2.2). 

Figure 2.3—Example Due To/From Accounts From Pattern

04 00-00 7142

Due To/From account pattern: 01 00-00 1990

The system takes the fund dimension from the Due To/From 
pattern and places it in the transfer dimension, takes the fund 
from transaction account number 1 and places it in the position 
of the transfer dimension, and retains the remaining numbers in 
the Due To/From pattern in their original positions.

Noted in bold, the remaining dimensions are taken from the Due 
To/From account pattern.

04 00-01 1990

Due To/From account 1
Debit $500.00

Due To/From account 3
Credit $500.00

The system takes the fund dimension from the Due To/From 
pattern and places it in the transfer dimension, takes the fund 
from transaction account number 2 and places it in the position of 
the transfer dimension, and retains the remaining numbers in the 
Due To/From pattern in their original positions.

Noted in bold, the remaining dimensions are taken from the Due 
To/From account pattern.

05 00-01 1990

The system takes the fund from transaction account number 2 
and places it in the position of the transfer dimension, and retains 
the remaining numbers in the Due To/From pattern in their 
original positions.

Noted in bold, the remaining dimensions are taken from the Due 
To/From account pattern.

01 00-05 1990
Due To/From account 2
Credit $500.00

Due To/From account 4
Debit $500.00

Transaction account number 1:

05 00-00 4510Transaction account number 2:

Debit $500.00

Credit $500.00

The system takes the fund from transaction account number 1 
and places it in the position of the transfer dimension, and 
retains the remaining numbers in the Due To/From pattern in 
their original positions.

Noted in bold, the remaining dimensions are taken from the Due 
To/From account pattern.

01 00-04 1990
Account Number Structure 
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DEFINING YOUR DUE TO/FROM ACCOUNTS

You should define your due to/from accounts, taking into consideration all funds that 
must balance with your clearing fund. If you do not define the due to/from accounts, the 
system will create the accounts “by posting” when you post your transactions. For more 
information, see:

• Created by Posting Accounts on page 68
• Viewing Transaction Information on page 152
• Viewing Account Balance Information on page 155

The Due To/From account is defined on the ID Types tab of the journal definition.

BALANCING ENTRIES—MANUAL OR AUTOMATIC

If you design you system using four-sided accounting, you can chose to create your 
balancing entries manually or to have the system create the entries automatically.

• Manual—You must enter all four transactions (i.e., the debit, the credit, and 
both balancing entries).

• Automatic—FundWare uses the Due To/From entry on the journal definition to 
enter the balancing entries. You must still enter the debit and credit transactions. 

If these accounts do not exist at the time you post, the accounts will be 
“created by posting.” For more information, see Created by Posting 
Accounts on page 68.

TWIN DIMENSIONS

Very simply, twinning is a FundWare term for a feature that saves you keystrokes when 
you need to post a transaction to two ID types. For example, GL ID type A in Division 
95 has a 10-digit account number structure with four dimensions, as shown in Table 
2.10. 

• The 04 in Dimension 1 designates the Federal Grants fund. 

Table 2.10—Example GL Account Structure for A01 02-01 6110

ID Type Dimension 1 Dimension 2 Dimension 3 Dimension 4

A 04 (Fund) 02 (Department) 01 (Sub-Department) 6110 (Object)

Financial 
Reporting System

Federal Grants Administration Finance Salaries/Wages
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• The 02-01 in Dimensions 2 and 3 designate the Administration department and 
Finance sub-department. 

• The 6110 in dimension 4 designates the object, Salaries/Wages.
P/G ID type F in Division 95 has a 9-digit account number structure with three 
dimensions, as shown in Table 2.11.

• The number 100 in Dimension 1 designates the Federal Grants project. 
• The number 01 in Dimension 2 designates the Urban Mass Transit Authority 

grant. 
• The number 6110 in Dimension 3 designates line item account object Salaries/

Wages. 
Notice that the 6110 object codes in each ID type are identical for salaries/wages. If you 
need to post transactions to both ID type A (General Ledger) and F (Project/Grant), you 
can twin these accounts. When you enter the account number for the first ID type and 
the ID type and non-twinned dimensions from the second ID type, the system provides 
the rest.

• You type the following (notice—no formatting): 
A0402016110F10001

• The system posts to:
— A04 02-01 6110
— F100-01 6110

For more information on twinning, see Appendix E—Using the Twinning Feature on 
page 367.

ATTRIBUTES
Attribute positions and attribute values are 1- to 3-digit alphanumeric codes, or tags, that 
you assign to specific positions in your accounts to allow you to:

Table 2.11—Example P/G Account Structure for F100-01 6110

ID Type Dimension 1 Dimension 2 Dimension 3

F 100 (Project) 01 (Grant) 6110 (Object)

Federal Grants Federal Grants Urban Mass Transit Authority Salaries/Wages
Attributes 
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• Define report page break and row contents
• Define year-end posting options (i.e., restricted vs. unrestricted)
• Enhance inquiries
• Define report columns
• Filter reports
• Define advanced allocations
• Set budget control
• Update groups of accounts

You must assign one of the standard attributes to position 1 (System Reserved) of the 
attribute string of every account to define the type of account (e.g., revenue, expense). 
However, you can also assign up to 14 additional attributes to each account. 
Most attributes will be defined for a specific position of the attribute string. You can 
specify that a position of the attribute string must always have an attribute assigned. 

In sample division 95, we modify attribute position 6 to be required and name 
the position “Location.” We have defined two attributes for this position: E1 
(Water Plant) and E2 (Sewer Plant). Now all accounts must have one of these 
attribute assigned to position 6 of the attribute string to indicate the location. 

Figure 2.4—Example Required Attribute Position and Associated Attributes
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USING ATTRIBUTES IN REPORTING

When you combine your account structure with your attributes, you can categorize your 
chart of accounts to meet all the reporting needs of your organization. For example:

• You can use attributes, exclusively or combined with dimensions, to define the 
row contents in reports (Figure 2.5). 

Figure 2.5—Example Row Definition Using Attributes
Attributes 
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• You can define how you use your attribute values for common financial 
categories (Figure 2.6). 

Figure 2.6—Example Report Attributes Tab
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• You can use attribute positions to define one or more columns (often called 
“combined” reports in FundWare) (Figure 2.7). 

Figure 2.7—Example Combined Report Using Attributes to Define Columns

For more information on defining report columns with attributes, see Chapter 11—
Creating and Producing Reports on page 281 and Appendix B—Using Attributes to 
Define Report Columns on page 339. 

ADDITIONAL USES OF ATTRIBUTES

You will also use attributes to define report rows if your organization has purchased the 
Advanced Financial Reporting, or to define Advanced Security if your organization has 
purchased this feature.
Attributes 
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DEFAULT STANDARD ATTRIBUTES

When you define an ID type, FundWare will propose a set of default standard attributes 
(Table 2.12). You can accept these attributes and add additional attributes later or you 
can modify this list of defaults within the System Parameter Wizard. 

The standard attributes are assigned to Position 1 of the attribute string (the System 
Reserved position). To help meet your reporting, you can define new attributes for the 
remaining attribute positions (i.e., 2–15). 

ATTRIBUTE POSITIONS AND ATTRIBUTE VALUES

You can define as many attributes as your organization needs to accomplish your goals. 
However, you can only assign 15 attributes (including the required first attribute) to 
each account, and these assignments are determined by position. For example, the office 

Table 2.12—Default GL and P/G Attributes

Abbreviation Description

General Ledger

AS Asset

LI Liability

NA Net Assets (FASB)

FB Fund Balance (GASB)

OE Owner Equity (Commercial)

RE Revenue

EX Expenditure

DS Descriptive

Project/Grant

RE Revenue

EX Expenditure

DS Descriptive
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supply accounts shown in Figure 2.8 have four attributes assigned to each—the required 
attribute in position 1, which indicates that this is an expense account, and optional 
attributes in positions 3 (Restrictions), 4 (Funds), and 5 (Figure 2.8). 

Figure 2.8—Example Account Attributes

Part of the attribute definition indicates to what position you can assign the attribute. 
Looking at an attribute from our example in Figure 2.8, you can see that attribute T1 can 
only be assigned to position 3 on an account (Figure 2.9). 

Figure 2.9—Example Attribute Definition

For example, if you want to identify the project manager for each account, you can:
Attributes 
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• Define position 7 as “Project Manager,”
• Define attributes for each project manager (Figure 2.10), 

Figure 2.10—Example Attribute Position and Attribute Values

• Assign one of the attributes to position 7 on all applicable accounts (Table 
2.13). 

Table 2.13—Example Account Number Including Attributes

Account Fund Dept. Sup-Dept. Object System Reserved
Attrib. Pos. 1

Source
Attrib. Pos. 7

Telephone A01 01 00 7130 EX JF

Telephone A02 00 00 7130 EX JF

Telephone A03 00 00 7130 EX RRK

Telephone A04 00 00 7130 EX PBJ
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• Produce reports that include or exclude accounts based on the applicable 
attribute (Figure 2.11). 

Figure 2.11—Balance Sheet Report for One Project Manager

Using combined reports, you could even create a report that displays 
these attributes in adjacent columns. See Appendix B—Using Attributes 
to Define Report Columns on page 339 for more information.

JOURNALS
Journals are the books of original entry for all transactions. When you post a transaction 
to a journal, the system stores the information in one of the “ledgers” (i.e., actual, budget 
type 1, budget type 2, encumbrance, or commitment). (These “ledgers” reside in specific 
areas of the database.) You define how the journal will collect information and what 
information it will accept. For example, you can define certain journals to accept 
transaction information from another FundWare module. 

In Sample Division 95, we have defined journals to which we post Accounts 
Payable purchases (PURCH) and cash disbursements (CDIS). Reserving 
specific journals for these transactions preserves the integrity between the two 
modules, Accounts Payable and General Ledger. These journals:

• Accept transaction information from AP.
• Do not allow direct, manual journal entries from General Ledger. 
Journals 
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SYSTEM-DEFINED JOURNALS

When you define your ID type, the system automatically creates one journal (an actual 
journal) and you have the option to create three additional journals: 

• Budget,
• Encumbrance, and/or
• Commitment.

The possible system-defined journals created when you define an ID type include the ID 
type letter as the last character of the journal name (Table 2.14). 

POSTING TYPES

General Ledger–Project/Grant stores financial and nonfinancial information in your 
database. This information is divided into five areas:

• Actual
• Budget Type 1
• Budget Type 2
• Commitment
• Encumbrance

The Posting Type setting on your journals indicates to the area of the program where 
your information will be stored. You cannot change the posting setting for the system-
defined default journals; however, you can change the setting for user-defined journals.

Table 2.14—Example Default Journals for ID Type A

Journal Building the Name Journal Name

General (i.e., actual) GJNL + ID type A GJNLA

Budget BDGT + ID type A BDGTA

Encumbrance ENCM + ID type A ENCMA

Commitment COMM + ID type A COMMA
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BUDGET TYPES 1 AND 2 AND GASB 34

In fiscal year 2002, government entities received new reporting requirements under 
“GASB 34” (Governmental Accounting Standards Board Statement Number 34). A 
portion of GASB 34 requires that these entities report both original and final (i.e., 
revised) budget amounts. 
To address the needs of GASB 34 reporting, FundWare divides budget information into 
two groups:

• Budget Type 1
• Budget Type 2

When you plan your FundWare setup, you must decide if you need to use the two budget 
areas of the database. You will then design your journals appropriately. 

1.  Decide which area of the database will hold your original budget information 
and which area will hold your revised and final budget information. 

— For these instructions, we will post original budget information to Budget 
Type 1 and revised/final budget information to Budget Type 2.

2. Create one or more journals that post to each of the defined budget areas (i.e., 
Budget Type 1 and Budget Type 2). (See Adding a Journal on page 107 for 
instructions to create your journals.)

If you do not need to post to both areas of the database, you should 
make sure that all your budget journals post to the same area (i.e., either 
Budget Type 1 or Budget Type 2).

3. Enter your original budget information and post that information to the database 
using the journal(s) that post to Budget Type 1.

4. Enter any budget revisions and post that information to the database using the 
journal(s) that post to Budget Type 2.

FOR UPGRADING FUNDWARE CUSTOMERS

If you are an existing customer upgrading from a version of FundWare earlier than 7.20, 
the information that was contained in the Budget area of the database is now stored in 
the Budget Type 1 area of the database. If you do not need or want to divide your budget 
information, you do not need to change any of your journal definitions. However, if you 
add any new journals, you should define the posting type as “Budget Type 1” to ensure 
that all your data is stored in the same area of the database.
Journals 
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If you want to take advantage of the two budget areas of the database, but have data that 
must be moved from one area to the other, you must:

1.  Create one or more new journals that post to the Budget Type 2 area (see Budget 
Types 1 and 2 and GASB 34 on page 56).

2. Move any applicable data from the original budget area (Budget Type 1) to the 
new budget area (Budget Type 2) (e.g., if you have already decided that Budget 
Type 1 will hold your original budget information, but have posted revisions, 
you will need to move those revisions to Budget Type 2). See Appendix C—
Adjusting Your System for GASB 34 on page 349.

3. Proceed with any new postings using the appropriate journals 

— Enter your budget information and post that information to the database 
using the journal(s) that post to your original budget area (e.g., Budget Type 
1).

— Enter any budget revisions and post that information to the database using 
the journal(s) that post to your revised/final budget area (Budget Type 2).

SUSPENSE ACCOUNTS

A suspense account is an account that you specify for your journals that allows you to 
post transactions that are “unclassified” (i.e., you’re not sure at the time of posting 
where the monies should post). Using a suspense account allows you to designate one 
account number that will hold transactions temporarily until such time as you reclassify 
the entry.

DEFINING YOUR JOURNALS TO USE MULTIPLE ID TYPES

When you define a journal, or create a default journal when adding an ID type, you are 
associating an ID type with the journal. By default, that ID type is required for 
transactions to that journal. However, you can change that setting or add additional ID 
types as:

• Required—All transactions posted to this journal must use an account of this ID 
type.
— For example, you define GJNLA with ID type A required. When you enter 

a transaction, you must use an account from ID type A. You will not be 
allowed to add additional accounts from other ID types.

• Optional—Transactions posted to this journal may (or may not) use this ID 
type.
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— This option is useful if you have more than one ID type, and you may be 
posting transactions to this journal using these ID types.

— For example, you define GJNLA with ID type A required and ID type F 
optional. You can now enter a transaction using accounts A01 01-00 6110 
and F100 01-6110.

— If you define only one ID type for the journal, and make that ID type 
optional, it has the same effect as required. (Because you must always post 
using an ID type, if the only allowed ID type is optional, it’s actually 
required in practical usage.)

• One of—Transactions posted to the journal must use the required ID type and 
“one of” the defined additional ID types. In other words, all transactions posted 
to this journal must include two accounts, one from the required ID type and 
one from one of the additional ID types.
— For example, you define GJNLA with ID type A required and ID type F and 

ID type S as “one of.” When you enter a transaction, you must include an 
account from ID type A and an account from either ID type F or ID type S.

For more information for why and how you would use multiple ID types, see Appendix 
E—Using the Twinning Feature on page 367. 

ACCOUNT DEFINITION AND DETAIL
In addition to an ID type, dimensions, and attributes, an account number can include the 
following elements:

• Description—A textual description of the account up to 30 characters in length.
• Status (required for all accounts):

— A (Active)—Active and available for data entry. Any type of transaction 
may be posted.

— B (Budget)—Active, Budget data entry only. Only budget entries may be 
posted.

— D (Descriptive)—No transactions may be posted. Used for titles on reports.
— S (System)—Active, no data entry. Only system generated transactions may 

be posted.
— I (Inactive)—Inactive, no transactions may be posted. May have previous 

activity and still be available for reporting.
• ID entry—other ID types to which the account must post (i.e., which other ID 

types is this account “twinned” with). This is optional.
Account Definition and Detail 
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• Data items—Data items for storing financial and non-financial information. 
Optional.

• Aliases 1 and 2—Alternate account number, name, or any additional reference 
that will assist in finding and/or reporting accounts. This is optional.

DATA ITEMS

Data items are a unique feature of FundWare that allows you to store financial and non-
financial information about an account or a transaction (via a journal). Data items can 
store a variety of information, including numbers (e.g., rates or amounts, negative 
numbers), dates, telephone numbers, keywords, or text (two options: 10- or 35-character 
fields). Once you define a data item, you can:

• Assign the data item to your accounts, either manually through the Chart of 
Accounts or to a group of accounts through Account Utilities (i.e., “static”).

• Assign the data item to a journal (i.e., “transactional”). When you add a journal 
entry for that journal, the system prompts you for the data item information. 
(Instructions for adding a data item to a journal can be found in Adding a 
Journal on page 107.) 

Once you enter information for a data item, you can use the information to enhance your 
inquiries and to enhance your user-defined balance sheet reports (type X) and user-
defined revenue and expense reports (type Y) in a number of ways:

• Include non-financial information; or
• Supplement aliases, budget amounts, or any other numerical information.

The user-defined balance sheet and revenue and expense reports (types X and 
Y) are the only types of reports for which you can include data items. For more 
on these reports, see Creating or Editing Reports on page 289.

Additionally, you can use data items to define advanced allocations using the Allocation 
Management module. You can also post data items from other modules (e.g., you can 
define the Accounts Payable cash disbursements journal, CDIS, to post the check 
number and invoice numbers as part of the journal entry as well as the standard 
description and up to three references).
Instructions for defining a data item can be found in Adding Data Items on page 113.

EXAMPLE DATA ITEMS—ON ACCOUNTS

The the City of Jonesville has restricted grants and they have decided to add data items 
to the accounts to note the following information:
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• Contact name and phone number—Two data items, one 35-alphanumeric 
character text and one 10-character phone number.

• Fund period—A 35-alphanumeric character text data item.
• Restrictions—Three 55-alphanumeric character text data items allowing us to 

enter up to 165 characters of text concerning our restrictions.
We can add some or all of these data items and enter values to an account through the 
Data Items window (a pop-up window accessed from the account definition) (Figure 
2.12). 

Figure 2.12—Example Data Items to Store Grant Information
Account Definition and Detail 
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We can also use the Account Utilities task to assign each of these data items to all 
accounts in fund 05 (Figure 2.13). 

Figure 2.13—Assigning a Data Item and Value to Fund 05
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EXAMPLE DATA ITEMS—ON JOURNALS

Smythe County enters our funding checks directly in to General Ledger and we must 
note with what services the check is associated. Therefore, we have added a 35-
alphanumeric character data item (SERVICES) and applied this to the journal for these 
received payments (RECPT) (Figure 2.14). 

Figure 2.14—Example Journal Definition With Data Item

Now, a column is added to the journal entry form when we select the RECPT journal 
(Figure 2.15). 

Figure 2.15—Example Journal Entry Form With “Services for” Column
Account Definition and Detail 
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ALIASES
The alias feature allows you to designate a second number or description (or both) for an 
account. You can use these aliases in a search and include them in your reports.
For example, let’s say you’re a new FundWare customer. You have imported your 
accounting information and have created a new chart of accounts, including new 
account numbers. But you have memorized all your old account numbers. You can add 
these account numbers as an alias, allowing you to search based on the account number 
you know.
This feature is also helpful if you have a funding source that requires different account 
names and numbers than those you normally use. You can save this information in the 
alias fields, then include them in your reports for the funding source.

In Division 95, fund 02 (Water Plant Fund) is funded by a State EPA grant. The 
grant agency wants your reports to reflect its account structure and naming 
convention. However, this system is different from your organization’s chart of 
accounts. Since this is only a reporting requirement, you can give all accounts in 
fund 02 a different account number and title using aliases 1 and 2 (Figure 2.16). 

Figure 2.16—Example Account Aliases for the Water Plant Fund
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If you produce a Chart of Accounts report, you can see the aliases for the 
accounts (Figure 2.17). 

Figure 2.17—Example Chart of Accounts for A02 XX-XX XXXX in Division 95

You can select these aliases to print in your reports rather than the standard account 
number.

If an account has no aliases, but the report definition indicates that the alias will 
display instead of the standard account number (or other option), then nothing 
will print in that column of the report.

Figure 2.18 shows the same Revenue and Expense report using different page and row 
settings. This allows us to create two reports that contain the same account data, but 
which display different account numbers and descriptions. The first report shows the 
standard Revenue and Expense report, which produces the report using the account 
Aliases 
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descriptions. For the second report, we changed the setting for Pages and Rows to 
produce the report using the information in aliases 1 and 2 (in this case, alternate 
account numbers and descriptions). 

Figure 2.18—Example Comparison of Revenue and Expense Reports
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Figure 2.19 shows how we modified the Pages and Rows tabs to display the alias 
information in the report. 

Figure 2.19—Revenue and Expense Report Definition Using Aliases

You will define alias information when you define your accounts (see Adding Individual 
Accounts on page 125 or Adding Accounts With Account Builder on page 132).

TIPS ABOUT USING ALIASES

• You can use the Maintenance > General Ledger > Account Utilities feature 
to copy account alias information from one group of accounts to another.

The page break 
description, account 
number, and 
account description 
are drawn from the 
aliases.
Aliases 
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• You cannot use aliases to sum accounts. FundWare uses the actual account 
number to sum amounts.

DESCRIPTIVE ACCOUNTS
Descriptive accounts are title accounts that help organize your chart of accounts. The 
position 1 attribute value is DS, the account status is D (Descriptive), and the account 
numbers consist mostly of zeros. You can then use these descriptive accounts to create 
report headings or row summary titles for ease of reading. These accounts do not 
contain financial data.

Some examples of the descriptive accounts, based on Division 95, are:

• 01 00-00 0000 General Fund—Any accounts with the first dimension 01 
belong in the General fund.

• 00 03-00 0000 Recreation—Any accounts with the second dimension 03 
are associated with Recreation programs.

• 00 00-01 0000 Baseball Park—Any accounts with the third dimensions 01 
are associated with the Baseball Park.

• 00 00-00 4110 Property Taxes—Any accounts where the last dimension is 
4110 are associated with property taxes.

Therefore, an account number of:

• A01 03-01 4110—Would involve the General fund, the recreation 
programs, the baseball park, and property taxes (probably property taxes for 
the baseball park).

When you define a dimension value (Maintenance > Dimensions), the program offers 
you the opportunity to automatically create the corresponding descriptive account. See 
Adding Dimension Values on page 86 for more information.

You add two new fund dimension values to division 95: 04 (Literacy) and 05 
(After School Care). The descriptive accounts are shown in Table 2.15 

Table 2.15—Example Descriptive Accounts From New Dimension Values

Account Number Account Description System Reserved
Attribute Position 1 Account Status

A04 00-00 0000 Literacy DS Descriptive

A05 00-00 0000 After School Care DS Descriptive
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CREATED BY POSTING ACCOUNTS
FundWare will define “created by posting” accounts if you post a transaction to an 
undefined account number (e.g., you have not defined your due to/from accounts, a 
transaction combines setup parameters to create an undefined account number, you 
enter an incorrect year-end closing mask). These accounts are most likely to occur when 
you are first setting up the system.

Instead of halting the process and generating an error, the system adds a “created by 
posting” account and produces a trace report noting these accounts in the summary 
portion of the report. You should always check your trace reports closely after posting a 
transaction to identify the following information for any created by posting accounts:

• The journal used to post the entry,
• The amount of the entry,
• The type of entry (debit or credit), and
• The description of the entry on the detail portion of the trace report.

See Responding to Created by Posting Accounts on page 174 for instructions on 
necessary adjustments your system.

USING MASKS
A mask is a FundWare term for using a “wild card” in an account number to indicate a 
group of accounts. The best use of this feature is for processing and reporting. Where an 
X is placed in a mask, any value in that digit position will be accepted. 

In Sample Division 96, if you enter the mask A01 00-00 111X in the Account 
Selector, you will get five accounts:

• A01 00-00 1110, 
• A01 00-00 1111, 
• A01 00-00 1112,
• A01 00-00 1114, and
• A01 00-00 1115.

 

Created by Posting Accounts 



C H A P T E R  3

DEFINING AND MAINTAINING GL–P/G

To configure and maintain your General Ledger–Project/Grant system, you must work 
with a number of elements:

• ID types, 
• Dimensions, 
• Attributes,
• Journals,
• Data items, and 
• Date tables.

DEFINING YOUR ID TYPES (SYSTEM PARAMETER WIZARD)
The first step to setting up your General Ledger–Project/Grant is to define your ID types 
using the System Parameter Wizard. Use the following instructions to activate the 
wizard. 

The examples used in the following steps act as a tutorial. However, when you 
set up your organization, your entries may be different.
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1.  Click Setup on the module navigator (if the module is not expanded, click 
General Ledger first) or select General Ledger > Setup from the menu bar. 
The first window of the System Parameter Wizard displays (Figure 3.1). 

Figure 3.1—Setup Wizard Opening Screen

2. Click Next.

3. Select the General Ledger or Project/Grant radio button, as applicable (Figure 
3.2). 

Remember, Project/Grant allows you to enter single-sided transactions 
(i.e., debits do not have to equal credits). Transactions to General 
Ledger ID types must be two-sided or four-sided (i.e., debits must 
equal credits). 

Figure 3.2—Selecting General Ledger

4. Click Next.
Defining Your ID Types (System Parameter Wizard) 
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5. Enter the number of days you want to allow for your posting window. The 
system will use your system date (i.e., not the business date used during login) 
and the value you enter here to determine the period of time, after the last day of 
a closed period, during which you can still post entries to that period (Figure 
3.3). 

This feature allows you to set a limit on the number of days after a 
month-end that transactions may be entered into a prior period. Once 
this limit has passed, transactions must be entered into a new period. 
For example, Figure 3.3 shows a posting window of 46 days. 

Figure 3.3—Entering the Posting Window

6. Click Next.

7. Select the check box if you want to use units and rate calculations in your 
journal entries. In Figure 3.4, we have selected the check box. 

Figure 3.4—Using Units and Rates
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8. Click Next. The wizard asks for information concerning the ID type, including 
the account structure, year-end date, and periods (Figure 3.5). 

Figure 3.5—Entering Various Accounting Information

9. Enter account-specific information according to Table 3.1. 

Table 3.1—Accounting Information Field Definitions

Field Valid Entry Definition

ID Type A–Z, excluding X Select the letter for your ID type from the drop-down menu.

Short 
Description

Up to 10 alphanumeric 
characters

Enter a short description of this ID type. 
• Displays on certain reports.

Description Up to 30 alphanumeric 
characters

Enter a longer description of this ID type.

System Type • Commercial
• FASB
• GASB

Choose the type of accounting system for the ID type you 
selected from the drop-down menu:
• Commercial—for-profit companies,
• FASB—fund accounting, or
• GASB—government accounting.
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Account 
Structure

• Manually defined
• XX XX-XX XXXX
• XXX XX-

XX XXXXX.XXX

Select your the Account Structure option from the drop-
down menu:
• System is Manually Defined—You define the account 

number structure
• System-defined 10-digit account structure—

XX XX-XX XXXX
• System-defined 15-digit account structure—

XXX XX-XX XXXXX.XXX
NOTE: If you select “System is Manually Defined,” the 
wizard will ask you to define the account structure and 
standard report structure. (See Setting Up a Manually-
Defined Account Structure on page 1.76.)

Year-End Date A valid date Enter your fiscal year-end date. To select a date from the 
calendar, click the ellipsis, . The program will then 
create the corresponding date table. (For more on date 
tables see Maintaining Your Date Tables on page 1.116.)
• Your year-end date, reporting period, and increment 

setting will determine the date tables created by the 
system. For more information, see Maintaining Your 
Date Tables on page 1.116.

Reporting 
Period

Monthly, Weekly Select either monthly or weekly reporting periods from the 
drop-down list. 

• Increment 1–12 From the drop-down menu, select the number of 
increments for your reporting periods.
• For example, an organization with a bi-weekly reporting 

period would enter Weekly for the Reporting Period and 
2 for the increment.

Adjustment 
Periods

• No adjustments
• 1 adjustment
• 2 adjustments
• 3 adjustments
• 4 adjustments

From the drop-down menu, select the number of 
adjustment periods added to the date table at the end of 
each year. Adjustment periods are used for audit and year-
end adjustments.

Table 3.1—Accounting Information Field Definitions (Continued)

Field Valid Entry Definition
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10. Click Next. The wizard now asks you to select the data items you want 
associated automatically with accounts for this ID type (Figure 3.6).

Figure 3.6—Selecting Default Data Items

All defined data items display in the Available Data Items area. For 
more information on data items, see Maintaining Your Data Items on 
page 113.

11. Under Available Data Items, select a data item, then click >> to move it to the 
Selected Data Items box. Repeat until you have selected all the items you want. 

12. Click Next. 

If you selected “System is Manually Defined” for the account structure, 
the wizard will ask you to define the account structure and standard 
report structure at this time. These are explained further in Setting Up a 
Manually-Defined Account Structure on page 76.

13. Select check box to indicate the journals that you want the system to create 
automatically (Figure 3.7). The system will always create the actual journal 
(e.g., GJNLA for ID type A) so this check box is disabled. 

Figure 3.7—Selecting Journals
Defining Your ID Types (System Parameter Wizard) 
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Selecting the Budget check box will allow you to post to either Budget 
Type 1 or Budget Type 2. 

14. Click Next.

15. Accept the default attribute values and descriptions or enter new (Figure 3.8). 

Figure 3.8—Entering Attributes

If you enter attributes that do not exist, FundWare will create those 
attributes when it creates the ID type. The attributes will be assigned to 
position 1. (For more on positions, see Attribute Positions on page 95.)

FundWare does not allow you to modify the attribute and description 
for descriptive accounts: DS—Description. These fields are disabled.
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16. Click Next. You have now finished the setup process (Figure 3.9). 

Figure 3.9—Finishing the Setup

17. Click Finish to keep the values you just entered, click Back if you want to 
change any of your entries, or click Cancel to delete all your entries and close 
the System Parameter Setup Wizard.

Before you can begin to use this ID type, you must edit the system-defined journals and 
add any necessary user-defined journals (Maintaining Your Journals on page 101). 

SETTING UP A MANUALLY-DEFINED ACCOUNT STRUCTURE

If you selected “System is Manually Defined” for the account structure, the wizard will 
ask you to define the account structure and standard report structure at this time (Figure 
3.10). 

Figure 3.10—Defining the Account Structure
Defining Your ID Types (System Parameter Wizard) 
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Use the following instructions to define the account and standard report structures.
1.  Enter the length and description (up to 200 alphanumeric characters) for each 

dimension in your account structure.

2. Enter any separator characters that you want to display between dimensions.

To define a display separate dimensions as a single dimension in the 
account number (useful for reporting), type N as a separator character 
(Figure 3.11). 

Figure 3.11—Example Null Character in Account Number Structure

3. Indicate the Fund and Transfer dimensions by selecting the appropriate radio 
button. There can be only one Fund dimension and one Transfer dimension. 
(For more information on Fund and Transfer dimensions, see Balancing Your 
Entries on page 38.)
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4. Click Next. The wizard asks you to define how you want the system to structure 
your standard reports (Figure 3.12). 

Figure 3.12—Defining the Standard Reports Structure

You can choose not to define your report structure at this time. 
However, you will need to complete the Define Reports task in Report 
Manager before the system will allow you to produce any reports 
(standard or user-defined).

5. Enter the dimension that the system should use to determine page breaks for the 
applicable standard reports in the Page break on field.

6. Enter the secondary dimension that the system can use to determine page breaks 
in the Secondary Levels break on field.

7. Finally, define how your accounts should be displayed on the rows of the 
standard reports. 

If you are breaking your pages by dimension 1, the applicable number 
and value will appear in the heading to each section, you may want to 
display only the remaining dimensions in the rows of a report.

8. Click Next. You return to the step 13 on page 74 of General Ledger setup 
instructions.
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EDITING YOUR ID TYPES

Much of the information in the ID type definition cannot be edited once the ID type has 
been defined. Settings that you can change include the default journals and the data item 
assignments. Use the following instructions to edit the settings for an ID type.

1.  Click Maintenance > ID Types on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > 
Maintenance > ID Types from the menu bar. The ID Types window displays, 
open to the General tab (Figure 3.13). 

Figure 3.13—ID Types Window—General Tab

2. Select the ID type that you want to edit from the ID Type drop-down list. The 
settings for the ID type display in the fields.

3. Edit the information on the General tab according to Table 3.2. 

Table 3.2—ID Type Field Definitions—General Tab

Field Valid Entry Definition

Description Up to 30 alphanumeric 
characters

Enter a longer description of this ID type
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Last Updated 
and By User

Cannot be edited The system maintains these fields to track when changes 
were last made and by whom.

System Type Cannot be edited You cannot change the accounting system (e.g., four-sided 
accounting) for the ID type.

Short 
Description

Up to 10 alphanumeric 
characters

Enter a short description of this ID type.

Year-End Date A valid date Enter your fiscal year-end date. 

Reporting 
Period

Monthly, Weekly Select either monthly or weekly reporting periods from the 
drop-down list. 

• Increment 1–12 From the drop-down menu, select the number of 
increments for your reporting periods.

Last Period 
Ends

On last full period
On year-end date

Select the setting to indicate when the last period of the 
fiscal year ends.

Default 
Journals

Valid journal Select a default journal from the drop-down list:
• Actual
• Budget
• Encumbrance
• Commitment
The journal description displays to the right.

Table 3.2—ID Type Field Definitions—General Tab (Continued)

Field Valid Entry Definition
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1.  Click the Account Structure tab (Figure 3.14). The information that you can edit 
is the dimension description. 

Figure 3.14—ID Types Window—Account Structure Tab

2. Edit the dimension description (up to 200 alphanumeric characters), as 
necessary.
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3. Click the Field Use tab (Figure 3.15). 

Figure 3.15—ID Types Window—Field Use Tab

4. Edit the information on the Field Use tab according to Table 3.3. 

Table 3.3—ID Type Field Definitions—Field Use Tab

Field Valid Entry Definition

Alias 1 and 2 Select the check box When this option is enabled, fields for Alias 1 and Alias 2 
display on each account record (e.g., Chart of Accounts) in 
the ID type.

Required ID 
types

Select the check box When this option is enabled, you can define required ID 
types for each account in the ID type (e.g., through the 
Chart of Accounts or Account Utilities).
Defining Your ID Types (System Parameter Wizard) 



Chapter 3—Defining and Maintaining GL–P/G
5. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window.

DELETING ID TYPES

Use the following instructions to delete an ID type.
You cannot delete an ID type that has transaction information (i.e., to which you 
have posted transactions.

1.  Click Maintenance > ID Types on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > 
Maintenance > ID Types from the menu bar. The Journals window displays, 
open to the General tab of the first journal in your list of journals. 

2. Select the ID type that you want to edit from the ID Type drop-down list. The 
settings for the ID type display in the fields.

3. Click Delete. A confirmation message displays.

Delete will be disabled if you have used this ID type to post a 
transaction. You cannot delete the journal.

4. Click Yes. The ID type is deleted.

5. Click OK or Cancel to close the ID Types window. 

Data Items Existing data items Modify the data items defaulted to new accounts by adding 
or removing data items from Default Data Items list. 
• Use the up and down arrows to rearrange the order the 

data items are displayed in the account definition (data 
items window) by reordering the Default Data Items list. 

Allow 
additional data 
items to be 
added by user

Select the check box When this option is enabled, the user can add additional 
data items to the account record (e.g., through the Chart of 
Accounts or Account Utilities).

Table 3.3—ID Type Field Definitions—Field Use Tab (Continued)

Field Valid Entry Definition
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MAINTAINING YOUR DIMENSIONS
Context-sensitive topic: Maintenance—Dimensions
Dimensions and dimension values allow you to organize your chart of accounts to best 
match the accounting and reporting needs of your organization. 

• Dimension—A segment of your account structure. This structure is defined 
when you define the ID type (General Ledger > Setup).

• Dimension value—Numeric values assigned to that dimension. These values 
usually have a specific meaning (e.g., Fund 02 is the Water Plant Fund—Fund is 
the dimension, 02 is the dimension value).

When you use dimensions to report your financial information, you can sum and 
subtotal accounts according to all or part of the dimension number (i.e., value). 

EDITING DIMENSIONS

Use the following instructions to edit the description of a dimension.
Maintaining Your Dimensions 
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1.  Click Maintenance > ID Types on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > 
Maintenance > ID Types from the menu bar. The ID Types window displays, 
open to the General tab (Figure 3.16). 

Figure 3.16—ID Types Window

2. Select the ID type that you want to edit from the ID Type drop-down list. The 
settings for the ID type display in the fields.
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3. Click the Account Structure tab (Figure 3.17). 

Figure 3.17—Account Structure Tab

4. Edit the dimension description, as necessary. This is the only information on 
this tab that you can edit.

5. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window.

ADDING DIMENSION VALUES

Use the following instructions to add dimension values.
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1.  Click Maintenance > Dimensions on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > 
Maintenance > Dimensions from the menu bar. The Dimensions window 
displays, open to the All position (Figure 3.18). 

Figure 3.18—Dimensions Window

2. Select the applicable ID type from the ID Type drop-down list.
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3. Select the applicable dimension from the Dimension drop-down list. The 
existing values display (Figure 3.19). 

Figure 3.19—Dimensions Window—Dimension 2 (Department)

4. Enter the Dimension Value and Description in the bottom (i.e., empty) row.

5. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window. The system asks if you want to create 
descriptive accounts for the new dimension values.

6. Click OK to create these account. For more on these accounts, see Descriptive 
Accounts on page 67.

ASSOCIATING DIMENSIONS AND ATTRIBUTE POSITIONS

Context-sensitive topic: Maintenance—Dimensions
Context-sensitive topic: Maintenance—Attributes
FundWare allows you to define relationships between:

• Dimensions and attribute positions, and
• Dimension values and attribute values.

This is an optional feature to help you maintain control over your chart of accounts and 
to simplify account creation by providing default attribute values when you create 
accounts.
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For example:
• Our account structure is XXX-XX XXXX (Project-Grant Object). 
• We define attribute position 4 as Project Manager. This allows us to include the 

name of the Project Manager with accounts for which they are responsible and 
in reports. However, it is an easy value to change when necessary.

• We define attribute position 6 as Location. 
• We associate dimension 1 (Project) with attribute position 4 (Project Manager) 

and attribute position 6 (Location)
• We further associate the values of dimension 2 with the attribute values for 

positions 4 and 6 (Table 3.4). 

• When we create a new account using dimension 100, attribute position 4 
(Project Manager) defaults to JF (Jeanne Foster) and attribute position 6 
(Location) defaults to CC (Community Center).

ADDING ASSOCIATIONS

Use the following instructions to associate a dimension with an attribute position. 
(Remember: Use of this feature is optional. It is intended to give you greater control 
over account creation and make the process easier.)

1.  Click Maintenance > Dimensions on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > 
Maintenance > Dimensions from the menu bar. The Dimensions window 
displays, open to the All position. 

2. Select the applicable ID type from the ID Type drop-down list.

Table 3.4—Example Dimension and Attribute Value Associations

Dimension 1 (Project) Attribute Position 4 (Project Manager) Attribute Position 6 (Location)

Value Description Value Description Value Description

100 Adult Literacy JF Jeanne Foster CC Community Center

200 Teen Literacy JF Jeanne Foster HS High School

300 After School Care RRK Robert R. Kirk PR Parks and Recreation 
Offices

400 Elder Care PBJ Paula B. Jones CC Community Center
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3. Select the applicable dimension from the Dimension drop-down list. The 
existing values display (Figure 3.20). 

Figure 3.20—Dimensions Window—Dimension 1 (Project)
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4. Click Edit Attribute Associations. The Dimension & Attribute Position 
Associations window displays (Figure 3.21). 

Figure 3.21—Dimension & Attribute Position Associations Window

5. Select the check box for one or more attribute positions that you want associated 
with the dimension. (Your selection here will impact what displays when you 
add or view your accounts. For example, see Adding Accounts With Account 
Builder on page 132 and Using the Chart of Accounts on page 141.)
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6. When complete, click OK. Columns are added to the Dimensions window for 
each attribute position selected (Figure 3.22). 

Figure 3.22—Example Attribute Positions Associated With Dimension 1

7. For each dimension value, click the attribute cell and select an attribute value 
from the drop-down list (Figure 3.23). 

Figure 3.23—Attribute Value Drop-Down List

You can begin typing the attribute value. When the system has searched 
for and found the matching value, press ENTER to accept the value and 
move to the next cell.
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8. Continue entering attribute values until you are done (Figure 3.24). 

Figure 3.24—Attribute Values Assigned to Dimension Values

9. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window.

EDITING DIMENSION VALUES

Use the following instructions to edit the description or associations for a dimension 
value. However, edits to the dimension value are not reflected in the associated 
descriptive account. If you want your changes reflected in the descriptive account (e.g., 
for reporting purposes), you must modify the account manually.

1.  Click Maintenance > Dimensions on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > 
Maintenance > Dimensions from the menu bar. The Dimensions window 
displays, open to the All position. 

2. Select the applicable ID type from the ID Type drop-down list.

3. Select the applicable dimension from the Dimension drop-down list. The 
existing values display. 

4. Edit the Description and/or attribute position and value assignments, as 
necessary.
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You cannot edit the dimension value. Under certain circumstances, you 
can delete a dimension value. See Deleting Dimension Values on page 
94.

5. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window.

DELETING DIMENSION VALUES

You can only delete a dimension value if no accounts (including a descriptive account) 
have been created using that value. Use the following instructions to delete a dimension 
value.

1.  Click Maintenance > Dimensions on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > 
Maintenance > Dimensions from the menu bar. The Dimensions window 
displays, open to the All position. 

2. Select the applicable ID type from the ID Type drop-down list.

3. Select the applicable dimension from the Dimension drop-down list. The 
existing values display. 

4. Select the row containing the dimension value.

5. Click Delete Row or right-click and select Delete Row from the shortcut menu. 
A confirmation message displays.

6. Click Yes to delete the dimension value.

7. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window.

PRINTING YOUR DIMENSION VALUES

You can print the values for each dimension.
1.  Click Maintenance > Dimensions on the module navigator (if the module is 

not expanded, click General Ledger first) or select General Ledger > 
Maintenance > Dimensions from the menu bar. The Dimensions window 
displays. 

2. Select the applicable ID type from the ID Type drop-down list.
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3. Select the applicable dimension from the Dimension drop-down list. The 
existing values display. 

4. Click Print Grid or right-click and select Print Grid from the shortcut menu. 
The preview window displays from which you can print your attribute 
information.

5. Click OK or Cancel to close the window. 

If you have completed other tasks while in this window (e.g., adding an 
attribute, editing a position name), clicking Cancel will negate your 
changes.

MAINTAINING YOUR ATTRIBUTES
Context-sensitive topic: Maintenance—Attributes
Attribute positions and attribute values are position-specific codes (1 to 3 alphanumeric 
characters) that you assign to specific positions in your accounts to allow you to:

• Produce better reports (e.g., define combined reports, filter reports)
• Enhance inquiries
• Define advanced allocations
• Set budget control
• Update groups of accounts

ATTRIBUTE POSITIONS

Context-sensitive topic: Maintenance—Attributes
Each account number can include up to 15 attributes in an attribute string. These 
attributes are entered by position. 

For example, when you defined your ID type, you had the chance to accept or 
redefine the default attributes. These attributes are automatically assigned to 
position 1 (System Reserved) and are used to define the type of account (e.g., 
revenue, expense). Because position 1 is a required position, you must assign 
one of these attributes to position 1 when you define an account.

When you are defining attributes, you can enter meaningful names for positions 2–15. 
(Position 1 is defined as “System Reserved” and you cannot modify this name.) 
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You may also occasionally define an attribute value that applies to all attribute positions 
(it is not likely that you will do this often). 

DEFINING YOUR ATTRIBUTE POSITIONS

Use the following instructions to define your attribute positions.
1.  Click Maintenance > Attributes on the module navigator (if the module is not 

expanded, click General Ledger first) or select General Ledger > 
Maintenance > Attributes from the menu bar. The Attributes window displays, 
open to the All position (Figure 3.25). 

Figure 3.25—Attributes Window

2. Select the applicable ID type from the ID Type drop-down list.
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3. Select the attribute position from the Attribute drop-down list. The position 
name, required setting, and any existing attributes display (Figure 3.26). 

Figure 3.26—Example Attribute Position 3

4. Enter a position name significant to your organization. (Remember, this 
position name applies to this position on all accounts.)

If you define a position name that is the same as a dimension position 
(e.g., your first dimension is named “Fund” and attribute position 5 is 
also named “Fund”), FundWare will display “A-” before the attribute 
column heading (e.g., your column headings would be “Fund” and “A-
Fund”).

5. Select the Required check box to require an entry on this attribute position for 
all accounts.

6. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window.

ATTRIBUTE VALUES

Attribute values are the individual codes that you apply to each account. For example, 
some of the attribute values defined for sample division 95 include the following:

• RE (Revenue)—Position 1 (System Reserved)
• EX (Expenditure)—Position 1 (System Reserved)
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• T2 (Enterprise)—Position 3
• D5 (Ice Rink)—Position 5

You can enter additional attribute values for position 1 or for any of the remaining 14 
positions of the attribute string. You can also modify the attribute definition and delete 
obsolete attributes.

ADDING ATTRIBUTE VALUES

Use the following instructions to add a new attribute value for an ID type. 
1.  Click Maintenance > Attributes on the module navigator (if the module is not 

expanded, click General Ledger first) or select General Ledger > 
Maintenance > Attributes from the menu bar. The Attributes window displays, 
open to the All position (Figure 3.27). 

Figure 3.27—Attributes Window

2. Select the applicable ID type from the ID Type drop-down list.
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3. Select the attribute position from the Attribute drop-down list. The position 
name, required setting, and any existing attributes display (Figure 3.28). 

Figure 3.28—Example Attribute Position 3

4. If necessary, modify the position name. (Remember, this position name applies 
to this position on all accounts.)

5. Select the Required check box to require an entry on this attribute position for 
all accounts. (This setting will apply to the position, not just to the attribute that 
you are defining at this time.)

6. Enter up to three characters for the attribute name in the Value cell of the first 
free row. (The asterisk will indicate the first free row.)

7. Enter a description of the attribute value. You can enter up to 60 alphanumeric 
characters.

You can include this attribute description on reports. See Chapter 10—
Understanding GL–P/G Reports on page 245 for more information.

8. Select the applicable radio button (Active or Inactive) to indicate the status of 
the attribute.

9. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window.
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EDITING AN ATTRIBUTE VALUE

Use the following instructions to edit an attribute value.
1.  Click Maintenance > Attributes on the module navigator (if the module is not 

expanded, click General Ledger first) or select General Ledger > 
Maintenance > Attributes from the menu bar. The Attributes window displays, 
open to the All position. 

2. Select the applicable ID type from the ID Type drop-down list.

3. Select the attribute position from the Attribute drop-down list. The position 
name, required setting, and any existing attributes display. 

4. Make your changes to the attribute, as necessary.

Remember: Changes made to the Attribute Position Name or Required 
setting are not specific to individual attribute values. These changes 
apply to the position as it appears or is used on all accounts. 

5. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window.

DELETING AN ATTRIBUTE VALUE

Use the following instructions to delete an attribute value. (However, if you have 
applied the attribute value to an account, you should make the value inactive rather than 
delete it from your system.)

1.  Click Maintenance > Attributes on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > 
Maintenance > Attributes from the menu bar. The Attributes window displays, 
open to the All position. 

2. Select the applicable ID type from the ID Type drop-down list.

3. Select the attribute position from the Attribute drop-down list. The position 
name, required setting, and any existing attributes display. 

4. Select the row containing the attribute value.

5. Click Delete Row or right-click and select Delete Row from the shortcut menu. 
A confirmation message displays.

6. Click Yes to delete the attribute value.
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7. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window. (Clicking Cancel will negate your 
deletion. In other words, the attribute will remain in your system.)

PRINTING YOUR ATTRIBUTE VALUES

You can print the values for each attribute position.
1.  Click Maintenance > Attributes on the module navigator (if the module is not 

expanded, click General Ledger first) or select General Ledger > 
Maintenance > Attributes from the menu bar. The Attributes window displays, 
open to the All position. 

2. Select the applicable ID type from the ID Type drop-down list.

3. Select the attribute position from the Attribute drop-down list. The position 
name, required setting, and any existing attributes display. 

4. Click Print Grid or right-click and select Print Grid from the shortcut menu. 
The preview window displays from which you can print your attribute 
information.

5. Click OK or Cancel to close the window. 

If you have completed other tasks while in this window (e.g., adding an 
attribute, editing a position name), clicking Cancel will negate your 
changes.

MAINTAINING YOUR JOURNALS
A journal is a book of original entry that records transactions to be posted to a ledger (or 
area of the database). When you enter a transaction (e.g., a GL journal entry, an AP 
obligation), that information is posted to the database through these journals. 
These different journal types allow you to enter differing types of information (e.g., 
budget entries will post to a budget journal). The defaults on the journal entry form may 
reflect your journal settings. (For example, you can assign data items to a journal. See 
Example Data Items—On Journals on page 62.)
When you add an ID type, the system allows you to select which default journals you 
would like created (the actual journal, GJNL + the ID type, is always created). You can 
modify the existing journal definitions, add new journals, or delete journals to which 
you have not yet posted information.
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MODIFYING YOUR SYSTEM-DEFINED JOURNALS

When you define your ID type, the system automatically creates one journal (an actual 
journal) and you have the option to create three additional journals: 

• Budget,
• Encumbrance, and
• Commitment.

The possible system-defined journals created when you define an ID type include the ID 
type letter as the last character of the journal name (Table 3.5). 

However, you must complete some definition tasks for these journals before you can 
correctly use the journal.

Table 3.5—Example Default Journals for ID Type A

Journal Building the Name Journal Name

General (i.e., actual) GJNL + ID type A GJNLA

Budget BDGT + ID type A BDGTA

Encumbrance ENCM + ID type A ENCMA

Commitment COMM + ID type A COMMA
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1.  Click Maintenance > Journals on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > 
Maintenance > Journals from the menu bar. The Journals window displays, 
open to the General tab of the first journal in your list of journals (Figure 3.29). 

Figure 3.29—Journals Window—General Tab

2. Select the journal to be modified from the Journal Name drop-down list. The 
journal displays, open to the General tab.

3. Modify the fields according to Table 3.6. 

Table 3.6—Journal Field Definitions

Field Valid Entry Definition

Description Up to 30 
alphanumeric 
characters

Modify the system-defined a description of the journal.
• This title is displayed on the journal entry form.

Posting 
Type

• Actual
• Budget Type 1
• Budget Type 2
• Encumbrance
• Commitment

You can change the system-defined posting type by selecting a 
new type from the drop-down menu. The posting type defines the 
type of entries that you will post to the journal, and defines how 
the information is stored.
• For more information on posting types, see Posting Types on 

page 55.
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Entry 
Security

• Data entry is 
allowed.

• Data entry is not 
allowed.

Select the entry security setting from the drop-down menu. 
• Allowing data entry means that you will be allowed to add 

journal entries directly into this journal. 
• Disallowing data entry means that you will add journal entries to 

this journal from another module, such as Accounts Payable. 
This allows you to segregate your entries from other modules.

• The default setting is “Data entry is allowed.”

Trace 
Report

• No trace report
• Detail list only
• Summary only
• Both detail & 

summary

Select the select option for the amount of information you want to 
include in trace reports from the drop-down menu.
• The default setting is “Both detail & summary.”
• We recommend that you retain this default.

Item 
Destination

Up to 30 
alphanumeric 
characters

The journal entry form provides a field for you to describe the 
entry. This field allows you to customize the title of this field.
• The default entry is “Description.”

Reference 
Titles
• Title 1
• Title 2
• Title 3

Up to 10 
alphanumeric 
characters

Context-sensitive topic: Maintenance—Journals (Reference 
Titles)
Each journal entry form will display three reference fields (default 
titles: Ref 1, Ref 2, Ref 3). The Title fields allow you to customize 
the reference field titles for this journal.
• The default titles are Ref 1, Ref 2, and Ref 3. If you delete any 

of the defaults, the fields will display on the journal entry form 
as Reference 1, Reference 2, and/or Reference 3.

For example, in a journal that handles only General Ledger 
journal entries:
• JE Number (for Journal Entry Number), or
• Source.
In a journal that handles only Accounts Receivable journal 
entries:
• Deposit Number, or
• Check Number.
Enter your field description in the applicable Title fields.

Table 3.6—Journal Field Definitions (Continued)

Field Valid Entry Definition
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4. Select the ID Types tab. The only entry is the ID type for which this journal was 
created. The Description, Required, Balancing, Due To/From, and Suspense 
fields are filled with the default settings:

• Description—From the ID type definition. This field is not editable (i.e., 
you cannot change this entry).

• Required—Defaults to Required.
• Balancing—Defaults to Manual.

Additional 
Data Items
• Item 1
• Item 2
• Item 3

A valid data item or 
“None.”

Context-sensitive topic: Maintenance—Journals (Addition Data 
Items)
Each journal entry form allows you to add up to three data item 
fields to the journal entry form for this journal. This information will 
also be included (if applicable) when you post to the journal from 
another module.
• By default, “None” is selected and no data items fields will 

display on the journal entry form.
For example, you add a field to include a P.O. number on a GL 
journal entry form for this journal.
• The P.O. number field (using the data item name, not 

description) displays on the form.
• You enter the information when you add a journal entry.
• The P.O. number is posted to the database along with the other 

journal entry information.
Additionally, you define this journal to allow posting from other 
modules, define AP to post to this journal, and define AP to 
include P.O. number on the obligation entry form.
• The P.O. number field displays on the obligation entry form.
• You enter the information when you add an obligation.
• The information is posted to the journal (and the database) 

when you post the obligation.
Select either “None” (the default) or a valid data item from the 
Additional Data Item drop-down menus (i.e., Item 1, Item 2, and 
Item 3). 
• The data item description will display in the text box to the right.
• If you select “None,” no data item field will display for that 

selection.
See Maintaining Your Data Items on page 113 for more 
information on data items.

Table 3.6—Journal Field Definitions (Continued)

Field Valid Entry Definition
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• Due To/From—Defaults to an account number of all zeros (e.g., A00 00-00 
0000).

• Suspense—Defaults to an account number of all zeros (e.g., A00 00-00 
0000) (Figure 3.30). 

Figure 3.30—Journals Window—ID Type Tab

5. You can modify the Required setting by clicking the cell and selecting an option 
from the drop-down menu (i.e., Required, Optional, One of). For more 
information on the implications of this setting, see Defining Your Journals to 
Use Multiple ID Types on page 57.

6. You can modify the Balancing setting by clicking the cell and selecting an 
option from the drop-down menu (i.e., Manual or Automatic). For more 
information on the implications of this setting, see Balancing Your Entries on 
page 38. 

7. Enter your Due To/From account pattern. For more information on this entry, 
see Defining Your Due To/From Account Pattern on page 43. 

This field will default to zeros for the account pattern numbers. 
However, because this can result in unexpected balancing entries, we 
strongly recommend that you complete this field with an applicable 
account pattern.

8. Enter your Suspense account. For more information on this entry, see Suspense 
Accounts on page 57.
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9. Add any additional ID types for cross-ID type posting to this journal. See 
Defining Your Journals to Use Multiple ID Types on page 57 for more 
information.

If you want to twin accounts (or append accounts), you must enter 
multiple ID types (Figure 3.31). See Twin Dimensions on page 45 for 
more information. 

Figure 3.31—Journal ID Types Tab

10. Click Apply to save your entries and remain in the Journals window or click 
OK to save your entries and close the window. You can now use the system-
defined journal to post transactions.

ADDING A JOURNAL

Use the following instructions to add a journal to your division.
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1.  Click Maintenance > Journals on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > 
Maintenance > Journals from the menu bar. The Journals window displays, 
open to the General tab of the first journal in your list of journals (Figure 3.32). 

Figure 3.32—Journals Window—General Tab

2. Click New. The journal information is cleared or returns to the default settings.

3. Complete the required fields according to Table 3.7. 

Table 3.7—Journal Field Definitions

Field Valid Entry Definition

Description Up to 30 
alphanumeric 
characters

Modify the system-defined a description of the journal.
• This title is displayed on the journal entry form.

Posting 
Type

• Actual
• Budget Type 1
• Budget Type 2
• Encumbrance
• Commitment

You can change the system-defined posting type by selecting a 
new type from the drop-down menu. The posting type defines the 
type of entries that you will post to the journal, and defines how 
the information is stored.
• For more information on posting types, see Posting Types on 

page 55.
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Entry 
Security

• Data entry is 
allowed.

• Data entry is not 
allowed.

Select the entry security setting from the drop-down menu. 
• Allowing data entry means that you will be allowed to add 

journal entries directly into this journal. 
• Disallowing data entry means that you will add journal entries to 

this journal from another module, such as Accounts Payable. 
This allows you to segregate your entries from other modules.

• The default setting is “Data entry is allowed.”

Trace 
Report

• No trace report
• Detail list only
• Summary only
• Both detail & 

summary

Select the select option for the amount of information you want to 
include in trace reports from the drop-down menu.
• The default setting is “Both detail & summary.”
• We recommend that you retain this default.

Item 
Destination

Up to 30 
alphanumeric 
characters

The journal entry for provides a field for you to describe the entry. 
This field allows you to customize the title of this field.
• The default entry is “Description.”

Reference 
Titles
• Title 1
• Title 2
• Title 3

Up to 10 
alphanumeric 
characters

Each journal entry form will display three reference fields (default 
titles: Ref 1, Ref 2, Ref 3). The Title fields allow you to customize 
the reference field titles for this journal.
• The default titles are Ref 1, Ref 2, and Ref 3. If you delete any 

of the defaults, the fields will display on the journal entry form 
as Reference 1, Reference 2, and/or Reference 3.

For example, in a journal that handles only General Ledger 
journal entries:
• JE Number (for Journal Entry Number), or
• Source.
In a journal that handles only Accounts Receivable journal 
entries:
• Deposit Number, or
• Check Number.
Enter your field description in the applicable Title fields.

Table 3.7—Journal Field Definitions (Continued)

Field Valid Entry Definition
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Additional 
Data Items
• Item 1
• Item 2
• Item 3

A valid data item or 
“None.”

Each journal entry form allows you to add up to three data item 
fields to the journal entry form for this journal. This information will 
also be included (if applicable) when you post to the journal from 
another module.
• By default, “None” is selected and no data items fields will 

display on the journal entry form.
For example, you add a field to include a P.O. number on a GL 
journal entry form for this journal.
• The P.O. number field (using the data item name, not 

description) displays on the form.
• You enter the information when you add a journal entry.
• The P.O. number is posted to the database along with the other 

journal entry information.
Additionally, you define this journal to allow posting from other 
modules, define AP to post to this journal, and define AP to 
include P.O. number on the obligation entry form.
• The P.O. number field displays on the obligation entry form.
• You enter the information when you add an obligation.
• The information is posted to the journal (and the database) 

when you post the obligation.
Select either “None” (the default) or a valid data item from the 
Additional Data Item drop-down menus (i.e., Item 1, Item 2, and 
Item 3). 
• The data item description will display in the text box to the right.
• If you select “None,” no data item field will display for that 

selection.
See Maintaining Your Data Items on page 113 for more 
information on data items.

Table 3.7—Journal Field Definitions (Continued)

Field Valid Entry Definition
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4. Click the ID Types tab (Figure 3.33). 

Figure 3.33—Journal ID Types Tab

5. Select the ID type from the ID drop-down menu. The ID type defaults display:

• Description—From the ID type definition. This field is not editable (i.e., 
you cannot change this entry).

• Required—Defaults to Required.
• Balancing—Defaults to Manual.
• Due To/From—Defaults to an account number of all zeros (e.g., A00 00-00 

0000). (Displays when you move off the ID type cell.)
• Suspense—Defaults to an account number of all zeros (e.g., A00 00-00 

0000). (Displays when you move off the ID type cell.)
6. You can modify the Required setting by clicking the cell and selecting an option 

from the drop-down menu (i.e., Required, Optional, One of). For more 
information on the implications of this setting, see Defining Your Journals to 
Use Multiple ID Types on page 57. 

7. You can modify the Balancing setting by clicking the cell and selecting an 
option from the drop-down menu (i.e., Manual or Automatic). For more 
information on the implications of this setting, see Balancing Your Entries on 
page 38.

8. Enter your Due To/From account pattern. For more information on this entry, 
see Defining Your Due To/From Account Pattern on page 43.

This field will default to zeros for the account pattern numbers. 
However, because this can result in unexpected balancing entries, we 
strongly recommend that you complete this field with an applicable 
account pattern.
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9. Enter your Suspense account. For more information on this entry, see Suspense 
Accounts on page 57.

10. Add any additional ID types for cross-ID type posting to this journal. See 
Defining Your Journals to Use Multiple ID Types on page 57 for more 
information. 

If you want to twin accounts (or append accounts), you must enter 
multiple ID types (Figure 3.34). See Twin Dimensions on page 45 for 
more information. 

Figure 3.34—Journal ID Types Tab

11. Click Apply to save your entries and remain in the Journals window or click 
OK to save your entries and close the window. You can now use the system-
defined journal to post transactions.

EDITING JOURNALS

Use the following instructions to edit your journals.
1.  Click Maintenance > Journals on the module navigator (if the module is not 

expanded, click General Ledger first) or select General Ledger > 
Maintenance > Journals from the menu bar. The Journals window displays, 
open to the General tab of the first journal in your list of journals. 

2. Select the journal to be modified from the Journal Name drop-down list. The 
journal displays, open to the General tab.

3. Modify the information on the General and ID Types tabs as necessary.

4. Click Apply to save your entries and remain in the Journals window or click 
OK to save your entries and close the window. 
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DELETING JOURNALS

Use the following instructions to delete journals.
You cannot delete a journal that has transaction information (i.e., to which you 
have posted transactions.

1.  Click Maintenance > Journals on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > 
Maintenance > Journals from the menu bar. The Journals window displays, 
open to the General tab of the first journal in your list of journals. 

2. Select the journal to be deleted from the Journal Name drop-down list. The 
journal displays, open to the General tab.

3. Click Delete. A confirmation message displays.

Delete will be disabled if you have used this journal to post a 
transaction. You cannot delete the journal.

4. Click Yes. The journal is deleted.

5. Click OK or Cancel to close the Journals window. 

MAINTAINING YOUR DATA ITEMS
Context-sensitive topic: Maintenance—Data Items
Data items are description elements that can be used to store financial or non-financial 
information about an account or a transaction. When you defined your ID type, you had 
the chance to select default data items. FundWare also allows you to add additional data 
items for the ID type, modify the data item definition, and delete obsolete data items.

ADDING DATA ITEMS

Use the following instructions to define a data item.
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1.  Click Maintenance > Data Items on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > 
Maintenance > Data Items from the menu bar. The Data Items window 
displays (Figure 3.35). 

Figure 3.35—Data Items Window

2. Click New. All entry fields clear and the cursor appears in the Data Item text 
box.

3. In the Data Item text box, enter a name (up to 10 alphanumeric characters, 
including blank spaces) for the new data item. 

4. In the Data Type text box, select the type of data that will be stored for this data 
item. Table 3.8 has a descriptions of the available data types. 

Table 3.8—Available Data Types

Data Type Definition

Not Used For an unused data item

Signed (15), number 15-digit numeric field, no decimal points. 
• For whole number values. 
• Allows negative or positive numbers.

Signed (13.2), amount 15-digit numeric field, two decimal places. 
• For amount-type values (dollars).
• Allows negative or positive numbers.

Signed (9.6), rate 15-digit numeric field, six decimal places. 
• For a rate-type value (per unit).
• Allows negative or positive numbers.
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5. In the Description field, enter up to 30 characters to describe the data item.

6. In the Prompt field, enter an abbreviated description of the data item (up to 10 
characters). This is the description that will display when you use this data item 
(e.g., as a column heading on the journal entry form).

7. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window.

EDITING A DATA ITEM

Use the following instructions to edit a data item.
1.  Click Maintenance > Data Items on the module navigator (if the module is not 

expanded, click General Ledger first) or select General Ledger > 
Maintenance > Data Items from the menu bar. The Data Items window 
displays. 

2. Select the data item you want to edit from the Data Item drop-down list.

3. Edit the data item, as necessary.

4. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window.

Numeric (mm/dd/yyyy), date Calendar dates.

Numeric (10), area code and nbr Telephone numbers.

Alphanumeric (10), keyword Text field (numbers, letters, characters, blank spaces), 10 character 
maximum.

Alphanumeric (35), text Text field (numbers, letters, characters, blank spaces), 35 character 
maximum.

Alphanumeric (55), extended 
text

Text field (numbers, letters, characters, blank spaces), 55 character 
maximum.

Table 3.8—Available Data Types (Continued)

Data Type Definition
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DELETING A DATA ITEM

You can delete a data item even if you have entered data for it in the past. Deleting will 
not affect your financial data. You can re-create a data item if you delete one by mistake. 
Use the following instructions to delete a data item.

1.  Click Maintenance > Data Items on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > 
Maintenance > Data Items from the menu bar. The Data Items window 
displays. 

2. Select the data item you want to edit from the Data Item drop-down list.

3. Click Delete. A confirmation message displays.

4. Click Yes. The attribute is deleted.

5. Click OK to close the window.

MAINTAINING YOUR DATE TABLES
Context-sensitive topic: Maintenance—Date Tables
Your date tables define the periods of time to which you can post transaction 
information within a fiscal year. FundWare creates date tables based on your year-end 
date, reporting period, and increment selections when you created the ID type.

DATE TABLE EXAMPLE

If you use a business date of 07/31/2004 to you define ID type A with the following:
• Year-end date: 12/31/2005,
• Reporting period: Monthly, and
• Increment: 2

FundWare creates two date tables:
• 2004, and
• 2005.
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Within each date table, the FundWare creates the following detail date periods (defined 
by the ending date of the period) for year-end 12/31/2004: 

The system also creates the following detail date periods for year-end 12/31/2005: 

At the end of the 2005 fiscal year (or sometime before the end of the year), you would 
need to define a new date table for 2006.

We recommend that you wait to add date tables until you are ready to use them. 
Extra Date Tables may interfere with the Roll Beginning Balances task (see 
Rolling Beginning Balances on page 225). 

ADDING NEW DATE TABLES

Use the following instructions to add a date table.

• 02/29/2004 • 06/30/2004 • 10/31/2004

• 04/30/2004 • 08/31/2004 • 12/31/2004

• 02/28/2005 • 06/30/2005 • 10/31/2005

• 04/30/2005 • 08/31/2005 • 12/31/2005
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1.  Click Maintenance > Date Tables on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > 
Maintenance > Date Tables from the menu bar. The Date Tables window 
displays (Figure 3.36). 

Figure 3.36—Date Tables Window

2. Click New. The Add New Date Table window displays (Figure 3.37). 

Figure 3.37—Adding a New Date Table

3. Select the ID type for the new date table from the ID Type drop-down list.

4. From the Adjustments drop-down list, select the number of periods following 
the close of the fiscal year that you can post audit and year-end adjustments.
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5. Select the Next Year or Previous Year radio button in the Add Date Table For 
section to indicate to which year you are adding the date table.

If you select Next Year, the first day of the new date table is the day 
after the last year end of existing date tables. If you select Previous 
Year, FundWare creates a date table prior to the earliest date table in the 
system.

6. Click OK. The date table and associated detail date periods are added.

EDITING A DATE TABLE

While you can edit the information associated with a date table, there are two rules you 
must follow when editing date tables:

• You cannot edit a date table to which you have posted any activity.
• You can only edit the following information in the date table:

— The number of adjustment periods.
— The detail date periods by adding or deleting periods.
— Adding and deleting periods in the Detail Date Periods box.

If the fields are disabled, you have posted activity to the date table and it cannot be 
edited. See the Fiscal Year Information box in the Activity field to confirm that activity 
has been posted to the date table (Figure 3.38). 

Figure 3.38—Fiscal Year Information for a Date Table

Use the following instructions to edit a date table.
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1.  Click Maintenance > Date Tables on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > 
Maintenance > Date Tables from the menu bar. The Date Tables window 
displays (Figure 3.39). 

Figure 3.39—Date Tables Window

2. Select the ID type for the date table from the ID Type drop-down list.

3. Select the date table’s year ending date from the Year end drop-down list.

4. Modify the number of adjustment periods or the detail date periods, as 
applicable.

5. To add a new detail date period, click Add. The Calendar displays. 
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6. Select the last day of the detail date period that you want to add (Figure 3.40). 

Figure 3.40—Date Table Calendar

7. Click OK. The new date table is added to the list of detail date periods.

8. To delete a period, select the one you want to delete and click Delete (within the 
Detail Date Period area of the window).

9. Click Apply to save your changes and remain in the Date Tables window or 
click OK to save your changes and close the window.

DELETING A DATE TABLE

While you can delete a date table, one rule applies:
• You cannot delete a date table to which you have posted any activity.
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If Delete is disabled, you have posted activity to the date table and it cannot be deleted. 
See the Fiscal Year Information box in the Activity field to confirm that activity has 
been posted to the date table (Figure 3.41). 

Figure 3.41—Fiscal Year Information for a Date Table

Use the following instructions to delete a date table. 
1.  Click Maintenance > Date Tables on the module navigator (if the module is 

not expanded, click General Ledger first) or select General Ledger > 
Maintenance > Date Tables from the menu bar. The Date Tables window 
displays. 

2. Select the ID type for the date table from the ID Type drop-down list.

3. Select the date table’s year ending date from the Year end drop-down list.

4. Click Delete. A confirmation message displays.

5. Click OK. The date table is deleted.

GLOBAL SETTINGS
The Global Settings task allows you to adjust the posting settings (i.e., posting window 
and posting unit/rates) for your entire system. When you change the settings on this 
window, you override the individual definitions for each ID type and apply the change 
to all ID types. This window also allows you to view information about each ID type:

• Locked periods,
• Associated module (i.e., General Ledger or Project/Grant), and
• Roll option selection.

Use the following instructions to view or edit the global settings.
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1.  Click Maintenance > Global Settings on the module navigator (if the module 
is not expanded, click General Ledger first) or select General Ledger > 
Maintenance > Global Settings from the menu bar. The Global Settings 
window displays (Figure 3.42). 

Figure 3.42—Global Settings Window

2. If necessary, adjust the posting settings. (Remember: Any change will be 
applied to all ID types within the division.)

3. Click Print Grid or right-click and select Print Grid from the shortcut menu. 
The preview window displays from which you can print your attribute 
information.

4. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window.

IMPORTING/EXPORTING
The General Ledger > Maintenance menu includes an option to export detail 
transactions. All information on importing and exporting, including this task, is 
presented in the Blackbaud FundWare System Administration Guide. 
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C H A P T E R  4

ADDING AND MAINTAINING ACCOUNTS

Accounts are the heart of your accounting system, and FundWare has designed two 
table-driven account creation tasks to simplify the process and provide your 
organization with greater control over your Chart of Accounts:

• New Accounts—Add one or more individual accounts.
• Account Builder—“Build” groups of accounts by selecting dimension values, 

from which FundWare creates all possible combinations. Once you have your 
combinations, you assign attribute values. 

Before defining accounts, you define many of the separate pieces of the account (e.g., 
dimension values, attributes, data items). When you are ready to add accounts, you 
“build” your account using these pieces. See Chapter 3—Defining and Maintaining GL–
P/G on page 69 for instructions to define these items. (You can also maintain your 
existing accounts through the Account Utilities task.)

ADDING INDIVIDUAL ACCOUNTS
Use the following instructions to add one or more individual accounts. 

Before adding an account, you must define your dimension values (see 
Maintaining Your Dimensions on page 84). 

You should also define your attributes and data items (see Maintaining Your 
Attributes on page 95 and Maintaining Your Data Items on page 113), although 
you can add this information (except the position 1 attribute) at a later date. 
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1.  Click Accounts > New Account on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > Accounts > 
New Account from the menu bar. The New Account window displays (Figure 
4.1). 

Figure 4.1—New Account Window—ID Type A in Sample Division 95

2. Select the ID type from the ID Type drop-down list. The columns displayed in 
the grid may change to reflect the account structure of the selected ID type 
(Figure 4.2). 

Figure 4.2—New Account Window—ID Type F in Sample Division 95
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3. Enter the dimension, description, and status information according to Table 4.1. 

Tip: You can use TAB or ENTER to move from one cell to the next in this 
form. Press the down arrow key to activate and move through a drop-
down list, and press ENTER to select an option.

Table 4.1—Defining the Account Dimension Values, Description, and Status

Account Element Valid Entry Description

Dimensions
• Reflect your 

account structure

Existing 
dimension value

Each of your dimensions display in a separate column. The 
dimension name displays as the column heading.
Select a dimension value from the drop-down list. (You 
cannot enter a new dimension value on this form. The value 
must already exist in your system.)
• For example, we have four dimensions in division 95: fund, 

department, sub-department, and object. Therefore, the 
New Account window displays these dimensions in four 
columns.

Description Up to 30 
alphanumeric 
characters

Enter the account description. 

Status Active
Budget
Descriptive
Inactive
System

Select the account status from the drop-down list:
• Active—You can post any type of transaction to an active 

account.
• Budget—You can post only budget entries to a budget 

account.
• Descriptive—You cannot post any type of transaction to a 

descriptive account. Descriptive accounts can be created 
automatically when you define dimension values. The 
most common use of descriptive accounts is for titles in 
reports.

• Inactive—You cannot post any type of transaction to an 
inactive account. An inactive account may have activity 
from previous posting that is still available for reporting 
(i.e., formerly an active or budget account).

• System—Only system-generated transactions may post to 
a system account. For example, you may use this option to 
ensure that only system-generated entries are posted to 
Accounts Payable control accounts, net asset accounts, 
and auto due to/from accounts.
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4. Double-click the Attributes cell for the account. The Attributes window 
displays (Figure 4.3). 

Figure 4.3—Adding an Account—Attributes Window With Associated Dimensions

If you have associated any dimension values with attribute positions 
and values, that information is reflected in this window. (For more 
information on this feature, see Associating Dimensions and Attribute 
Positions on page 88.)

5. Select the attributes for each position from the Value and Description drop-
down list. 

If the Required box is checked, you must select an attribute or accept a 
default entry for that position.

6. Click OK. Your entries are saved and the Attributes window closes. You return 
to the New Account window.
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7. Double-click the Data Items cell for the account. The Data Items window 
displays (Figure 4.4). 

Figure 4.4—Adding an Account—Data Items Window

If you have defined any data items for this ID type, they will display in 
this window. For more information, see the instructions for the Field 
Use tab of the ID type definition (Editing Your ID Types on page 79).

8. Select any applicable data items from the Data Item Name drop-down list. The 
prompt and value format defined for the data item display in read-only cells 
(Data Item Prompt and Value Format cells, respectively).

9. Enter the data item value in the Value field.

To delete an entry, select the row and click Delete Rows. To print your 
data items, click Print Grid.

10. Click OK. Your entries are saved and the Data Items window closes. You return 
to the New Account window.
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11. Double-click the Aliases cell for the account. The Aliases window displays 
(Figure 4.5). 

Figure 4.5—Adding an Account—Aliases Window

You can only define an alias for the account if you enabled the Alias 1 
and 2 option for the ID type. For more information, see the instructions 
for the Field Use tab of the ID type definition (Editing Your ID Types 
on page 79).

12. Enter up to 30 alphanumeric characters in the Alias 1 and/or Alias 2 fields. 

13. Click OK. Your entries are saved and the Aliases window closes. You return to 
the New Account window.

14. Double-click the Required ID Types cell for the account. The Required ID 
Types window displays the remaining ID types (i.e., all ID types but the one to 
which you are adding an account) defined for your system with a status of <not 
selected> (Figure 4.6). 

Figure 4.6—Adding an Account—Required ID Types Window
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You can only require ID types for the account if you enabled the 
Required Id Types option for the ID type. For more information, see the 
instructions for the Field Use tab of the ID type definition (Editing Your 
ID Types on page 79).

15. Select one of the following options from the Status drop-down list:

• Required—All transactions posted to this new account must also post to an 
account of this ID type.

• One of (Pick at least 2 ID types)—All transactions posted to this new 
account must also post to “one of” the defined additional ID types. 

This feature is referred to as “twinning.” For more information, see Appendix 
E—Using the Twinning Feature on page 367.

16. Click OK. Your entries are saved and the Required ID Types window closes. 
You return to the New Account window.

17. Move to the next row to enter another additional account, if necessary.

To delete an entry, select the row and click Delete Rows. To print your 
data items, click Print Grid.

18. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window.

WHAT IS THE ACCOUNT BUILDER?
The Account Builder feature lets you actually “build” accounts by selecting dimension 
values, from which FundWare creates all possible combinations. Once you have your 
combinations, you assign attribute values. 
For example, our organization has a new project. We have added a new dimension value 
for the second dimension (400–Elder Care) and want to create accounts for this project.

1.  We add a dimension value (400) for the project through the Maintenance > 
Dimension task.

2. In Account Builder, we select the two grants (i.e., dimension 1) already defined 
for our system:

• 01 (UMTA)
• 02 (HUD)
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3. We select the object values (i.e., dimension 3) already defined for our system: 

4. The system creates 44 possible accounts using all combinations of the selected 
dimension values. We must still define attribute values and validate the accounts 
before we can add them to our Chart of Accounts.

5. We save these settings so our manager can review the possible accounts before 
they are added to our Chart of Accounts.

ADDING ACCOUNTS WITH ACCOUNT BUILDER

Before adding accounts with Account Builder, you must define your dimension values 
(see Maintaining Your Dimensions on page 84). You should also define your attributes 
and data items (see Maintaining Your Attributes on page 95 and Maintaining Your Data 
Items on page 113), although you can add this information (except the position 1 
attribute) at a later date. 
Use the following instructions to add accounts. At any point in the process, you can save 
your entries (Saving Account Builder Selections on page 139). 

• 4100 (Revenue sharing)
• 4150 (Grant Income)
• 5020 (Local Match)

• 6110 (Salaries and Wages)
• 6112 (Hourly Wages)
• 6120 (Payroll Taxes)
• 6130 (Employee Benefits)

• We enter a mask of 7XXX to 
select all object values in this 
range.
What Is the Account Builder? 
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1.  Click Accounts > Account Builder on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > 
Accounts > Account Builder from the menu bar. The Account Builder window 
displays (Figure 4.7). 

Figure 4.7—Account Builder—ID Type A in Sample Division 95
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2. Select the ID type to which you are adding accounts. The columns displayed in 
the grid may change to reflect the account structure and attribute positions 
defined for the selected ID type (Figure 4.8). 

Figure 4.8—Account Builder—ID Type F in Sample Division 95

3. Select the Account Status for the new accounts from the drop-down list:

• Active—You can post any type of transaction to an active account.
• Budget—You can post only budget entries to a budget account.
• Descriptive—You cannot post any type of transaction to a descriptive 

account. Descriptive accounts can be created automatically when you 
define dimension values. The most common use of descriptive accounts is 
for titles in reports.

• Inactive—You cannot post any type of transaction to an inactive account. 
An inactive account may have activity from previous posting that is still 
available for reporting (i.e., formerly an active or budget account).

• System—Only system-generated transactions may post to a system account. 
For example, you may use this option to ensure that only system-generated 
entries are posted to Accounts Payable control accounts, net asset accounts, 
and auto due to/from accounts.

Note: The columns for attribute positions 4 
and 6 display the position name: Project 
Manager and Location, respectively.
What Is the Account Builder? 
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4. Select the dimension that the program will use to create the account description 
from the drop-down list (Dimension to use for descriptions). For each 
dimension value defined for the selected dimension, Account Builder will apply 
the value description to the account description.

In most cases, you will select the lowest (i.e., most detailed) dimension 
level. For example, in division 95, the most detailed dimension level in 
all ID types is the Object dimension.

5. Select the Grid Display radio button to determine how the dimension values will 
display:

• Values only—Only the dimension value displays in the cells of the grid.
• Values and descriptions—Both the dimension value and the description 

display in the cells of the grid.
6. Click the column heading to display the dimension value selection window 

(Figure 4.9). The dimension values defined for that dimension display, 
including a “null” value (i.e., all zeros). 

Figure 4.9—Selecting Dimension Values

7. Select individual check boxes for each dimension value or select multiple check 
boxes with any of the following options:

• Click Select All—All dimension values are selected.
• Enter a mask—Enter a mask of the dimension and all dimension values 

matching that mask are selected.
You can remove all your selections by clicking Deselect All.
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If you need to add or modify a dimension value while working in 
Account Builder, click the Edit Dimension Values link to access the 
dimension maintenance window (i.e., Maintenance > Dimensions). 
See Adding Dimension Values on page 86 or Editing Dimension Values 
on page 93 for more information.

8. Click OK. Your entry is added to the grid.

9. Continue selecting values for each dimension. As you make your selections, 
entries are added to the grid reflecting all possible combinations (Figure 4.10). 

Figure 4.10—Example Accounts

Account Builder will enter default attribute values if you have defined attribute/
dimension associations. See Associating Dimensions and Attribute Positions on 
page 88 for more information.

10. Continue to the validation process or save your entries.

Piece by piece, you 
build your accounts.

In this example, we 
associated System Reserved attribute 
values with some of the Object 
dimension values.
Account Builder enters this default for 
the System Reserved attribute position 
(and other attribute/dimension 
associations).
What Is the Account Builder? 
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VALIDATING YOUR ACCOUNTS WITH ACCOUNT BUILDER

The validation process ensures that all accounts built by Account Builder:
• Do not already exist in your Chart of Accounts,
• Have all required attributes,
• Have a description.

When you have entered all your information into the Account Builder grid, use the 
following instructions to validate and, if necessary, correct your entries. 

At any point in this process, you can save your entries. You do not need to wait 
until any errors have been addressed.

1.  Click Validate Accounts. (Your Account Builder selections must be displayed 
in the grid. If you saved your entries and closed Account Builder, open the 
saved selections.) The system reviews your entries and displays the validation 
status for each account (Figure 4.11). 

Figure 4.11—Example Validated Accounts With Errors

2. Review your entries and correct your accounts according to Table 4.2. 
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If you want to return Account Builder to the state before you validated 
(e.g., you want to change the description dimension), click Redo 
Account Selection. A confirmation message informs you that you will 
lose any entries made after validation. 

3. When all your accounts are valid, you are ready to move to the generation task 
(Generating Accounts Created by Account Builder).

GENERATING ACCOUNTS CREATED BY ACCOUNT BUILDER

Any accounts that you create with Account Builder will not be added to your Chart of 
Accounts (i.e., you cannot use them) until you complete the account generation process. 

Table 4.2—Account Validation Messages

Validation Message and Icon Description and Solution

Valid account.

•

Account is valid. 
• When all accounts are valid, you can generate the accounts, at 

which point the accounts will be added to your chart of 
accounts.

Account already exists and cannot 
be created.

•

The account currently exists in your chart of account.
• Select the check box in the Delete column and click Delete 

Checked to remove the account.

Account missing required Attribute 
or Description field is empty.

•

One or both of the following applies:
• You have not defined an attribute value for a required position. 

— Select an attribute value from the drop-down list for all 
required positions.

• The account does not have a description. (This can happen if a 
dimension value does not have a description.)
— In the Description cell for the account, enter up to 30 

alphanumeric characters.
What Is the Account Builder? 
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1.  Click Generate Accounts. (Your Account Builder selections must be displayed 
in the grid. If you saved your entries and closed Account Builder, open the 
saved selections.) Account Builder generates the accounts and displays the 
results (Figure 4.12). 

Figure 4.12—Account Generation Results

If some of your accounts were not created, the reasons will be listed in 
the log file. For example, between the time you validate your Account 
Builder settings and the time you generate your accounts, someone else 
creates one of the accounts. Because the account now exists in your 
system, Account Builder cannot generate that account.

2. Click the link to view a log file of your new accounts.

3. Click OK to close the message. 

PRINTING ACCOUNT BUILDER ENTRIES

Click Print Grid to print the information displayed in the Account Builder window.

SAVING ACCOUNT BUILDER SELECTIONS

At any point in the process, you can save your entries and close the form. At any time in 
the future, you can re-open saved account selections and continue the Account Builder 
process. However, these saved settings are only available to the original user (i.e., if you 
save Account Builder selections, only you will be able to view these settings at a later 
date). 

Saved account builder entries are not added to your chart of account, even if you 
have defined all necessary information and validated the account numbers. 
These accounts will only be added to your Chart of Accounts when you 
generate the accounts (Generating Accounts Created by Account Builder on 
page 138).

Use the following instructions to save your account selections.
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1.  Click the Save Account Selections. The Account Builder Name window 
displays (Figure 4.13). 

Figure 4.13—Account Builder Name

2. Enter a name for the saved selections (up to 30 alphanumeric characters).

3. Click OK. The window closes and you return to Account Builder.

OPENING ACCOUNT BUILDER SELECTIONS

Use the following instructions to open saved account selections that you saved (i.e., you 
cannot access selections saved by another user).

1.  Click Accounts > Account Builder on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > 
Accounts > Account Builder from the menu bar. The Account Builder window 
displays.

2. Click Open Saved. The Saved Account Builder Work window displays (Figure 
4.14). 

Figure 4.14—Opening Saved Selections

3. Select the entry to open.

4. Click OK. You return to Account Builder and your selections display in the 
grid.
What Is the Account Builder? 
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DELETING ACCOUNT BUILDER SELECTIONS

Use the following instructions to delete saved account selections.
1.  Click Accounts > Account Builder on the module navigator (if the module is 

not expanded, click General Ledger first) or select General Ledger > 
Accounts > Account Builder from the menu bar. The Account Builder window 
displays.

2. Click Open Saved. The Saved Account Builder Work window displays (Figure 
4.15). 

Figure 4.15—Opening Saved Selections

3. Select the entry to open.

4. Click Delete. A confirmation message displays.

5. Click Yes. The Account Builder selections are deleted from your system and the 
entry is removed from the Open Saved Selections window.

6. Click OK to return to Account Builder.

USING THE CHART OF ACCOUNTS
The Chart of Accounts (COA) is a table-driven display of the accounts defined for an ID 
type. The feature allows you to sort and filter the information. From the Chart of 
Accounts, you can also add, edit, copy, and delete accounts from this window, as well as 
view account transaction and balance information. 
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VIEWING ACCOUNTS THROUGH THE COA
Use the following instructions to view your accounts through the Chart of Accounts.

1.  Click Accounts > Chart of Accounts on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > 
Accounts > Chart of Accounts from the menu bar. The Chart of Accounts 
displays the first ID type in your list of ID types (Figure 4.16). 

Figure 4.16—Chart of Accounts—Division 95, ID Type A

2. Select an ID type from the drop-down list. The display may change to reflect the 
ID type account structure.

Right-click and select columns to hide or show in the COA. (By default, 
all columns are displayed, including attribute positions, aliases, and 
data items.)
Using the Chart of Accounts 
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3. To move directly to an account, enter one or more numbers in the Jump To text 
box. Focus moves to the first matching record (Figure 4.17). (This feature does 
not change the number of accounts displayed.) 

Figure 4.17—“Jumping To” an Account

In this example, we enter 7 in the first position of the object dimension.

The arrow indicating the row focus moves to the first account matching the 
mask. (Your display may scroll down to display the first matching account.)
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4. To filter the accounts displayed, enter one or more numbers in the dimension 
masks at the top of each column. Accounts not matching the filter settings are 
hidden from the display (Figure 4.18). (This feature changes the number of 
accounts displayed, but does not remove them from your system.) 

Figure 4.18—Filtering the Chart of Accounts Display

5. Click any column heading to sort the display by that column.

If other employees are adding accounts while you have the Chart of 
Accounts window open, these new accounts may not be included in 
your display. Click Refresh at any time to update your display.

ADDING ACCOUNTS THROUGH THE COA
As you view your accounts, you may realize that you need to add one or more accounts 
to your system. (Remember: For adding large numbers of accounts, it is more efficient 
to use the Account Builder.)

1.  Click Accounts > Chart of Accounts on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > 
Accounts > Chart of Accounts from the menu bar. The Chart of Accounts 
displays the first ID type in your list of ID types. 

2. Select an ID type from the drop-down list. The display may change to reflect the 
ID type account structure.

In this example, our entries in the dimension masks reduce the 
display to 10 accounts.
Using the Chart of Accounts 
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Right-click and select columns to hide or show in the COA. (By default, 
all columns are displayed, including attribute positions, aliases, and 
data items.)

3. Click New Account. The New Accounts window displays (Figure 4.19). 

Figure 4.19—New Accounts Window

4. Enter the dimension, description, and status information according to Table 4.3. 

Table 4.3—Defining the Account Dimension Values, Description, and Status

Account Element Valid Entry Description

Dimensions
• Reflect your 

account structure

Existing 
dimension value

Each of your dimensions display in a separate column. The 
dimension name displays as the column heading.
Select a dimension value from the drop-down list. (You 
cannot enter a new dimension value on this form. The value 
must already exist in your system.)
• For example, we have four dimensions in division 95: fund, 

department, sub-department, and object. Therefore, the 
New Account window displays these dimensions in four 
columns.

Description Up to 30 
alphanumeric 
characters

Enter the account description. 
Blackbaud, Inc. 145



Blackbaud FundWare General Ledger–Project/Grant Guide

146
Tip: You can use TAB or ENTER to move from one cell to the next in this 
form. Press the down arrow key to activate and move through a drop-
down list, and press ENTER to select an option.

Status Active
Budget
Descriptive
Inactive
System

Select the account status from the drop-down list:
• Active—You can post any type of transaction to an active 

account.
• Budget—You can post only budget entries to a budget 

account.
• Descriptive—You cannot post any type of transaction to a 

descriptive account. Descriptive accounts can be created 
automatically when you define dimension values. The 
most common use of descriptive accounts is for titles in 
reports.

• Inactive—You cannot post any type of transaction to an 
inactive account. An inactive account may have activity 
from previous posting that is still available for reporting 
(i.e., formerly an active or budget account).

• System—Only system-generated transactions may post to 
a system account. For example, you may use this option to 
ensure that only system-generated entries are posted to 
Accounts Payable control accounts, net asset accounts, 
and auto due to/from accounts.

Table 4.3—Defining the Account Dimension Values, Description, and Status (Continued)

Account Element Valid Entry Description
Using the Chart of Accounts 



Chapter 4—Adding and Maintaining Accounts
5. Double-click the Attributes cell for the account. The Attributes window 
displays (Figure 4.20). 

Figure 4.20—Adding an Account—Attributes Window With Associated Dimensions

If you have associated any dimension values with attribute positions 
and values, that information is reflected in this window. (For more 
information on this feature, see Associating Dimensions and Attribute 
Positions on page 88.)

6. Select the attributes for each position from the Value and Description drop-
down list. 

If the Required box is checked, you must select an attribute or accept a 
default entry for that position.

7. Click OK. Your entries are saved and the Attributes window closes. You return 
to the New Accounts window. 
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8. Double-click the Data Items cell for the account. The Data Items window 
displays (Figure 4.21). 

Figure 4.21—Adding an Account—Data Items Window

If you have defined any data items for this ID type, they will display in 
this window. For more information, see the instructions for the Field 
Use tab of the ID type definition (Editing Your ID Types on page 79).

9. Select any applicable data items from the Data Item Name drop-down list. The 
prompt and value format defined for the data item display in read-only cells 
(Data Item Prompt and Value Format cells, respectively).

10. Enter the data item value in the Value field.

To delete an entry, select the row and click Delete Rows. To print your 
data items, click Print Grid.

11. Click OK. Your entries are saved and the Data Items window closes. You return 
to the New Account window.
Using the Chart of Accounts 
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12. Double-click the Aliases cell for the account. The Aliases window displays 
(Figure 4.22). 

Figure 4.22—Adding an Account—Aliases Window

You can only define an alias for the account if you enabled the Alias 1 
and 2 option for the ID type. For more information, see the instructions 
for the Field Use tab of the ID type definition (Editing Your ID Types 
on page 79).

13. Enter up to 30 alphanumeric characters in the Alias 1 and/or Alias 2 fields. 

14. Click OK. Your entries are saved and the Aliases window closes. You return to 
the New Account window.

15. Double-click the Require ID Types cell for the account. The Require ID Types 
window displays the remaining ID types (i.e., all ID types but the one to which 
you are adding an account) defined for your system with a status of <not 
selected> (Figure 4.23). 

Figure 4.23—Adding an Account—Required ID Types Window
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You can only require ID types for the account if you enabled the 
Required Id Types option for the ID type. For more information, see the 
instructions for the Field Use tab of the ID type definition (Editing Your 
ID Types on page 79).

16. Select one of the following options from the Status drop-down list:

• Required—All transactions posted to this new account must also post to an 
account of this ID type.

• One of (Pick at least 2 ID types)—All transactions posted to this new 
account must also post to “one of” the defined additional ID types. 

This feature is referred to as “twinning.” For more information, see Appendix 
E—Using the Twinning Feature on page 367.

17. Click OK. Your entries are saved and the Required ID Types window closes. 
You return to the New Account window.

18. Move to the next row to enter another additional account, if necessary.

To delete an entry, select the row and click Delete Rows. To print your 
data items, click Print Grid.

19. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and return to the Chart of Accounts display.

EDITING ACCOUNTS THROUGH THE COA
Use the following instructions to edit one or more existing accounts from the Chart of 
Accounts window. You can change any of the information defined for the accounts 
except the dimension values (i.e., account numbers).

1.  Click Accounts > Chart of Accounts on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > 
Accounts > Chart of Accounts from the menu bar. The Chart of Accounts 
displays the first ID type in your list of ID types. 

2. Select an ID type from the drop-down list. The display may change to reflect the 
ID type account structure. 

3. Select one or more accounts and click Edit. (Remember: You can use the Jump 
To or dimension mask features to find your account.) The accounts display in 
the Edit Accounts window.
Using the Chart of Accounts 
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Use SHIFT or CTRL to select multiple accounts.

4. Edit your information, as necessary. (Remember: You cannot edit the dimension 
values.)

5. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window.

DUPLICATING ACCOUNTS THROUGH THE COA
Use the following instructions to copy one or more existing accounts from the Chart of 
Accounts window. Once duplicated, you must specify the dimension values (i.e., 
account numbers).
Use the following instructions to duplicate an account.

1.  Click Accounts > Chart of Accounts on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > 
Accounts > Chart of Accounts from the menu bar. The Chart of Accounts 
displays the first ID type in your list of ID types. 

2. Select an ID type from the drop-down list. The display may change to reflect the 
ID type account structure. 

3. Select one or more accounts and click Duplicate. (Remember: You can use the 
Jump To or dimension mask features to find your account.) The accounts 
display in the Duplicate Accounts window.

Use SHIFT or CTRL to select multiple accounts.

4. Select the dimension values from the drop-down list and edit the account 
information, as necessary.

5. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window.

DELETING AN ACCOUNT THROUGH THE COA
Use the following instructions to delete accounts that have no financial activity. 

If one or more accounts has financial activity, you can only change the status to 
Inactive.
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1.  Click Accounts > Chart of Accounts on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > 
Accounts > Chart of Accounts from the menu bar. The Chart of Accounts 
displays the first ID type in your list of ID types. 

2. Select an ID type from the drop-down list. The display may change to reflect the 
ID type account structure.

3. Select one or more accounts and click Delete. (Remember: You can use the 
Jump To or dimension mask features to find your account.) A confirmation 
message displays.

Use SHIFT or CTRL to select multiple accounts.

4. Click Yes to delete the account or accounts.

VIEWING TRANSACTION INFORMATION
General Ledger–Project/Grant allows you to view account transaction information 
quickly and easily from a task on the menu/navigator bar or from the Chart of Accounts 
window. You can specify a number of different criteria to filter the transactions 
displayed (e.g., date, journals, account mask, dimension values, attribute values).
Viewing Transaction Information 
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1.  Click Accounts > Transactions on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > Accounts > 
Transactions from the menu bar. The Account Transactions window displays 
(Figure 4.24). 

Figure 4.24—Transactions Window

From the Chart of Accounts window, you can select an account and 
click View Transactions. The Account Transactions window displays.

2. Select the applicable Group By option: ID type/Date/Journal or Date/Journal. If 
you select Date/Journal, the results will include all ID types and you cannot 
specify an account mask or dimension range.

3. Complete the remaining filter settings.
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Click the Show More/Show Less buttons to hide or reveal the journal 
and attribute search parameters. By hiding these options, you have more 
room to display the results.

4. Click Find Now. The transactions that match the filter criteria display (Figure 
4.25). 

Figure 4.25—Transactions—Search Results

5. You can click Print Grid to print your account transaction information. The 
report output will reflect the current sorting and displays in a preview window, 
from which you can print the information.

6. Modify your filter criteria to refine or change the transactions displayed, or 
click Close to exit this window.
Viewing Transaction Information 
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VIEWING ACCOUNT BALANCE INFORMATION
General Ledger–Project/Grant allows you to view account balance information quickly 
and easily from a task on the menu/navigator bar or from the Chart of Accounts window. 
(You can only view balance information for one account at a time.) 

From the Journal Entry form, you can also select the Account Balance option 
on the shortcut menu to display this form.

1.  Click Accounts > Balances on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > Accounts > 
Balances from the menu bar. The Balances window displays (Figure 4.26). 

Figure 4.26—Balances Window

From the Chart of Accounts window, you can select an account and 
click View Balance. (Remember: The Jump To or dimension mask 
features can help you find your account.) The Balances window 
displays with the account pre-selected in the Account Number text box.
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2. Enter an account number in the Account Number text box. Click the ellipsis to 
find an account number using the Account Selector.

3. Select the Fiscal Year that you want to view from the drop-down list. 

4. Select the information to view: net amounts, year-to-date amounts, or all 
amounts.

5. Click Look-Up. The account balance information displays (Figure 4.27). 

Figure 4.27—Example Account Balances

6. Click Print to print your account balance information. The report output will 
reflect the current sorting and displays in a preview window, from which you 
can print the information.

7. View additional fiscal years by selecting from the drop-down list, view other 
accounts by entering new account numbers, or click Close to exit this window.
Viewing Account Balance Information 
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USING ACCOUNT UTILITIES TO MAINTAIN ACCOUNTS
The Account Utilities option allows you to maintain large numbers of accounts easily. 
To access the Account Utilities tasks, select Maintenance > General Ledger > 
Account Utilities (or Maintenance > Project/Grant > Account Utilities) from the 
menu bar. The Account Utilities window displays, open to Duplicate Accounts by 
default (Figure 4.28). 

Figure 4.28—Account Utilities—Duplicate Accounts

You can select from the following account maintenance options from the Action drop-
down list: 

• Duplicate accounts,
• Modify account information,
• Copy account information,
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• Add data item and value,
• Modify data item value,
• Remove data item,
• Clear data item value,
• Create accounts from descriptive accounts, and
• Remove unused accounts.

As you select utility tasks from the Action drop-down list, the options enabled within 
the Account Utilities window will change. The following sections describe the 
applicable options for each of the utility tasks.

The system will synchronize your accounts when you exit the form. You do not 
need to use the Synchronize Accounts task after completing any of the Account 
Utilities tasks.

DUPLICATE ACCOUNTS TASK

Context-sensitive topic: Account Utilities
The Duplicate Accounts task allows you to create a new set of accounts using an 
existing set of accounts as the source (or “model”). You can select the source accounts 
using an account mask, status, or attributes (included or excluded). 

You have an existing fund—Acme grant, fund dimension 04—that includes 700 
accounts. You are awarded a new grant—Smith Co. grant, will have fund 
dimension 07. You want the accounts for the Smith Co. grant to have the same 
organization, so instead of entering 700 accounts, you duplicate using account 
mask A04 XX-XX XXXX and account status Active.

Use Table 4.4 to complete the Duplicate Accounts task to create a new set of accounts. 
Using Account Utilities to Maintain Accounts 
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A red asterisk will appear beside a field if the information does not meet 
requirements. You will not be able to continue with the Account Utilities task 
until you correct the information. 

Table 4.4—Options for Duplicate Accounts

Option Allowed Entry Description

Source

Account Mask Alphanumeric; use X as a 
“wild card”

The account mask is the highest level of filter to 
create your source group of accounts.
• As soon as you enter the account mask, the 

attribute boxes displayed will reflect the 
attributes associated with the source ID type. 

Status Select from the drop-down list:
• Active
• Budget
• Descriptive
• System
• Inactive

Accounts that meet the selected status will be 
included in the source group. Accounts with any 
other status will be excluded from the source group.
Leave the Status box blank to include all accounts, 
regardless of status.

Attributes Click the attribute box and 
select attributes to include or 
exclude.

Accounts with attributes that match the include 
pattern will be included in the source group. 
Accounts that meet the exclude pattern will be 
excluded from the source group.
Leave the attribute boxes blank to include all 
accounts, regardless of attribute.
Tip: If you include and exclude attributes, don’t 
forget to include your descriptive accounts!

Create

Account Mask Alphanumeric; use X as a 
“wild card”

The Account Mask that you enter in this text box 
defines the new accounts (created as a result of the 
account duplication). 
Any wild cards (i.e., X) must occupy the same 
position as the Source Account Mask.

Duplicate 
Data Items on 
new accounts

Select this check box if you want the new accounts 
to have the same data items and values as the 
source account group.
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MODIFY ACCOUNT INFORMATION TASK

The Modify Account Information task allows you to change or add the following 
information for a group of accounts:

• Status,
• Attributes, and/or
• Required ID types.

You can select the source accounts using an account mask, status, or attributes (included 
or excluded). 

Set Status Select from the drop-down list:
• Active
• Budget
• Descriptive
• System
• Inactive

If you select a Status, that status will be applied to 
all new accounts regardless of the status of each 
source account.
If you do not select a status, each account will retain 
the status of its individual source account.

Set Attributes Click the attribute box and 
select attributes for the new 
accounts.

Any entry here will override the attribute setting of 
the source accounts.
Tip: To set an attribute as “blank,” select ** (two 
asterisks) from the drop-down list in the appropriate 
text box.

Required ID 
Type(s)

Alphanumeric If you are using more than one ID type, enter one or 
more ID types that must be entered when a 
transaction is posted to the new accounts.

One of 
Required ID 
Type(s)

Alphanumeric This field lets you list one or more ID types to 
require depending on the data to be entered when 
using the account in a transaction task.

Print Options Select the radio button for 
CSIDUPS file:
• Print All—Prints all 

accounts additions, 
changes, deletions, 
errors, and warnings.

• Print Errors Only—Print 
only errors and warnings.

When the source accounts have been duplicated, 
FundWare will save the CSIDUPS file to your report 
directory.

Table 4.4—Options for Duplicate Accounts (Continued)

Option Allowed Entry Description
Using Account Utilities to Maintain Accounts 
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You have a grant that has ended—Jones Bottle Air grant, fund dimension 08. 
You modify all the accounts for fund dimension 08 so that their status is 
Inactive.

Use Table 4.5 to complete the Modify Account Information task. 
A red asterisk will appear beside a field if the information does not meet 
requirements. You will not be able to continue with the Account Utilities task 
until you correct the information. 

Table 4.5—Options for Modify Account Information

Option Allowed Entry Description

Source

Account Mask Alphanumeric; use X as a 
“wild card”

The account mask is the highest level of filter to 
create your source group of accounts.
• As soon as you enter the account mask, the 

attribute boxes displayed will reflect the 
attributes associated with the source ID type. 

Status Select from the drop-down list:
• Active
• Budget
• Descriptive
• System
• Inactive

Accounts that meet the selected status will be 
included in the source group. Accounts with any 
other status will be excluded from the source group.
Leave the Status box blank to include all accounts, 
regardless of status.

Attributes Click the attribute box and 
select attributes to include or 
exclude.

Accounts with attributes that match the include 
pattern will be included in the source group. 
Accounts that meet the exclude pattern will be 
excluded from the source group.
Leave the attribute boxes blank to include all 
accounts, regardless of attribute.
Tip: If you include and exclude attributes, don’t 
forget to include your descriptive accounts!

Modify

Set Status Select from the drop-down list:
• Active
• Budget
• Descriptive
• System
• Inactive

If you select a Status, that status will be applied to 
all the accounts, regardless of their current status.
If you do not select a status, each account will retain 
its current status. 
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COPY ACCOUNT INFORMATION TASK

The Copy Account Information task allows you to copy the following account 
information from a source group of accounts to a second group of accounts:

• Descriptions, 
• Attributes, 
• Aliases, 
• Required ID types, and/or
• Data items

You can select the source accounts using an account mask, status, or attributes (included 
or excluded). 

You have six departments (01, 02, 03, 04, 05, and 06) that all have an account 
for Employee Training. However, each account description is slightly different 
(e.g., one is Emp. Train., another is Empl. Training). You would like to copy the 
description from the descriptive account (A00 00-00 9123) to the six 
department accounts.

Set Attributes Click the attribute box and 
select attributes for the new 
accounts.

Any entry here will override the existing attribute 
setting of the accounts.
Tip: To set an attribute as “blank,” select ** (two 
asterisks) from the drop-down list in the appropriate 
text box.

Required ID 
Type(s)

Alphanumeric If you are using more than one ID type, enter one or 
more ID types that must be entered when a 
transaction is posted to the accounts.

One of 
Required ID 
Type(s)

Alphanumeric This field lets you list one or more ID types to 
require depending on the data to be entered when 
using the account in a transaction task.

Print Options Select the radio button for 
CSIDUPS file:
• Print All—Prints all 

accounts additions, 
changes, deletions, 
errors, and warnings.

• Print Errors Only—Print 
only errors and warnings.

When the source accounts have been modified, 
FundWare will save the CSIDUPS file to your report 
directory.

Table 4.5—Options for Modify Account Information (Continued)

Option Allowed Entry Description
Using Account Utilities to Maintain Accounts 
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Use Table 4.6 to complete the Copy Account Information task. 
A red asterisk will appear beside a field if the information does not meet 
requirements. You will not be able to continue with the Account Utilities task 
until you correct the information. 

Table 4.6—Options for Copy Account Information

Option Allowed Entry Description

Source

Account Mask Alphanumeric; use X as a 
“wild card”

The account mask is the highest level of filter to 
create your source group of accounts.
• As soon as you enter the account mask, the 

attribute boxes displayed will reflect the 
attributes associated with the source ID type. 

• Enter an account number for the Source 
Account Mask to copy information from one 
account to one or more accounts.

• If you enter an account mask for the Source 
Account Mask to copy information from 
multiple account to multiple accounts, the 
system may behave unexpectedly if the source 
has more accounts than the recipient (e.g., 
copying information from 10 accounts to 5 
accounts).

Status Select from the drop-down list:
• Active
• Budget
• Descriptive
• System
• Inactive

Accounts that meet the selected status will be 
included in the source group. Accounts with any 
other status will be excluded from the source group.
Leave the Status box blank to include all accounts, 
regardless of status.

Attributes Click the attribute box and 
select attributes to include or 
exclude.

Accounts with attributes that match the include 
pattern will be included in the source group. 
Accounts that meet the exclude pattern will be 
excluded from the source group.
Leave the attribute boxes blank to include all 
accounts, regardless of attribute.
Tip: If you include and exclude attributes, don’t 
forget to include your descriptive accounts!
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ADD DATA ITEM AND VALUE TASK

The Add Data Item and Value task allows you to add a single data item and value to a 
group of accounts. You can select the account group using an account mask, status, or 
attributes (included or excluded). 

You have added a new data item to your system and want to include that data 
item on the Acme grant (fund dimension 04) accounts. Instead of entering the 
data item on each individual account, you can add it using account mask A04 
XX-XX XXXX.

Use Table 4.7 to complete the Add Data Item and Value task. 

Create

Account Mask Alphanumeric; use X as a 
“wild card”

The Account Mask that you enter in this text box 
defines the accounts to which you will copy the 
account information. 

Copy Select the check box for the 
information to be copied:
• Description
• Attributes
• Alias 1
• Alias 2
• ID Entry

The selected information will be copied from the 
source group of accounts to the second (or 
“recipient”) group of accounts.

Print Options Select the radio button for 
CSIDUPS file:
• Print All—Prints all 

accounts additions, 
changes, deletions, 
errors, and warnings.

• Print Errors Only—Print 
only errors and warnings.

When the account information has been copied 
from, FundWare will save the CSIDUPS file to your 
report directory.

Table 4.6—Options for Copy Account Information (Continued)

Option Allowed Entry Description
Using Account Utilities to Maintain Accounts 
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A red asterisk will appear beside a field if the information does not meet 
requirements. You will not be able to continue with the Account Utilities task 
until you correct the information. 

Table 4.7—Options for Add Data Item and Value

Option Allowed Entry Description

Source

Account Mask Alphanumeric; use X as a 
“wild card”

The account mask is the highest level of filter to 
create your source group of accounts.
• As soon as you enter the account mask, the 

attribute boxes displayed will reflect the 
attributes associated with the source ID type. 

Status Select from the drop-down list:
• Active
• Budget
• Descriptive
• System
• Inactive

Accounts that meet the selected status will be 
included in the source group. Accounts with any 
other status will be excluded from the source group.
Leave the Status box blank to include all accounts, 
regardless of status.

Attributes Click the attribute box and 
select attributes to include or 
exclude.

Accounts with attributes that match the include 
pattern will be included in the source group. 
Accounts that meet the exclude pattern will be 
excluded from the source group.
Leave the attribute boxes blank to include all 
accounts, regardless of attribute.
Tip: If you include and exclude attributes, don’t 
forget to include your descriptive accounts!

Modify

Data Item Select from the drop-down list 
of existing data items.

The data item that you select will be added to the 
selected accounts.
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MODIFY DATA ITEM VALUE TASK

The Modify Data Item Value task allows you to modify the value of a single data item 
for a group of accounts. You can select the account group using an account mask, status, 
or attributes (included or excluded). 

You have a data item to store the name of the program manager for the fund 
(.PROGMGR), but now there is a new PM. You can modify the value for 
.PROGMGR to reflect the name of the new program manager.

Use Table 4.8 to complete the Modify Data Item Value task. 
A red asterisk will appear beside a field if the information does not meet 
requirements. You will not be able to continue with the Account Utilities task 
until you correct the information. 

Data Item 
Value

Alphanumeric and/or 
character

Enter the value of the data item. This value will be 
added to all the selected accounts.
• A data item value is not required.

Print Options Select the radio button for 
CSIDUPS file:
• Print All—Prints all 

accounts additions, 
changes, deletions, 
errors, and warnings.

• Print Errors Only—Print 
only errors and warnings.

When the data item and value have been added to 
the accounts, FundWare will save the CSIDUPS file 
to your report directory.

Table 4.8—Options for Modify Data Item Value

Option Allowed Entry Description

Source

Account Mask Alphanumeric; use X as a 
“wild card”

The account mask is the highest level of filter to 
create your source group of accounts.
• As soon as you enter the account mask, the 

attribute boxes displayed will reflect the 
attributes associated with the source ID type. 

Table 4.7—Options for Add Data Item and Value (Continued)

Option Allowed Entry Description
Using Account Utilities to Maintain Accounts 
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REMOVE DATA ITEM TASK

The Remove Data Item task allows you to delete a single data item from a group of 
accounts. You can select the account group using an account mask, status, or attributes 
(included or excluded). 

You have a data item to store the name of the program manager for the fund 
(.PROGMGR), but this position has a lot of turnover. You’ve decided to just 
remove the data item so that you do not need to update it frequently.

Status Select from the drop-down list:
• Active
• Budget
• Descriptive
• System
• Inactive

Accounts that meet the selected status will be 
included in the source group. Accounts with any 
other status will be excluded from the source group.
Leave the Status box blank to include all accounts, 
regardless of status.

Attributes Click the attribute box and 
select attributes to include or 
exclude.

Accounts with attributes that match the include 
pattern will be included in the source group. 
Accounts that meet the exclude pattern will be 
excluded from the source group.
Leave the attribute boxes blank to include all 
accounts, regardless of attribute.
Tip: If you include and exclude attributes, don’t 
forget to include your descriptive accounts!

Modify

Data Item Select from the drop-down list 
of existing data items.

The value of the data item that you select will be 
modified on the selected accounts.

Data Item 
Value

Alphanumeric and/or 
character

Enter the new value of the data item. This value will 
be changed for all the accounts in the source group

Print Options Select the radio button for 
CSIDUPS file:
• Print All—Prints all 

accounts additions, 
changes, deletions, 
errors, and warnings.

• Print Errors Only—Print 
only errors and warnings.

When the data item value has been modified on the 
accounts, FundWare will save the CSIDUPS file to 
your report directory.

Table 4.8—Options for Modify Data Item Value (Continued)

Option Allowed Entry Description
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Use Table 4.9 to complete the Remove Data Item task. 
A red asterisk will appear beside a field if the information does not meet 
requirements. You will not be able to continue with the Account Utilities task 
until you correct the information. 

Table 4.9—Options for Remove Data Item

Option Allowed Entry Description

Source

Account Mask Alphanumeric; use X as a 
“wild card”

The account mask is the highest level of filter to 
create your source group of accounts.
• As soon as you enter the account mask, the 

attribute boxes displayed will reflect the 
attributes associated with the source ID type. 

Status Select from the drop-down list:
• Active
• Budget
• Descriptive
• System
• Inactive

Accounts that meet the selected status will be 
included in the source group. Accounts with any 
other status will be excluded from the source group.
Leave the Status box blank to include all accounts, 
regardless of status.

Attributes Click the attribute box and 
select attributes to include or 
exclude.

Accounts with attributes that match the include 
pattern will be included in the source group. 
Accounts that meet the exclude pattern will be 
excluded from the source group.
Leave the attribute boxes blank to include all 
accounts, regardless of attribute.
Tip: If you include and exclude attributes, don’t 
forget to include your descriptive accounts!

Modify

Data Item Select from the drop-down list 
of existing data items.

The data item that you select will be removed from 
the selected accounts.

Print Options Select the radio button for 
CSIDUPS file:
• Print All—Prints all 

accounts additions, 
changes, deletions, 
errors, and warnings.

• Print Errors Only—Print 
only errors and warnings.

When the data item has been removed from the 
accounts, FundWare will save the CSIDUPS file to 
your report directory.
Using Account Utilities to Maintain Accounts 
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CLEAR DATA ITEM VALUE TASK

The Clear Data Item Value task allows you to delete the value of a single data item for a 
group of accounts. You can select the account group using an account mask, status, or 
attributes (included or excluded). 

You have a data item to store the name of the program manager for the fund 
(.PROGMGR), but the current PM has left the position and a new PM has not 
yet been hired. You don’t want the incorrect information (the old PM’s name) to 
be attached to the accounts, but you don’t have the name of the new PM yet. 
You can clear the value for .PROGMGR and add a value at a later date.

Use Table 4.10 to complete the Clear Data Item Value task. 
A red asterisk will appear beside a field if the information does not meet 
requirements. You will not be able to continue with the Account Utilities task 
until you correct the information. 

Table 4.10—Options for Clear Data Item Value

Option Allowed Entry Description

Source

Account Mask Alphanumeric; use X as a 
“wild card”

The account mask is the highest level of filter to 
create your source group of accounts.
• As soon as you enter the account mask, the 

attribute boxes displayed will reflect the 
attributes associated with the source ID type. 

Status Select from the drop-down list:
• Active
• Budget
• Descriptive
• System
• Inactive

Accounts that meet the selected status will be 
included in the source group. Accounts with any 
other status will be excluded from the source group.
Leave the Status box blank to include all accounts, 
regardless of status.

Attributes Click the attribute box and 
select attributes to include or 
exclude.

Accounts with attributes that match the include 
pattern will be included in the source group. 
Accounts that meet the exclude pattern will be 
excluded from the source group.
Leave the attribute boxes blank to include all 
accounts, regardless of attribute.
Tip: If you include and exclude attributes, don’t 
forget to include your descriptive accounts!
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CREATE ACCOUNTS FROM DESCRIPTIVE ACCOUNTS TASK

The Create Accounts from Descriptive Accounts task allows you to create a new set of 
accounts using the descriptive accounts for an existing set of accounts (i.e., source). You 
can select the source accounts using an account mask or attributes (included or 
excluded). 

You have added a new descriptive account for fees associated with your fax 
machine (A00 00-00 7835). Now you want to add this descriptive account to all 
funds and departments (e.g., A01 00-00 7835, A03 02-00 7835).

Use Table 4.11 to complete the Create Accounts from Descriptive Accounts task to 
create a new set of accounts. 

Modify

Data Item Select from the drop-down list 
of existing data items.

The value of the data item that you select will be 
removed from the selected accounts.

Print Options Select the radio button for 
CSIDUPS file:
• Print All—Prints all 

accounts additions, 
changes, deletions, 
errors, and warnings.

• Print Errors Only—Print 
only errors and warnings.

When the data item value has been cleared from 
the accounts, FundWare will save the CSIDUPS file 
to your report directory.

Table 4.10—Options for Clear Data Item Value (Continued)

Option Allowed Entry Description
Using Account Utilities to Maintain Accounts 
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A red asterisk will appear beside a field if the information does not meet 
requirements. You will not be able to continue with the Account Utilities task 
until you correct the information. 

Table 4.11—Options for Create Accounts From Descriptive Accounts

Option Allowed Entry Description

Source

Account Mask Alphanumeric; use X as a 
“wild card”

The account mask is the highest level of filter to 
create your source group of accounts.
• As soon as you enter the account mask, the 

attribute boxes displayed will reflect the 
attributes associated with the source ID type. 

Attributes Click the attribute box and 
select attributes to include or 
exclude.

Accounts with attributes that match the include 
pattern will be included in the source group. 
Accounts that meet the exclude pattern will be 
excluded from the source group.
Leave the attribute boxes blank to include all 
accounts, regardless of attribute.
Tip: If you include and exclude attributes, don’t 
forget to include your descriptive accounts!

Create

Account Mask Alphanumeric; use X as a 
“wild card”

The Account Mask that you enter in this text box 
defines the new accounts. 

Duplicate 
Data Items on 
new accounts

Select this check box if you want the new accounts 
to have the same data items and values as the 
source account group.

Set Status Select from the drop-down list:
• Active
• Budget
• Descriptive
• System
• Inactive

If you select a Status, that status will be applied to 
all new accounts regardless of the status of each 
source account.
If you do not select a status, each account will retain 
the status of its individual source account (i.e. 
Descriptive).

Set Attributes Click the attribute box and 
select attributes for the new 
accounts.

Any entry here will override the attribute setting of 
the source accounts.
Tip: To set an attribute as “blank,” select ** (two 
asterisks) from the drop-down list in the appropriate 
text box.
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USING THE ? CHARACTER WITH DESCRIPTIVE ACCOUNTS

You can use the ? character in the Create account mask when you create accounts from 
descriptive accounts. The character tells FundWare to use the actual numbers from the 
source accounts. For example, if you:

• Enter a Source Account Mask of A00 00-00 7835, and
• Enter a Create Account Mask of AXX XX-?? 7835

FundWare looks to your chart of accounts to see that there are the following funds and 
departments:

• A01 01
• A01 02
• A02 01
• A03 01

The program then looks to the source account mask to see that the subdepartment is 
defined as 00 (the subdepartment dimension has ?? in the create account mask). As a 
result, Fundware creates the following new accounts:

• A01 01-00 7835
• A01 02-00 7835
• A02 01-00 7835

Required ID 
Type(s)

Alphanumeric If you are using more than one ID type, enter one or 
more ID types that must be entered when a 
transaction is posted to the new accounts.

One of 
Required ID 
Type(s)

Alphanumeric This field lets you list one or more ID types to 
require depending on the data to be entered when 
using the account in a transaction task.

Print Options Select the radio button for 
CSIDUPS file:
• Print All—Prints all 

accounts additions, 
changes, deletions, 
errors, and warnings.

• Print Errors Only—Print 
only errors and warnings.

When the source accounts have been created, 
FundWare will save the CSIDUPS file to your report 
directory.

Table 4.11—Options for Create Accounts From Descriptive Accounts (Continued)

Option Allowed Entry Description
Using Account Utilities to Maintain Accounts 
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• A03 01-00 7835
If the source account mask contains a masking X character instead of a digit (i.e., 0–9), 
FundWare would create accounts to match all possible digits in the ? position. For 
example, if you:

• Enter a Source Account Mask of A00 00-00 783X, and
• Enter a Create Account Mask of AXX XX-?? 783?

Again, FundWare looks to your chart of accounts to see that there are the following 
funds and departments:

• A01 01
• A01 02
• A02 01
• A03 01

The program then looks to find what descriptive accounts you have where the first three 
numbers of the object dimension are “783,” finding:

• A00 00-00 7834
• A00 00-00 7835
• A00 00-00 7836

Because the subdepartment in the source account mask is defined as 00 (the 
subdepartment dimension has ?? in the create account mask), Fundware creates the 
following new accounts: 

REMOVE UNUSED ACCOUNTS TASK

The Remove Unused Accounts task allows you to delete accounts that have no financial 
activity.

• A01 01-00 7834 • A02 01-00 7834

• A01 01-00 7835 • A02 01-00 7835

• A01 01-00 7836 • A02 01-00 7836

• A01 02-00 7834 • A03 01-00 7834

• A01 02-00 7835 • A03 01-00 7835

• A01 02-00 7836 • A03 01-00 7836
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If one or more accounts has financial activity, you can only change the status to 
Inactive.

You can select the account group using an account mask. 
You used the Duplicate Accounts to create accounts that you really didn’t need. 
You never posted to these accounts, so you use the Remove Unused Accounts 
task to delete them from your system.

Use Table 4.12 to complete the Remove Unused Accounts task. 
A red asterisk will appear beside a field if the information does not meet 
requirements. You will not be able to continue with the Account Utilities task 
until you correct the information.

The Print Options are not enabled for this task. However, FundWare will create a report 
(CSPURGE) listing the accounts removed by the Remove Unused Accounts task.

RESPONDING TO CREATED BY POSTING ACCOUNTS
FundWare will define “Created by Posting” accounts if you post a transaction to an 
undefined account number (e.g., you have not defined your due to/from accounts, a 
transaction combines setup parameters to create an undefined account number, you 
enter an incorrect year-end closing mask). Instead of halting the posting and generating 
an error, the system makes a Created by Posting account. (These accounts are most 
likely to occur when you are first setting up the system.)
If your trace report indicates that a created by posting account has been used, you need 
to determine if:

• The account is incorrect (i.e., you did not intend to post to this account, and it 
should not be in your chart of accounts), or

Table 4.12—Options for Remove Unused Accounts

Option Allowed Entry Description

Source

Account Mask Alphanumeric; use X as a 
“wild card”

The account mask that will define the group of 
accounts to be removed.
• You must enter all the characters of the 

account mask; the program will not autofill any 
information.
Responding to Created by Posting Accounts 
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• The account is correct, but had not been defined before you posted the 
transaction (i.e., the account is correct, but didn’t previously exist in your chart 
of accounts).

Once you determine the cause of the created by posting account, you can correct the 
information as necessary.

CORRECTING AN INCORRECT ACCOUNT NUMBER

If you determine that the Created by Posting account is an incorrect account (i.e., you 
did not intend to post to this account and it should not be in your Chart of Accounts), 
you must:

1.  Reverse the journal entry.

2. Correct the parameters that lead to the incorrect created by posting account. For 
example:

• Correct your Due To/From settings.
• Change the setup parameters for the module.

3. Post the transaction to the correct account.

• You may need to create a new account first.
4. Print and review your trace report to ensure that the postings are correct.

5. Review the account balance for the created by posting account to ensure that the 
account balances to zero.

6. Make the created by posting account inactive.

INTEGRATING A CORRECT CREATED BY POSTING ACCOUNT

If you determine that a created by posting account was created because of a missing 
account (i.e., the account is correct, but didn’t previously exist in your Chart of 
Accounts), you must edit the account (e.g., from the Chart of Accounts) to properly 
incorporate the new account into your system.

1.  Change the “Created by Posting” description to a more applicable/meaningful 
description.

2. Add the required position 1 attribute value (no values are defined automatically 
for Created by Posting accounts). 
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C H A P T E R  5

CREATING JOURNAL ENTRIES

General Ledger–Project/Grant allows you to add journal entries in a variety of ways:
• Manually create transactions using the journal entry form. You can save these 

entries to post later or post the entries directly from the journal entry form.
• Import transactions using the import instructions in the Blackbaud FundWare 

System Administration Guide. Once imported, you can review and post the 
transactions.

• Memorize a manual journal entry (e.g., Rent). This becomes a “template” from 
which you can create journal entries whenever required.

CREATING JOURNAL ENTRIES
Use the following instructions to create journal entries.
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1.  Click Journal Entry > New on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > Journal 
Entry > New from the menu bar. The New Journal Entry form displays (Figure 
5.1). 

Figure 5.1—New Journal Entry Form

2. Select the applicable journal from the Journal drop-down list. The Posting Type 
associated with the journal displays in the Posting Type field.

The Journal field will default to the journal that you selected that last 
time you worked in this form.

3. Select the Posting Action (e.g., normal, adjustment, reclassification) from the 
drop-down list. This field defaults to Normal. 

4. If you need to auto reverse this entry, select the check box and enter the date 
when the system will reverse the entries. For more information on this feature, 
see Using the Auto Reverse Feature on page 183.

The column headings for the Reference columns reflect the journal settings. Reference 1, 
Reference 2, and Reference 3 are the defaults. Your columns may have different headings.

Also, your organization may have defined up to three data items to include with journal 
entries. Therefore, your form may have up to three additional columns.
Creating Journal Entries 
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5. Complete the fields according to Table 5.1. 

Table 5.1—New Journal Entry Form—Field Definitions

Field/Setting Valid Entry Definition

Account 
Number

Valid account Enter an account number or click the Account Selector 
button (on the right side of the Account Number cell) to 
search for an account.
• See Using the Account Selector on page 211 for 

instructions on the Account Selector tool.
• This field is required.
• Press CTRL+D to copy the entry from the previous row. 

(Does not apply to the first entry on the form.)

Account 
Description

Not editable Displays the description for the selected account.
• You cannot edit this information. 
• If you use your keyboard to move through the form, you 

automatically skip over this field. 

References Up to 10 alphanumeric 
characters per column

Enter the requested information. 
• The column headings reflect the Reference Title 

settings on the journal definition.
• Each entry defaults to the entry from the previous row. 

(Does not apply to the first entry on the form.)

Additional 
Data Items

User-specified Enter any requested data item information.
• You journal definition allows you to define up to three 

data items to include with the journal entry. 
• The column headings will reflect the data item 

description.
• For more information, Maintaining Your Journals on 

page 101.
• Each entry defaults to the entry from the previous row. 

(Does not apply to the first entry on the form.)

Line Item 
Description

Up to 30 alphanumeric 
characters

Enter a description of the journal entry.
• The description defaults to the entry form the previous 

row. (Does not apply to the first entry on the form.)
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Tip: You can use shortcut keys to copy (CTRL+C), paste (CTRL+V), and 
delete (CTRL+D) cell contents.

Units 0 to 9,999,999,999,999 Enter the number of units.
• Units are multiplied by the rate to enter a default amount 

(or debit).
• This column will only display if General Ledger is 

configured for units and rates. See Global Settings on 
page 122 for more information.

• This field is optional.

Rates 0 to 9,999,999,999,999 Enter the rate.
• Units are multiplied by the rate to enter a default amount 

(or debit).
• This column will only display if General Ledger is 

configured for units and rates. See Global Settings on 
page 122 for more information.

• This field is optional.

Amount
Debit/Credit

0 to 
9,999,999,999,999.00

Enter the amount of the journal entry. 
• The form will display either a single column (Amount) or 

two columns (Debit and Credit). 
• See Amount vs. Debit/Credit on page 182 for more 

information.
• Press CTRL+D to copy the entry from the previous row. 

(Does not apply to the first entry on the form.)

Table 5.1—New Journal Entry Form—Field Definitions (Continued)

Field/Setting Valid Entry Definition
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6. Move to the next row of the form. The Balancing Totals and Net balances 
reflect your entries (Figure 5.2). 

Figure 5.2—Example Journal Entry

7. Continue adding entries, as necessary.

General Ledger requires that your debits equal your credits. Therefore, 
the Net balance must be $0.00 for you to consider the transaction 
complete. Project/Grant does not have this requirement.

8. When your entries are complete:

• Click Save Entries to save your entries and clear the New Journal Entry 
form. You will be asked to enter a transaction name. For more information, 
see Working With Saved Journal Entries on page 184.

• Click Post to post your entries directly to the specified journal. A 
confirmation message will display.

• Click Memorize to memorize your entries. You will be asked to enter a 
memorized transaction name. For more information, Working With 
Memorized Journal Entries on page 189. 

If you click Close, your entries are not saved and the form closes.
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AMOUNT VS. DEBIT/CREDIT

General Ledger–Project/Grant allows you to choose how you want to enter the dollar 
amounts for your journal entries. Right-click and select the option from the shortcut 
menu (only the option not currently in use displays in the menu).

• Amount—One column displays. You must enter any credit information with 
some negative indicator (minus sign, parentheses). Debits do not need a plus 
sign.

• Debit/Credit—Two columns display. Enter only numbers in the appropriate 
columns. FundWare applies the necessary plus/minus signs.

ENABLING/DISABLING THE ACCOUNT SELECTOR PROMPT

When the Account Selector Prompt option on the shortcut menu is enabled (i.e., a 
check mark appears beside the menu option), a message will prompt you to open to the 
Account Selector if an account number that you enter is invalid. If this option is 
disabled, FundWare will not display a message but will indicate in the account 
description cell that the account is invalid.

USING THE AUTO COMPLETE ACCOUNTS LIST

When you enable the Auto Complete Accounts option (i.e., a check mark appears 
beside the shortcut menu option), FundWare will “remember” the accounts that you 
enter into the journal entry form. As you type the account number, the program will 
attempt to match your entry with previously entered account numbers.

FundWare will only store account numbers during the time you enable the Auto 
Complete Accounts option.

If this list becomes too large to be useful, you can clear the contents by selecting Clear 
Auto Complete Accounts List from the shortcut menu.

ACCOUNT BALANCE

You can access the balance of an account entered in the journal entry form by right-
clicking and selecting Account Balance from the shortcut menu. The Balances window 
displays. For more information on the Balances feature, see Viewing Account Balance 
Information on page 155.
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USING THE AUTO REVERSE FEATURE

The Auto Reverse feature allows you to enter journal entries and specify that these 
entries will be automatically reversed by the system on a specified date.

You need to run reports for the month of October, but an expected invoice has 
not yet arrived. This expense needs to be reflected in the October financials, but 
you have only an estimate of the expense. You add a journal entry for the 
estimated expense and schedule the entry to be auto reversed on November 1. 
When the invoice arrives on November 6, you don’t need to remember to 
reverse the original entry. You simply enter the actual invoice amount.

You can manually reverse a transaction from the Posted Transactions window. (See 
Manually Reversing a Transaction on page 206.)

MOVING THROUGH THE JOURNAL ENTRY FORM

You can use the TAB key or the ENTER key to move from one cell to the next editable 
cell.

DELETING A ROW FROM THE JOURNAL ENTRY FORM

To delete a row of the journal entry form, click the far left cell to highlight one or more 
rows and click Delete Row(s).

To delete more than one row, press SHIFT and select consecutive rows or press 
CTRL and select nonconsecutive rows.

PRINTING TRANSACTIONS FROM THE JOURNAL ENTRY FORM

Click Print Grid to print the information displayed in the New Journal Entry window.

BUDGET CONTROL MESSAGES

If you are using the Budget Control feature, the system may return budgeting messages 
during journal entry. See Chapter 9—Using Budget Control on page 233 for more 
information.
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WORKING WITH SAVED JOURNAL ENTRIES
Context-sensitive topic: Journal Entry—Saved Transactions
Saved journal entries are in a “suspended” state. Your entries are saved, allowing you to 
modify the transaction as necessary. But the information does not impact your financial 
balances until you post the transaction.
Once you save journal entries, you can impact the transaction in the following ways:

• Edit—Modify the transaction, include adding or deleting individual journal 
entries.

• Delete—Delete the entire transaction.
• Post—Post the entire transaction to the specified journal.
• Memorize—Memorize the transaction.

To access your saved transactions, click Journal Entry > Saved on the module 
navigator (if the module is not expanded, click General Ledger first) or select General 
Ledger > Journal Entry > Saved from the menu bar. The Saved Journal Entries 
window displays (Figure 5.3). 

Figure 5.3—Saved Journal Entries Window

The system displays the following information about each saved transaction:
• Description—The name of the saved transaction. Entered when you saved the 

transaction from the New Journal Entry form.
• Journal—The journal to which this transaction will post.
• Saved Date—The date the user saved the transaction.
• User ID—The user who saved this transaction.
Working With Saved Journal Entries 
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EDITING SAVED JOURNAL ENTRIES

Use the following instructions to edit a saved transaction.
1.  Click Journal Entry > Saved on the module navigator (if the module is not 

expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Saved from the menu bar. The Saved Journal Entries window displays 
(Figure 5.4). 

Figure 5.4—Saved Journal Entries Window

2. Select the saved transaction click Edit. The journal entries display in the 
Journal Entry form.

3. Edit the journal entries, as necessary.

4. When your entries are complete:

• Click Save Entries to save your entries and clear the New Journal Entry 
form. You will be asked to enter a transaction name. For more information, 
see Working With Saved Journal Entries on page 184.

• Click Post to post your entries directly to the specified journal. A 
confirmation message will display and the transaction no longer displays.

• Click Memorize to memorize your entries. You will be asked to enter a 
memorized transaction name. Once memorized, the transaction no longer 
displays. For more information, Working With Memorized Journal Entries 
on page 189. 

If you click Close, your entries are not saved and the form closes.

POSTING SAVED JOURNAL ENTRIES

Use the following instructions to post a saved transaction on the current business date.
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1.  Click Journal Entry > Saved on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Saved from the menu bar. The Saved Journal Entries window displays 
(Figure 5.5). 

Figure 5.5—Saved Journal Entries Window

2. Select the saved transaction click Post. A confirmation message displays.

3. Click Yes to post the saved transaction. When the task is complete, a message 
displays the trace report number (Figure 5.6). 

Figure 5.6—Successful Posting and Trace Report Message

4. Click OK.

5. Print the trace report and review. You should store the printed trace report for 
your records.

6. Click Close to exit the task.

MEMORIZING SAVED JOURNAL ENTRIES

Use the following instructions to memorize a saved transaction.
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1.  Click Journal Entry > Saved on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Saved from the menu bar. The Saved Journal Entries window displays 
(Figure 5.7). 

Figure 5.7—Saved Journal Entries Window

2. Select the saved transaction click Memorize. A confirmation message displays.

3. Click Yes. When the task is complete, a message displays.

4. Click OK. The transaction now displays in the Memorized Journal Entries 
window (i.e., it is removed from the Saved Journal Entries window) (Figure 
5.8). 

Figure 5.8—Memorizing a Saved Transaction

Because the Guide Example has not been posted yet, nothing displays 
in the Posted Date and Post/Reverse columns.

COPYING SAVED JOURNAL ENTRIES

Use the following instructions to copy a saved transaction.
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1.  Click Journal Entry > Saved on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Saved from the menu bar. The Saved Journal Entries window displays 
(Figure 5.4). 

Figure 5.9—Saved Journal Entries Window

2. Select the saved transaction click Copy. The Copy window displays (Figure 
5.10). 

Figure 5.10—Copying a Saved Batch

3. Enter a unique description for this batch.

4. Select the radio button to indicate if the new batch created by the copy task 
should be a Saved batch or a Memorized batch.

5. Click OK. The new batch is stored in the applicable folder (i.e., either Journal 
Entry > Saved or Journal Entry > Memorized). 

If you indicated that the new batch is a Saved batch, click Refresh to 
see the batch in the Journal Entry > Saved display.
Working With Saved Journal Entries 
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DELETING SAVED JOURNAL ENTRIES

Use the following instructions to delete a saved transaction.
1.  Click Journal Entry > Saved on the module navigator (if the module is not 

expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Saved from the menu bar. The Saved Journal Entries window displays 
(Figure 5.11). 

Figure 5.11—Saved Journal Entries Window

2. Select the saved transaction click Delete. A confirmation message displays.

3. Click Yes to delete the saved transaction. When the task is complete, a message 
displays.

4. Click OK. The transaction no longer displays in the Saved Journal Entries 
window.

5. Click Close to exit the task.

PRINTING SAVED JOURNAL ENTRIES

Click Print Grid to print the summary information displayed in the Saved Journal 
Entries window.

You can also produce reports (e.g., Special Journal Entries List) of this 
information.

WORKING WITH MEMORIZED JOURNAL ENTRIES
Context-sensitive topic: Journal Entry—Saved Transactions
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By memorizing journal entries, you can define a set of entries once that are posted on a 
regular basis. Once the entries are memorized, you can post the information at any time. 
You can memorize a journal entry from many locations within General Ledger–Project/
Grant:

• The New Journal Entry form (General Ledger > Journal Entries > 
New)—Allows you to memorize the entries currently displayed on the form.

• The Saved Journal Entries window (General Ledger > Journal Entries > 
Saved)—Allows you to select a saved transaction and memorize it.

• The Imported Journal Entries window (General Ledger > Journal Entries > 
Imported)—Allows you to select a memorized transaction and memorize it.

To access your memorized transactions, click Journal Entry > Memorized on the 
module navigator (if the module is not expanded, click General Ledger first) or select 
General Ledger > Journal Entry > Memorized from the menu bar. The Memorized 
Journal Entries window displays (Figure 5.12). 

Figure 5.12—Memorized Journal Entries Window

The system displays the following information about each memorized transaction:
• Description—The name of the memorized transaction. Entered when you 

memorized the transaction from the New Journal Entry form or the original 
name of a saved or imported transaction that was later memorized.

• Journal—The journal to which this transaction will post.
• Posted Date—The date the user saved the transaction.
• Post/Reverse—Indicates if the transaction was posted as a normal post or in 

reverse.
• User ID—The user who memorized this transaction.
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EDITING MEMORIZED JOURNAL ENTRIES

Use the following instructions to edit a memorized transaction.
1.  Click Journal Entry > Memorized on the module navigator (if the module is 

not expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Memorized from the menu bar. The Memorized Journal Entries 
window displays (Figure 5.13). 

Figure 5.13—Memorized Journal Entries Window

2. Select the memorized transaction click Edit. The journal entries for the 
transaction display in the Journal Entry form. 

3. Edit your entries, as necessary. To remove an entry, select the row and click 
Delete Row(s) (or right-click and select from the shortcut menu).

4. When your entries are complete:

• Post to post your entries and save the changes to the memorized transaction, 
• Save Entries to save your changes as a saved transaction, or 
• Memorize to save your entries as a new memorized transaction or 

overwrite the existing memorized transaction.

POSTING MEMORIZED JOURNAL ENTRIES

Use the following instructions to post a memorized transaction on the current business 
date.
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1.  Click Journal Entry > Memorized on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Memorized from the menu bar. The Memorized Journal Entries 
window displays (Figure 5.14). 

Figure 5.14—Memorized Journal Entries Window

2. Select the memorized transaction click Post. A confirmation message displays.

3. Click Yes to post the memorized transaction. When the task is complete, a 
message displays the trace report number (Figure 5.15). 

Figure 5.15—Successful Posting and Trace Report Message

4. Click OK.

5. Print the trace report and review. You should store the printed trace report for 
your records.

6. Click Close to exit the task.

POSTING MEMORIZED JOURNAL ENTRIES IN REVERSE

The Reverse Post option allows you to post a memorized transaction “in reverse.” In 
other words, the system reverses the financial entries included within the selected 
memorized transaction.
Working With Memorized Journal Entries 
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By mistake, you posted the Rent transaction twice in January when you meant 
to post it once (Table 5.2). 

To correct the second posting, you post the transaction in reverse (Table 5.3). 

Table 5.2—Example Double Post

Account Number (Description) Posting Net Result

A01 01-00 7145 (Rent) $1,500+
$1,500+

$3,000+

A01 02-00 7145 (Rent) $800+
$800+

$1,600+

A01 03-01 7145 (Rent) $1,200+
$1,200+

$2,400+

A01 03-02 7145 (Rent) $1,800+
$1,800+

$3,600+

A01 00-00 1111 (Cash in Bank - Alpenglow) $5,300–
$5,300–

$10,600–

Table 5.3—Example Correcting Post

Account Number (Description) Posting Net Result

A01 01-00 7145 (Rent) $1,500+
$1,500+
$1,500–

$1,500+

A01 02-00 7145 (Rent) $800+
$800+
$800–

$800+

A01 03-01 7145 (Rent) $1,200+
$1,200+
$1,200–

$1,200+

A01 03-02 7145 (Rent) $1,800+
$1,800+
$1,800–

$1,800+
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• A01 01-00 7145 (Rent) has two $1,500 entries and one –$1,500 entry.
• A01 02-00 7145 (Rent) has two $800 entries and one –$800 entry.
• A01 03-02 7145 (Rent) has two $1,800 entries and one –$1,800 entry.
• A01 00-00 1111 (Cash in Bank - Alpenglow) has two –$5,300 entries and 

one –$5,300 entry.
Use the following instructions to post a memorized journal entry in reverse on the 
current business date.

1.  Click Journal Entry > Memorized on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Memorized from the menu bar. The Memorized Journal Entries 
window displays (Figure 5.16). 

Figure 5.16—Memorized Journal Entries Window

2. Select the memorized transaction click Reverse Post. A confirmation message 
displays.

A01 00-00 1111 (Cash in Bank - Alpenglow) $5,300–
$5,300–
$5,300+

$5,300–

Table 5.3—Example Correcting Post (Continued)

Account Number (Description) Posting Net Result
Working With Memorized Journal Entries 
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3. Click Yes to post the memorized transaction in reverse. When the task is 
complete, a message displays the trace report number (Figure 5.17). 

Figure 5.17—Successful Posting and Trace Report Message

4. Click OK.

5. Print the trace report and review. You should store the printed trace report for 
your records.

6. Click Close to exit the task.

COPYING MEMORIZED JOURNAL ENTRIES

Use the following instructions to copy a memorized transaction. 
1.  Click Journal Entry > Memorized on the module navigator (if the module is 

not expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Memorized from the menu bar. The Saved Journal Entries window 
displays (Figure 5.18). 

Figure 5.18—Memorized Journal Entries Window
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2. Select the saved transaction click Copy. The Copy window displays (Figure 
5.19). 

Figure 5.19—Copying a Memorized Batch

3. Enter a unique description for this batch.

4. Select the radio button to indicate if the new batch created by the copy task 
should be a Saved batch or a Memorized batch.

For example, our organization has a memorized batch that we produce 
each month, but the dollar amounts vary. We don’t want to change the 
memorized batch each month, so we copy the batch, saving the new 
batch (with this month’s dollar amount) to the Saved folder.

5. Click OK. The new batch is stored in the applicable folder (i.e., either Journal 
Entry > Saved or Journal Entry > Memorized). 

If you indicated that the new batch is a Memorized batch, click Refresh 
to see the batch in the Journal Entry > Memorized display.

DELETING MEMORIZED JOURNAL ENTRIES

The Delete task for memorized journal entries allows you to delete the actual 
memorized transaction (i.e., the “template”). You are not deleting actual posted 
transactions.
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1.  Click Journal Entry > Memorized on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Memorized from the menu bar. The Memorized Journal Entries 
window displays (Figure 5.20). 

Figure 5.20—Memorized Journal Entries Window

2. Select the memorized transaction click Delete. A confirmation message 
displays.

3. Click Yes to delete the memorized transaction. When the task is complete, a 
message displays.

4. Click OK. The transaction no longer displays in the Memorized Journal Entries 
window.

5. Click Close to exit the task.

PRINTING MEMORIZED JOURNAL ENTRIES

Click Print Grid to print the summary information displayed in the Memorized Journal 
Entries window.

You can also produce reports (e.g., Special Journal Entries List) of this 
information.

WORKING WITH IMPORTED JOURNAL ENTRIES
Context-sensitive topic: Journal Entry—Memorized Transactions
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You can export information from another accounting package or create a text file, then 
import that information into your General Ledger–Project/Grant system. (The 
instructions for importing a transaction can be found in the Blackbaud FundWare System 
Administration Guide.) Once imported, you can memorize or post the information at any 
time.
To access your imported transactions, click Journal Entry > Imported on the module 
navigator (if the module is not expanded, click General Ledger first) or select General 
Ledger > Journal Entry > Imported from the menu bar. The Imported Journal Entries 
window displays (Figure 5.21). 

Figure 5.21—Imported Journal Entries Window

The system displays the following information about each saved transaction:
• Description—The name of the imported transaction. Taken from the description 

or transaction name defined in the import file.
• Journal—The journal to which this transaction will post.
• Saved Date—The date the transaction was imported to the system.
• User ID—The user who imported this transaction.

EDITING IMPORTED JOURNAL ENTRIES

Use the following instructions to edit an imported transaction.
Working With Imported Journal Entries 
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1.  Click Journal Entry > Imported on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Imported from the menu bar. The Saved Journal Entries window 
displays (Figure 5.22). 

Figure 5.22—Imported Journal Entries Window

2. Select the imported transaction click Edit. The journal entries for the 
transaction display in the Journal Entry form.

3. Edit the journal entries, as necessary.

4. When your entries are complete:

• Click Save Entries to save your entries and clear the New Journal Entry 
form. 

• Click Post to post your entries directly to the specified journal. A 
confirmation message will display and the transaction no longer appears in 
the Imported Journal Entries window.

• Click Memorize to memorize your entries. You will be asked to enter a 
memorized transaction name. For more information, Working With 
Memorized Journal Entries on page 189. 

POSTING IMPORTED JOURNAL ENTRIES

Use the following instructions to post an imported transaction on the current business 
date.
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1.  Click Journal Entry > Imported on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Imported from the menu bar. The Saved Journal Entries window 
displays (Figure 5.23). 

Figure 5.23—Imported Journal Entries Window

2. Select the imported transaction click Post. A confirmation message displays.

3. Click Yes to post the imported transaction. When the task is complete, a 
message displays the trace report number (Figure 5.24). 

Figure 5.24—Successful Posting and Trace Report Message

4. Click OK.

5. Print the trace report and review. You should store the printed trace report for 
your records.

6. Click Close to exit the task.

MEMORIZING IMPORTED JOURNAL ENTRIES

Use the following instructions to memorize an imported transaction.
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1.  Click Journal Entry > Imported on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Imported from the menu bar. The Saved Journal Entries window 
displays (Figure 5.25). 

Figure 5.25—Imported Journal Entries Window

2. Select the imported transaction click Memorize. A confirmation message 
displays.

3. Click Yes. When the task is complete, a message displays.

4. Click OK. The transaction now displays in the Memorized Journal Entries 
window (i.e., it is removed from the Imported Journal Entries window) (Figure 
5.26). 

Figure 5.26—Memorizing an Imported Transaction

Because the SUMMER BUDGET ENTRY transaction has not been 
posted yet, nothing displays in the Posted Date and Post/Reverse 
columns.
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COPYING IMPORTED JOURNAL ENTRIES

Use the following instructions to copy an imported transaction.
1.  Click Journal Entry > Imported on the module navigator (if the module is not 

expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Imported from the menu bar. The Saved Journal Entries window 
displays (Figure 5.27). 

Figure 5.27—Imported Journal Entries Window

2. Select the saved transaction click Copy. The Copy window displays (Figure 
5.28). 

Figure 5.28—Copying an Imported Batch

3. Enter a unique description for this batch.

4. Select the radio button to indicate if the new batch created by the copy task 
should be a Saved batch or a Memorized batch.

5. Click OK. The new batch is stored in the applicable folder (i.e., either Journal 
Entry > Saved or Journal Entry > Memorized). 
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If you indicated that the new batch is a Memorized batch, click Refresh 
to see the batch in the Journal Entry > Memorized display.

DELETING IMPORTED JOURNAL ENTRIES

Use the following instructions to delete an imported transaction.
1.  Click Journal Entry > Imported on the module navigator (if the module is not 

expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Imported from the menu bar. The Saved Journal Entries window 
displays (Figure 5.29). 

Figure 5.29—Imported Journal Entries Window

2. Select the imported transaction click Delete. A confirmation message displays.

3. Click Yes to delete the imported transaction. When the task is complete, a 
message displays.

4. Click OK. The transaction no longer displays in the Imported Journal Entries 
window.

5. Click Close to exit the task.

PRINTING IMPORTED JOURNAL ENTRIES

Click Print Grid to print the summary information displayed in the Imported Journal 
Entries window.

You can also produce reports (e.g., Special Journal Entries List) of this 
information.
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WORKING WITH POSTED TRANSACTIONS
Context-sensitive topic: Journal Entry—Memorized Transactions
From the Posted Transactions window, you can:

• View summary information of transactions posted within a specified date range.
• View detail information for a posted transaction.
• Reverse a selected transaction.
• Print summary or detail information for posted transactions.

VIEWING POSTED TRANSACTIONS

Use the following to view summary or detail information for a posted transaction.
1.  Click Journal Entry > Posted on the module navigator (if the module is not 

expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Posted from the menu bar. The Posted Transactions window displays. 
The date range defaults to the current business date (Figure 5.30). 

Figure 5.30—Posted Transactions Window

2. Enter a date range to filter the displayed transactions or click the All Dates 
check box to include all transactions in the display.
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3. Click Find Now. The posted transactions that match the date range (or all 
transactions) display, including the debit and credit totals for the displayed 
transactions (Figure 5.31). 

Figure 5.31—Posted Transactions—Filtered by Posted Date

4. You can type a value in the blank cells at the top of each column to filter the 
results.

5. To view the details of a posted transaction, select the transaction and click Drill 
Down (Figure 5.32). (You can also double-click the transaction or right-click 
and select Drill Down from the shortcut menu.) 

Figure 5.32—Drill Down Feature—Transaction Details

6. Click Close to exit the Drill Down window.
Blackbaud, Inc. 205



Blackbaud FundWare General Ledger–Project/Grant Guide

206
7. Click Close to exit the Posted Transactions window.

MANUALLY REVERSING A TRANSACTION

You can manually reverse a transaction from the Posted Transactions window. (For 
information on the auto reverse feature, see Using the Auto Reverse Feature on page 
183.)

1.  Click Journal Entry > Posted on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > Journal 
Entry > Posted from the menu bar. The Posted Transactions window displays. 
The date range defaults to the current business date (Figure 5.33). 

Figure 5.33—Posted Transactions Window

2. Enter a date range to filter the displayed transactions or click the All Dates 
check box to include all transactions in the display.
Working With Posted Transactions 
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3. Click Find Now. The posted transactions that match the date range (or all 
transactions) display, including the debit and credit totals for the displayed 
transactions (Figure 5.34). 

Figure 5.34—Posted Transactions—Filtered by Posted Date

4. Select the transaction that you want to reverse and click Reverse. The Reverse 
window displays (Figure 5.35). 

Figure 5.35—Reverse Window

5. Enter a description of the reversal and any reference information. 
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The field titles for the references will reflect the Reference Title settings 
on the journal definition. This default setting is Reference 1, Reference 
2, and Reference 3.

6. Click OK. When the task is complete, a message displays the trace report 
number (Figure 5.36). 

Figure 5.36—Successful Posting and Trace Report Message

7. Click OK. A reverse posting of the transaction has been posted.

8. Click Close to exit the Posted Transactions window.

PRINTING POSTED TRANSACTIONS

Click Print Grid to print the summary information displayed in the New Journal Entry 
window. 

You can also produce reports (e.g., Special Journal Entries List) of this 
information.

PRINTING JOURNAL ENTRIES
You can access your saved, imported, and memorized journal entries via Report 
Manager using the following instructions.

1.  Select File > Report Manager from the menu bar. The Report Manager 
window displays. 
Printing Journal Entries 
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2. Select General Ledger and the Transaction Reports category (Figure 5.37). 

Figure 5.37—General Ledger Reports—System Lists

3. From the ID type drop-down list, select the ID type for the report you want to 
run.
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4. Double-click the Special Journal Entry List report (CSENTRY), or select the 
report and click Produce. The report parameters pop-up window displays 
(Figure 5.38). 

Figure 5.38—Special Journal Entries List Report Parameters

5. Enter your report parameters according to Table 5.4. 

Table 5.4—Special Journal Entry List—Report Parameters

Field Description

Journal Entry 
Type

Select what kind of journal entries you want to view from the drop-down list.
• All—Includes all saved, imported, and memorized transactions in the report.
• Saved data entry transaction—Includes only the saved transactions in the report
• Imported transaction—Includes only the saved imported in the report
• Memorized journal entry—Includes only the memorized transactions in the report

Select Journals To select one or more journals, select the journal in the left box and click the right 
arrow to move it to the right box.
• By default, all journals will be included in your report.
• To remove a journal from the report, select the journal in the right box and click the 

left arrow to return it to the left box.

Select 
Transaction 
Names

To select one or more transactions, select the transaction in the left box and click the 
right arrow to move it to the right box.
• By default, all transactions will be included in your report.
• To remove a transaction from the report, select the transaction in the right box and 

click the left arrow to return it to the left box.
Printing Journal Entries 
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6. Click OK. The report is sent to your selected output option (i.e., View, Print, or 
File).

FundWare also creates a trace report for each journal entry type. For more information 
on trace reports, see Trace Reports on page 213.

USING THE ACCOUNT SELECTOR
The Account Selector provides a search function if you do not know the account number 
to be entered.

Page Break on 
Every Entry

Select the check box to enable the page break option.

Report Select the option for the report output:
• View—Report is saved to your reports directory and displayed in Print Manager.
• Print—Report is printed directly to your default printer.
• File—Report is saved to your reports directory.

Table 5.4—Special Journal Entry List—Report Parameters (Continued)

Field Description
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1.  Click the button beside the Account text box, . The Account Select window 
displays (Figure 5.39). 

Figure 5.39—Account Selector

2. Select the ID type from the drop-down list.

3. Select the check box for the appropriate status. (Optional)

4. Enter any of the following information to help filter your accounts: an Account 
Mask, Description, or Aliases (1 and 2) in the text boxes, or select the Last 
Updated check box and enter a date in the date text box. (Optional)

You can use a percent sign in the Description or Alias fields as a “wild 
card.” For example, in Division 95 we enter a “% supplies” in the 
Description field (no other filter criteria) and click Search. The 
Account Selector displays all the accounts with “supplies” in the 
description (i.e., operating, office, computer, and inventory).

5. Click the All check box for Attributes (deselects this option) and select which 
available attributes to include or exclude. (Optional)
Using the Account Selector 
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You do not need to enter any search parameters other than the ID type. 
However, the more specific you are in your search, the fewer accounts 
will be included in the results.

6. Click Search. The accounts found display in the data window below.

7. Select the account that you want to add.

8. Click OK.

TWINNING ACCOUNTS

Use the following steps to twin, or append, accounts.
1.  Once you have selected an account, click OK. 

2. Open the Account Selector again.

3. Select a new ID type from the drop-down list.

4. Select the check box for the appropriate status.

5. Enter an Account Mask, Description, or Aliases (1 and 2) in the text boxes, or 
select the Last Updated check box and enter a date in the date text box. Or select 
the All check box for Attributes and select which available attributes to include 
or exclude.

6. Click Search. The accounts found display in the data window below.

7. Select the second account that you want to append.

8. Click Append.

9. Click OK.

TRACE REPORTS
Every time you post transactions to General Ledger–Project/Grant, either through the 
journal entry window or from another module such as Accounts Payable, the system 
produces an audit report (i.e., “trace report”). 
You can view and print the trace report in detail and in summary format through Report 
Manager:
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• Detail—Contains a line-by-line printout of the journal entry as it is entered, 
including the account number, account description, item description, three 
reference fields, and debit and/or credit amount. Optional information such as 
data items or units and rates may also be shown if it is collected by the journal.

• Summary—Summarizes all items by account number for the entire transaction, 
includes the business date, calendar date, and ID of the operator that posted the 
transaction. It also shows the transaction total.

We strongly recommend that you produce both the detail and summary sections of the 
report and retain them in paper or electronic format. Trace reports can be produced at 
any time using Re-Print Trace Reports in Report Manager. However, if your site 
experiences an equipment failure, the reports you have saved can be invaluable.

The journal definition determines whether the trace report is produced in detail 
or summary format. For more information, see Maintaining Your Journals on 
page 101. 

VIEWING TRACE REPORTS

You view trace reports with Print Manager.
1.  Select File > Print Manager from the menu bar. The Print Manager window 

displays, listing the reports in your Data folder.

2. Select the trace report from the list. Trace reports begin with the letters CS, 
followed by a system number that is generated in sequential order (i.e. 
CSXXXXX.L##).

3. Click Open. The report displays.

4. To print the report, click  or select File > Print from the Print Manager tool 
bar.

Complete information on Print Manager can be found in the Printer Manager User 
Guide.

 

Trace Reports 
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LOCKING PERIODS AND YEARS

Context-sensitive topic: Locking Periods and Years
Once you have completed and confirmed all your entries for a fiscal period or year, your 
organization may choose to lock (or “close”) that fiscal period or year to data entry. 
Locking a fiscal period is not a financial or accounting procedure; it simply prevents 
users from posting transactions to a specific ID type during that period.

Smith County has completed and confirmed all their accounting entries for the 
month of August. Now they want to ensure that no one can accidently post an 
entry to that month. Therefore, the County closes the system through 8/31/2004.

All your information is still available for reporting purposes, but as long as the period is 
closed, there are only two ways that an entry could post to this period:

• If the system date falls within the posting window defined for the ID type.
• If your organization uses Advanced Security, an add-on security feature, and the 

user has been given rights to post to closed periods.
When necessary, you can also re-open a closed period to enter additional transactions.

LOCKING A PERIOD OR YEAR TO POSTING
Use the following instructions to lock one or more periods or years to posting.
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1.  Click Lock Periods/Years to Posting on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > Lock 
Periods/Years to Posting from the menu bar. The task displays (Figure 6.1). 

Figure 6.1—Lock Periods/Years to Posting—Fiscal Years Collapsed

2. From the ID Type drop-down list, select the ID type for which you are closing 
the period or year.
Locking a Period or Year to Posting 
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3. Click the plus sign to expand a fiscal year. The system displays all periods, 
reclass periods, and adjustment periods for the year (Figure 6.1). 

Figure 6.2—Lock Periods/Years to Posting—Fiscal Years Collapsed

4. Click the check box to open a period. A check mark displays in the box for the 
selected period and any preceding periods.

For example, if March 2005 and April 2005 are both open periods and 
you click the April 2005 check box, the system will close both March 
and April to posting.

Click the top check box to close an entire year. Check marks display for all 
periods within the year.
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5. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window. 

OPENING A CLOSED PERIOD OR YEAR
Use the following instructions to open a period or year to data entry.

1.  Click Lock Periods/Years to Posting on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > Lock 
Periods/Years to Posting from the menu bar. The task displays (Figure 6.1). 

Figure 6.3—Lock Periods/Years to Posting—Fiscal Years Collapsed

2. From the ID Type drop-down list, select the ID type for which you are opening 
the period or year.
Opening a Closed Period or Year 
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3. Click the plus sign to expand a fiscal year. The system displays all periods, 
reclass periods, and adjustment periods for the year (Figure 6.1). 

Figure 6.4—Lock Periods/Years to Posting—Fiscal Years Collapsed

4. Click the check box to open a period. The check mark no longer displays in the 
box for the selected period and any subsequent periods.

For example, if March 2005 and April 2005 are both closed periods and 
you click the March 2005 check box, the system will open both March 
and April to posting.

Click the top check box to open an entire year. The check mark no longer 
displays in any period box for the year.
Blackbaud, Inc. 219



Blackbaud FundWare General Ledger–Project/Grant Guide

220
5. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and close the window. 

REOPENING CLOSED PERIODS PRIOR TO SAVING/PURGING
For a year to be saved or purged, you must ensure that all periods within the year are 
open for data entry. If any period within the year is closed, the fiscal year will not 
display in the Available Periods drop-down menu. 

 

Reopening Closed Periods Prior to Saving/Purging 
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YEAR-END PROCESSING

Context-sensitive topic: Year-End Processing
At the end of each fiscal year, you must complete some tasks to close out the past year 
and prepare your system for the next fiscal year. You must:

• Post your revenue and expense account balances to fund balance or net asset 
accounts, and

• Roll the closing balances forward to create beginning balances for the new year.
You can repeat these steps as many times as necessary. Organizations often perform 
multiple closes to correctly balance the old and new years.
Once these tasks are complete, you should close the fiscal year to data entry. Depending 
on the needs of your organization, you may also purge information from your system.

Don’t forget: If you are ending one fiscal year, you must add date tables for the 
next year. See Adding New Date Tables on page 117.

BEFORE YOU BEGIN
Before you begin any year-end task, you must:

• Backup your data, 
• Ensure that all users are logged off the system, and
• Log onto FundWare using the last day of the fiscal year.

BACKING UP YOUR DATA

Before beginning any year-end task, you must complete all backup procedures for the 
FundWare data directory, as well as other related FundWare files. (These procedures 
should be established by your organization.)
Blackbaud, Inc. 221



Blackbaud FundWare General Ledger–Project/Grant Guide

222
This precaution will allow data restoration in case incorrect accounts are closed, a final 
close is performed instead of a preliminary close or data/system errors occur.

Failure to institute proper backup and restore procedures could result in serious 
damage to your accounting database. When you encounter an error message or 
condition, the only way to recover your data may be to restore from a backup.

WHAT IS YOUR CLOSING ID?
Before you begin, you should determine what your closing ID is for the ID type. The 
closing ID is an account mask that identifies the accounts that may be impacted by this 
task. (During the task, you can also specify a fund range and attributes to further filter 
your accounts.) When you enter the closing ID, you must mask at least the fund 
dimension of your account number and enter the object code that defines the net asset or 
fund balance accounts. For example:

• Closing ID: AXX 00 00 3110
— Will close all Fund 01 accounts into account A01 00 00 3110, Fund 02 

accounts into A02 00 00 3110, etc. 
• Closing ID: AXX XX 00 3110

— Will close all Fund 01, Department 01 accounts into A01 01 00 3110, all 
Fund 01, Department 02 accounts into A01 02 00 3110, etc. 

• Closing ID: AXX XX XX XXXX 
— Will close each individual revenue/expense account into itself (not the 

correct result). 
If you do not know the closing ID, you can search your Chart of Accounts for NA or FB 
attribute values (depending on your system setup) or produce a chart of accounts report 
and include only attributes NA or FB. Reviewing this information should help you 
determine the closing ID.

VIEWING LOGGED IN USERS

Before you begin any year-end task, you must ensure that all users are logged off 
FundWare.

1.  Open an instance of FundWare.

2. From the Division Selection window, select System Administration. (System 
Administration tasks can apply to multiple divisions. Therefore, instead of 
selecting a single division you must select System Administration.) The 
System Administration HomePage displays. 
Before You Begin 
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3. Ensure that no users are logged in to the division in which you are working. 

POSTING REVENUE AND EXPENSE BALANCES
One of the steps necessary to close a fiscal year is to post the balances from revenue and 
expense accounts to the appropriate equity accounts (net assets or fund balance 
accounts). The balances for all revenue and expense accounts are zeroed, an entry is 
made to the net assets or fund balance accounts, and your system is ready for the coming 
year.

You do not need to complete this task for Project/Grant ID types. You will only 
need to roll balances forward into the new year. 

After posting the revenue and expense accounts to the equity accounts, you should 
always Roll Beginning Balances forward to create new beginning balances for the 
balance sheet accounts for the new year.

POSTING REVENUE AND EXPENSE FOR AN ID TYPE

Use the following instructions to post your revenue and expense balances.
1.  Click Maintenance > Year-End Processing on the module navigator (if the 

module is not expanded, click General Ledger first) or select General Ledger 
> Maintenance > Year-End Processing from the menu bar. The Year-End 
Processing window displays, open to the Post Revenue & Expense tab (Figure 
7.1). 

Figure 7.1—Year-End Processing—Post Revenue & Expense Tab
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2. Complete the required fields according to Table 7.1. 

Table 7.1—Post Revenue & Expense Field Definitions

Field Definitions

Closing ID Enter an account mask to identify the accounts that may be closed by this task. 
(You can specify a specific fund range and/or attributes in later steps.)
• You must mask at least the fund dimension of your account number and enter 

the object code that defines the net asset or fund balance accounts.

Closing Year-End Select the year you want to close from the drop-down list.

Fund Range Defines the funds to be closed for the specified ID type.
• For example, in Division 95 a range of 00–99 closes the fiscal year activity for 

all funds in ID type A.

Preview (no 
posting)

Allows you to preview the results of the task without actually posting the 
balances.
• If the box is checked, FundWare does a “test” closing and produces a report of 

the results (i.e., the balances are not posted). You should review the report to 
ensure the closing meets your expectations and is correct. 
— The Post Revenue & Expense report is called GLREEX.L## (where ## 

represents your division number). 
• If the box is not checked, FundWare does final year-end processing (i.e., the 

balances are actually posted). 
We strongly recommend that you do at least one Preview to be sure you have 
correctly masked the closing accounts.

Produce Report Produces a report (GLREEX.L##, where ## represents your division number). 
• If you are previewing the task, this report is automatically created and this 

check box is disabled. (In other words, you do not have the option of not 
producing this report if you are previewing the task.)

• If you are actually posting your revenue and expense balances, we strongly 
recommend that you produce this report and keep a printed copy for your 
records. (It can be useful next year when you need to remember what closing 
accounts you used.)

• The produced report also posts to the General Ledger–Project/Grant and 
creates a trace report. 

Include/Exclude 
Attributes

Enter an attribute an account must have to be included or excluded by clicking in 
the desired position number and selecting the appropriate attribute(s).
• By selecting specific attributes on this window, you are selecting groups of 

accounts to include or exclude from the task. 
• If you enter multiple attributes, an account must match all of the criteria you 

entered in order to be selected for the report or task.
Posting Revenue and Expense Balances 



Chapter 7—Year-End Processing
3. Click Apply to start the task and remain in the window, or click OK to start the 
task and close the window. The account balances are posted to the equity 
accounts and the GLEEX report is produced (if you selected this option).

4. Repeat this task, as necessary, using other closing IDs until all your revenue and 
expense balances have been posted.

You are now ready for the Roll Beginning Balances task.

“NOT IN SYSTEM” ACCOUNTS

When you post revenue and expense balances in “preview,” the system produces the 
REEX report automatically. (You have the option of producing this report when you run 
the task to post your balances.)
When you review this report, you may find entries listed as “Not in System.” (These 
entries would be listed at the end of the report.) If your report lists Not in System entries 
(it may not, and that’s OK), you must verify that the system should create accounts for 
these entries.
When you actually complete the post revenue and expense task (i.e., not in preview), 
FundWare will create accounts for each of these Not in System accounts. You will need 
to change the titles and put an attribute on the account after it is created. 

ROLLING BEGINNING BALANCES
When you roll beginning balances at the end of a fiscal year, FundWare takes the closing 
balance of an account and “rolls” it forward to create the opening balance for the new 
year. 

For General Ledger ID types, you must post revenue and expense balances to 
equity accounts before you can roll these balances forward. For Project/Grant 
ID types, you do not need to post these balances. You only need to roll the 
balances forward.

Use the following instructions to roll your beginning balances forward. 
1.  Click Maintenance > Year-End Processing on the module navigator (if the 

module is not expanded, click General Ledger first) or select General Ledger 
> Maintenance > Year-End Processing from the menu bar. The Year-End 
Processing window displays, open to the Post Revenue & Expense tab.
Blackbaud, Inc. 225



Blackbaud FundWare General Ledger–Project/Grant Guide

226
You must be signed on to the last day of the fiscal year being posted. If 
necessary, open a new instance of FundWare using that date.

2. Select the Roll Beginning Balances tab (Figure 7.2). 

Figure 7.2—Year-End Processing—Roll Beginning Balances Tab

3. From the ID type drop-down list, select the ID type for which you are rolling the 
balances. The ID type description displays in the Description field and is not 
editable.

4. Click Apply to start the task and remain in the window, or click OK to start the 
task and close the window. The account balances are rolled forward and the 
system produces a trace report.

If the task does not produce a trace report, there were no transactions in 
prior years to roll forward or no changes in balances since the last time 
balances were rolled forward.

5. Repeat this task, as necessary, for each ID type.

PURGING OR SAVING FISCAL YEARS
FundWare allows you to maintain as many fiscal years in your database as your 
organization requires. The Purge/Save Fiscal Year function allows you to remove and 
save data from the database. (This is an optional task and you should fully understand 
the option before proceeding.)

• Purge removes all information for the ID type and year specified. This includes 
detail journal entries as well as the summary balances.
Purging or Saving Fiscal Years 
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• Save removes only the detail of the journal entries while retaining summary 
balances. This option allows you to continue to produce historical comparison 
reports showing multiple years. 
Once a year is saved, it cannot be re-opened for data entry. Therefore, it is 
critical that you create a permanent backup (i.e., do not rely on the FundWare 
division maintenance task) prior to purging/saving your data.

OPENING ALL PERIODS

Before you can save or purge a fiscal year, you must ensure that all periods within that 
year are open for data entry. If any period within the year is closed, the fiscal year will 
not display in the drop-down list for the purge/save task. 
To open the year to data entry, access the Lock Periods/Years to Posting task and 
ensure that no check marks appear in the boxes for the year. See Reopening Closed 
Periods Prior to Saving/Purging on page 220 for more information.

PURGING OR SAVING A FISCAL YEAR

Use the following instructions to purge or save your fiscal year. 
It is vital that this task complete without interruption. If the power goes down, 
an error message is displayed, or any other event causes the task to halt before 
completion, you must restore from the backup and begin again.

1.  Click Maintenance > Year-End Processing on the module navigator (if the 
module is not expanded, click General Ledger first) or select General Ledger 
> Maintenance > Year-End Processing from the menu bar. The Year-End 
Processing window displays, open to the Post Revenue & Expense tab.
Blackbaud, Inc. 227



Blackbaud FundWare General Ledger–Project/Grant Guide

228
2. Select the Open/Close Fiscal Year tab (Figure 7.3). 

Figure 7.3—Purge/Save Fiscal Year Tab

3. Complete the required fields according to Table 7.2. 

4. Click Apply to start the task and remain in the window, or click OK to start the 
task and close the window. 

5. Repeat this task, as necessary, for each ID type.

 

Table 7.2—Purge/Save Fiscal Year Field Definitions

Field Definitions

ID Type Select the ID type for which you are closing the year. 

Description The ID type description displays in the Description field and is not editable.

Fiscal Year End Select the year to be purged or saved from the drop-down list.
• If a year does not appear, ensure that all periods within the year are open to 

data entry.

Process Options Select which task you want to complete:
• Save Fiscal Year—Removes detail transactions for the year(s) to be processed, 

but account balances for the fiscal year(s) are saved. Reports that print 
balances can be produced for the saved year(s), but transaction reports are 
unavailable.

• Purge Fiscal Year—Completely deletes the year(s) to be processed. No reports 
can be produced for the purged year(s).
Purging or Saving Fiscal Years 
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USING THE COST ALLOCATION FEATURE

The FundWare Cost Allocation feature allows you to distribute costs from pooled 
accounts to specific cost centers. Cost Allocations are performed on a single month 
basis. The period allocated depends on the current business date. 
Cost Allocation can be used with FundWare’s cost reporting modules: General Ledger 
and Project/Grant. For example, grant agencies often allow an organization to allocate a 
certain percentage of allowable overhead costs to a grant. However, when entering 
invoices, it is difficult and time consuming to break down individual invoices into many 
cost centers. Cost Allocation allows the daily data entry to post to a pooled account or 
group of accounts, followed by a monthly reclassification of those expenses to the 
appropriate grants by the user-defined percentage tables.
Although Cost Allocation is commonly used to distribute indirect expenses, it is also 
useful for distributing revenue. For example, interest revenue on investments may be 
posted to a pooled account and then allocated based on user-defined percentages.

THE COST ALLOCATION PROCESS
The cost allocation process involves three steps:

• Defining the allocations to reflect the way your organization’s indirect costs or 
other allocations are distributed. 

• Previewing how the allocation entries will actually be recorded in reporting.
• Posting the allocations.

Cost Allocation Setup and Procedures on page 230 provides the instructions for 
defining and previewing your allocations.
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COST ALLOCATION SETUP AND PROCEDURES
Use the following steps to set up an allocation and preview allocations.

1.  Select File > Cost Allocation. The Cost Allocation feature opens to the Define/
View Allocations tab (Figure 8.1). 

Figure 8.1—Example New Cost Allocation: Define/View Allocations Tab

2. Click New. 

3. Complete the required fields, as described in Table 8.1. 

Table 8.1—Define/View Allocations Field Definitions

Field Definition

Source mask The account(s) from which amounts are allocated.
Cost Allocation Setup and Procedures 
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4. Click Apply to save the allocation. 

5. Select the Post/Preview Allocations tab (Figure 8.2). 

Figure 8.2—Example New Cost Allocation: Post/Preview Allocations Tab

6. Click Preview Allocations. This runs a report that displays the allocation 
results without affecting the actual books.

Remainder mask The account(s) to which the non-allocated percentage goes. A remainder mask is 
required because all allocations will have some remainder amounts. Valid percent 
allocations are from .0001 to 99.9999, so there will always be an amount, due to 
rounding, that will go to the remainder mask.

Allocation detail Where you specify percentages of the allocation to go to specific accounts, and 
also set limits on dollar amounts to be allocated to any one account during the 
posting. 

Table 8.1—Define/View Allocations Field Definitions (Continued)

Field Definition
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7. Select the allocation you want to preview. In our example, we would click 
TELE2 on the left side of the Select Allocations box, and click the right double 
arrows to move it to the right box.

8. Click Apply, and a preview of the allocation will be reported. The report can be 
viewed in Report Manager. 

If the allocation is correct, you can then post the allocation to your General Ledger.

COST ALLOCATION TIPS
The following tips can help you create and use your allocations.

• Cost Allocation works within one ID type only and does not cross ID types.
• We recommend that you set up a journal specific to the cost reporting system, 

which can be useful for auditing purposes.
• Sign on with or change to the business date within the period to which you want 

to post. The system uses the net transactions of each account for that period.
• Make use of account masking.
• Print a Chart of Accounts report showing all your accounts and account 

numbers to help you select masks.
• Any digit masked in the source accounts must be masked in the target accounts.
• If your organization has more complex allocation requirements, ask FundWare 

Support or your reseller for information about the FundWare Allocation 
Management module.

 

Cost Allocation Tips 
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USING BUDGET CONTROL

If you want to use the Budget Control feature, you must define a Budget Control 
parameter for each ID type that you want to monitor. When you define the parameter, 
you can specify the accounts and to what level Budget Control will operate for the ID 
type. You also specify percentages and amounts that trigger three levels of messages that 
will be included in the Budget Control report as you approach or surpass your budget:

• Message—Informs you that the transaction brings you within the specified 
message limits of the budgeted amount for the account. You can continue 
posting to this account.

• Warning—Informs you that the transaction brings you within the specified 
warning limits of the budgeted amount for the account. You can continue 
posting to this account.

• Error—Informs you that the transaction brings you within the specified error 
limits of the budgeted amount for the account. You cannot continue posting to 
this account.

Once you have defined the parameters, you must define the budget year to which the 
parameters apply. This is done using the Start Budget Control Year task, which allows 
you to:

• Activate a budget year when you first enter your Budget Control Parameters,
• Restart your control year each time you modify the balance of any budget 

amount for an account,
• Restart your control year each time you modify a parameter, and
• Restart each parameter at the beginning of each budget year.

DEFINING YOUR BUDGET CONTROL PARAMETERS
Use the following instructions to define the Budget Control parameter for an ID type.
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The ID type for which you are defining the parameter must be defined before 
you can proceed.

1.  Click Budget Control > Define Parameter on the module navigator (if the 
module is not expanded, click General Ledger first) or select General Ledger 
> Budget Control > Define Parameter from the menu bar. The Define 
Parameter option menu displays (Figure 9.1). 

Figure 9.1—Define Parameter Option Menu

2. Type A to add a parameter for an ID type. The system asks you to identify the 
ID type (Figure 9.2). 

Figure 9.2—Define Parameter—Enter ID Type
Defining Your Budget Control Parameters 
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3. Enter the ID type or press F1 and select the ID type from the list.

4. Press ENTER. The fields defining the parameter record display (Figure 9.3). 
(Page 1 of 2 displays; however, page 2 stores system information only. As this 
is not editable information, page 2 will only display when you are viewing an 
existing data item, not while you are adding a new data item.) 

Figure 9.3—Define Parameter—Page 1 of 2

5. Complete the required fields according to Table 9.1.

Table 9.1—Define Parameter—Page 1 of 2

Field Valid Entry Definition

Budget detail Y
N

Indicates the level at which the system will monitor your budget, 
based on dimensions. Your options are:
• Y (Control using all dimensions)—Budget control is on the detail (or 

full) level of the account using all dimensions.
• N (Control using selected dimensions)—Budget control is on 

selected dimensions of the account number. In addition to this 
option, the dimensions on which the budget is to be controlled must 
also be entered. These dimensions then define the budget control 
account.
— When budgeting on selected dimensions, make sure to include 

the DS attributes. This will allow the DS account description to 
be used for the title that appears on the Budget Control report.
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Control level 1
2

Enter the basis by which you will monitor your budget:
• 1 (Control by year only)—Only yearly totals are controlled.
• 2 (Control by period and year)—Both period and yearly totals are 

controlled.

Include attrs a1/a2/a3/.../
a9/a10

The attributes that you include define the accounts that will require 
budget control. You can define up to 15 included attributes; if an 
account has any of the listed attributes in the specified position, it 
requires budget control. For example, you define the following:
• EX/ / / / / / / / / / / / / /
Therefore, Budget Control will impact only the Expenditure accounts 
(i.e., accounts defined with the EX attribute in the first position). 
Press F1 to select from a list of attributes allowed in each position. 
You must define at least one included or excluded attribute.

Exclude attrs a1/a2/a3/.../
a9/a10

The attributes that you exclude define the accounts that will not 
require budget control. You can define up to 15 excluded attributes; if 
an account has any of the listed attributes in the specified position, it 
is excluded from the budget control process. For example, you define 
the following:
• / / /F1/ / / / / / / / / / /
Therefore, Budget Control will never be applied to fund F1 accounts 
(i.e., accounts defined with the F1 attribute in the fourth position), 
regardless of any match in the Include attr field.
Press F1 to select from a list of attributes allowed in each position. 
You must define at least one included or excluded attribute.

Year message 
(Period)

____%
____.00

Enter the annual percentage and/or flat amount at which you want to 
receive a first-level message (i.e., “you are getting close to an out of 
budget condition”). Depending on the setting that triggers the 
message, the system will print Percentage warning or Amount 
warning in the Error Level column of the Budget Control report.
• Entering zeroes in both the percentage and amount positions of this 

field turns off Budget Control for this error level. 
• The defaults for this field are:

— Year: 90% / 500.00
— Period: 95% / 100.00

Note: The system will ask you to define settings for year and period 
only if you selected Control by period and year option for Control 
level.

Table 9.1—Define Parameter—Page 1 of 2 (Continued)

Field Valid Entry Definition
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6. At the option menu, type 0 to accept your entries.

7. Type E to exit the Define Parameter task.

CHANGING YOUR BUDGET CONTROL PARAMETERS

Use the following instructions if you must change the settings of a Budget Control 
parameter. After you have modified these settings, you must restart the Budget Control 
year (Starting Your Budget Control Year on page 241).

Year warning 
(Period)

____% / 
____.00

Enter the annual percentage and/or flat amount at which you want to 
receive a second-level message (i.e., “you are getting close to an out 
of budget condition”). Depending on the setting that triggers the 
message, the system will print Percentage warning or Amount 
warning in the Error Level column of the Budget Control report.
• Entering zeroes in both the percentage and amount positions of this 

field turns off Budget Control for this error level. 
• The defaults for this field are:

— Year: 95% / 250.00
— Period: 100% / 50.00

Note: The system will ask you to define settings for year and period 
only if you selected Control by period and year option for Control 
level.

Year error 
(Period)

____% / 
____.00

Enter the annual percentage and/or flat amount at which you want to 
receive a final-level message (i.e., “you have surpassed your 
budget”). Depending on the setting that triggers the message, the 
system will print Percentage warning or Amount warning in the Error 
Level column of the Budget Control report.
• Entering zeroes in both the percentage and amount positions of this 

field turns off Budget Control for this error level. 
• The defaults for this field are:

— Year: 100% / 0.00
— Period: 105% / 10.00

• Entering 105% allows accounts to go over budget by 5 percent.
Note: The system will ask you to define settings for year and period 
only if you selected Control by period and year option for Control 
level.

Table 9.1—Define Parameter—Page 1 of 2 (Continued)

Field Valid Entry Definition
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1.  Click Budget Control > Define Parameter on the module navigator (if the 
module is not expanded, click General Ledger first) or select General Ledger 
> Budget Control > Define Parameter from the menu bar. The Define 
Parameter option menu displays.

2. Type C to change your settings. The system asks you to identify the ID type for 
which you are changing the Budget Control parameter.

3. Enter the ID type and press ENTER. The parameter settings display.

4. Edit your settings as necessary. (For field definitions, refer to Defining Your 
Budget Control Parameters on page 233.)

5. When complete, press ESC to display the option menu.

6. Type 0 to accept your entries.

7. Type E to exit the Define Parameter task.

8. Restart the Budget Control year (Starting Your Budget Control Year on page 
241).

REMOVING YOUR BUDGET CONTROL PARAMETERS

Use the following instructions if you must remove a Budget Control parameter.
1.  Click Budget Control > Define Parameter on the module navigator (if the 

module is not expanded, click General Ledger first) or select General Ledger 
> Budget Control > Define Parameter from the menu bar. The Define 
Parameter option menu displays.

2. Type R to remove the data item. The system asks you to identify the ID type for 
which you are removing the Budget Control parameter.

3. Enter the ID type and press ENTER. A confirmation message displays.

4. Type Y to remove the parameter. When complete, the system informs you that 
the parameter has been removed.

5. Press ENTER and press ESC to return to the option menu.

6. Type E to exit the Define Parameter task.
Defining Your Budget Control Parameters 
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DISPLAYING YOUR BUDGET CONTROL PARAMETERS

You can display your Budget Control parameters to view (not edit) the information. Use 
the following instructions to display a parameter.

1.  Click Budget Control > Define Parameter on the module navigator (if the 
module is not expanded, click General Ledger first) or select General Ledger 
> Budget Control > Define Parameter from the menu bar. The Define 
Parameter option menu displays.

2. Type D to display your settings. The system asks you to identify the ID type for 
which you are changing the Budget Control parameter.

3. Enter the ID type and press ENTER. The parameter displays (Figure 9.4). 

Figure 9.4—Displaying a Budget Control Parameter—Page 1 of 2
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4. Press enter to display the second page of the parameter, which stores the system 
information (Figure 9.5). 

Figure 9.5—Displaying an Budget Control Parameter—Page 2 of 2

The Status displays the current status of Budget Control:

• 0—System has not yet been defined. Value assigned as record is added.
• 1—System has been defined but requires the START NEW CONTROL 

YEAR task to activate.
• 2—Control years are active.
• 3— needs to be restarted.
The For years entry indicates the range of dates which are being controlled. This 
field is determined when the system is activated via the Start New Control Year 
task (see Starting Your Budget Control Year on page 241).

5. When complete, press ESC to display the option menu.

6. Type E to exit the Define Parameter task.

SCROLLING YOUR BUDGET CONTROL PARAMETERS

The Scroll option allows you to view summary information for a Budget Control 
parameter. Use the following instructions to scroll parameter information.
Defining Your Budget Control Parameters 
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1.  Click Budget Control > Define Parameter on the module navigator (if the 
module is not expanded, click General Ledger first) or select General Ledger 
> Budget Control > Define Parameter from the menu bar. The Define 
Parameter option menu displays.

2. Type S to scroll the parameter. The system asks you to identify the ID type for 
which you are changing the Budget Control parameter.

3. Enter the ID type and press ENTER. The parameter displays (Figure 9.6). 

Figure 9.6—Budget Control Parameter

4. When complete, press ESC to display the Define Parameter option menu. 

5. Type E to exit the Define Parameter task.

STARTING YOUR BUDGET CONTROL YEAR
Once you have defined the parameters, you must define the budget year to which the 
parameters apply. This is done using the Start Budget Control Year task, which allows 
you to:

• Activate a budget year when you first enter your Budget Control Parameters,
• Restart your control year each time you modify the balance of any budget 

amount for an account,
• Restart your control year each time you modify a parameter, and
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• Restart each parameter at the beginning of each budget year.
You can define only two control years at any one time. When you define a third control 
year, the system deletes (i.e., purges) the oldest of the existing control years.

When you execute the Start Budget Control Year task, the system builds (or 
rebuilds) its internal control files. You cannot post while the system is 
processing the task. Therefore, you should schedule time for this task with your 
organization.

Use the following instructions to activate a budget control year.
1.  Click Budget Control > Start Control Year on the module navigator (if the 

module is not expanded, click General Ledger first) or select General Ledger 
> Budget Control > Start Control Year from the menu bar. The Start Control 
Year page displays (Figure 9.7). 

Figure 9.7—Start Control Year

2. Complete the required fields according to Table 9.2. 

Table 9.2—Start Control Year

Field Valid Entry Definition

ID type Valid ID type Enter the ID type for which a new control year is to be started. 
• If there is currently an active year, a warning is displayed 

indicating that an old control year may be removed.
Starting Your Budget Control Year 
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3. Type 0 and press ENTER to accept your entries and close the window.

PRODUCING THE BUDGET CONTROL REPORT
Use the following instructions to produce the budget control report.

1.  Click Budget Control > Budget Control Report on the module navigator (if 
the module is not expanded, click General Ledger first) or select General 
Ledger > Budget Control > Budget Control Report from the menu bar. The 
Budget Control Report window displays (Figure 9.8). 

Figure 9.8—Budget Control Report Parameters

Function S
P
R

Enter the task to be completed:
• R (Restart control year)—Does not require a year ending date. 

This function purges the existing year and starts a new control 
year. Use this function after making changes to the parameter. If 
two years are being controlled, the oldest year will be purged.

• S (Start new control year)—Requires the entry of a year ending 
date, indicating which fiscal year is to be controlled, (mm/dd/
yyyy).

• P (Purge control year)—Requires the entry of a year ending 
date, indicating which control year is to be purged, (mm/dd/
yyyy).

Table 9.2—Start Control Year (Continued)

Field Valid Entry Definition
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2. To define your report, enter the required information according to Table 9.3. 

3. Type 0 and press ENTER to accept your entries and produce the report. The 
window closes and the report (BCRPT.L##, where ## represents your division 
number) is saved to your reports directory (default is FundWare > Data).

 

Table 9.3—Produce the Budget Control Report

Field Valid Entry Definition

Select Valid ID type 
and account 
mask

Enter the ID type and an account mask to filter the information 
included in the report. 
• An asterisk (*) will return information on all ID types within the 

division.
• A mask of all Xs (e.g., AXX XX-XX XXXX) will return information 

on all accounts in the ID type.

Report level Y
P

Indicates the level of information included in the report.
• Y—Only yearly totals are to be reported. Requires the entry of a 

year ending date (mm/dd/yyyy).
• P—Only period totals are to be reported. Requires the entry of a 

period ending date (mm/dd/yyyy).

Report type A
E

Indicates the account information included in the report.
• A—Report all accounts.
• E—Report exceptions only.
Producing the Budget Control Report 
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UNDERSTANDING GL–P/G REPORTS

The General Ledger–Project/Grant reporting feature provides you with more than 30 
system-defined reports, and more than 20 report “types,” or templates, from which you 
can create an unlimited number of user-defined reports. 
The following sections provide you with reference information necessary when you 
define reports, including:

• Report types;
• Using dimensions and attributes to define page breaks, subheading, row 

contents (e.g., detail or summary reports), and row dimensions;
• Report levels;
• Advanced field;
• Relative dates; and
• Excluding attribute types.

UNDERSTANDING REPORT TYPES
All General Ledger–Project/Grant reports use a report type as a template to determine 
the content of the report. Table 10.1 describes the report types available in General 
Ledger. 

Table 10.1—Report Types

Report Type Description

A—Chart of Accounts 
Report

Provides several ways of printing a chart of your accounts. This report may be 
defined to produce lists sorted for the requirements of your organization.
• User-defined reports of this type are saved to the System Lists category.
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B—Ledger Report Allows you to choose the attributes to include in or exclude from the report.
• User-defined reports of this type are saved to the Transaction Reports 

category.

C—Balance Sheet Uses one level of break and row dimensions. The system prompts for two 
phrases on this report and for asset, liability, and fund balance attributes.
• User-defined reports of this type are saved to the Financial Statements 

category.

D—Trial Balance Uses one level of break and row dimensions. Enter attributes in revenue and 
expenditure positions in the Report Attributes tab. All account types 
accepting posting are included on trial balance reports.
• User-defined reports of this type are saved to the Financial Statements 

category.

E—Working Trial 
Balance

Shows the full account number in numerical order so that adjustments can be 
made. This report uses two levels of break and row dimensions.
• User-defined reports of this type are saved to the Financial Statements 

category.

F—Account Detail 
Report

Allows you to produce a report for a date range rather than for a fiscal period. 
Select the date range when the report is produced, not when it is defined.
• User-defined reports of this type are saved to the Transaction Reports 

category.

G—Statement of 
Financial Position

Uses total liabilities and net assets to show the overall financial position of 
your organization. Allows you to use an attribute position to define one or more 
report columns.
• User-defined reports of this type are saved to the Financial Statements 

category.

H—Statement of 
Activities

Uses revenues, expenses, and change in net assets from the beginning of the 
year to the end of the year to display activities. Allows you to use an attribute 
position to define one or more report columns.
• User-defined reports of this type are saved to the Revenue & Expense 

category.

I—Statement of Cash 
Flow

Uses the net assets and operating activities, investing activities, financing 
activities, and cash and cash equivalents to report the cash flow for the period. 
Allows you to use an attribute position to define one or more report columns.
• User-defined reports of this type are saved to the Financial Statements 

category.

Table 10.1—Report Types (Continued)

Report Type Description
Understanding Report Types 
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K—Enhanced Ledger 
Report

Allows you to show all transaction types at once in the report (Actual, budget 
and encumbrance)
User-defined reports of this type are saved to the Transaction Reports 
Category.

L—Revenue and 
Expense w/Change in 
Fund Balance

Allows accounts to be grouped and subtotaled in different ways using the 
break and report subfields. Level 3 is available to show the change in fund 
balance (this information is printed directly after the Level 2 data is printed). 
This report type may also be used as a revenue and expense statement 
without the change in fund balance by leaving the level 3 break and row 
dimensions blank.
• User-defined reports of this type are saved to the Revenue & Expense 

category.

M—Revenue and 
Expense PTD & YTD

Compares actual and budget revenue and expense figures for both period- 
and year-to-date time frames. The dollar variance between budget and actual 
is also shown for both time periods.
• User-defined reports of this type are saved to the Revenue & Expense 

category.

N—Revenue and 
Expense Actual vs. 
Actual by Year

Compares actual revenue and expense figures for two consecutive years for 
both period- and year-to-date. The dollar variance between the two years is 
also shown.
• User-defined reports of this type are saved to the Revenue & Expense 

category.

O—Revenue and 
Expense w/% 
Variance

Compares actual and budget revenue and expense figures for both period- 
and year-to-date time frames. The variance between budgeted and actual 
amounts is shown in both dollars and percentages for both time frames.
• User-defined reports of this type are saved to the Revenue & Expense 

category.

P—Revenue and 
Expense Act vs. YTD 
w/Annual Budget

Compares actual and budget revenue and expense figures for period and 
year-to-date time frames plus the annual budget. Account numbers and 
descriptions print in the center of the report rather than in the left column. The 
variance between budget and actual is shown as a dollar amount for both time 
frames.
• User-defined reports of this type are saved to the Revenue & Expense 

category.

Table 10.1—Report Types (Continued)

Report Type Description
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Q—Revenue and 
Expense w/
Encumbrances

Shows period-to-date actual, year-to-date actual, year-to-date encumbrances, 
and annual budget amounts. Columns display that calculate the variance 
between the year-to-date actual and annual budget including a percent of 
budget used.
• User-defined reports of this type are saved to the Revenue & Expense 

category.

S—Combined 
Balance Sheet

Presents the excess revenue over (or under) expenditures and the liabilities/
fund balance. Allows you to use an attribute position to define one or more 
report columns.
• User-defined reports of this type are saved to the Financial Statements 

category.

T—Combined Rev. & 
Exp.

Shows the excess revenue over (or under) expenditures to show combined 
revenue and expense. Allows you to use an attribute position to define one or 
more report columns.
• User-defined reports of this type are saved to the Revenue & Expense 

category.

U—Combined Rev. & 
Exp. W/Var.

Presents the excess revenue over (or under) expenditures to show combined 
revenue and expense with variance. Allows you to use an attribute position to 
define one or more report columns.
User-defined reports of this type are saved to the Revenue & Expense 
category.

V—Combined 
Statement of Change 
in Fin. Pos.

Presents the excess revenue over (or under) expenditures to show combined 
change in financial position. Allows you to use an attribute position to define 
one or more report columns.
• User-defined reports of this type are saved to the Financial Statements 

category.

X—User-Defined Rev. 
& Exp.

User-defined revenue and expense reports. 
• Allows you to use define your report columns.
• User-defined reports of this type are saved to the Revenue & Expense 

category.

Y—User-Defined 
Balance Sheet

User-defined balance sheet reports. 
• Allows you to use define your report columns.
• User-defined reports of this type are saved to the Financial Statements 

category.

Table 10.1—Report Types (Continued)

Report Type Description
Understanding Report Types 
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USING DIMENSIONS IN YOUR REPORTS
Dimensions and dimension values allow you to organize your chart of accounts to best 
match the accounting and reporting needs of your organization. When you use 
dimensions to report your financial information, you can sum and subtotal accounts 
according to all or part of the dimension number (i.e., value). 
For example, in sample division 95 the second dimension for ID A is defined as the 
department dimension. We define departments and dimension values:

• Dimension value 01—Administration department,
• Dimension value 02—Legal department, and
• Dimension value 03—Recreation department.

When you define your reports, you can enter a dimension number in the Page 
Values and Row Values subfields to break up and report the information. Some of the 
sections discussing dimensions and reports include:

• Entering Page Values on page 250,
• Entering Row Values on page 254, and
• Using Dimension and Attribute Order on page 270.

USING ATTRIBUTES IN YOUR REPORTS
Attribute values are 1- to 3-digit alphanumeric codes, or tags, that you assign to specific 
positions in your accounts. When you are defining and producing reports, you can use 
attributes to:

• Define report page break and row contents, 
• Define report columns, and
• Filter report contents.

You must assign one of the standard attributes to position 1 (System Reserved) of the 
attribute string of every account to define the type of account (e.g., revenue, expense). 
However, you can also assign up to 14 additional attributes to each account. 
When you define your reports, you can enter an attribute position in the Page 
Values and Row Values subfields to break up and report the information. You 
can also use your attributes to define the contents of your columns. Some of the sections 
discussing dimensions and reports include:

• Entering Page Values on page 250,
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• Entering Row Values on page 254, and
• Defining or Editing the Report Attributes Tab on page 295.

ENTERING PAGE VALUES
By defining a report to break on dimensions or attributes (or combination of both), you 
can separate and subtotal information about specific account groups. You enter Page 
Values on the Pages tab of the report definition.
For example, we have defined attribute position 7 in Division 95 to hold the Project 
Manager, then defined and applied attribute values representing each of our project 
managers. Now we want to produce a revenue and expense report that divides the 
information by fund and by project manager.
We copy an existing revenue and expense report. On the Pages tab, we move D1 (Fund) 
and A07 (Project Manager) to the Page Values field (Figure 10.1). This indicates that 
each time the dimension 1 and/or attribute 7 value changes, Report Manager subtotals 
the information and enters a page break. 

Figure 10.1—Example Page Break Dimension

Note: The 
dimensions and 
attributes (and 
associated 
descriptions) 
displayed will 
depend on the 
setup of your 
organization.
Entering Page Values 



Chapter 10—Understanding GL–P/G Reports
Tip: It’s often easier to copy an existing report that is similar to what you need. 
You can then change the definition to fully meet the needs of your organization.

The resulting report enters a page break and new subheading at each change in the 
dimension 1 value or attribute position 7 value (Figure 10.2). 

Figure 10.2—Example Page Break Dimension and Attribute in Subheading

PAGE BREAK (SUBHEADING) DESCRIPTIONS

In addition to specifying a page break, you can use your entries in the Page Values field 
to add information to the report subheading. You have five options for printing 
descriptions with the page break parameters: 

• No description
• Pull from description
• Build from descriptions
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• Use descriptive alias 1
• Use descriptive alias 2

You select the description setting from the Page Break Description Printing drop-down 
list on the Pages tab of the report definition. 

NO DESCRIPTION PRINTING

If you select this option, no description will print. The report will print only the selected 
dimensions and/or attributes in the subheading.

PULLING AND BUILDING FROM DESCRIPTIVE ACCOUNTS

The Pull From Descriptive Account and Build From Descriptive Accounts options both 
look for descriptive accounts (i.e., accounts defined as DS in the System Reserved 
attribute position or defined with dimension values of zero) to create a subheading. The 
difference is in the number of accounts:

• Pull From Descriptive Account—FundWare takes either 1) the first consecutive 
dimension values defined in the Page Values field and looks for the descriptive 
account, or 2) the first attribute value defined in the Page Values field and looks 
for the value’s description. 

• Build From Descriptive Accounts—Combines all descriptive account and/or 
attribute descriptions to create the subheading.

For either option, if FundWare doesn’t find a matching account, it will not print any 
description in the subheading.

We define a report with the following:

• Page Values: D1 D2 D3 A07
• Page Break Description: Pull From Descriptive Accounts
When the report begins a new page with dimension values 01 03 01 and 
attribute value RRK, FundWare looks for the following descriptive account:

• A01 03-01 0000—Has the description “Baseball Park”
Therefore, the subheading is “01 03-01 RRK Baseball Park” (Figure 10.3). 

Figure 10.3—Example Description Pulled From Account

Dimension and 
attribute values

Description “pulled” from 
descriptive account
Entering Page Values 
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We define a report with the following:

• Page Values: D1 D2 D3 A07
• Page Break Description: Build From Descriptive Accounts
When the report begins a new page with dimension values 01 03 01 and 
attribute value RRK, FundWare looks for the following descriptive accounts 
and attribute definitions:

• A01 00-00 0000—Has the description “General Fund”
• A00 03-00 0000—Has the description “Recreation”
• A00 00-01 0000—Does not exist in the system
• Attribute value RRK—Has the description “Robert R. Kirk”
Therefore, the program “builds” the subheading “01 03-01 RRK General Fund 
Recreation Robert R. Kirk” (Figure 10.4). 

Figure 10.4—Example Description Built From Dimensions

USE DESCRIPTIVE ALIAS 1 AND DESCRIPTIVE ALIAS 2

If you select either of these options, the description printed with the subheading will be 
taken from the applicable alias (Alias 1 or Alias 2) defined on the descriptive account 
for the first dimension in the Page Values field.
If the program doesn’t find a matching account or no dimensions are entered in the Page 
Values field, it will not print any description in the subheading. 

WHAT IF YOU DON’T USE DESCRIPTIVE ACCOUNTS?

In addition to the DS attribute value in the System Reserved position, descriptive 
accounts usually have zeros for all the dimensions except the dimension being defined, 
or “described.” For example, A00 01-00 0000 in Division 95 has a System Reserved 
attribute value of DS and a description of “Administrative.” Therefore, according to the 
way we have organized our accounts, all accounts with 01 in the second dimension are 
associated with Administrative costs or fees.

For purposes of reporting with the Pull From Descriptive Account option, some 
customers define descriptive accounts that “describe” more than one dimension. 
For example, A01 03-01 0000 has the description “Baseball Park.”
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Because not all customers define descriptive accounts, the program doesn’t just look for 
the DS attribute to define your subheadings. Instead, the program looks for the numeric 
indication of a descriptive account; in other words, zeros.
So FundWare takes the page break dimensions and tries to find a matching account 
number where the remaining (i.e., unlisted) dimensions are all zeros.

Remember, the program is looking for an account with zeros in the “remaining” 
dimensions. The account does not have to be assigned a DS attribute in the first 
position.

If the program doesn’t find a matching account, it will not print any description in the 
subheading.

TIPS ABOUT USING PAGE VALUES

• Leave the Page Values field blank—By not having the report enter specific page 
breaks and subtotals, you can create organization-wide reports.

• Use the Advanced field to add text to the subheading—You can type text in the 
Advanced text field. This text will be printed before the page break dimension 
and description at the top of each page. See Using the Advanced Field on page 
272 for more information.

If we select dimension 1 as our page break dimension and type Fund in 
the Text Before Account Number text field, the text and numbers Fund 
01, Fund 02, Fund 03, and Fund 04 will appear at the top of each page.

ENTERING ROW VALUES
When you define the row dimensions for a report, you have two applications for these 
settings:

• How the dimensions and/or attributes display on each row of the report, and
• If you want to subtotal within a section based on the selected dimensions.

By using row dimensions, you can produce reports with different degrees of detail or 
summary information. You can report accounts individually or sum individual accounts 
to an account group using a dimension number. You can enter row dimensions on the 
Rows tab.
Entering Row Values 
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WHAT IS A DETAIL REPORT?
In Division 95, dimension 4 (the object or line item number) includes the most detailed 
information about accounts.

• XX XX-XX 6110 Salaries and Wages
• XX XX-XX 6112 Hourly Wages
• XX XX-XX 6114 Seasonal Wages

To produce a report that shows the most dimension detail and some attribute detail, we 
define the Row Values as D1 D2 D3 D4 (Figure 10.5). The resulting report will display 
a row of the report for each account and display the full account number on each row. 

Figure 10.5—Example Detail Report

WHAT IS A SUMMARY REPORT?
In Division 95, dimension 1 (the fund) represents the most general information about 
accounts.

• 01 XX-XX XXXX General Fund
• 02 XX-XX XXXX Water Plant Fund
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• 03 XX-XX XXXX Sanitation Plant Fund
• 04 XX-XX XXXX Federal Grants Fund

To produce a report that summarizes at the fund level, we enter only D1 (the Fund 
dimension) in the Row Values field (Figure 10.6). The resulting report will display a 
single row for each fund, summarizing the information for all the accounts in the fund. 

Figure 10.6—Example Summary Report
Entering Row Values 
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SUBTOTALING WITH THE ROW DIMENSIONS AND ATTRIBUTES

When you select a row dimension, the report will subtotal at the end of each section (i.e., 
at each page break). However, you also use the entries in the Row Values field to define 
additional subtotaling (Subtotal Options on the Rows tab). Each value (i.e., dimension 
and/or attribute) that you add to the Row Values field is available on the Subtotal 
Options window (Figure 10.7). 

Figure 10.7—Example Subtotal Using Entries in Row Values Field
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To subtotal on an attribute, select the check box for the attribute. To subtotal on a 
dimension, select the check box for the dimension and select the subtotaling mask from 
the drop-down list (Figure 10.8). 

Figure 10.8—Example Subtotaling Options For Division 95 Object Dimension

The beginning number of the subtotaling options is determined by the 
dimension number (e.g., our example uses dimension 4, therefore the options 
start with 4). The length of the subtotaling options reflects the length of the 
dimension (e.g., the Object dimension used in our example is defined to be four 
characters long).

The masked characters in your dimension value indicate the level of subtotaling. For 
example, we define the Row Values as D1 D2 D3 D4, where D4 represents the Object 
dimension. When we click Subtotal Options and select the check box for Object, the 
drop-down list offers the following options:
Entering Row Values 



Chapter 10—Understanding GL–P/G Reports
• 4000—Default selection; report will subtotal at each change of the dimension. 
For example, we want to subtotal our object codes, regardless of the fund, 
department, or subdepartment (Figure 10.9). 

Figure 10.9—Example Report Subtotaling on Dimension

Tip: You can nullify this option based on the order of your dimensions 
and/or the Page Values entries (i.e., if the numbers are presented 
together in the report, they won’t be subtotaled).

• 400X—Report adds a subtotal at each change of the third number of the 
dimension. (In other words, the fourth number of the dimension is masked.)

• 40XX—Report adds a subtotal at each change of the second number of the 
dimension. (In other words, the third and fourth numbers of the dimension are 
masked.)

• 4XXX—Report adds a subtotal at each change of the first number of the 
dimension. (In other words, the second, third, and fourth numbers of the 
dimension are masked.)
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Figure 10.10 shows example results using the Subtotal Options. 

Figure 10.10—Example Reports Using Sub-Total Digits Button

SUBTOTALING ON A DIMENSION—EXAMPLE

The Division 95 R/E Subtotaling by Object and Fund report (RVEXD) has the Row 
Values defined as D4 D1 D2 D3, with subtotaling on D4 (Object) and D1 (Fund) 
(Figure 10.11). 

Figure 10.11—Subtotal Options—REVEXD Report

400X

40XX

4XXX
Entering Row Values 
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The subtotal options indicate that the program should subtotal every account with the 
same object (dimension 4) and every account with the same fund (dimension 1). Figure 
10.12 shows the R/E Subtotaling by Object and Fund report for Division 95. 

Figure 10.12—Example R/E Subtotaling by Object and Fund Report

SUBTOTALING WITHIN A DIMENSION—EXAMPLE

The Division 95 R/E Subtotaling Third Digit in Dimen. 4 (RVEXG) has the Row Values 
defined as D4 (Figure 10.13). 

Figure 10.13—Subtotal Options—REVEXG Report

Subtotaled object

Subtotaled fund
Blackbaud, Inc. 261



Blackbaud FundWare General Ledger–Project/Grant Guide

262
The subtotal options indicate that the program should subtotal on the specified digit of 
the object (in this case, the third digit of the fourth dimension). Figure 10.14 shows the 
R/E Subtotaling Third Digit in Dimen. 4 report for Division 95. 

Figure 10.14—Example R/E Subtotaling Third Digit in Dimen. 4 Report

Subtotal as 
report moves 
from 714X to 
715X

These lines show 
no subtotal 
because there is 
only one entry per 
change in the third 
digit.
Entering Row Values 
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ROW DESCRIPTIONS

When you select row dimensions, those dimensions display in each row of the report 
body (Figure 10.15). 

Figure 10.15—Example Row Dimension

FundWare also gives you the opportunity to specify:
• How (or if) the report account numbers will print,
• Account descriptions that may print with the accounts on each row of the report, 

and
• Account descriptions that may print with the subtotal rows (if you select the 

subtotal option—see Subtotaling With the Row Dimensions and Attributes on 
page 257).

These results of the print options are taken from the account definition. Table 10.2 
shows the various options, may of which are used by all three print settings. 

Table 10.2—Print Setting Options

Account Number Description Subtotal

No value No description printing No description printing

Use first occurrence Use first occurrence Pull from descriptive account

Standard alias 1 Pull from descriptive account Build from descriptive accounts

Standard alias 2 Build from descriptive accounts Descriptive alias 1

Descriptive alias 1 Standard alias 1 Descriptive alias 2

Descriptive alias 2 Standard alias 2

The Row Values are 
D2 D3 D4 in the 
report definition.
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These options are discussed in the following sections.

NO VALUE

Table 10.3 summarizes the use of the No Value option. 

NO DESCRIPTION PRINTING

Table 10.4 summarizes the use of the No Description Printing option. 

Use row values Descriptive alias 1

Descriptive alias 2

Table 10.3—Results for No Value Option

Entries in Row 
Values Field Account Number Printing Description 

Printing
Subtotal 

Descriptions

Dimensions only No information prints in the account 
number area of the row.

Not available Not available

Attributes only No information prints in the account 
number area of the row.

Not available Not available

Mix of dimensions 
and attributes

No information prints in the account 
number area of the row.

Not available Not available

Table 10.4—Results for No Description Printing Option

Entries in Row 
Values Field

Account 
Number 
Printing

Description Printing Subtotal Descriptions

Dimensions only Not available No information prints in the 
description area of the row.

No information prints in the 
description area of the row.

Attributes only Not available No information prints in the 
description area of the row.

No information prints in the 
description area of the row.

Mix of dimensions 
and attributes

Not available No information prints in the 
description area of the row.

No information prints in the 
description area of the row.

Table 10.2—Print Setting Options (Continued)

Account Number Description Subtotal
Entering Row Values 
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USE FIRST OCCURRENCE

Table 10.5 summarizes the use of the Use First Occurrence option. 

If the program doesn’t find a matching account, it will not print any description in the 
row. 

PULL FROM DESCRIPTIVE ACCOUNTS

Table 10.6 summarizes the use of the Pull From Descriptive Accounts option. 

Table 10.5—Results for Use First Occurance Option

Entries in Row 
Values Field Account Number Printing Description Printing Subtotal 

Descriptions

Dimensions only The dimension values print in 
the account number area of 
the row.

The account description prints 
in the description area of the 
row.

Not available

Attributes only The attribute value for the first 
attribute prints in the account 
number area of the row.

The account description for 
the first account in the Chart of 
Accounts with that attribute.

Not available

Mix of dimensions 
and attributes

Takes the first information in 
the Row Values field:
• If one or more attributes is 

first: prints the attribute 
values. 

• If one or more dimensions 
are first: prints the 
dimension values.

The account description for 
the first account in the Chart of 
Accounts with that 
combination of dimensions 
and attributes.

Not available

Table 10.6—Results for Pull From Descriptive Accounts Option

Entries in Row 
Values Field

Account 
Number 
Printing

Description Printing Subtotal Descriptions

Dimensions only Not available The account description prints 
in the description area of the 
row. 
The account number is 
determined by the section and 
row dimensions and a zero-fill 
of any remaining numbers.

The account description prints 
in the description area of the 
subtotal row.
The account number is 
determined by the section and 
row dimensions and a zero-fill 
of any remaining numbers.
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See Pulling and Building From Descriptive Accounts on page 252 for an example of a 
page subheading pulled from descriptive accounts. The same concept applies to a row or 
subtotal description pulled from descriptive accounts.
If the program doesn’t find a matching account, it will not print any description in the 
row. 

Attributes only Not available The attribute description for 
the first attribute prints in the 
description area of the row.

The attribute description for 
the first attribute prints in the 
description area of the 
subtotal row.

Mix of dimensions 
and attributes

Not available If one or more dimensions are 
listed first the Row Values 
field: 
• The program uses all 

dimension values in the row 
and prints the description for 
the matching “descriptive” 
account in the description 
area of the row.

If an attribute is listed first in 
the Row Values field: 
• The attribute description 

prints the description area of 
the row in the description 
area of the row. 

If one or more dimensions are 
listed first the Row Values 
field: 
• The program uses all 

dimension values in the row 
and prints the description for 
the matching “descriptive” 
account in the subtotal row.

If an attribute is listed first in 
the Row Values field: 
• The attribute description 

prints the description area of 
the subtotal row. 

Table 10.6—Results for Pull From Descriptive Accounts Option (Continued)

Entries in Row 
Values Field

Account 
Number 
Printing

Description Printing Subtotal Descriptions
Entering Row Values 
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BUILD FROM DESCRIPTIVE ACCOUNTS

Table 10.7 summarizes the use of the Build From Descriptive Accounts option. 

See Pulling and Building From Descriptive Accounts on page 252 for an example of a 
page subheading built from descriptive accounts. The same concept applies to a row or 
subtotal description built from descriptive accounts.
If the program doesn’t find a matching account, it will:

• Not print any description in the body row of the report, and 
• Print “Subtotal” in the subtotal row of the report. 

Table 10.7—Results for Build From Descriptive Accounts Option

Entries in Row 
Values Field

Account 
Number 
Printing

Description Printing Subtotal Descriptions

Dimensions only Not available A combination of the 
decorations for each 
dimension in the Row Values 
field prints in the description 
area of the row.

The account description prints 
in the description area of the 
subtotal row.

Attributes only Not available A combination of the 
descriptions for each attribute 
in the Row Values field prints 
in the description area of the 
row. 

A combination of the 
descriptions for each attribute 
in the Row Values field prints 
in the description area of the 
subtotal row.

Mix of dimensions 
and attributes

Not available If one or more dimensions are 
listed first the Row Values 
field: 
• A combination of the 

decorations for each 
dimension in the Row 
Values field prints in the 
description area of the row. 

If an attribute is listed first in 
the Row Values field: 
• A combination of the 

descriptions for each 
attribute in the Row Values 
field prints in the description 
area of the row.

If one or more dimensions are 
listed first the Row Values 
field: 
• A combination of the 

decorations for each 
dimension in the Row 
Values field prints in the 
description area of the 
subtotal row.

If an attribute is listed first in 
the Row Values field: 
• A combination of the 

descriptions for each 
attribute in the Row Values 
field prints in the description 
area of the subtotal row. 
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For example, we create a report that defines the Page Values as D1 D2 D3 and 
the Row Values as D1 D3. We then define the Description Printing setting as 
Build from Descriptive Accounts, the report body rows look like Figure 10.16. 

Figure 10.16—Example Row Description Built From Descriptive Accounts

In another example, we create a report that defines the Page Values as D1 D2 
D3 and the Row Values as D1 D4. Then we define the Subtotal Descriptions 
setting as Build from Descriptive Accounts, the subtotal rows look like Figure 
10.17. 

Figure 10.17—Example Sub-Total Description Pulled From Account

STANDARD ALIAS 1 AND STANDARD ALIAS 2

Table 10.8 summarizes the use of the Standard Alias 1 or Standard Alias 2 option. 

Table 10.8—Results for Standard Alias 1 or Standard Alias 2 Option

Entries in Row 
Values Field Account Number Printing Description Printing Subtotal 

Descriptions

Dimensions only Alias 1 or Alias 2 from the 
account number prints in the 
account number area of the 
row. 

Alias 1 or Alias 2 from the 
account number prints in the 
description area of the row. 

Not available

Attributes only No information prints in the 
account number area of the 
row.

No information prints in the 
description area of the row.

Not available

General Fund is pulled from the 
matching (or “descriptive”) account of 
A01 00-00 0000.

Description pulled from 
matching (or “descriptive”) 
account of A00 00-00 4100. 

No matching account found, so 
the report inserts “Subtotal” on 
the row. 
Entering Row Values 
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If the program doesn’t find a matching account, it will not print any description in the 
row. 

DESCRIPTIVE ALIAS 1 AND DESCRIPTIVE ALIAS 2

Table 10.9 summarizes the use of the Descriptive Alias 1 or Descriptive Alias 2 option. 

If the program doesn’t find a matching account, it will not print any description in the 
row. 

Mix of dimensions 
and attributes

Alias 1 or Alias 2 from the 
account number prints in the 
account number area of the 
row. 

Alias 1 or Alias 2 from the 
account number prints in the 
description area of the row. 

Not available

Table 10.9—Results for Descriptive Alias 1 or Descriptive Alias 2 Option

Entries in Row 
Values Field Account Number Printing Description Printing Subtotal Descriptions

Dimensions only Alias 1 or Alias 2 from 
the descriptive account 
prints in the account 
number area of the row. 

Alias 1 or Alias 2 from 
the descriptive account 
prints in the description 
area of the row. 

Alias 1 or Alias 2 from 
the descriptive account 
prints in the description 
area of the subtotal row. 

Attributes only No information prints in 
the account number 
area of the row.

No information prints in 
the description area of 
the row.

No information prints in 
the description area of 
the subtotal row.

Mix of dimensions 
and attributes

Alias 1 or Alias 2 from 
the descriptive account 
prints in the account 
number area of the row. 

Alias 1 or Alias 2 from 
the descriptive account 
prints in the description 
area of the row. 

Alias 1 or Alias 2 from 
the descriptive account 
prints in the description 
area of the subtotal row. 

Table 10.8—Results for Standard Alias 1 or Standard Alias 2 Option (Continued)

Entries in Row 
Values Field Account Number Printing Description Printing Subtotal 

Descriptions
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USE ROW VALUES

Table 10.10 summarizes the use of the Use Row Values option. 

USING DIMENSION AND ATTRIBUTE ORDER
The order of the dimensions and attributes in the Page Values and Row Values fields will 
determine the order that the information is displayed in the subheadings (Page Values 
entries) and the rows (Row Values entries) of the report. 
For example, Figure 10.18 shows the results for same subheading when the order of the 
entries in the Page Values field is changed. 

Figure 10.18—Example Subheading Results Based on Entry Order

Table 10.10—Results for Use Row Values Option

Entries in Row 
Values Field Account Number Printing Description 

Printing
Subtotal 

Descriptions

Dimensions only Prints the actual dimension values in the 
account number area of the row.

Not available Not available

Attributes only Prints the actual attribute values in the 
account number area of the row.

Not available Not available

Mix of dimensions 
and attributes

Prints the actual dimension and attribute 
values in the account number area of the row.

Not available Not available

Page Values defined as:
D1 D2-D3 A07 

Page Values defined as:
D1 A07 D3-D2
Using Dimension and Attribute Order 
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Figure 10.19 shows results for same row when the order of the entries in the Row 
Values field is changed. 

Figure 10.19—Example Reports Using Row Dimension Order

USING REPORT LEVELS
Report levels, defined on the Pages and Rows tabs, allow you to take the information 
included in your report and present it in varying ways. 

You must produce three different revenue and expense reports for the same 
information. The first report, given to department heads, presents detailed 
information by department. The second report, given to the CFO, summarizes 
the information by department. The third report, given to the CEO, provides a 
complete summary of revenue and expenses. Define report levels for each level. 
Then you only have to produce the report once.

Each report type (e.g., N—Revenue and Expense Actual vs. Actual by Year) is 
predefined for 1–5 report levels. You are not required to use all report levels. However, 
you cannot define additional report levels.

Tip: Don’t forget to define page and row formats for each level. For example, if 
you define row formatting for level 2, but do not define page formatting for 
level 2, you will not have any page formatting in the second section of your 
report.

By default, the Pages and Rows tabs will display report level 1. To define additional 
levels, select from the Report Level drop-down list.

Row Values defined as: D2-D3 D4 Row Values defined as: D4 D3 D2
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USING THE ADVANCED FIELD
The Advanced check box and field on the Pages and Rows tab allows you to view and 
edit the entries in the Page Values and Row Values fields, and add text or certain 
mathematical commands. Click the check box to display the text box (Figure 10.20). 

Figure 10.20—Example Rows Tab—Advanced Options

A tilde (~) and number indicates a dimension and a pipe sign (|) and number indicates an 
attribute. These entries are considered a unit and you cannot delete one element without 
changing the meaning of your selections (Figure 10.21). 

Figure 10.21—Example Modification to Advanced Field

Modifications to the Advanced field are synchronized with the applicable 
Values field (i.e., either Page Values or Row Values field). Changes to one are 
reflected in the other.

ADDING TEXT TO THE ADVANCED FIELD

You can add text to your subheadings (Pages tab) or rows (Rows tab) by entering the 
text in the Advanced field. For example, the Division 95 report Rev/Exp using Text in 
Report Field (RVEX8) has the row dimensions defined as:

By removing the tilde (~) in front of the 1, 
we are indicating that the number 1 
should precede dimensions 2 and 3 and 
attribute 7. 
Dimension 1 has been removed from the 
Page Values field and is not displayed in 
the Sample Output.
Using the Advanced Field 
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• Fed. Fund ~2-~3 ~4 (the Advanced text box for this report is shown in Figure 
10.22) 

Figure 10.22—Example Entry to Subtotal Dimensions

We have manually added the text “Fed. Fund” before the dimensions and inserted a 
hyphen between dimensions 2 and 3. In the report output, the text and hyphen will print 
with the account numbers. Figure 10.23 shows the Rev/Exp using Text in Report Field 
report for Division 95. 

Figure 10.23—Example Rev/Exp Using Text in Report Field Report

• Subtotaling (Dimensions and Attributes)
• Subtotaling by Digits (Dimensions Only)
• Subtotaling With the Row Dimensions and Attributes
• Entering Page Values
• Entering Row Values
• Using Report Levels
• Using the Advanced Field
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SUBTOTALING (DIMENSIONS AND ATTRIBUTES)
Using the Subtotal Options (on the Rows tab), you can define subtotaling for attributes 
and dimensions. You can use the Advanced field to enter manually the same subtotaling 
commands for the entries in the Row Values field by placing brackets around the 
dimensions and/or attributes for which you want to obtain subtotals. 
For example, the Division 95 report R/E Subtotaling by Object and Fund (RVEXD) has 
the row dimensions defined as D4 D1 D2 D3, with subtotaling on D4 (Object) and D1 
(Fund), which looks like the following in the Advanced field (Figure 10.22):

•  [~4 ~1] ~2-~3 

Figure 10.24—Example Advanced Field and Subtotal Options to Subtotal Dimensions

Modifications to the Advanced field are synchronized with the Subtotal Options 
window. Changes to one are reflected in the other.

SUBTOTALING BY DIGITS (DIMENSIONS ONLY)
Using the Subtotal Options (on the Rows tab), you can define subtotaling levels within a 
dimension. You can also use the Advanced field to enter manually the same subtotaling 
commands for the entries in the Row Values field by placing parentheses around a digit 
representing the position within the dimension for which you want to obtain a subtotal. 

In this example, the Advanced 
field and the Subtotal Options 
window define the same 
subtotaling. 
Using the Advanced Field 
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For example, the Division 95 report R/E Subtotaling Third Digit in Dimen. 4 (RVEXG) 
has the row dimensions defined as [~4(3)]. This matches the selection in the Subtotal 
Options window (Figure 10.25). 

Figure 10.25—Example Advanced Field and Subtotal Options—Subtotal by Digit

See Figure 10.14—Example R/E Subtotaling Third Digit in Dimen. 4 Report on 
262 for the report output for this command.

You can also subtotal on more than one digit within a dimension. (This option is only 
available by manually entering the commands into the Advanced field.) For example, 
the Division 95 report R/E Subtotaling Third Digit in Dimen. 4 (RVEXG) has the row 
dimensions defined as: 

• [4(13)] (the Advanced text box for this report is shown in Figure 10.26). 

Figure 10.26—Example Entry to Subtotal by Multiple Digits
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Figure 10.27 shows the R/E Subtotaling on Digits 1&3 in Dimen. 4 report for Division 
95. 

Figure 10.27—Example R/E Subtotaling on Digits 1&3 in Dimen. 4 Report

ENTERING RELATIVE DATES
When you modify or create a report definition for X and Y report types (i.e., X—User-
Defined Rev. & Exp. and Y—User-Defined Balance Sheet), each column can report a 
different period. Therefore, you must indicate how the reporting period will be 
determined for the columns each time you run the report. You will do this by defining 
relative dates on the Columns tab.

For example, every time you run your report, do you want a column to include 
data for the two months before the report date? 

Subtotal on 
third digit

Subtotal on 
first digit
Entering Relative Dates 
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The relative dates specified in the report definition tell the program to offset the 
information in a column relative to your reporting period (specified in the Produce 
Reports parameters window). Therefore, the information contained in the report is 
“relative” to the report date. Figure 10.28 is a visual example of this concept. 

Figure 10.28—Example Relative Period Offset

When you define your report, you will select columns to include on the Columns tab 
(Figure 10.29). 

Figure 10.29—Example Report Definition With Relative Dates

Jan Apr May June July Aug Sept Oct Nov DecMarFeb

-9 -6 -5 -4 -3 -2 -1 +1 +2-7-8

This figure shows the relative offsets for a reporting period in October (relative period 0). If you wanted to 
report earlier than January of the reporting year, you would continue to count backwards (e.g., December 
of the previous year would be -10). If you wanted to report later than December of the reporting year, you 
would continue to count forwards (e.g., January of the next year would be +3).

0
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When you select a column that contains financial data, the relative date fields are 
enabled (Figure 10.30). 

Figure 10.30—Relative Date Options

Using the example in Figure 10.28, we could design our report to provide data for the 
two months prior to the report date that you enter when you run the report. On the 
Columns tab, we would enter –2 in the First Per field and would leave the relative year 
field blank (Figure 10.31). 

Figure 10.31—Example Relative Dates in Report Definition

FASB REPORTS
The Financial Accounting Standard Board (FASB) established standards for general-
purpose external financial statements provided by not-for-profit organizations its 
Statement of Financial Accounting Standards No. #117. The Statement requires that all 
not-for-profit organizations provide a statement of financial position, a statement of 
activities, and a statement of cash flows. It requires reporting amounts for the 
organization’s total assets, liabilities, and net assets in a statement of financial position; 
reporting the change in an organization’s net assets in a statement of activities; and 
reporting the change in its cash and cash equivalents in a statement of cash flows.
The Statement requires classifications of the organization’s net assets as permanently 
restricted, temporarily restricted, or unrestricted be displayed in the statement of 
financial position, and that the changes in its revenues, expenses, gains, and losses be 
displayed in these three categories in the statement of activities.

The First Per option becomes enabled when you select 
Net for period from the Period drop-down list.
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General Ledger–Project/Grant provides three report types to assist you with your FASB 
reporting needs (Table 10.11). 

Please see the Blackbaud FundWare FASB Guide for more information.

 

Table 10.11—FASB Report Types

Report Type Description

G—Statement of 
Financial Position

Uses total liabilities and net assets to show the overall financial position of 
your organization. 
• You must assign attribute values to multiple financial categories (i.e., assets, 

liabilities, fund balance, revenue, and expense) on the Report Attributes 
tab of the report definition.

• User-defined reports of this type are saved to the Financial Statements 
category.

H—Statement of 
Activities

Uses revenues, expenses, and change in net assets from the beginning of the 
year to the end of the year to display activities. 
• You must indicate which attribute value represents fund balance on the 

Report Attributes tab of the report definition.
• User-defined reports of this type are saved to the Revenue & Expense 

category.

I—Statement of Cash 
Flow

Uses the net assets and operating activities, investing activities, financing 
activities, and cash and cash equivalents to report the cash flow for the period.
• You must assign attribute values to multiple financial categories (i.e., assets, 

liabilities, fund balance, revenue, expense, and cash & equivalents) on the 
Report Attributes tab of the report definition.

• User-defined reports of this type are saved to the Financial Statements 
category.
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CREATING AND PRODUCING REPORTS

The General Ledger–Project/Grant reporting feature provides you with more than 30 
system-defined reports and more than 20 report “types,” or templates, from which you 
can create an unlimited number of user-defined reports (Table 11.1). 

Table 11.1—System-Defined Reports and Report Types for Each Category

System-Defined Reports Report Types

Financial Statements

The system-defined financial statement reports 
are:
• Balance Sheet (BALSH)
• Combined Balance Sheet (COMB1)
• Combined Statement of Changes (COMB4)
• Statement of Cash Flows (SOCF)
• Statement of Financial Position (SOFP)
• Trial Balance (TRBAL)
• Working Trial Balance (WTBAL)

Any user-defined reports using the following 
reporting types are saved to this category: 
• Balance Sheet (C)
• Trial Balance (D)
• Working Trial Balance (E)
• Statement of Financial Position (G)
• Statement of Cash Flow (I)
• Combined Balance Sheet (S)
• Combined Statement of Change in Fin. Pos. (V)
• User-Defined Balance Sheet (Y)
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Revenue & Expense Reports

The system-defined revenue and expense reports 
are:
• Combined Revenue and Expense (COMB2)
• Combined R/E With Variance (COMB3)
• R/E Act vs Act by Year (REAA1)
• R/E Act vs Bud PTD & YTD (REAB1)
• R/E Act vs Bud W/Var/Percent (REAB2)
• R/E Act vs Bud W/Var/Annual (REAB3)
• R/E Act vs Bud W/Encumbrance (REAB4)
• Revenue and Expense (RVEX)
• Stmt of Activities (SOA)

Any user-defined reports using the following 
reporting types are saved to this category: 
• Statement of Activities (H)
• Revenue and Expense w/Change in Fund 

Balance (L)
• Revenue and Expense PTD & YTD (M)
• Revenue and Expense Actual vs. Actual by Year 

(N)
• Revenue and Expense w/% Variance (O)
• Revenue and Expense Act vs. YTD w/Annual 

Budget (P)
• Revenue and Expense w/Encumbrances (Q)
• Combined Rev. & Exp. (T)
• Combined Rev. & Exp. W/Var. (U)
• User-Defined Rev. & Exp. (X)

System Lists

The system-defined system reports are:
• Chart of Accounts (CHART)
• Attributes List (CSAREP)
• ID Types List (CSBREP)
• Journal Controls List (CSCREP)
• Date Tables List (CSDREP)
• Cost Allocations List (CAICDEF)
• Account Verification List (CSACVER)
• Reports List (GLAREP for General Ledger ID 

types, PGAREP for Project/Grant ID types)
• Advanced Financial Report Definition 

(CWRDEFN) (provided only if your organization 
has purchased and installed the Advanced 
Financial Reporting add-on)

• Data Item List (CWDREF)

Any user-defined reports using the following 
reporting types are saved to this category: 
• Chart of Accounts (A)

Table 11.1—System-Defined Reports and Report Types for Each Category (Continued)

System-Defined Reports Report Types
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PRODUCING REPORTS
Use the following instructions to produce a report.

Transaction Reports

The system-defined transaction reports are:
• Account Detail (ACDTL)
• Ledger Report (LEDGR)
• Special Journal Entries List (CSENTRY)
• Journals List (CSJNL)
• Re-print Trace Reports (CSTRACE)
• Multiple ID Reconciliation (CSRECON)
• Transaction Log (CSTRANS)
• Transactions Sorted by Reference (CSREFTR)

Any user-defined reports using the following 
reporting types are saved to this category: 
• Ledger Report (B)
• Enhanced Ledger Report (K)
• Account Detail Report (F)

Table 11.1—System-Defined Reports and Report Types for Each Category (Continued)

System-Defined Reports Report Types
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1.  Click Report Manager on the module navigator or select File > Report 
Manager from the menu bar. The Report Manager Window displays (Figure 
11.1). 

Figure 11.1—Report Manager

You can also access the report through the Reports area of the 
HomePage. Display the report category and select the report to produce. 
Move to step 4 on page 286.
Producing Reports 
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2. Select the module, report category, and ID type from the drop-down lists. The 
reports in the report category display (Figure 11.2). 

Figure 11.2—General Ledger Revenue and Expense Reports
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3. Select the report that you want to produce and double-click or click Produce. 
The Produce Reports parameters window displays (Figure 11.3). The 
parameters will vary based on the report that you select. 

Figure 11.3—Produce Reports: ACDTL Report

4. Enter an account mask to indicate what account information you want to include 
in your report. (For more information on masks, see Using Masks on page 68.)

You may get a message if you enter an ID type that does not match the 
ID type selected in the Report Manager drop-down list.

The remaining report settings are dependent on the type of report that you are 
producing. 
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5. Complete the report parameters according to Table 11.2, which lists all the 
possible settings that may display on the parameters window. 

Table 11.2—Report Parameter Options

Option Entry Description

Report Type Select from the 
drop-down list.

Select the type of data to be included on the report (i.e., actual, 
budget type 1, budget type 2, encumbrance, or commitment).

Dimension
(The title of this 
option will 
depend on the 
names of your 
dimensions.)

Select the check 
box or enter a 
fund number.

If you select the check box, the report will include data from all 
dimensions.
If you want to specify a single dimension, enter the dimension 
number in both range fields (the default entry for this option is 
specified in the report definition).
If you want to specify a dimension range, enter the beginning 
dimension in the first field and the ending dimension in the 
second field (the default entry for this option is specified in the 
report definition).

Date Range Select the check 
box or enter a 
date.

If you select the check box, the report will include data from all 
dates.
If you want to specify a single date, enter the date in both date 
range fields (the date will default to the business date).
If you want to specify a date range, enter the beginning date in 
the first date field and the ending date in the second date field.

Date Enter a date; 
default is the 
business date.

The report date is used to determine the information included in 
your report, according to the report definition.

Year End Enter a year-
end date; 
default is based 
on the business 
date.

The report year is used to determine the year-end upon which 
your report is based, according to the report definition.

Period Enter a period 
end-date; 
default is based 
on the business 
date.

The report date is used to determine the period upon which your 
report is based, according to the report definition.
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Amount Range Select the check 
box or enter an 
amount.

If you select the check box, the report will include all financial 
data, regardless of amount.
If you want to specify a single amount, enter the amount in both 
fields.
If you want to specify a range of amounts, enter the beginning 
amount in the first field and the ending amount in the second 
field.

Select Journals Use arrows to 
move journals.

Use the arrows to specify journals to be included in (right box) 
or excluded from (left box) the report. 
By default, all journals are included. (In this case, all the journal 
names will display in the left box, but *All* will display in the right 
box.)

Include Periods Use arrows to 
move periods.

Use the arrows to specify periods to be included in (right box) or 
excluded from (left box) the report. 
By default, all periods are included. (In this case, all the periods 
will display in the left box, but *All* will display in the right box.)

Include/Exclude 
Attributes

Click the box 
and select from 
the drop-down 
list.

Select the attribute to include or exclude from your report (the 
default entry for this option is specified in the report definition).
Click Clear All to remove include/exclude settings.

Options Select one or 
more check 
boxes.

Options will vary, but can include:
• Show report detail—Includes/excludes detail information from 

report.
• Report reclass period—Includes/excludes any reclass period 

data.
• Show pennies—Includes/excludes pennies from report.
• Report zero balances—Includes/excludes zero balances from 

report.
• Report fiscal totals—Includes/excludes fiscal totals from 

report.

Table 11.2—Report Parameter Options (Continued)

Option Entry Description
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6. Click OK. Click Cancel to exit the Produce Reports window without creating 
the report.

CREATING OR EDITING REPORTS
To meet the reporting needs of your organization, FundWare gives you a number of 
options when working with reports. You can:

• Copy an existing report (system- or user-defined)—Select the report and click 
Copy.

• Create a new report using one of the report types (“templates”)—Select the 
report category to which the new report will belong (according to report type) 
and click New.

• Edit an existing user-defined report—Select the report and click Edit. (Edit will 
not be enabled if the report is system-defined.)

Once you begin working with the report definition, the tabs and fields will vary 
depending on the report type. The following sections provide instructions for all 
possible fields on each tab.

ENTERING REPORT NAME, TITLE, AND TYPE

Use the following instructions to enter or modify the report name, title, and type.
1.  Enter the report name (up to 5 alphanumeric characters).

2. Enter the report title (up to 40 alphanumeric characters).

Report Select the 
applicable radio 
button.

Select the radio button for your desired report output:
• View—Saves a file (using the report name and the letter L 

plus the division name) in the report directory and displays the 
report in Print Manager.

• Print—Saves a file (using the report name and the letter L 
plus the division name) in the report directory and prints the 
report from your default printer.

• File—Saves a file (using the report name and the letter L plus 
the division name) in the report directory.

Table 11.2—Report Parameter Options (Continued)

Option Entry Description
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3. Select the ID type from the drop-down list. 

• If you are copying or editing a report definition, you cannot change this 
information.

4. Select the report type from the drop-down list. (Your options are restricted to the 
reporting types assigned to the report category you were in when you clicked 
New.) 

• If you are copying or editing a report definition, the report category does not 
display and you cannot change this information.

The tabs and fields displayed may change depending on the report type that you 
select. For example, some report types display the Report Attributes tab or the 
Attribute Columns tab, but X and Y reports are the only types to display a 
Columns tab. 

Complete the report definition according to the instructions in the following sections.

DEFINING OR EDITING THE GENERAL TAB

The General tab will display for all reports (Figure 11.4). 

Figure 11.4—Example General Tab
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1.  Enter a new Report Group or select an existing Report Group from the drop-
down list. The Report Group is not required; however, this option allows you to 
organize your new reports and print groups of reports with one step.

As you create your own Report Groups, those groups will display in the 
drop-down list. If you have not entered any Report Groups yet, the 
drop-down list will be empty. See Grouping Your Reports on page 306 
for more information.

2. Enter the number of lines per page. The default is 60.

3. The Select Dimensions option allows you to enter a dimension range when you 
produce the report, or to include all dimensions in the report. If you select a 
dimension from the drop-down list, you can then set a default for the report—all 
dimensions or a range of dimensions.

• If you leave the default of *None*, you will not be asked to provide 
dimension information when you produce the report.

• If you select a dimension from the drop-down list, the Dimension check box 
and range text boxes become active and allows you to set a default for the 
report (Figure 11.5). 

Figure 11.5—Example—Fund Dimensions

4. Select the check box to indicate that all of the dimensions will be included in the 
report (Figure 11.6). (This field is not enabled unless you select a dimension 
from the Select Dimensions drop-down list.) 

Figure 11.6—Example—All Fund Dimensions

Or enter a beginning and ending number to include only a range of the 
dimensions (Figure 11.7). 

Figure 11.7—Example—Range of Fund Dimensions
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Using the example in Figure 11.7, Figure 11.8 shows the Report 
Parameters window that displays when you produce the report. The 
default dimension settings are displayed; however, you could enter a 
different dimension range or include all Fund dimensions. 

Figure 11.8—Example Report Parameters Window

5. Some reports will allow you to print references or accounts (or a combination) 
in your report. If this option displays, select the print setting from the drop-
down list (Figure 11.9). 

Figure 11.9—Print References/Accounts

6. One of the following two check boxes may be displayed (Figure 11.10), 
offering additional report options:

• Print User—Adds a column to the report that indicates the user who posted 
the transaction.

• Include Data Items—Adds a line to the report for each data item associated 
with each account number. 

Select the check box to activate the option for your report. 

Figure 11.10—Print Option Check Boxes

7. The Currency Symbol field may be displayed (Figure 11.11), allowing you to 
define the symbol used to indicate currency. 

Figure 11.11—Currency Symbol
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8. The Include Comparative Column check box will display (Figure 11.12) for 
Statement of Financial Position reports, allowing you include a column for 
comparative purposes. This column will contain data from the previous year 
(i.e., the year prior to the report year). 

Figure 11.12—Include Comparative Column

9. Some reports will allow you to modify one or more phrases that will appear in 
your report (Figure 11.13). (The availability of this option is determined by the 
Report Type.) For example:

• Phrase 1—Displays with Revenue and Expense math lines.
• Phrase 2—Displays with Balance Liability and Equity math lines. 

Figure 11.13—Example General Tab—Phrases

Phrases 3–6 are available for Statement of Activities and Statement of Cash 
Flow reports for net amounts.

10. Click Apply to save your changes and remain in the Define window, or click 
OK to save your changes and return to Report Manager.
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DEFINING OR EDITING THE INCLUDE/EXCLUDE ATTRIBUTES TAB

The Include/Exclude Attributes tab (Figure 11.14) allows you to select default 
attributes to be included in or excluded from your report. You can override these 
defaults when you produce the report. 

Figure 11.14—Include/Exclude Attributes Tab

1.  Click the Include or Exclude box. A drop-down list of attributes for the selected 
position displays (Figure 11.15). 

Figure 11.15—Example—Position 1 Include/Exclude Attributes List

2. Select the attribute from the list.

You can remove your entries by clicking Clear All.

3. Continue defining include/exclude attributes, as necessary.

The available 
Include/Exclude 
boxes reflect the 
attribute positions 
for which you 
have defined 
attribute values.

In this example, 
we have only 
defined attribute 
values for 
positions 1–6. 
Therefore, we 
cannot select 
attribute to 
include or 
exclude at any 
other position.
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Tip: Do not define the same attribute as both included and excluded.

Tip: When you define multiple values, accounts included in the report 
must match all the settings to be included or excluded from the report. 
For example, if you define AS as included for position 1 and T1 as 
excluded for position 3, the accounts included in the report must have 
AS in position 1 and any attribute but T1 in position 3.

4. Click Apply to save your changes and remain in the Define window, or click 
OK to save your changes and return to Report Manager.

DEFINING OR EDITING THE REPORT ATTRIBUTES TAB

This tab displays for most reports and allows you to indicate the attributes you use for 
certain financial categories (e.g, assets, liabilities, fund balance, revenue, expense). The 
categories displayed will depend on the report type. For example, in a revenue and 
expense report, you only need to identify the attribute that you use to identify your 
revenue and expense accounts (Figure 11.16). 

Figure 11.16—Report Attributes Tab

1.  Click the drop-down arrow for the Revenue and Expense fields to select the 
appropriate attribute.
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2. Click Apply to save your changes and remain in the Define window, or click 
OK to save your changes and return to Report Manager.

DEFINING OR EDITING THE PAGES TAB

Use the Pages tab to control the page break and subheadings at the top of each page 
(Figure 11.17). 

Figure 11.17—New Financial Report: Pages Tab

1.  Select the applicable Report Level from the drop-down list. (For more on this 
feature, see Using Report Levels on page 271.)

The number of available report levels will depend on the report type. If 
the report type only allows one level, this field will be disabled.

2. “Drag and drop” any dimensions and/or attribute upon which you want the 
report to break to the Page Values field (i.e., click the dimension and use the 
mouse to move it to the field). (See Entering Page Values on page 250 for more 
information on using page break dimensions in your report definition.)
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Remember: The order of the dimensions and/or attributes in the Page 
Values field will impact the way the report will break. (See Using 
Dimension and Attribute Order on page 270 for more information.)

3. Select the appropriate description option from the Page Break Description 
Printing drop-down list. (See Page Break (Subheading) Descriptions on page 
251 for more information.)

4. Click the Advanced check box to enter any text that you want to print in the 
subheading in the Advanced field. Your dimension and attribute selections are 
reflected in the field (Figure 11.18). (For more information, see Adding Text to 
the Advanced Field on page 272.) 

Figure 11.18—Example Advanced Field

A tilde (~) and number indicates a dimension and a pipe sign (|) and 
number indicates an attribute. These entries are considered a unit and 
you cannot delete one element without changing the meaning of your 
selections. 

5. Click Apply to save your changes and remain in the Define window, or click 
OK to save your changes and return to Report Manager.
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DEFINING OR EDITING THE ROWS TAB

Use the Rows tab to define or modify how data is presented or subtotaled by rows 
(Figure 11.19). 

Figure 11.19—New Financial Report: Rows Tab

1.  Select the applicable Report Level from the drop-down list. (For more on this 
feature, see Using Report Levels on page 271.)

The number of available report levels will depend on the report type. If 
the report type only allows one level, this field will be disabled.

2. “Drag and drop” any dimensions and/or attribute upon which you want the 
report to break to the Row Values field (i.e., click the dimension and use the 
mouse to move it to the field). (See Entering Row Values on page 254 for more 
information on using page break dimensions in your report definition.)

Remember: The order of the dimensions and/or attributes in the Row 
Values field will impact the way the report will break. (See Using 
Dimension and Attribute Order on page 270 for more information.)
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3. Select the appropriate description options from the Account Number Printing 
and Descriptions drop-down lists. (See Row Descriptions on page 263 for more 
information.)

4. If you want to enter subtotaling commands, click Subtotal Options to define 
subtotaling for the rows (Figure 11.20). (See Subtotaling With the Row 
Dimensions and Attributes on page 257 for more information.) 

Figure 11.20—Subtotal Options

If you do not want to enter subtotal options, move to step 8 on page 300.

5. Click the check box and select a subtotal option from the drop-down list.

6. Select a description option from the Subtotal Descriptions drop-down list. (See 
Row Descriptions on page 263 for more information.)

7. Click OK to save your settings and return to the Rows tab.
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8. Click the Advanced check box to enter in the Advanced field any text that you 
want to print in the rows or additional subtotaling commands. Your dimension 
and attribute selections are reflected in the field (Figure 11.18). (For more 
information, see Using the Advanced Field on page 272.) 

Figure 11.21—Example Advanced Field

A tilde (~) and number indicates a dimension and a pipe sign (|) and 
number indicates an attribute. These entries are considered a unit and 
you cannot delete one element without changing the meaning of your 
selections. 

9. Click Apply to save your changes and remain in the Define window, or click 
OK to save your changes and return to Report Manager.

DEFINING OR EDITING THE ATTRIBUTE COLUMNS TAB

This tab displays for certain reports (e.g., “combined” reports) and allows you to 
indicate the content of the report columns based on attribute positions. For example:

• You define four attribute values for position 6 and assign these values to 
accounts.

• You assign attribute position 6 to Attribute Column 1 of the report definition.
• The report information is divided into four columns based on the attribute value 

in position 6.
“Attribute Column” doesn’t mean that your selection represents a single 
column. It is simply the first definition of an attribute position to 
determine the content of your columns. It will result in multiple 
columns.

Different report types will allow you to define multiple “levels” for your report. For 
example:

• You define two attribute values for position 5 and four attribute values for 
position 6 and assign these values to accounts.

• You assign attribute position 6 to Column 1 of the report definition and attribute 
position 5 to Column 2 of the report definition.
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• The report information is divided into eight columns based on the combination 
of position 6 and position 5 attribute values (i.e., 4 x 2 = 8).

The number of available column/attribute position assignments that you can define will 
depend on the report type. For example, a combined balance sheet report (type S) allows 
you to make up to two assignments, while a statement of financial position (type G) 
allows you to define up to five assignments (Figure 11.22). 

Figure 11.22—Example Attribute Columns Tabs—Two and Five Columns

For more information on defining reports with the Attribute Columns tab, see 
Appendix B—Using Attributes to Define Report Columns on page 339. 

1.  Click the drop-down arrow in each column to define how the report should filter 
your accounts, based on the values assigned to the attribute position. 

Remember: The number of columns in your report will increase 
significantly with each entry in an Attributes Column field. 
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2. Click Apply to save your changes and remain in the Define window, or click 
OK to save your changes and return to Report Manager.

DEFINING OR EDITING THE COLUMNS TAB

Use the Columns tab to define the columns in type X (revenue and expense) and type Y 
(balance sheet) reports (Figure 11.23). 

Figure 11.23—Define a New Report: Columns Tab

1.  Select the Columns tab. 
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2. Select a column type (i.e., the type of information to populate the column) by 
clicking the associated button. The column is added under the associated 
column letter, as shown in Figure 11.24. 

Figure 11.24—Adding Columns

After you add columns, it is easy to reorder them by simply dragging 
them to a different position. 

For more information on the different budget options, see Budget Types 
1 and 2 and GASB 34 on page 56.

3. For the active column (i.e., highlighted), enter the text for the column heading in 
the Text Line 1 and Text Line 2 text boxes, or select one of the two options from 
the drop-down list:

• Period Ending Date—Displays the period ending date, based on your 
selection when you produce the report.

• Fiscal Period Number—Displays the number of the fiscal period, based on 
your selection when you produce the report.

These fields are optional; however, we recommend that you can use one or both 
to define the data in the column.
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4. Each column type requires different data parameters (Column Type, Data Item, 
Period, Operation, Relative Year, First Period, Last Period, Print Column, and 
Width). Enter the required parameters for each column according to Table 11.3 
(if a parameter is not required, the field will not be enabled). 

Table 11.3—Columns Tab Parameter Options

Option Entry Description

Column Type Select from the 
drop-down list 
to change your 
selection.

You can change the selection that you made in the Add Column 
step. This controls the type of data that the column will hold (e.g., 
actual, budget type 1, budget type 2, calculated, data item).
• The entry in this field defaults to your selection using the column 

buttons.
• Note: If you select “Budget,” the FundWare will combine the 

applicable totals from Budget Type 1 and Budget Type 2. To 
separate your budget amounts (e.g., original and revised), select 
the appropriate individual budget type (i.e, Budget Type 1 or 
Budget Type 2).

Data Item Select from the 
drop-down list.

Select a data item from the drop-down list. The data item value will 
display in the report column.

Period Select from the 
drop-down list.

The report period that you select determines the data that displays 
in this column of the report. (Note: In the following definitions, 
“reporting year” refers to the date entered when you produce the 
report.)
• Year beginning balance—Balances rolled forward from the 

previous year (i.e., year prior to the reporting year).
• Account ending balance—Balance for the reporting year without 

adjustments or beginning balances.
• Annual ending balance—Balance for the reporting year with 

adjustments and beginning balances.
• Net to date—Balance from the beginning of the reporting year to 

the report date (i.e., date entered when you produce the report) 
without adjustments or beginning balances.

• Net for year—Balance for the reporting year with adjustments but 
without beginning balances.

• Net for period—Balance for the reporting period (i.e., based on 
the date entered when you produce the report) without 
adjustments or beginning balances.
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5. Click Apply to save your changes and remain in the Define window, or click 
OK to save your changes and return to Report Manager.

Operation Select from the 
drop-down list.

For calculated columns, the Operation parameters allow you to 
define the calculation.
• Select a column letter from the drop-down list.
• Select a mathematical calculation option from the drop-down list
• Select a column letter from the drop-down list.
See Calculating Columns on page 306 for more information.

Relative Dates—The relative year, first period, and last period indicate the report year and periods 
(beginning and ending) in relation to the report date (defined on the Produce Reports parameter 
window).
• For more information, see Entering Relative Dates on page 276 for more information.

• Relative 
Year

Use up and 
down arrows to 
enter a number.

Enter which year to report in this column, relative to the report date 
(defined on the Produce Reports parameter window).

• First Per Use up and 
down arrows to 
enter a number.

Only used in conjunction with the Net for Period option. When 
combined with the Last per, this field determines what time frame a 
period represents. 
• If the first and last periods span 3 months, this column will 

represent a quarterly figure.

• Last Per Use up and 
down arrows to 
enter a number.

Only used in conjunction with the Account ending balance, Net to 
date, and Net for period options. 
• To extract a monthly figure in a column, choose Net for period, 

then enter a 0 in 1st period and Last period. 
• This column will always reflect the net transactions for the period 

determined in the reporting date.

Print Column Select or 
deselect the 
check box.

If you deselect the check box, the column will not print in your 
report. 
See Hiding Columns on page 306 for more information.

Width Enter the 
column width.

This allows you to specify the width of the column within your 
report.

Table 11.3—Columns Tab Parameter Options (Continued)

Option Entry Description
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HIDING COLUMNS

The Print Column options allows you to “hide” a column of your report. A good use of a 
“hidden” column is in a calculation—you can compile information to use in a 
calculation, but you do not need to display the information in your report.

You want to create a report with a column that reports the money you know you 
will spend, but haven’t actually spent yet—in other words, your committed and 
encumbered funds. You can create two hidden columns for Commitment and 
Encumbrance amounts. You can then create a calculated column that adds these 
amounts. This calculation column is the one that you would display in your 
report.

CALCULATING COLUMNS

You can use the Calculated column option to calculate the information in the column 
using other columns of the report (e.g., use Columns C and E to calculate a percentage 
to appear in Column G). When you define a calculated column, you will select a column 
letter, a mathematical operation that you want to apply, and a second column letter (e.g., 
Column A, Column B, Subtract will subtract Column B values from Column A values).

When you produce the report, FundWare will progress through the columns 
alphabetically. Therefore, the columns used in the calculation must be “before” 
the calculation column. For example, you can use Column G to add Columns C 
and E. But you’ll get an error if we use Column G to add Columns C and M.

Remember—A good use of a “hidden” column is in a calculation. This allows you to 
compile information to use in a calculation, but you do not need to display the 
information in your report.

GROUPING YOUR REPORTS
If you have a set of GL–P/G reports that you often run at the same time, you may find 
the Group feature in Report Manager very useful. The Group feature allows you to 
assign user-defined reports to a group. (A report can belong to only one group.) You can 
then produce the group of reports in one step. 

You create a MTHND group and assign 12 reports that you run at the end of 
every month. Then, instead of running each report individually, you just run the 
MTHND group. 

You can create new groups and add reports to existing groups in two ways, as described 
in the following sections:
Grouping Your Reports 
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• From the General tab of the report definition, or
• From the Groups window.

CREATING AND ADDING TO GROUPS FROM THE REPORT DEFINITION

When you are in the report definition, use the following instructions to create a new 
group, or add a report to an existing group.

1.  Click Report Manager on the module navigator or select File > Report 
Manager from the menu bar. The Report Manager Window displays.

2. Select the applicable report definition and click Edit, or click New to create a 
new report definition.

3. Enter a new group name (up to five alphanumeric characters) in the Report 
Group text box, or select an existing group from the drop-down list.

4. Click Apply or OK.

Once you have created a group, it will display in the Report Group drop-down list when 
you edit or create a report definition for that module, and is displayed in the Groups 
window.

CREATING AND ADDING TO GROUPS FROM THE GROUPS WINDOW

From the Groups window, use the following instructions to create a new group and add 
reports to the group.

1.  Click Report Manager on the module navigator or select File > Report 
Manager from the menu bar. The Report Manager Window displays. 
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2. Click Groups. The Report Manager—Groups window displays (Figure 11.25). 

Figure 11.25—Report Manager—Groups Window

3. Select the ID type for which the reports are defined.

4. Click New to create a new group. The Edit Group Name window displays 
(Figure 11.26). 

Figure 11.26—Edit Group Name

5. Enter a new group name (up to five alphanumeric characters).

6. Click OK. The new group displays in the Groups window.
Grouping Your Reports 
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7. Select the Un-grouped reports folder (Figure 11.27). 

Figure 11.27—Un-Grouped Reports Folder

8. Select one or more reports. (To select a consecutive list of files, press SHIFT and 
click the first and the last file in the list. To select non-consecutive files, press 
CTRL as you click each file.)

9. Drag the reports to the applicable group. The reports are now listed on the right 
side of the window. 

10. Click Done to close the Report Manager—Groups window.

You can also “drag and drop” reports between groups. 

PRODUCING A GROUP OF REPORTS

Use the following instructions to produce a group of reports.
1.  Click Report Manager on the module navigator or select File > Report 

Manager from the menu bar. The Report Manager Window displays.
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2. Click Groups. The Report Manager—Groups window displays (Figure 11.28). 

Figure 11.28—Report Manager—Groups Window

3. Select the group. The reports in the group are listed on the right side of the 
window.

4. Click Produce. The Produce Reports window displays (Figure 11.29). 

Figure 11.29—Producing a Group of Reports

5. Enter the applicable report parameters. (The report parameters will vary 
depending on the types of reports in the group. See Producing Reports on page 
283 for detailed instructions on these options.)

6. Click OK. The reports are produced and saved to your Reports folder.

7. Click Done to close the Report Manager—Groups window.
Grouping Your Reports 
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EDITING A GROUP NAME

Use the following instructions to modify the name of a group.
1.  Click Report Manager on the module navigator or select File > Report 

Manager from the menu bar. The Report Manager Window displays.

2. Click Groups. The Report Manager—Groups window displays. 

3. Select the group. The reports in the group are listed on the right side of the 
window.

4. Click Edit. The Edit Group Name window displays.

5. Edit the group name, as necessary. 

6. Click OK. The modified group displays in the Groups window.

7. Click Done to close the Report Manager—Groups window.

REMOVING A REPORT FROM A GROUP

You can remove a report from a group by deleting the group name from the Report 
Name text box of the report definition. You can also remove a report from a group 
through the Report Manager—Groups window.

1.  Click Report Manager on the module navigator or select File > Report 
Manager from the menu bar. The Report Manager Window displays.

2. Click Groups. The Report Manager—Groups window displays. 

3. Select the group. The reports in the group are listed on the right side of the 
window.

4. Select one or more reports to me removed from the group. (To select a 
consecutive list of files, press SHIFT and click the first and the last file in the list. 
To select non-consecutive files, press CTRL as you click each file.)

5. Drag the reports to the Un-grouped reports folder, or to another group folder. 
The reports are moved to the selected folder and display in the list on the right 
side of the window. 

6. Click Done to close the Report Manager—Groups window.
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DELETING A GROUP

Use the following instructions to remove a group from your system, returning the 
reports to the Un-grouped reports folder.

1.  Click Report Manager on the module navigator or select File > Report 
Manager from the menu bar. The Report Manager Window displays.

2. Click Groups. The Report Manager—Groups window displays. 

3. Select the group. The reports in the group are listed on the right side of the 
window.

4. Click Delete. A confirmation message displays. 

5. Click OK. The group is deleted and the reports included in the group are moved 
to the Un-grouped reports folder.

6. Click Done to close the Report Manager—Groups window.

COPYING REPORTS
You can copy a user-defined report format to use it as a basis for a new report. To do so:

1.  Select a report from a Report Manager list.

2. Click Copy. The Define window displays with a blank Report Name field. 

3. Make your changes in the tabs, enter a report name, and click OK. 

DELETING REPORTS
Use the following instructions to delete a user-defined report. (You cannot delete the 
reports that are provided with FundWare, only the reports that you create.)

1.  Click Report Manager on the Navigator bar or select File > Report Manager 
from the menu bar; and select General Ledger, the report category, and the 
report name.

2. Click Delete. A confirmation message displays.
Copying Reports 
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3. Click OK. The report is deleted and no longer displays in the Report Manager 
list of reports.

PRINTING REPORTS
The FundWare Print Manager allows you to view, delete, print, format reports, and 
search for text. It can be used by both versions of FundWare (i.e., character-based and 
Windows-based versions). 
To access Print Manager, click Print Manager on the module navigator or select File > 
Print Manager from the menu bar. Print Manager launches, displaying the Open 
window (Figure 11.30). 

Figure 11.30—Opening Print Manager

You can also access Print Manager from Report Manager:
• Click Print Manager from the Report Manager window, or
• Select the View option on any report parameters window (i.e., when you 

produce a report) to view the produced report in Print Manager
Refer to the Blackbaud FundWare Print Manager Guide for detail information and 
instructions regarding Printing and the Print Manager Setup Wizard.
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EXPORTING REPORT INFORMATION
All General Ledger–Project/Grant reports, including standard reports, trace reports, 
even check files, are in ASCII format. ASCII is a generic format that most spreadsheet 
or word processing programs can read. You can bring any of your FundWare reports 
into your favorite word processor or spreadsheet and modify them there. 

1.  Create the report through Report Manager. 

2. Note the name and location of your report (i.e., the file name that you use to 
open the file through Print Manager). 

For example, the trial balance is called GLTRBAL.L##, where ## 
represents your division number. By default, this report is saved as an 
ASCII formatted file in your FundWare > Data folder. 

3. Using the secondary software program of your choice (e.g., Excel), select File > 
Open to open the FundWare report file.

4. The secondary software may display a “Wizard” to guide you through the 
process of importing and formatting the file. Follow these instructions.

 

Exporting Report Information 



A P P E N D I X  A

SAMPLE STANDARD REPORTS

This appendix includes examples of the following standard reports:
• CSCHART—Chart of Accounts
• CSLEDGR—Ledger
• GLBALSH—Balance Sheet
• GLTRBAL—Trial Balance
• GLWTBAL—Working Trial Balance
• GLCOMB1—Combined Balance Sheet
• GLCOMB2—Combined Revenue & Expense
• GLCOMB3—Combined R/E With Variance Report
• GLCOMB4—Combined Statement of Changes Report
• CSACDTL—Account Detail Report
• CSRVEX—Revenue & Expense Report
• GLREAA1—R/E Act vs Act by Year Report
• GLREAB1—R/E Act vs Bud PTD & YTD Report
• GLREAB2—R/E Act vs Bud W/Var/Percent
• GLREAB3—R/E Act vs Bud W/Var/Annual
• GLREAB4—R/E Act vs Bud W/Encumbrance
• GLSOFP—Statement of Financial Position
• GLSOA—Statement of Activities
• GLSOCF—Statement of Cash Flows
• CSACVER—Account Verification List
• CSAREP—Attributes List
• CSBREP—ID Types List
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• CSCREP—Journal Controls List
• CSDREP—Date Tables List
• CSENTRY—Special Journal Entries List
• CSREFTR—Transactions Sorted by Reference
• CSTRANS—Transaction Log
• CSJNL—Journals List
• CSRECON—Multiple ID Reconciliation
• CSTRACE—Re-print Trace Report
• GLBAL1—User-Defined Balance Sheet
• GLREEX—User-Defined Revenue & Expense Report
• CAICDEF—Cost Allocation List
• GLRREP—Report Definitions 

Figure A.1—CSCHART: Chart of Accounts
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Figure A.2—CSLEDGER: Ledger

Figure A.3—GLBALSH: Balance Sheet
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Figure A.4—GLTRBAL: Trial Balance
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Figure A.5—GLWTBAL: Working Trial Balance

Figure A.6—GLCOMB1: Combined Balance Sheet
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Figure A.7—GLCOMB2: Combined Revenue & Expense

Figure A.8—GLCOMB3: Combined R/E With Variance Report
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Figure A.9—GLCOMB4: Combined Statement of Changes Report
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Figure A.10—CSACDTL: Account Detail Report

Figure A.11—CSRVEX: Revenue & Expense Report
 



Appendix A—Sample Standard Reports
Figure A.12—GLREAA1: R/E Act vs Act by Year Report

Figure A.13—GLREAB1: R/E Act vs Bud PTD & YTD Report
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Figure A.14—GLREAB2: R/E Act vs Bud W/Var/Percent

Figure A.15—GLREAB3: R/E Act vs Bud W/Var/Annual

Figure A.16—GLREAB4: R/E Act vs Bud W/Encumbrance
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Figure A.17—GLSOFP: Statement of Financial Position

Figure A.18—GLSOA: Statement of Activities
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Figure A.19—GLSOCF: Statement of Cash Flows

Figure A.20—CSACVER: Account Verification List
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Figure A.21—CSAREP: Attributes List
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Figure A.22—CSBREP: ID Types List
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Figure A.23—CSCREP: Journal Controls List
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Figure A.24—CSDREP: Date Tables List
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Figure A.25—CSENTRY: Special Journal Entries List

Figure A.26—CSREFTR: Transactions Sorted by Reference
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Figure A.27—CSTRANS: Transaction Log

Figure A.28—CSJNL: Journals List
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Figure A.29—CSRECON: Multiple ID Reconciliation
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Figure A.30—CSTRACE: Re-Print Trace Report
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Figure A.31—USBAL1: User-Defined Balance Sheet
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Figure A.32—GLREEX: User-Defined Revenue & Expense Report
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Figure A.33—CAICDEF: Cost Allocation List
Blackbaud, Inc. 337



Blackbaud FundWare General Ledger–Project/Grant Guide

338
Figure A.34—GLRREP: Report Definitions
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USING ATTRIBUTES TO DEFINE REPORT COLUMNS

Most report types (i.e., “templates”) provided by General Ledger–Project/Grant allow 
you to define only the rows of the report; the columns are predefined as part of the 
template (e.g., one row may contain actual data and another budget, but you define the 
time period). However, there are certain report types that allow you to use your 
attributes to define the column contents by attribute position to define one or more 
columns (often called “combined” reports in FundWare).
Table B.1 defines those report types and explains their use. 

Table B.1—Report Types That Allow You to Define Attribute Columns

Report Type Description

G—Statement of 
Financial Position

Uses total liabilities and net assets to show the overall financial position of 
your organization. Allows you to use an attribute position to define one or more 
report columns.
• User-defined reports of this type are saved to the Financial Statements 

category.

H—Statement of 
Activities

Uses revenues, expenses, and change in net assets from the beginning of the 
year to the end of the year to display activities. Allows you to use attributes to 
define the report columns.
• User-defined reports of this type are saved to the Revenue & Expense 

category.

I—Statement of Cash 
Flow

Uses the net assets and operating activities, investing activities, financing 
activities, and cash and cash equivalents to report the cash flow for the period. 
Allows you to use attributes to define the report columns.
• User-defined reports of this type are saved to the Financial Statements 

category.

S—Combined 
Balance Sheet

Presents the excess revenue over (or under) expenditures and the liabilities/
fund balance. Allows you to use attributes to define the report columns.
• User-defined reports of this type are saved to the Financial Statements 

category.
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USING YOUR ATTRIBUTE POSITIONS FOR REPORT COLUMNS
The Attribute Columns tab of the report definition displays for those reports that allow 
you to define column contents using attribute positions. For example:

• You define four attribute values for position 6 and assign these values to 
accounts.

• You assign attribute position 6 to Attribute Column 1 of the report definition.
• The report information is divided into four columns based on the attribute value 

in position 6.
“Attribute Column” doesn’t mean that your selection represents a single 
column. It is simply the first definition of an attribute position to 
determine the content of your columns. It will result in multiple 
columns.

Different report types will allow you to define multiple “levels” for your report. For 
example:

• You define three attribute values for position 3 and five attribute values for 
position 4 and assign these values to accounts.

T—Combined Rev. & 
Exp.

Shows the excess revenue over (or under) expenditures to show combined 
revenue and expense. Allows you to use attributes to define the report 
columns.
• User-defined reports of this type are saved to the Revenue & Expense 

category.

U—Combined Rev. & 
Exp. W/Var.

Presents the excess revenue over (or under) expenditures to show combined 
revenue and expense with variance. Allows you to use attributes to define the 
report columns.
• User-defined reports of this type are saved to the Revenue & Expense 

category.

V—Combined 
Statement of Change 
in Fin. Pos.

Presents the excess revenue over (or under) expenditures to show combined 
change in financial position. Allows you to use attributes to define the report 
columns.
• User-defined reports of this type are saved to the Financial Statements 

category.

Table B.1—Report Types That Allow You to Define Attribute Columns (Continued)

Report Type Description
Using Your Attribute Positions for Report Columns 
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• You assign attribute position 3 to Column 1 of the report definition and attribute 
position 4 to Column 2 of the report definition.

• The report information is divided into 15 columns based on the combination of 
position 3 and position 4 attribute values (i.e., 3 x 5 = 15).

The number of available column/attribute position assignments that you can define will 
depend on the report type. For example, a combined balance sheet report (type S) allows 
you to make up to two assignments, while a statement of financial position (type G) 
allows you to define up to five assignments (Figure B.1). 

Figure B.1—Example Attribute Columns Tabs for Different Report Types

DEFINING YOUR SYSTEM

There are three main steps to defining your system to use attribute positions in report 
definitions:
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• Define your attributes by position, keeping in mind how you might want to 
report on this information.

• Assign these attributes values to your accounts.
• Assign attribute positions on the Attribute Columns tab of the report 

definition.

EXAMPLE—DEFINING ATTRIBUTE POSITIONS AND VALUES

For reporting purposes, we want to see our restricted accounts by fund. Therefore, we 
define the following in Division 95:

• We define attribute position 3 as Restrictions. 
• We define attribute position 4 as Funds. 
• We define attribute values for each position (Table B.2). 

Table B.2—Example Attribute Positions and Values

Value Description

Attribute Position 3 (Restrictions)

T1 General Government

T2 Enterprise

T3 Fixed Asset Group

Attribute Position 4 (Funds)

F1 General Fund

F2 Water Fund

F3 Sanitation Fund

F4 Grant Fund

F5 Fixed Assets Accounts
Using Your Attribute Positions for Report Columns 
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EXAMPLE—ASSIGNING ATTRIBUTE VALUES TO ACCOUNTS

Once we have defined our attribute values, we can assign those values to accounts. (If an 
account does not have the attribute value that the report is looking for, it won’t be 
included in the report.) If we look at the Salaries and Wages accounts, we can see how 
the attributes are assigned (Figure B.2). 

Figure B.2—Example Attribute Values Assigned to Accounts
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EXAMPLE—DEFINING AND PRODUCING A REPORT USING ONE POSITION

We can define a revenue and expense report that creates columns for only the restricted 
accounts by entering only one attribute position (position 3, Restrictions, which has 
three values) (Figure B.3). 

Figure B.3—Example “Combined” Attributes Column Tab—Using One Position
Using Your Attribute Positions for Report Columns 
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When we produce the report, the information is sorted into three columns by the 
restriction attribute value (Figure B.4). 

Figure B.4—Example Report—Using One Position

T1 T2 T3
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EXAMPLE—DEFINING AND PRODUCING A REPORT USING TWO POSITIONS

We can define a revenue and expense report that creates columns for the restricted 
accounts, which are then divided into columns by fund, by entering attribute position 3 
(Restrictions, which has three values) and attribute position 4 (Funds, which has five 
values) (Figure B.5). 

Figure B.5—Example “Combined” Attributes Column Tab—Using Two Positions
Using Your Attribute Positions for Report Columns 
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When we produce the report, the information is sorted into three groups of columns by 
the restriction attribute value and by the fund attribute value (Figure B.6). (Because of 
the number of columns, the report columns stretch across two pages. Figure B.6 shows 
only the first page.) 

Figure B.6—Example Report—Using Two Positions

 

T1 T2

F1 F4 F2 F3 F4
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ADJUSTING YOUR SYSTEM FOR GASB 34

If you are an existing FundWare customer, you may need to re-classify and re-post 
historic data to allow for accurate GASB 34 reporting. The process includes the 
following tasks:

• Backing up your data.
• Performing a reorg on the data. 

You must create a temporary “Results” directory before you begin this 
process. The Results directory is used as a temporary directory during 
the reorg process. To help us in our support of you and your use of 
FundWare, we suggest the following directory path: FundWare > 
Maintenance > Results. However, you are not required to use this 
suggested path.

• Creating the necessary journals that post to Budget Type 2 and identifying the 
transactions that must be moved to the new journal.

• Executing two programs to:
— Convert the CSK/CSL transaction detail files, and 
— Repost the CSJ file from the CSK/CSL transaction detail files.

Use the steps in the following sections to complete this process for each applicable 
division.

BACKING UP YOUR DATA
Use the following steps to backup your data for the applicable division.
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1.  Select Maintenance > System Administration > Division Maintenance from 
the menu bar. The Division Maintenance window displays (Figure C.1). 

Figure C.1—Division Maintenance

2. Select the division to be backed up.

3. Click Backup. When the backup is complete, a confirmation message displays 
providing the name and location of the backup folder (Figure C.2). 

Figure C.2—Backup Confirmation Message
Backing up Your Data 
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4. Click OK. The date and time of the backup displays in the Last Backup column 
of the data window (Figure C.3). 

Figure C.3—Division Maintenance: Backup Date and Time Stamp

PERFORMING A REORG ON THE DATA
Use the following steps to reorg your data for the applicable division.
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1.  Using Microsoft Explorer, locate the FundWare > 7.20 > Bin directory and 
double-click the FILEMAINT.EXE file to open. The FundWare File 
Maintenance feature displays (Figure C.4). 

Figure C.4—FundWare File Maintenance

2. Type the Data directory path in the Data directory text box, or click the ellipsis 
to search for the directory. (File Maintenance will enter a default directory 
based on your FundWare system.)

3. Select the Division radio button and select the division from the drop-down list 
(Figure C.5). 

Figure C.5—Selecting the Division

Division filter
Performing a Reorg on The Data 
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File Maintenance displays the data files in the selected division in the detail 
pane below (Figure C.6). 

Figure C.6—Example Search Results

Any files that cannot be addressed by the File Maintenance procedures 
will be highlighted with a pink row color. For example, files ending in 
.L95 are the report files for division 95, but these files are not data files. 
Therefore, they are highlighted with pink and you will not be 
reorganized.

4. Type the results directory path in the Results directory text box, or click the 
ellipsis to search for the directory.

The Results directory is used as a temporary directory during the reorg 
process. To help us in our support of you and your use of FundWare, we 
suggest the following directory path: FundWare > Maintenance > 
Results. However, you are not required to use this suggested path.

5. Click  on the toolbar or select Maintenance > Reorg to Results Directory 
from the menu bar. 
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6. Review the results in the detail pane.

7. If the results of the reorg are correct, click  on the toolbar or select 
Maintenance > Copy Files From Results to Data Directory from the menu 
bar. You have completed the reorg process for your Data directory.

CREATING THE JOURNALS AND IDENTIFYING BATCHES
Use the following steps to create the necessary journals that post to Budget Type 2.

1.  Complete the journal setup necessary to meet the needs of your organization 
(i.e., add at least one journal that posts to Budget Type 2).

2. Through Report Manager, select the division, General Ledger module, and 
Transaction Reports category.

3. Produce the transaction log report (CSTRANS) and carefully review the results 
to determine which budget transactions will be reposted to the new journal.

In other words, if you have designated Budget Type 2 as the area for 
your budget modifications, then any adjustment transactions must be 
reposted to the journal that posts to Budget Type 2.

EXECUTING THE PROGRAMS
Use the following steps to execute the two necessary programs.

1.  Open an instance of FundWare.

2. From the Division Selection window, select System Administration. (System 
Administration tasks can apply to multiple divisions. Therefore, instead of 
selecting a single division you must select System Administration.)
Creating the Journals and Identifying Batches 
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3. Click System Utilities on the module navigator or select System 
Administration > System Utilities from the menu bar. The System Utilities 
window displays (Figure 3.7). 

Figure 3.7—System Utilities Window

4. In the Execute Program area, enter the required information according to Table 
C.1 to convert the CSK/CSL transaction detail files. 

Table C.1—Encrypting Checks

Field Entry

Program Name CST934

Switches Leave blank

Parameters Leave blank

Business Date Defaults to the current date. Accept default.

Division Select the applicable division from the drop-down list.
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5. Click Run. A confirmation message displays (Figure C.8). 

Figure C.8—Running CST934

6. Enter Y (for yes) to proceed. The system prompts you for more information. 

7. Enter the batch number, original journal, and new journal (i.e., Budget Type 2 
journal) (Figure C.9). 

Figure C.9—Additional Information for CST934

8. Press ENTER. A confirmation message displays.
Executing the Programs 
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9. Enter Y (for yes) and press ENTER to proceed. FundWare processes the records 
and reports the CSK records, CSL records, and modified records and displays a 
completion message (Figure C.10). 

Figure C.10—CST934 Results

10. Press ENTER. You return to the System Utilities window.

11. In the Execute Program area, enter the required information according to Table 
C.1 to repost the CSJ file from the CSK/CSL transaction detail files. 

Table C.2—Encrypting Checks

Field Entry

Program Name CST900

Switches Leave blank

Parameters CST901

Business Date Defaults to the current date. Accept default.

Division Select the applicable division from the drop-down list.
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12. Click Run. A confirmation message displays (Figure C.11). 

Figure C.11—Running CST900

13. Type Y (for yes) to proceed. When the program has processed the information, a 
completion message displays.

14. Press ENTER to return to the System Management menu.
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A P P E N D I X  D

USING THE ENHANCED LEDGER REPORT

OVERVIEW OF NEW ENHANCED LEDGER REPORT TYPE K
Type K includes all types of transactions: Budget, Encumbrance, and Actual
Previous standard GL transaction reports allowed for only one type of transaction per 
report. Actual, budget or encumbrance could be selected, but not all three on the same 
report.
The new report includes beginning balances for each account for encumbrance, actual 
and budget, followed by detailed transactions of all three types for the period specified. 
There are columns for budget, encumbrance and actual. 

CREATING THE REPORT
Use the following instructions to add the Enhanced Ledger Report to your system.

1.  Open Report Manager and Select General Ledger Reports> Transaction 
Reports.

2. Click New to create a report definition.

3. Complete the required fields on the following tabs:

GENERAL TAB

Give the Report a short name in the Name field and a title that will print on the report 
heading when produced. The New Report Type field is K which can be selected from 
the drop-down list.  The remaining fields are identical to standard setup on the pre-
existing LEDGR report.
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Figure D.1—General Tab

• Include/Exclude Attributes Tab
This may be left blank, or can be used for selected attributes.

You may wish to include only EX accounts on one report to mirror an 
Expenditure report and have a second report that shows all attributes that meet 
the mask you will use when producing the report. 
Creating the Report 
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Figure D.2—Include/Exclude Attributes Tab

PAGES TAB

The pages tab determines on which dimensions or attributes your Report will break.
If you use the break dimension settings, at each change in the dimension that you define 
in your report, it will:
Total the information in the section

Insert a page break

Start a new section
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In the example below, the report is set to break on the first dimension (i.e., the 
fund dimension), and each section of the report would be fund-specific. When 
the fund changes from 01 to 02, the report would detail and subtotal fund 01 and 
start reporting fund 02 on a new page.

Figure D.3—Pages Tab
Creating the Report 
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ROWS TAB

The Rows tab determines if the full account number should be printed or if they should 
be summarized.  The figure below is set to print each account number individually.

Figure D.4—Rows Tab

See your Blackbaud FundWare General Ledger/Project Grant Guide for further 
information on creating and producing reports.
After clicking Apply or OK to exit the form, the report is ready to be produced.
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PRODUCING YOUR REPORT
Select the report from either the General Ledger Homepage or the Report Manager list 
of reports.
User-defined reports of this type are saved to the Transaction Reports category.
Double-click or click Produce. The Produce Report window displays.

Figure D.5—Producing the Report

When printing the new enhanced ledger report, you need to use the "Wide 
letter.tpl" template in Print Manager to get it to print landscape and not wrap.
Producing Your Report 
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Figure D.6—General Ledger Report Type K

Example General Ledger Report Type K with Budget, Encumbrance Actual and 
Balance.
The Balance column on the right is showing by how much the Actual and Encumbrance 
are over the budget amount.
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A P P E N D I X  E

USING THE TWINNING FEATURE

FundWare allows you to have multiple ID types (remember—an ID type is a single-
letter code that identifies a specific group of accounts for tracking and reporting 
purposes). Because your account structure is based on the ID type, using different ID 
types allows you to track account information in a variety of ways. 

ID types A (primary) and Z (subsidiary project) are set up to use twinning. All 
entries must flow through A and then, optionally, post to Z. This represents a 
common use of twinning which is a project or grant that has its own ID type and 
still needs to be recorded in the required books.

To design your system to allow twinning, you must define the following:
• The account structure for each ID type must include a twinned dimension
• The journals to which you will post twinned transactions must be defined to 

allow entry from each ID type
• The accounts 

DEFINING YOUR ACCOUNT STRUCTURE TO TWIN ACCOUNTS
To use the twinning feature, you must define the account structure for each ID type with 
identical dimensions. Each ID type must have a dimension that:

• Has the same number of digits, and
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• Has the exact same dimension name (e.g., same spelling and capitalization) 
(Table E.1). 

Remember, you define the account structure when you define your ID types (General 
Ledger > Setup). However, if you are planning to twin accounts, you should design the 
account structure for all your ID types before you begin the definition process.

You can rename a dimension after you have defined the ID type, but you cannot 
change the length of the dimension.

RENAMING A DIMENSION

Use the following instructions to rename an existing dimension (e.g., the capitalization 
doesn’t match between ID types) from the ID Types window.

1.  Click Maintenance > ID Types on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > 
Maintenance > ID Types from the menu bar. The ID Types window displays. 

2. Select the applicable ID type from the drop-down list.

3. Select the Account Structure tab.

4. Enter a new dimension name in the Description field.

5. Click Apply to save your entries and remain in the ID Types window or click 
OK to save your entries and close the window.

Table E.1—Designing Dimensions for Twinning

Dimension in 
ID Type G

Length 
Fund X

Dimension in 
ID Type L

Length 
Fund Y

Twinning 
Allowed Why?

OBJECT 4 Object 4 No Capitalization does not match.

Object 4 Object 3 No Dimension length does not match.

OBJECT 4 OBJECT 4 Yes Both capitalization and dimension 
length match.

Object 3 Object 3 Yes Both capitalization and dimension 
length match.
Defining Your Account Structure to Twin Accounts 
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DEFINING YOUR JOURNALS TO TWIN ACCOUNTS
You must now define the journal (or journals) to which you will post your twinned 
entries. 

1.  Click Maintenance > Journals on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > 
Maintenance > Journals from the menu bar. The ID Types window displays. 

2. Add a new journal or select an existing journal.

3. Select the ID Types tab.

4. Add the ID types and necessary Required, Balancing, Due To/From, and 
Suspense information for each ID type. For more information on these fields, 
see Modifying Your System-Defined Journals on page 102 or Adding a Journal 
on page 107.

5. Click Apply to save your entries and remain in the Journals window or click 
OK to save your entries and close the window.

Figure E.1 shows an example of a journal that allows entry from four ID types. 

Figure E.1—Division 95 Journal Definition Allowing Posts From Multiple ID Types
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TIPS FOR DEFINING YOUR MODULES TO TWIN ACCOUNTS

If you plan to allow twinning in a module, you must define all the journals for that 
module to allow posting to multiple ID types. This is true even if you only want to use 
twinning in one journal. 

DEFINING YOUR ACCOUNTS TO TWIN
You must also define the specific accounts in each ID type to allow for twinned entries.

• The accounts must have the same number in the shared dimension:
— A04 02-01 6110
— F100-01 6110

• Define one or both accounts to:
— Require each ID type, or
— Allow addition ID types as option (i.e., One of).

Figure E.2 shows twinned accounts in ID type A and ID type F of Sample Division 95.
• A01 00-00 4145 requires that any posting to this account include a posting to ID 

type F (note that the account number isn’t specified).
Defining Your Accounts to Twin 
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• F100-01 4145 allows the user to include a posting to ID type A, but does not 
require that posting. 

Figure E.2—Example Twinned Accounts

Use the following instructions to define an account to twin.
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1.  Click Accounts > Chart of Accounts on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > 
Accounts > Chart of Accounts from the menu bar. The Chart of Accounts 
displays the first ID type in your list of ID types (Figure E.3). 

Figure E.3—Chart of Accounts—Division 95, ID Type A

2. Select an ID type from the drop-down list. The display may change to reflect the 
ID type account structure.
Defining Your Accounts to Twin 
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3. Select the account and click Edit. The account displays in the Edit Accounts 
window (Figure E.4). 

Figure E.4—Example Account

4. Double-click the Require ID Types cell for the account. The Require ID Types 
window displays the remaining ID types (i.e., all ID types but the one to which 
you are adding an account) in defined for your system with a status of <not 
selected> (Figure E.5). 

Figure E.5—Adding an Account—Required ID Types Window

Remember: You can only require ID types for the account if you 
enabled the Required Id Types option for the ID type. For more 
information, see the instructions for the Field Use tab of the ID type 
definition (Editing Your ID Types on page 79).

5. Select one of the following options from the Status drop-down list:
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• Required—All transactions posted to this new account must also post to an 
account of this ID type.

• One of (Pick at least 2 ID types)—All transactions posted to this new 
account must also post to “one of” the defined additional ID types. 

6. Click OK. Your entries are saved and the Required ID Types window closes. 
You return to the New Account window.

7. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and return to the Chart of Accounts display.

USING AN ACCOUNT THAT REQUIRES A TWIN

When you enter an account number that requires or allows a twin, twinning saves you 
the keystrokes of the second twinned dimension (it does not matter which ID type you 
start with). For example:

• You type A0402016110F10001
• The system posts to:

— A04 02-01 6110
— F100-01 6110
Defining Your Accounts to Twin 
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If you enter an account number that requires a twin (i.e., the Other Options tab of the 
account definition specifies that an additional ID type is Required), you try to leave the 
field without adding the information for the additional ID type, the system will display a 
message (Figure E.6). 

Figure E.6—Example Error Message for Missing Required Account

An account defined to allow (optionally) posting with an additional ID type 
(i.e., the Other Options tab of the account definition specifies that an additional 
ID type is One Of) will not display any message if you forget to include a 
twinned entry.

TIPS FOR DEFINING YOUR ACCOUNTS TO TWIN

Remember, if you defined your journal to require twinned entries, you must also define 
all applicable accounts to allow twinned entries from the same ID types.

• You can define an additional ID type as Optional at the journal level, and 
required or “one of” at the account level.

• You can define an additional ID type as Required at the journal level, but must 
then define the ID type as required at the account level. (You could define the 
ID type as One Of, but the journal entry form will not catch when you forget to 
include the twinned account information, but the journal will catch the error 
when you try to post.)
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A P P E N D I X  F

ENTERING BEGINNING BALANCES

Use the following instructions to enter your beginning balances.
1.  Verify that a date table exists for the year in which you want to post beginning 

balances (Maintenance > Date Tables).

If necessary, use this task to define the year. See Adding New Date 
Tables on page 117 for instructions to add a date table.

2. Print a Working Trial Balance report (WTBAL in the Financial Reports 
category) from your old accounting system.

Select the report to print zero balance accounts so that all account 
numbers print on the report.

3. Use the report to help transfer the balances from your old system to FundWare. 
You can use the report columns to write in your new General Ledger account 
numbers next to your old account numbers. (Remember: If you want, you can 
enter your old account numbers into the alias fields of your new account 
numbers.)

4. The maximum number of entries that the General Ledger posts at once is 999. If 
you have more than 999 entries, separate them into smaller transactions.

5. Log on to FundWare with the business date to which you want to enter your 
beginning balances. 

For example, you want beginning balances as of the end of 2003. Enter 
the date as December 31, 2003.

6. Backup your division data files. (This task is completed through the System 
Administration > Division Maintenance task. See the Blackbaud FundWare 
System Administration Guide for more information.) 
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7. Click Journal Entries > New on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > Journal 
Entries > New from the menu bar. The Journal Entry form displays (Figure 
F.1). 

Figure F.1—New Journal Entry Form

8. Select the journal to which you want to add beginning balances from the 
Journals drop-down list.

9. Enter the balances for each account. (For more detailed instructions on adding 
journal entries, see Creating Journal Entries on page 177.)

10. Post the transactions. The system creates a trace report for the transactions.

11. Print and review your trace reports.

12. Print a Trial Balance report (TRBAL in the Financial Reports category) for the 
period for which you entered the beginning balances. 

13. Review the report. To make corrections, enter a new transaction for the net 
difference for any incorrect balances.

14. If you entered balances for revenue and expense accounts for a prior year, you 
must use the Post Revenue & Expense task to close the balances into the fund 
balance account (see Posting Revenue and Expense Balances on page 223). 
This must be done before you can produce financial reports in the current year. 
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If you entered only balances for balance sheet accounts (assets, 
liabilities, and fund balances), skip this step.

15. Produce a trial balance report for the closing period to make sure all accounts 
are posted correctly.

16. Roll beginning balances for balance sheet accounts forward to the current fiscal 
year (see Rolling Beginning Balances on page 225).

17. Backup your division data files. (This task is completed through the System 
Administration > Division Maintenance task. See the Blackbaud FundWare 
System Administration Guide for more information.)

18. Produce a Trial Balance report (TRBAL in the Financial Reports category) for 
the beginning balance period of the new fiscal year to verify that all amounts are 
correct.

You are now ready to begin entering information for the new year.
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A P P E N D I X  G

ENTERING YOUR BUDGET

You can enter your budget information on an annual or non-annual (e.g., monthly) basis.
• Annual—You enter a single amount that is the budgeted amount for the account 

number during the fiscal year.
• Non-annual—You enter a series of budget amounts for periods of your fiscal 

year.
If you are using the Budget Forecasting or Budget Preparation modules, you will not 
track your budget information through this feature.

ENTERING BUDGET INFORMATION
Use the following instructions to enter budget information. (If you are entering non-
annual budget information, you will have one additional step in this process, as noted in 
Additional Steps for Entering Non-Annual Budget Information on page 383.)

1.  Produce a Working Trial Balance report (WTBAL in the Financial Reports 
category). This worksheet lists all accounts defined.
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Select the report to print zero balance accounts so that all account 
numbers print on the report (Figure G.1). 

Figure G.1—Producing the Working Trial Balance Report for Zero Balances

2. If your system is missing accounts for which you must enter budgets, create the 
needed accounts. (See Chapter 4—Adding and Maintaining Accounts on page 
125 for instructions to add accounts.)

3. If necessary, re-run the Working Trial Balance report to ensure that all your 
accounts are defined.

4. Use the Working Trial Balance printout to define your annual budget amounts.

5. Log into FundWare using the first day of your fiscal year.

Since you are entering annual budget amounts, you must enter the 
budget in the first period of the fiscal year. 
Entering Budget Information 
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6. Click Journal Entries > New on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > Journal 
Entries > New from the menu bar. The Journal Entry form displays (Figure 
G.2). 

Figure G.2—New Journal Entry Form

7. Select the journal to which you want to add beginning balances from the 
Journals drop-down list. (This should be a budget journal.)

8. Enter the balances for each account. (For more detailed instructions on adding 
journal entries, see Creating Journal Entries on page 177.)

9. Post the transactions. The system creates a trace report for the transactions.

10. Print and review your trace reports. 

11. After you have entered and posted the budget amount for each account, produce 
any of the reports that include annual budget information (e.g., GLREAB1 - R/
E Act vs Bud PTD & YTD) to verify your entries.

ADDITIONAL STEPS FOR ENTERING NON-ANNUAL BUDGET INFORMATION

Use the following instructions if you need to enter budget information on any basis other 
than annual (e.g., monthly).

1.  Define a memorized journal entry for a portion of the amount, relative to your 
fiscal year. 
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For example, if you are creating a monthly budget, you would define a 
memorized transaction for one-twelfth of the annual amount.

2. Sign on to each applicable period in your fiscal year and post the recurring 
entry. 

3. Sign on to FundWare using a business date that is within the applicable fiscal 
period and post the memorized transaction.

4. Produce a revenue and expense report with period-to-date, year-to-date, and 
annual budget columns to verify the posting.

 

Entering Budget Information 



A P P E N D I X  H

USING THE .YEAR END DATA ITEM
(PROJECT/GRANT)

The .YEAR END data item is a powerful feature that allows you to report information in 
user-defined balance sheet reports (type X) for Project/Grant ID types for a fiscal period 
different than the year ending date defined in your date table (i.e., cross-fiscal year 
reporting) by adding the .YEAR END data item to descriptive accounts. The data item is 
only on the account record and is not related to data items on transactions. 

Your year end is defined in your date table as 12/31. Your .YEAR END data 
item has been added to the applicable descriptive accounts and defined with a 
date of 6/30/0000. You produce an X-type report with a date of 6/30/2003 that 
compiles information gathered for the periods of 7/1/2002 through 6/30/2003. 

This feature is available only for X-type standard reports in Project/Grant.

ADDING .YEAR END
Use the following instructions to create the .YEAR END data item.
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1.  Click Maintenance > Data Items on the module navigator (if the module is not 
expanded, click General Ledger first) or select General Ledger > 
Maintenance > Data Items from the menu bar. The Data Items window 
displays (Figure H.1). 

Figure H.1—Data Items Window

2. Click New. All entry fields clear and the cursor appears in the Data Item text 
box (Figure H.2). 

Figure H.2—New Data Item—Empty Fields

3. Define the data item according to Table H.1. 

Table H.1—.YEAR END Data Item Field Definitions

Field Entry Description

Data Item .YEAR END Enter the name of the data item.

Data Type Date mm/dd/yyyy From the drop-down list, select the option for a numeric date.
Adding .YEAR END 
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4. Click Apply to save the data item definition and remain in the screen or click 
OK to save the definition and close the screen.

ADDING .YEAR END TO YOUR DESCRIPTIVE ACCOUNTS
Before you can add the .YEAR END data item to your descriptive accounts, you must 
determine which descriptive accounts are used for page breaks in each level of the report 
that you are creating (or modifying). (This information is on the Page tab of the report 
definition.)
For new reports:

• Look up the dimensions defined in the Page Values field of the Pages tab for 
each level of the report.

• From this, determine the necessary descriptive accounts.
For existing reports:

• In Report Manager, select the report for which you will be using the .YEAR 
END option.

• Click Edit to view the report definition.
• Select the Pages tab and determine the dimensions defined for each level of the 

report.
• From this, determine the necessary descriptive accounts.

Description 30-alphanumeric 
characters

Enter a description of the data item. 
• We recommend “Grant Year End.”

Prompt 15-alphanumeric 
characters

Enter the description that will display when you use this data item 
(e.g., as a column heading on the journal entry form). 
• We recommend “Grant Year End.”

Table H.1—.YEAR END Data Item Field Definitions (Continued)

Field Entry Description
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Level 1 breaks on dimensions 1-2 and Level 2 breaks on dimension 1 (Figure 
H.3). 

Figure H.3—Example Page Values Fields for a Two-Level Report

To report information for a different year-end date for project 100, grant 01, you 
add the .YEAR END data item to the following descriptive accounts:

• 100 01 0000 (Level 1)
• 100 00 0000 (Level 2)
If the accounts do not exist, you must create them.
Adding .YEAR END to Your Descriptive Accounts 
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Use the following instructions to add the .YEAR END data item to your descriptive 
accounts.

1.  Click Accounts > Chart of Accounts on the module navigator (if the module is 
not expanded, click General Ledger first) or select General Ledger > 
Accounts > Chart of Accounts from the menu bar. The Chart of Accounts 
displays the first ID type in your list of ID types.

2. Select an ID type from the drop-down list. The display may change to reflect the 
ID type account structure.

This feature is only available for Project/Grant ID types. You must 
select a Project/Grant ID type.

3. Select an existing account or click New to add an account. (For specific 
instructions to add an account, see Adding Accounts Through the COA on page 
144. 

You can also add an account through the New Account task. See 
Adding Individual Accounts on page 125.

The New Accounts or Edit Accounts window displays (Figure H.4). 

Figure H.4—Edit Accounts Window

4. Double-click the Data Items cell for the account. The Data Items window 
displays. 
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If you have defined any data items for this ID type, they will display in 
this window. For more information, see the instructions for the Field 
Use tab of the ID type definition (Editing Your ID Types on page 79).

5. Select .YEAR END from the Data Item Name drop-down list (Figure H.5). The 
prompt and value format defined for the data item display in read-only cells 
(Data Item Prompt and Value Format cells, respectively). 

Figure H.5—Adding an Account—Data Items Window

6. In the Value field, enter the year-end date for the cross-fiscal year reporting, but 
enter zeros for the year.

7. Click OK. Your entries are saved and the Data Items window closes. You return 
to the New Accounts window.

8. Click Apply to save your settings and remain in the window, or click OK to 
save your settings and return to the Chart of Accounts display. 

DEFINING AND PRODUCING YOUR REPORT
Before you produce your report, you must understand how the Period options that you 
select on the Columns tab of the X-type report definition will be interpreted (Figure 
H.6).

• Year beginning balance—Balances rolled forward from the previous year (i.e., 
year prior to the reporting year).

• Account ending balance—Balance for the reporting year without adjustments or 
beginning balances.
Defining and Producing Your Report 
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• Annual ending balance—Balance for the reporting year with adjustments and 
beginning balances.

• Net to date—Balance from the beginning of the reporting year to the report date 
(i.e., date entered when you produce the report) without adjustments or 
beginning balances.

• Net for year—Balance for the reporting year with adjustments but without 
beginning balances.

• Net for period—Balance for the reporting period (i.e., based on the date entered 
when you produce the report) without adjustments or beginning balances 
(Figure H.6). 

Figure H.6—Example Columns Tab for X-Type Report

Use the following instructions to produce your report.
1.  Double-click the report or select the report and click Produce.
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2. In the Date field, enter the date of the period for which you want the report 
(Figure H.7). 

Figure H.7—Example Produce Report Screen

3. Click OK. 
Defining and Producing Your Report 



GLOSSARY

A
Account Builder—Table-driven tool to define groups of accounts.
Account Number—The number that stores information about transactions to an 
account.
Account Number Structure—The foundation of accounts based on dimensions and 
separator characters. The structure represents account groups such as funds, 
departments, sub-departments, line items, and locations. For example, the Model Not-
for- Profit Division has an account number 0101006110 structured in the following way 
to include the fund, department, sub-department, and line item. 

Additional Data Items—Data items are pieces of information that can be included in 
account definition or in a transaction. Typically they are used to store non-financial 
information. Transactional data items are defined in Journal Maintenance.
Adjustment Periods—Periods added to the end of each year in the date table. These 
periods are designed specifically for audit and year-end adjustments.
Attribute Positions—Each account string allows up to 15 attribute values. The first 
position is required by the system.
Attribute Values—An attribute value is a code that is one to three characters in length 
assigned to a position in the account string. Attribute values allow accounts to be 
grouped on reports according to their type. You can have up to 15 attribute values per 
account. The standard attributes are as follows:

Table 1.2—General Ledger Account Number Structure

Fund Department Sub-Department Object (Line Item)

01 01- 00 6110

Table 1.3—Project/Grant Account Number Structure

Project Grant Object (Line Item)

100 01 6110
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• AS—Asset
• LI—Liability
• NA—Net Assets (FASB)
• FB—Fund Balance (GASB)
• OE—Owner Equity
• RE—Revenue
• EX—Expenditure
• DS—Descriptive

Project/Grant uses only RE, EX, and DS. In Project/Grant, you also have up to 
15 attributes available. Every account must have one of these attributes. 
Additional attributes can be defined and used for reports.

Automatic Suspense Account—A temporary storage account for journal entries for 
which there is either no existing account or the appropriate account is unknown. If you 
plan to use a suspense account, one needs to be created for each journal. To use a 
suspense account, right-click in the Accounts field in the Journal Entry window and 
select Suspense Account. A trace report will be produced with a warning that the 
suspense account was used.

B
Page Break Dimensions—A page break dimension organizes information in reports. It 
allows you to break information in a report on to separate pages and to subtotal the 
information. Page Break dimensions are defined in Report Manager.
Business Date—The date used to post an entry to a ledger. It must be a valid calendar 
date that exists in the date table. The business date determines the period in which a 
transaction is reported. If the date is in a closed period, a transaction task may not be 
selected. The business date is also called the posting date.

C
Chart of Accounts—List of your accounts. From this window, you can add, edit, and 
delete accounts or view account information.
Clearing Account—An account defined in each fund to maintain the balance due to or 
from an individual fund or from the clearing fund. Also called a “due to/from account”.
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Clearing Fund—This is a fund designated as the “Fund Manager” or clearing fund for 
all other funds. It is usually a general, operating, or unrestricted fund that contains the 
primary checking account, asset, and liability accounts. A clearing fund balances 
transactions that cross funds. See due to/from account.
Closed Period—The last closed period is always the last day of a date table period. That 
day, along with all dates prior, is closed to data entry. The first day of the next period, 
and all dates thereafter, are open to data entry. By closing a period, all information is still 
available for reporting, but additional transactions may not be posted. It is possible to 
open a closed period if additional transactions are required.
Cost Allocation—Cost allocation lets you easily distribute indirect expenses and 
revenues from pooled accounts to specific cost centers or designated accounts.
Created by Posting Account—Created by posting accounts occur if a control account 
was incorrectly defined in a parameter, or an auto due to/from account or other account 
required by a setup mask has not been defined. Instead of halting the posting and 
generating an error, the system makes a “created by posting” account. Created by 
posting accounts need to be corrected immediately.
Current Balance—The net current total of debits and credits for the first ID type. It is 
the number used to verify that entries are made correctly.

D
Date Table—The date table contains the fiscal-period ending dates for each year.
Default—A value supplied by the General Ledger if you do not enter your own value.
Dimension—A piece of your account structure representing categories in your 
accounting system (e.g., funds, projects, object codes, funding sources) or information 
that you must report. You can use account number dimensions to sort, sum, and select 
information to include on your reports.
Dimension Values—Numeric values assigned to each dimension. These values usually 
have a specific meaning (e.g., Fund 02 is the Water Plant Fund—02 is the dimension 
value).
Due To/From Account—An account defined in each individual fund to maintain the 
balance due to/from an individual fund or from the clearing fund. The clearing fund has 
a due to/from account to maintain the balance due to/from each individual fund. A due 
to/from account is updated by the General Ledger automatically each time an interfund 
transaction is posted, if the journal is defined as automatic balancing. It is also called a 
clearing account. See clearing fund.
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E
Entry—A single item within a transaction. Also called an item.

F
FASB—Financial Accounting Standards Board.
Fiscal Period—The period and year in which transactions are grouped for reports. For 
monthly reporting systems, it is the month and year. For weekly reporting systems, it is 
the week and year. The date table determines the beginning and ending dates of fiscal 
years and periods. Fiscal periods can be created in intervals of one, two, three, or four 
weeks, or by month.
Fiscal Year—A period of any pre-defined amount of consecutive months, but not 
greater than 12 months. The General Ledger allows each organization to define its own 
fiscal year. Provisions are included for non-standard years if a fiscal year changes.

G
GASB—Government Accounting Standards Board.
GLA—The GLA, or general ledger account, is the object or line item account number.

I
ID Type—An ID type is a single-letter code that identifies a specific group of accounts 
for reporting purposes. The ID type controls the end of the fiscal year, the type of 
accounting, fiscal period, names for the default journals, and account number structure. 
For example, the Model Not-For-Profit Division has four ID types. “A” represents all 
accounts; “F” accounts are associated with federal grant, “M” are meetings; and “S” are 
accounts associated with state grants.
Identifier—A number that stores information for a transaction in a reporting system 
such as the General Ledger. Also called the account number.
Item—A single entry within a transaction. Also called entry.
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J
Journal—A book of original entry that records transactions to be posted to a ledger. 
Journals may be defined by using the Journal Maintenance task prior to using a 
transaction task. Journals are also known as Books of Original Entry.
Journal Control—The journal control contains information about each journal and 
controls the way transactions are processed.

L
Ledger—A book or file of all of an organization’s accounts. The General Ledger 
contains ledgers: the actual, budget type 1, budget type 2, encumbrance, and 
commitment. 
Locking Periods/Years—A feature of FundWare that allows you to prevent 
transactions from being posted to a specific ID type during a period or year for which 
you have completed and confirmed all your entries.

M
Mask—A “wild card” code used to represent a group of accounts for reports, 
maintenance, or for account duplication. Use a mask to represent a group of accounts 
using only one entry. A mask uses an X in the place of an actual number in the account 
number. The General Ledger extracts all accounts that match the digits with no regard to 
the numbers in the position indicated by the X.
Master Records—Master records contain the information needed to process 
transactions. The system refers to the master records every time you use a task. The 
master records are the ID type, attributes, date table, and journal controls.

N
Name—The name given to a journal entry during data entry and in tasks that maintain 
and post memorized, imported, and saved journal entries.
Net Transaction—Sum of debit and credits posted to an account in a fiscal period, or 
range of fiscal periods.
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P
Parameter—The parameter controls data entry, whether you can save the transaction, 
fiscal years, and related information.
Posting Date—The date used to post a transaction to a ledger. Also called the business 
date.
Posting Window—The number of days after the last closed period during which 
posting is allowed. The system will use your system date (i.e., not the business date used 
during login) and the number of days in the posting window to determine the period of 
time, after the last day of a closed period, during which you can still post entries to that 
period.

R
Reclass Period—A memo period at the end of the year designed for financial statement 
reclassification entries. Entries made in the reclass period do not affect the closing 
balances for any accounts and are not rolled forward.
Reference Fields—These are fields you can use to store information about a 
transaction. The contents of reference fields vary depending on the journal used. These 
fields contain information you need about a particular transaction.
Remainder Mask—Defines the account that holds the left-over amount of an allocation 
that results from rounding. 
Report Definition—The way a report is defined using the Report Manager. Once a 
report is defined, use the same report definition to reproduce it at any time. Specifically, 
the definition identifies the field entries to be included in the report. Entry fields are the 
report name, report type, report title, and dimensions that are to be summed for the 
report.
Row Dimensions—Allow reports to be produced with different degrees of detail or 
summary information. With row dimensions, accounts can be reported individually, or 
individual accounts can be summed to an account group using a dimension number.
Report Group—A group of reports produced at the same time. A five character alpha 
numeric code can be assigned to each report when it is defined allowing the report to be 
produced with other reports.
Report Level—Allows different amounts of information to be included in a report 
using a single definition. Most General Ledger reports have from one to five report 
levels allowing you to report varying degrees of detail or summary.
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Report Name—Names a standard report that you define. Use this name to select the 
report for production.
Report Type—Indicates the type of information included in a General Ledger standard 
report. Each report is assigned a report type letter.
Revenue and Expense Report—A report that shows the total revenue and expense by 
period or year.

S
Select—The field on display and report windows that prompts you to enter the mask to 
select the accounts to include in the report.
Session—One cycle of using a transaction task from beginning to end.
Shortcut Menu—Menu displayed when you click the right mouse button (i.e., right-
click).
Standard Attribute—A code of up to three characters that allows accounts to be 
grouped on reports according to their accounting type. These attributes are defined 
automatically by the system. 
Standard Report—In the General Ledger, Standard Report allows you to format rows 
for each report. Type X and Y reports allow columns to be defined. All other reports are 
pre-defined.

T
Trace Report—Automatically created and saved to a file each time a transaction is 
posted through a journal to a ledger. Trace Reports can be printed for a ‘paper trail’.
Transaction—An item or group of items (account entries) entered at the same time. 
General Ledger posts a single transaction that is made up of individual entries. 
Transaction Account—Accounts entered for a single item in a transaction. If using 
only one ID type, the transaction account is the same as the account. For multiple ID 
types, all ID types comprise the transaction account.
Transaction Number—Number assigned by the system to a group of entries that make 
up a transaction. General Ledger automatically generates these numbers beginning with 
“1T” and continues consecutively. The transaction number is the same as the trace 
report number. The number is not reset at the beginning of the fiscal year. Transaction 
numbers cannot be changed.
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Transaction Reports—Reports that retrieve information from the detail records of the 
reporting system. The reports are: Journal List, Re-Print Trace Report, Transaction Log, 
Multiple ID Reconciliation, and Transactions Sorted by Reference.
Transfer (Xfer) Dimension—The dimension in the clearing account or due to/from 
account that represents the fund to be cleared when an interfund transaction occurs. In 
the Model Not-For-Profit Division, dimension 3 is the Xfer dimension.
Twin Dimensions—Twin dimensions are identical dimensions between ID types that 
allow easy data entry when information is duplicated between ID types.

U
User-Defined Attribute—Allows accounts in certain categories to be grouped on 
reports, identified for security purposes, or grouped together for allocations.

Y
Year-End Processing—Revenue and expense accounts are closed at the end of every 
fiscal year. An entry is made to an appropriate equity account (net assets or fund balance 
accounts) that reflects the sum of revenues and expenses.

W
Wizard—An interactive help program that guides you through a task. For example, the 
System Parameter Wizard which helps you set up FundWard 7.X to your organization’s 
specifications.
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