Internet Browser Requirements

If your internet browser is more than one version old, performance may be reduced. Beta versions of internet browser are not fully supported.

To ensure your browser is fully supported, use the latest version of:

  • Google Chrome

  • Mozilla Firefox

  • Internet Explorer

  • Safari

    Tip: We recommend all users who use Safari as an internet browser make the following change to prevent an error that affects how the TAB key functions when users attempt to login. From your Safari browser menu, select Preferences and choose Advanced. Then enable the Press Tab to highlight each item on a webpage option.

  • Edge (Windows 10)