Versions of Blackbaud Products That Support TLS 1.1+

May 11, 2018, 18:26 PM
Featured Video :
Text Alignment : Left
Underlay Position : Left
Select a choice : YouTube
Has Underlay? : No
Has video : No
Green-Blue-Gradient

Product

On-Premise or Hosted?

Compatible Version

Release Date

Current Release Download Link

Altru

Hosted

No client upgrade Required

n/a

n/a

AngelPoints

Hosted

No client upgrade Required

3/15/18

n/a

Attentive.ly

Hosted

No client upgrade Required

11/8/17

n/a

Blackbaud CRM

On-Prem

V4.0/SP5

Currently Available

n/a

Blackbaud CRM

Hosted

V4.0/SP13 HF

Currently Available

n/a

Blackbaud Direct Marketing

Both

4.0.196

05/01/2018

n/a

Blackbaud Internet Solutions

Both

V4.0/SP13 HF

Currently Available

n/a

Blackbaud NetCommunity

Both

V7.1/SP2 or higher

10/29/2017

n/a

DonorCentral

Hosted

No client upgrade Required

n/a

n/a

Education Edge

Both

V 7.87/Patch 21

10/31/2017

n/a

Everyday Hero

Hosted

No client upgrade required

n/a

n/a

eTapestry

Hosted

No client upgrade required

n/a

n/a

Faculty Access for the Web

Both

V7.87/Patch 20

10/31/17

n/a

FIMS Host*Net

Hosted

No client upgrade Required

All clients upgraded by 3/15/2018

n/a

FIMS (on-premise)

On-Prem

Customers with FIMS IGAM: Upgrade to FIMS IGAM 6.0 to continue retrieving online applications past March 31, 2018.

2/21/2018

n/a

FIMS (on-premise)

On-Prem

14.60 or higher.

3/22/2018

n/a

Financial Edge 7

Both

V7.87/Patch 21

10/31/2017

n/a

Financial Edge NXT

Hosted

No client upgrade required

n/a

n/a

GIFTS Online

Hosted

No client action required for core functionality; upgrade to GIFTS Online Link to Outlook plugin required to continue using that functionality past March 15, 2018.

2/28/2018

n/a

GIFTS and GIFTS Alta

On-Prem

GIFTS 6.7.2, GIFTS Alta 1.8.2, GIFTS Plus Pack 5.3.1. Upgrade required to continue retrieving online applications and using tax status features past March 31, 2018.

1/29/2018

n/a

Luminate CRM

Hosted

No client upgrade required

All clients upgraded 7/21/2017

n/a

OnMessage; On Campus; OnRecord; OnBoard

Hosted

No client upgrade required

n/a

n/a

NetClassroom

Both

V7.87/Patch 20

11/15/16

n/a

Raiser’s Edge 7

Both

V 7.96

2/7/2018

n/a

Raiser’s Edge NXT

Hosted

No client upgrade required

n/a

n/a

ResearchPoint

Hosted

No client upgrade Required

n/a

n/a

Sphere

Hosted

No client upgrade required

Currently available

n/a

Teamraiser

Hosted

No client upgrade required

n/a

n/a

 

Don’t see your product listed on the table above? Click here to chat with customer support.

*Version 7.96 of Raiser’s Edge 7 is compatible with TLS 1.1+. It is not required that customers upgrade to Patch 8 for compatibility, but Patch 8 does contain an additional change that allows users to disable TLS 1.0 on their internal servers and workstations (which is above and beyond current TLS compliance requirements). For more information and considerations when disabling TLS 1.0 locally, please visit this Knowledgebase solution.