Blackbaud NetCommunity

System Requirements

This page lists the system requirements Blackbaud suggests for each of the Blackbaud NetCommunity 7.2 SP 1 components. For a more in-depth technical configuration of Blackbaud NetCommunity, read the Blackbaud NetCommunity Configuration Overview under SupportHow-to Documentation on our website. Please contact your Blackbaud account manager if you do not have access to this information.

System requirements are subject to change. Please ensure you have the latest information before making any purchase decisions. If you are running any other Blackbaud products, please refer to the System Requirements for those products separately.

Last updated: May 26, 2020

Database server

Operating system

Only the Standard and Enterprise editions of the listed operating systems are supported.

WINDOWS SERVERno spSP1SP2
Windows Server 2012 R2 (64-bit)YesN/AN/A
Windows Server 2016 (64-bit)YesN/AN/A

Note: Blackbaud NetCommunity does not support domain controllers, peer-to-peer networks, or any operating system that is not specifically listed above.

Processor (CPU)
  • Pentium D-class 3 GHz or more, or AMD equivalent recommended.
  • Larger networks and databases that require faster processors can upgrade to any CPU that runs Windows Server.
  • SQL Server provides enhanced support for Windows server with multiple processors. It is designed to improve the performance of multi-user databases under heavy use and increase the workload the database can handle. It can also handle larger databases and/or a large number of users (20 and more).
  • A dedicated database server should be considered, especially for high user loads and activity. No mission-critical databases or other client/server applications, including other Blackbaud applications, should run on the same server.
  • If running more than one client/server application on the same server, the server needs to exceed the minimum recommendations for optimal performance.
SQL server

Only the Standard and Enterprise editions of the listed SQL server versions are supported.

WINDOWS SERVERcompatibility levelno spSP1sp2sp3sp4
SQL Server 2012 R2 (64-bit)110YesYesYesYesYes
SQL Server 2014 (64-bit)110YesYesN/AN/AN/A
SQL Server 2016 (64-bit)130YesYesYesN/AN/A

Note: Search functionality in Blackbaud NetCommunity requires full-text search to be installed with SQL Server.

Memory (RAM)

2 GB minimum and 4 GB or more recommended. More memory may be required for databases larger than 1 GB. The maximum memory for SQL Server is limited to the operating system maximum.

Note: SQL Server can dynamically allocate the optimal amount of memory (or cache) to the database to increase performance. Consider purchasing more than the recommended RAM to allow for a larger cache.

Disk space

2 GB or more for Blackbaud NetCommunity database.

Note: Requirements depend on the number of records and pages developed.

Hard disk

A high-performance disk subsystem, such as SCSI-2 and RAID technology is recommended.

Web server & core components

Operating system

Microsoft .NET Framework v4.5.2 or higher must be installed. 64-bit supported on x64 hardware. Only the Standard and Enterprise editions of the listed operating system is supported.

windows serverno spsp1sp2
Windows Server 2012 (64-bit)YesN/AN/A
Windows Server 2012 R2 (64-bit)
YesN/AN/A
Windows Server 2016 (64-bit)
YesN/AN/A
Windows Server 2019 (64-bit)
YesN/AN/A

Note: Blackbaud NetCommunity does not support domain controllers, peer-to-peer networks or any operating system that is not specifically listed above. Microsoft .NET Framework v4.5.2 or higher must be installed prior to any Blackbaud NetCommunity installation.

Memory (RAM)

4 GB or more recommended.

Disk space

1.5 GB or more for Blackbaud NetCommunity program, system, core components and database management console files; plus 50 MB for the workstation deployment files, which can be installed in a different location. Additional space is required for the database.

Processor (CPU)

Pentium D-class 3 GHz minimum or AMD equivalent recommended.

Note: Larger networks and databases require faster processors.

Internet connection

Dedicated circuit (such as full T1 to a tier 1 ISP) scaled to aggregate the concurrent application users (100200 kbps per typical web user). Necessary speed of the connection depends on your website’s usage by visiting users and should be reviewed with your consultant during implementation. Typical request size is 10kb. HTTPS traffic requires port 443. Non-default ports are not supported.

Security

Blackbaud recommends securing your web server with Transport Layer Security (TLS) 1.2 or equivalent technology to prevent unauthorized access to transmitted data.

Note: Blackbaud is not responsible for the installation, configuration, or testing of any web-security measures. Blackbaud assumes no responsibility for the security of your web server and any adverse consequences from security issues.

Blackbaud software does not establish or modify security on the web server. Refer to Microsoft's web site for best practices and security recommendations.

Raiser's Edge web service server

Operating system

Windows Server 2012 or higher. Raiser’s Edge 7.96 Patch 17 or higher and Raiser's Edge 7 web service. Microsoft
.NET Framework v4.5.2 or higher must be installed. 64bit supported on x64 hardware.

It is expected that Blackbaud NetCommunity, the plug-in and RE7 web service be on the same versions.

Note: Blackbaud NetCommunity does not support domain controllers, peer-to-peer networks or any
operating system that is not specifically listed above. Microsoft .NET Framework v4.5.2 must be installed
prior to any Blackbaud NetCommunity installation. 

Processor (CPU)

Pentium D-class 3 GHz minimum or AMD equivalent recommended.

Memory (RAM)

2 GB

Disk space

Minimum of 50 MB available space for the Raiser's Edge web service installation.

Internet connection

Dedicated circuit (such as full T1 to a tier 1 ISP) scaled to aggregate the concurrent applications users (100200 kbps per typical web user). Necessary speed of the connection depends on your website’s usage by visiting users and should be reviewed with your consultant during implementation. HTTPS traffic requires port 443. Nondefault ports are not supported.

Blackbaud software requirements

Security

Blackbaud recommends securing your web server with Transport Layer Security (TLS) 1.2 or equivalent technology to prevent unauthorized access to transmitted data.

Note: Blackbaud is not responsible for the installation, configuration, or testing of any web-security measures. Blackbaud assumes no responsibility for the security of your web service server or any adverse consequences from security issues. Blackbaud software does not establish or modify security on the web service server. Refer to Microsoft's web site for best practices and security recommendations.

Blackbaud eStore

Blackbaud NetCommunity 7.2 is compatible with Blackbaud eStore 7.1 or higher.

Raiser's Edge

Blackbaud NetCommunity is compatible with Raiser’s Edge 7.96 Patch 17 or higher. Blackbaud NetCommunity is not compatible with the MSDE or SQL Server 2005 Express versions of Raiser’s Edge. Note: Please refer to the latest Raiser’s Edge system requirements for supported client systems.

Blackbaud Direct Marketing

Blackbaud NetCommunity 7.2 is compatible with Blackbaud Direct Marketing 4.0. Note: Integration between Blackbaud NetCommunity and Blackbaud Direct Marketing is not supported when the solutions are deployed as separate instances.

The Raiser's Edge module requirements

Recurring gifts

Blackbaud NetCommunity requires Electronic Funds Transfer for the Donation Form part and Donation 2.0 part. if you want to batch and process recurring credit card and direct debit transactions in The Raiser’s Edge.

Tributes

Blackbaud NetCommunity requires Honor/Memorial Tracking to accept tribute gifts on the Donation Form part and Donation 2.0 part.

Memberships

Blackbaud NetCommunity requires Membership Management to use the Membership Form part.

Alumni

Blackbaud NetCommunity requires Alumni Tracking for display alumni fields on some parts.

Events

Blackbaud NetCommunity requires Event Management to use the Event Registration Form part. It also is required to use events in the Fundraiser part.

Matching gifts

Blackbaud NetCommunity requires Matchfinder Online to allow donors to see if their employers match gifts. It also allows you to look up a donor’s company to retrieve matching gift details when you process donations in the Blackbaud NetCommunity plug-in. This module is not required to support matching gift pledges in Blackbaud NetCommunity.

Volunteer management

Blackbaud NetCommunity requires Volunteer Management to use the Volunteer Opportunity part.

Other compatibility info

Credit card processing

Credit card processing in Blackbaud NetCommunity works with Blackbaud Merchant Services. For more information about other supported gateways, see the Tier 3 gateways page.

Note: Direct debit processing is not managed by these vendors. For Paypal Payflow Pro, a Paypal PayFlow Pro account is required, and Payments Pro is not supported.

Administrative and client browsers

Blackbaud NetCommunity is compatible with W3C-compliant browsers (www.w3.org). Blackbaud NetCommunity supports a Document Type Declaration of XHTML 1.0 Transitional. Depending on your web design, the look and feel of your website may vary across different client browsers. Consider modifying layouts, templates, page designs, and styles to accommodate these differences.

You must enable cookies for all Blackbaud NetCommunity form validations.

Note: Full-page functionality testing is conducted on IE 11 and the latest versions of Firefox, Chrome, Safari on Mac OS, and Microsoft Edge. We recommend using one of these browsers for the best experience.

Mobile browsers

Mobile page functionality testing is conducted on latest native versions of Android and iOS mobile browsers for Blackbaud NetCommunity. Depending on your web design, the look and feel of your mobile website may vary across different mobile browsers. Consider modifying layouts, templates, page designs, and styles to accommodate these differences.

Note: The Blackbaud NetCommunity administrative features and client HTML editor are not supported in mobile browsers at this time.

Database backup

Blackbaud strongly recommends the purchase and scheduled use of a tape or archival backup solution. Power blackouts and brownouts, hardware and network failures, and other unexpected circumstances can lead to an unrecoverable data loss. Blackbaud is not a vendor of backup software or hardware and cannot determine the right backup system for your organization. Consult with reputable dealers and qualified information systems professionals to implement a reliable backup system.

You should make backups daily and test them periodically to ensure their reliability. The SQL Server Enterprise Manager includes a backup utility to conduct or schedule backups while the database engine is running. These backups should then be archived to your chosen tape or archival backup solution. You should also test these backups to ensure their reliability.