Blackbaud eTapestry

System Requirements

System requirements are subject to change. Please ensure you have the latest information before making any purchase decisions. If you are running any other Blackbaud products, please refer to the System Requirements for those products separately.

Last updated: May 26, 2020

Workstation supported versions

Browser

You can access eTapestry using any of the following browsers. We recommend using the latest version available.

  • Google Chrome (latest)
  • Firefox (latest)
  • Internet Explorer 11
  • Internet Explorer 10

Note: Your browser must accept cookies and have javascript enabled to display eTapestry.

Display

A minimum screen resolution of 1024 x 768, 256 colors, 16-bit color or better is recommended.