GrantsConnect

System Requirements

System requirements are subject to change. Please ensure you have the latest information before making any purchase decisions. If you are running any other Blackbaud products, please refer to the System Requirements for those products separately.

Last updated: May 26, 2020

Workstation supported versions

Web browser

To access the GrantsConnect module, clients are required to have the latest version of one of the following browsers: Internet Explorer, Chrome, Safari or Firefox. To protect the data of our clients, our nonprofit partners and the donor information we maintain, YourCause does not allow users with outdated browsers to access the platform. Older browsers do not maintain optimal data security and could put information at risk.